Port 995 verbindung verweigert mit XP,nicht mit Ubuntu?[erl]

  • Grüß Gott an alle,


    Ich bin neue hier, und auch eigentlich etwas neue in dem deutschsprachigen Raum. Deshalb bitte ich euch für eventuellen Sprachfehlern um Verzeihung. So nach dieser kurzen Präsentation, findet ihr hier meine Problemstellung des Tages. Es sieht am Anfang als ein ganz klassische Problem aus, jedoch habe ich das Eindruck das es nicht dem Fall ist. :help:


    Zwei Geräten: Laptop und PC (selbe Konfiguration)
    Thunderbird/3.1.4
    Problem: "Konnte nicht mit dem Server pop.mail.yahoo.de verbinden; die Verbindung wurde verweigert"
    Server POP, Port 995, Windows XP als Betriebssystem
    Telnet-test gemacht und Verbindung wurde verweigert.


    Jetzt wird es spannend. Eigentlich, auf dem selben Laptop gibt es auch ein anderes Betriebssystem - nämlich Ubuntu (linux)
    Damit kann ich meine E-mails ganz genau abrufen, ohne Verbindungsfehler.
    Ich habe auch durch Telnet die Verbindung probiert, und es ist (ohne Überraschung) erfolgreich!


    Nun, habe ich gedacht, dass das Fehler etwas mit windows, bzw. XP firewall, und nicht mit TB etwas zu tun hat. Ich habe dann das Firewall deaktiviert aber die Verbindung mit dem Server wird immer verweigert. Was soll ich tun? :gruebel:


    Ich danke euch für eure Hilfe im Voraus
    Liebe Grüße aus Wien.
    Nicolas

  • Hallo Nicolas,


    und willkommen im Forum!
    Zuerst einmal vielen Dank für deine vielen Informationen und deine gute Beschreibung!


    Der Server lässt sich auf beiden Ports ansprechen:


    ... aber das hast du ja schon selbst festgestellt.
    Und da es unter Linux funktioniert, kann es auch nicht an deinem Netz (Router usw.) liegen.


    - Hast du es unter Windows auch mal unverschlüsselt auf :110 versucht?
    - Hast einen Virescanner, welcher den Mailtraffic überwachen darf? (=> er kann den verschlüsselten Traffic nicht lesen und blockiert!)


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    Danke für deine Mithilfe, ich bin eigentlich noch von diesem Problem verwirrt...
    Mein AON-mailbox (internet provider) erfordert den Port 110 und alles funktioniert einwandfrei, sowohl auf dem Laptop als auf dem PC.
    Gestern, habe ich auch probiert meinen Yahoo-Mails mit diesem Port (110) abzurufen. Und nach einem Warnungsnachricht von Thunderbird wegen dem unverschlüsselten Charakter der Verbindung, wurden fast alle Mails abgerufen. Fast, weil es war keine Mails von Samstag (also gestern) im Thunderbird... Komisch... :gruebel:


    Was teilweise für yahoo funktionieren würde, funktioniert sowieso nicht für andere server (z.B: Universität mit dem Port SSL 993)


    Sonst benutze ich AVG als Antivirus (Scanmail), habe ich schone das e-mail Scanner deaktiviert, leider ohne Erfolg...Aber ich schaue noch einmal genau ein, da die Lösung sowieso irgendwo (oder irgendwann) sich befinden muss. :machkaputt:


    MfG.
    Nicolas

  • Hi Nicolas,


    Ich will mal versuchen, die Verwirrung noch etwas zu vergrößern ;-)


    - an erster Stelle steht, was der Provider überhaupt anbietet. Bietet er nur unverschlüsselte Verbindungen an, dann kannst du nur diese nutzen. Manche Provider verlangen auch eine verschlüsselte Verbindung (entweder STARTTLS oder TLS/SSL), dann bist du gezwungen auch diese zu nutzen. Manche Provider ermöglichen beides, also kannst du wählen. Und manche Provider bieten zwar beides an, aber mit jeweils unterschiedlichen Servern. Mir ist da nur unsere "tonline" bekannt.
    ==> zuerst also auf der Webseite des Providers die Möglichkeiten in Erfahrung bringen.


    - Für die einzelnen Varianten der Verbindung sind unterschiedliche Ports festgelegt, auf denen die Server lauschen, der Client also senden muss. Bsp: POP3 unverschlüsselt: 110, SSL-verschlüsselt: 995 und STARTTLS: 110. Bei letzterem wird ausgetestet, was möglich ist.


    - Wenn du die Wahl hast, oder nicht weißt was verlangt wird, dann kannst du das austesten. Fange mit "UNGESICHERT" an, und teste dann STARTLS bzw. TLS/SSL. Nimm das letzte, was funktioniert.


    - In manchen Umgebungen (Ausland, Firmennetzwerk!!!) funktionieren nicht alle o.g. Möglichkeiten. Sicherheitsgateways wollen aus Sicherheits- (und anderen Gründen ...) den Traffic nach Viren (oder vielleicht nach Informationen?) scannen. Diese haben dann naturgemäß Probleme mit verschlüsselten Verbindungen - und sperren sie einfach. Gleiches passiert auch mitunter beim eigenen AV-Scanner. => eigentlich ist das ein gutes Zeichen. Denn nichts ist schlimmer, als den Nutzer in einer trügerischen Sicherheit zu wiegen, welche gar nicht vorhanden ist.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Lieber Peter,


    Zuerst danke, dass du Zeit für "mein" Problem nimmst!
    Dann, will ich dir nur erinnern, dass alles einwandfrei unter Ubuntu funktioniert.
    Für mich Die Lösung liegt daran, durch den Ports 995 (und 993) ein zugriff zu ermöglichen.
    Alles war okay bevor ich Thunderbird 3.1.4 downloadet habe (vielleicht ist es hier reiner Zufall?)


    Wie gesagt, Telnet unter Linux sagt mir dass alles ok ist
    Jedoch Telnet unter Windows XP antwortet mir:

    Code
    1. C:\Dokumente und Einstellungen\User>telnet pop.mail.yahoo.de 995
    2. Verbindungsaufbau zu pop.mail.yahoo.de...Es konnte keine Verbindung mit dem Host hergestellt werden, auf Port 995: Verbinden fehlgeschlagen


    Weil es unter Linux funktioniert kommt es nicht von meinem Router, und auch nicht von meinem Provider.
    Ich habe das Firewall von XP und AVG (antivirus) deaktiviert, leider ohne Erfolg. Was kann ich machen?


    Eigentlich ich bin nicht sicher, dass ich in dem guten Forum bin, jedoch weiß ich nicht mehr wo ich suchen soll (habe nichts unter Internet gefunden).


    Cordialement,
    Nicolas

  • "Nicowien" schrieb:


    Weil es unter Linux funktioniert kommt es nicht von meinem Router, und auch nicht von meinem Provider.


    Hallo Nicolas :)


    ok.


    Zitat


    Ich habe das Firewall von XP und AVG (antivirus) deaktiviert, leider ohne Erfolg.


    Die Windows-Firewall ist unkritisch, die brauchst Du nicht deaktivieren. Bei Fremd-Firewalls und Virenscannern reicht das Deaktivieren in der Regel nicht. Ich glaube aber nicht, dass es bei Dir am Virenscanner liegt.


    Zitat


    Was kann ich machen?


    Wie sieht es mit telnet nach einem sauberen Systemstart aus?


    Konfigurieren von Windows XP auf die Durchführung eines "sauberen Neustarts"


    HTH
    Gruß Ingo

  • 1.) Dass du unter Linux und den sonst gleichen Netzwerkbedingungen den Server erreichst, sagt mir, dass du kein "Netzwerkproblem" hast.


    2.) Dass du unter Windows bereits mit telnet den Server nicht erreichst, sagt mir, dass es sich nicht um ein "Thunderbird-Problem", sondern um ein Problem deines Betriebssystems handelt. Wenn du mit telnet (und der richtigen Syntax) keine Verbindung bekommst, dann wird dir das auch mit keinem Mailclient gelingen, denn beide benutzen die gleichen Befehle.


    Das bedeutet, du solltest von TB so lange die Finger lassen, bis du von deinem Windows aus den Server per telnet ansprechen kannst. Dazu empfiehlt es sich alles zu deaktivieren, was die Verbindung irgendwie behindern könnte. AV-Scanner, "Firewall" und sonstige "Sicherheits-"Software so konfigurieren, dass sie nicht mir dem Betriebssystem mitstarten. Reboot, Test ob die vorgenannten auch ja nicht gestartet wurden und dann wieder mit telnet testen. Auch mal einen der vielen anderen Mailserver ausprobieren bei diesem Test.
    Erst, wenn per telnet eine Verbindung zustande kommt, lohnt es sich, den Test mit Thunderbird zu wiederholen.
    Und wenn dieser dann erfolgreich ist, zuerst die Windows-Firewall (=> dann Testen!), dann weitere "Sicherheits-"Programme schrittweise zuzuschalten. Dabei kannst du feststellen, an welcher Stelle die Verbindung nicht mehr funktioniert.


    MfG Peter
    edit: schlingo war schneller, aber im Endeffekt gleiche Aussage. Wenn du - wie üblich - einen Router nutzt, kannst du bedenkenlos auch zeitweilig den Windows-Firewall ausschalten. Auch hier kann man falsch konfigurieren. Der Router schützt ausreichend (für die Dauer des Tests!).

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • "schlingo" schrieb:

    Wie sieht es mit telnet nach einem sauberen Systemstart aus?


    Nach einem sauberen Systemstart startet zwar windows schneller, jedoch Telnet könnte immer noch keine Verbindung mit dem Server herstellen... :wall:

  • "Peter_Lehmann" schrieb:

    Wenn du - wie üblich - einen Router nutzt, kannst du bedenkenlos auch zeitweilig den Windows-Firewall ausschalten.


    Hallo Peter :)


    das ist grundsätzlich völlig richtig.


    Zitat


    Auch hier kann man falsch konfigurieren.


    Richtig. Aber es ist im Gegensatz zu den Fremd-Firewalls relativ schwer. Dafür musst Du schon gut rumfummeln.


    Zitat


    Der Router schützt ausreichend (für die Dauer des Tests!).


    Unter den genannten Voraussetzungen völlig korrekt.


    "Nicowien" schrieb:


    Nach einem sauberen Systemstart startet zwar windows schneller


    Logisch ;) Prüfe mal, abgesehen von Deinem Problem, ob Du das wirklich alles brauchst.


    Zitat


    jedoch Telnet könnte immer noch keine Verbindung mit dem Server herstellen...


    Hm. Falls Du, wie Peter vermutet, einen Router verwendest, versuche mal seinen Tipp, zusätzlich die Windows-Firewall zu deaktivieren. Ansonsten leider ratlos :(


    HTH
    Gruß Ingo

  • Hallo Liebe Leute!


    Etwas Zucker dazu?


    Ich bin gerade an der Uni und benutze die W-Lan Verbindung dieser Institution.
    Und weißt ihr was? Ich kann meine Yahoo-mails einwandfrei bekommen. :freak:
    Es heißt das mein Problem weder von windows, noch von TB, und noch von meinem Internet-Provider /oder meinem Router (weil alles funktioniert unter linux) verursacht ist, sondern von der Kombination Windows + Internet-Provider :les:


    Jetzt bin ich TOTAL Ahnungslos :nixweiss:


    Au secours !!!


    LG
    Nico

  • Hallo,

    Zitat

    sondern von der Kombination Windows + Internet-Provider


    Möchte ich bezweifeln, ich würde ausschließlich Windows + Sicherheitssoftware dafür verantwortlich machen.
    Ich habe ja selbst Windows und einen Yahoo-Account mit Port 995 und der klappt.
    Allerdings habe ich keine Sicherheitssoftware, die den TB-Profilordner abscannt und Mails abscannt (bitte den Unterschied berücksichtigen) oder Programme bzw. Ports blockiert, genau das müsste bei dir der Fall sein.


    Ach übrigens hilft es manchmal aus unerfindlichen Gründen, das Konto zu entfernen und neu einzurichten.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:

    ich würde ausschließlich Windows + Sicherheitssoftware dafür verantwortlich machen.
    Ich habe ja selbst Windows und einen Yahoo-Account mit Port 995 und der klappt.
    Allerdings habe ich keine Sicherheitssoftware, die den TB-Profilordner abscannt und Mails abscannt (bitte den Unterschied berücksichtigen) oder Programme bzw. Ports blockiert, genau das müsste bei dir der Fall sein.


    Merci!


    Das e-mail scanner von AVG war das Problem, ich habe es deaktiviert und nach dem reboot alles funktioniert einwandfrei.
    Danke die Hilfe.