about:config manuell pflegen

  • Hallo,
    meines Wissens pflegt man normalerweise die about:config-Parameter mit Extras=>Einstellungen=>Konfiguration. Da kann man zwar Werte verändern, aber es gibt keinen expliziten Button zum Speichern. Ich habe festgestellt, dass anschließend, also nach dem Enter und Verlassen des Pflegebildes, spätestens aber nach einem Neustart des TB, die Werte wieder auf dem alten Stand sind. Meine Angaben wirken offenbar nur temporär.


    Frage: Kann man die about:config-Parameter irgendwo separat mit einem Editor (notepad o.ä.) pflegen, so dass die Settings dauerhaft bestehen bleiben? Wäre m.E. nicht schlecht. :lol:


    Viele Grüße
    rocketracer

  • Hi,
    das ist nicht das Normalverhalten, die Einstellungen werden gespeichert und bleiben auch nach einem Neustart erhalten.
    Da du trotz Hinweis
    Bitte machen Sie unbedingt folgende Angaben in Ihrer Problembeschreibung:
    Thunderbird-Version (2.0.0.* / 3.0.* / 3.1.*) • Kontoart (POP / IMAP) • Betriebssystem
     
    keine Angaben zu Betriebssystem und Thunderbird-Version gemacht hast, empfehle ich für den Fall des Falles ein Update auf die aktuelle Version.
    Man kann, wenn man eine Datensicherung hat, entweder bei ausgeschaltetem Thunderbird die Datei prefs.js im Profil editieren, oder die zu ändernden Einträge in der user.js (falls nicht vorhanden, anlegen) bearbeiten. Die zweite Variante ist sicherer. Mit dem Editieren der prefs.js kann man auch viel Schaden anrichten.

  • Hallo frog,
    erst mal hier meine techn. Daten (sorry hatte ich vergessen):


    Thunderbird-Version 3.1.5
    Kontoart IMAP
    Betriebssystem Win 7


    Ich habe alles probiert nach Anleitung: neues Profil angelegt (ich hatte bisher noch keines außer dem default). Jetzt habe ich default und Standard-Benutzer.


    Dann habe ich verschiedenes ausprobiert, um den Parameter "mail.server.server1.timeout" auf 300 zu setzen (im Profilordner xxxxxx.Standard-Benutzer):
    Zuerst in der prefs.js den Wert geändert mit notepad und gesichert => TB gestartet, hat wieder Standardwert 29.


    Dann habe ich die prefs.js kopiert und in user.js umbenannt, in dieser dann den Wert auf 300 gesetzt.
    => TB gestartet, hat wieder Standardwert 29.
    Anscheinend hat user.js nicht gezogen, der Wert in der Datei steht noch auf 300 wie ich ihn haben will.


    Was mache ich falsch???
    Grüße
    rocketracer

  • Zitat

    mail.server.server1.timeout

    Und du hast auch den richtigen Server erwischt? Und bist im richtigen Profil?
    Übrigens ist es nicht sinnvoll, die prefs.js komplett in die user.js zu kopieren, weil dann die user bei jedem Start die prefs überschreibt. Du solltest dort (in die user.js) nur die Werte eintragen, die du ändern willst, also z.B. den Timeout.
    Schreib einfach mal in eine ansonsten leere user.js etwas sinnfreies wie
    user_pref("mail.thunderbird_can_fly", true);
    und überprüfe nach dem nächsetn Neustart die Einstellungen in about:config.

  • Hallo frog,


    du hast recht, der Server hat die Nr. 3 statt 1.
    Mit der user.fs habe ich es jetzt gemacht wie du sagtest. Sie sieht jetzt so aus - nur 1 Eintrag:


    user_pref("mail.server.server3.timeout", 300);


    Aber nichts funktioniert. Wenn ich den TB starte und in die Konfig schaue, steht wieder der Standardwert 29 drin. Frage: muss ich den den Parameter, den ich user-bezogen machen will, aus dem normalen Profil rausnehmen? Ich war davon ausgegangen, dass der User-Wert den korrespondierenden Wert aus dem Standard-Profil überschreibt - oder?


    Noch ein Hinweis: das eben habe ich mit dem default-Profil ausprobiert. Außerdem habe ich den TB gerade zuvor auf 3.1.6 upgraded.


    Gruß
    rocketracer

  • Hallo,
    Frage, du hast jedes Mal bei der Änderung TB vorher beendet?
    Wenn nicht, passiert nämlich gar nichts.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,
    Klar, ich bin mittlerweile der Weltmeister im 'auf' und 'zu' und 'öffnen mit ...' der Profile-Dateien und der TB-Mailanwendung. Ich habe aufgepasst und alles wie o.g. eingestellt und vorgegangen, aber wenn ich unter => Extras => Einstellungen => Konfiguration bearbeiten => filtern nach 'timeout' nachsehe, bekomme ich


    "mail.server.server1.timeout vom Benutzer festgelegt integer 29"


    Wo ist meine 300 geblieben aus der user.js?


    Beim Senden großer Mails (Versuch mit ca. 6 MB) kommt immer die Fehlermeldung "Senden der Nachricht fehlgeschlagen.
    ... konnte nicht gesendet werden, weil die Verbindung mit dem SMTP-Server ... ihre Ablaufzeit (timeout) überschritten hat..."


    Aber es gelingt mir nicht, den Parameter dauerhaft hochzusetzen - wobei noch nicht mal klar ist, ob damit das Sendeproblem zu lösen wäre???
    Was mach ich falsch?
    Grüße
    rocketracer