Doppelklick auf Wort markiert ebenfalls Absatzzeichen

  • aktuelleste TB-Version unter Win7/64


    Hi,
    per Doppelklick auf ein Wort, das am Zeilen-/Absatzende steht, sieht es in TB so aus, als ob wirklich nur dieses Wort markiert wurde.
    Nun kopiere ich es in die Zwischenablage. Beim Einfügen zB in Word, wurde mir jedoch auch der nachfolgende Absatzumbruch eingefügt. Beim Einfügen in ein einzeiliges Formularfeld erscheinen noch zwei Leerzeichen.


    Lässt sich dieses -- leider nicht "offensichtliche" Verhalten irgendwie deaktivieren?


    In meinem konkreten Fall wollte ich ein Passwort aus einer Mail per Doppelklick und STrg-C in die Zwischenablage kopieren und in das Passwort-Feld eines Web-Formulars einfügen. Da diese Zeichen maskiert werden, konnte ich nicht erkennen, dass noch zusätzlich zwei Leerzeichen eingefügt wurden -- somit war das Passwort nicht korrekt.
    Inzwischen weiß ich dies und lösche nach dem Einfügen die letzten beiden "schwarzen Punkte"... Doch sehr unschön.



    Danke
    Carlos

  • Hallo Carlos,
    das Verhalten wie du es beschreibst tritt bei jedem markierten und kopierten Wort auf, wenn man nach deiner Vorgabe vorgeht. Und nicht nur das, auch wenn man korrekt manuell markiert - die Markierung hört ja immer bis zum nächsten Leerzeichen und nicht bis zum letzten Buchstaben - springt nach dem Kopieren Word zur nächsten Zeile.
    Habe das allerdings nur in einer sehr alten Word-Version (98) testen können.
    Das Merkwürdige dabei ist, dass dieses Verhalten nicht auftritt, wenn ich aus einem Verfassenfenster oder dem Ordner Entwürfe kopiere.
    Wenn du gut Englisch kannst, kannst du ja gerne mal in https://bugzilla.mozilla.org/ etwas stöbern und wenn du nichts findest, einen Bug melden.
    Du hast übrigens das gut erkannt. Das selbe Verhalten tritt nämlich auch beim Kopieren von Word nach TB auf,
    wenn man die von TB kopierten Wörter markiert.


    Gruß
    edit: vielleicht tritt dieser BUg hierauf zu:
    https://bugzilla.mozilla.org/show_bug.cgi?id=437679

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Noch etwas:
    Das Verhalten tritt nicht auf, wenn die Mail in HTML geschrieben wurde.
    Es reicht aber nicht eine HTML Mail in Reintext anzeigen zu lassen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für die Antworten und den Link zu Bugzilla. Beruhigend, nicht der einzige zu sein...


    Muss wohl vorerst noch damit leben und daran denken, ein derart übernommenes Wort, spez. Passwort, zu überprüfen, falls ich nach Abschicken des Formulars die Meldung bekomme "ungültiges Passwort".