3.1.1: Zeilenumbrüche nach "Neu umbrechen" gehen verloren

  • Hi,
    wenn ich auf eine Mail antworte, dabei mehrere Absätze markiere, um direkt "kontextabhängig" antworten zu können, führe ich als erste "Neu umbrechen", damit mir TB die Absätze nicht einzeilig anzeigt, sondern auf diese 72 Zeichen begrenzt.


    So weit, so gut.


    Weniger gut, dass die Absatzumbrüche verloren gehen. Ich bekomme also einen zusammenhängenden Fließtext aus dem nicht mehr hervorgeht, wo Absatzumbrüche/-marken eingefügt worden waren.
    (Ist auch im abgesicherten Modus der Fall.)


    Hat jemand 'nen goldenen Tipp?


    Danke!
    Carlos

  • Hallo,
    du hast welches Betriebssystem und welche TB-Version?
    Die betr. Mail ist in Reintext oder HTML geschrieben?


    Schwieriges Problem, da ich kaum mal eine solche Mail mit Scrollbalken zu Gesicht bekomme und so es auch nicht nachvollziehen kann.
    Ich weiß nur eins: nur wenn die erhaltene Mail auch im Quelltext (Strg+U) mit falschen Umbrüchen (also mit Scrollbalken), entsteht dieser Effekt. I.R. braucht man "neu umbrechen" nur dann.
    Dann hat der Versender schon falsch umgebrochen.
    Hinzu kommt das Chaos, welches manchmal zwischen Umbruch und Absatz herrscht, besonders, wenn der Text in Word geschrieben wurde.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    du hast welches Betriebssystem und welche TB-Version?
    Die betr. Mail ist in Reintext oder HTML geschrieben?


    Tschuldige, hatte die Versionsnummer 3.1.1 nur im Betreff aufgeführt.
    Unter Win7/64.


    Zur Veranschaulichung meines Problems:
    Ich hab mir (= an Thunderbird) über Gmail eine Mail geschickt mit drei Absätzen/Absatzmarken. Hier die Darstellung der verschickten Mail in der Browseransicht von Gmail:


    Empfangene eMail in Thunderbird:


    Hier der Quellcode:


    -> Bis jetzt alles bestens.


    Nun antworte ich auf diese Mail in TB (Strg-R) -- Ergebnis:


    Da ich die flowed-Einstellung (genau Bezeichnung weiß ich gar nicht) in den erweiteren Einstellmöglichkeiten nicht aktiviert habe, werden mir die 3 Absätze als 3 lange Zeilen angezeigt. Also drücke ich Strg-R für neu umbrechen (was ich auch bei aktivierter flowed-Einstellung gemacht hätte).


    Ergebnis:


    -> und siehe da, TB hat alle drei Zeilen/Absätze zu einem einzigen Absatz verschmolzen, die Absätze blieben also nicht erhalten (eines der "ehemaligen" Absatzenden habe ich für den obigen Screenshot invertiert). Doch genau das soll nicht passieren, die drei Absätze sollten auch nach dem Umbrechen durch TB erhalten bleiben -- damit zB die STruktur der Übersichtlichkeit wegen gewahrt bleibt und ich bspw. direkt unter den zitierten Absätzen Antworten hinzufügen kann.


    Dieses Verhalten ist auch bei Nutzung von TB im abgesicherten Modus der Fall. An möglichen "verstellten Einstellungen" einer meiner installierten Plugins liegt also nicht.



    Verhält sich bei Euch TB ebenso?
    Für mich kein Feature, sondern ein Bug...



    Carlos

  • Die Frage ist, in welchem Format lag der Ursprungstext vor?
    Ich sagte bereits, dass TB und Word andere Verfahren für Umbrüche und Absätze benutzen.
    Vermutlich kann TB das Absatzzeichen nicht als solches erkennen.
    Teste das mal in TB selbst und schicke eine Mail an dich selbst.


    Nur damit ich eine echte Vergleichsmöglichkeit habe:
    bei dir ist format=flowed also beim Lesen und Versenden abgeschaltet?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Die Frage ist, in welchem Format lag der Ursprungstext vor?
    Ich sagte bereits, dass TB und Word andere Verfahren für Umbrüche und Absätze benutzen.
    Vermutlich kann TB das Absatzzeichen nicht als solches erkennen.
    Teste das mal in TB selbst und schicke eine Mail an dich selbst.


    Hmm, von Word hatte ich nichts erwähnt.
    Das beschriebene Verhalten taucht bei mir in allen Mails auf, die ich bekomme und die ich mit Zitierung beantworten möchte. Sprich, es werden natürlich die unterschiedlichsten Mailprogramme mit den unterschiedlichsten Einstellungen benutzt.
    Gmail habe ich nur genommen, um das Verhalten exemplarisch darzustellen und die Screenshots zu erstellen.


    Den Test habe ich gemacht -- selbes Verhalten.


    Zitat

    Nur damit ich eine echte Vergleichsmöglichkeit habe:
    bei dir ist format=flowed also beim Lesen und Versenden abgeschaltet?


    Hatte die Standardeinstellung mal versuchsweise geändert (nachdem ich auf diese Einstellung per Google gestoßen war), weil ich eben dachte, dass dies daran liegen könnte. Doch dem war nicht so, darum wieder auf die Standardeinstellungen zurückgesetzt:



    Mich würd nach wie vor interessieren, ob dieses Verhalten durchgängig ist...


    Danke für Deine/Eure Hilfe!
    Carlos



    PS: Tests ohne Ende, gerade eben ausprobiert:
    wenn eine Leerzeile zwischen zwei Absätzen vorhanden gewesen wäre, dann wäre beim Zitieren aus dieser Darstellung...:


    ... und nachfolgendem "Neu umbrechen" das erwünschte Ergebnis entstanden:


    -> hier wurden also keine Absätze verschluckt -- so wie ich es auch ohne Leerzeilen erwarten würde und liebend gerne hätte...

  • Hallo,
    also ich kann dir im Moment nicht weiterhelfen, werde das morgen noch einmal testen.
    Ich meine über dieses Problem (Bug?) schon einmal irgendwo gelesen zu haben.
    Wenn du gut Englisch kannst, würde ich dir empfehlen, mal im englischen Mozilla-Forum zu erkundigen.
    http://forums.mozillazine.org/viewforum.php?f=39


    Ich werde auch noch recherchieren.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Auch hier im Forum mal bitte danach suchen!
    Thunderbird Mail DE • Thema anzeigen - Absätze (Leerzeile) werden ...


    Gib mal in unsere Suche "zeilenumbruch" und "Absatz" (ohne " ") ein.
    Jetzt weiß ich noch immer nicht, ob dein Text Rein-Text ist oder formatiert (HTML).


    Sind deine Mails in quoted printable kodiert? Überprüfe die Deklarierung im Quelltext (Strg+U) der Mails.


    Zum Problem lies:
    http://autorewrap.mozdev.org/
    Allerdings wird das Add-on nicht kompatibel sein.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Bin deine Screenshots noch einmal durchgegangen und habe festgestellt, dass die Mail zwar in HTML geschrieben wurde

    Zitat

    Content-type text/html


    aber danach überhaupt kein HTML-Code zu sehen ist. Dort müssten ja Zeichen <br> oder <p> zu sehen sein.
    Es ist dort aber überhaupt kein Code enthalten, so dass TB diesen falsch interpretiert.
    Stelle daher unter Ansicht, Nachrichtentext, mal auf "Reiner Text".
    Evtl. hast du dann das Problem beim Weiterleiten nicht mehr.
    Allerdings musst du darauf achten, dass kein HTML-Verfassenfenster dabei geöffnet wird, evtl. die Umschalttaste dabei gedrückt halten.
    Der Fehler liegt am Versender der ursprünglichen Mail. So etwas passiert auch beim Versenden über einen Webmailer (googlemail). Da es keinen Standard für HTML in Mails gibt, kann ich dir nur empfehlen, alle in Reintext zu lesen und zu verfassen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat von "mrb"

    Auch hier im Forum mal bitte danach suchen!


    Hatte natürlich nicht nur dort gesucht. Sieht aber so aus, dass entweder nur ich dieses Problem habe oder nur für mich dieses Feature ein Bug ist ;))



    Zitat

    Jetzt weiß ich noch immer nicht, ob dein Text Rein-Text ist oder formatiert (HTML).


    Na ja, wie gesagt, ist dieses Verhalten unabhängig von der Formatierung der Mail.
    Habe gerade nochmals Tests gemacht aus Gmail und Freemail, jeweils als HTML-Mails und als Plaintext-Mails.
    Und wie schon berichtet, tritt dieses Verhalten bei mir darüber hinaus bei allen Mails aus, die also mit den verschiedensten eMail-Programmen oder Webmailern und den verschiedensten Einstellungen etc.pp. verfasst werden.


    Zitat

    Sind deine Mails in quoted printable kodiert?


    Mal so und mal so.


    Zitat

    Allerdings wird das Add-on nicht kompatibel sein.


    In der Tat: zu veraltet, um noch kompatibel zu sein.


    Zitat

    Es ist dort aber überhaupt kein Code enthalten, so dass TB diesen falsch interpretiert.


    Mein Gmail-Mails/-Screenshots dienten rein zur Illustration und sind gegen andere Mailprogramme/Webmailer austauschbar.


    Zitat

    Stelle daher unter Ansicht, Nachrichtentext, mal auf "Reiner Text".


    Gut, das hätte den Vorteil, dass die Zeilenlängenbegrenzung auf 72 Zeichen aktiviert wird
    Sprich, beim Zitieren bräuchte ich keine Neuformatierung machen, um diese Zeilenbegrenzung zu erhalten. Würde ich trotzdem diese Neuformatierung machen (Strg-R), wären die Zeilenumbrüche futsch -- weil TB nicht mehr weiß, wie die Mail formatiert war vor dieser Umstellung der Ansicht.


    {Nebenbemerkung: die Begrenzung der Zeilenlänge ist für mich insofern ungeschickt, da ich häufig Texte per copy&Paste übernehmen muss und nicht im Nachhinein wieder mühsamst die einzelnen Zeilen zu Absätzen zusammenfügen möchte}


    -> Ok, ich gebe mich geschlagen (und möchte auch nicht weiter mit "diesem meinem ganz eigenen Problem" nerven und diesen Thread in eine unendliche Länge ziehen...):
    TB kann nur dann Absätze als Absätze erkennen, wenn diese mit einer Leerzeile getrennt wurden. Nach Neuformatierung bleiben die Absätze -- sprich diese Leerzeilen -- also erhalten.
    Ansonsten geht TB grundsätzlich davon aus, dass ein zusammenhängender Text vorlag und fügt somit bei einer Neuformatierung wieder alles zusammen.



    Somit vielen herzlichen Dank für Eure Bemühungen -- die Euch Zeit & vermutlich noch mehr Nerven gekostet haben...!
    Carlos



    PS:

    Zitat

    alle in Reintext zu lesen und zu verfassen.


    Das hatte ich schon seit jeher so gehandhabt. Die "vereinfachte HTML-Darstellung" habe ich jedoch deswegen der Reintext-Darstellung vorgezogen, damit ich eben keine "künstliche" Aufsplittung von Absätzen in einzelne Zeilen bekommen aus dem oben genannten Grund: damit ich per Copy&Paste arbeiten kann, ohne danach die Zeilen wieder händisch zusammenfügen zu müssen.



    Puh...

  • Ich bin keineswegs genervt, weil mich das selbst interessiert und das auch schon hier gefragt wurde.
    Ich werde heute Abend mal einen Text zusammenstellen und das testen, obwohl ich fast sicher bin, dass es bei mir anders ist als bei dir.
    Ist jetzt dein Problem gelöst - wenn auch nicht zu deiner vollen Zufriedenheit?
    Mich würde ja mal interessieren, ob dieses bei Konkurrenzprogrammen auch so ist.


    Außerdem wäre ich dir dankbar, wenn du mir die empfangene Mail als *.eml Datei zusenden würdest, so dass ich ein vollwertiges Testobjekt habe.
    Fall du das machen würdest, schicke ich dir per PN meine Mailadresse.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    meine Tests konnten den Fehler - wie erwartet - nicht reproduzieren.


    Aber mir ist dieser Thread eingefallen:
    Zeilenumbruch bei quoted-printable [erl.]


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw