Chinesische Zeichen beim Download

  • Hallo,


    ich arbeite mit 3.1.10 und manchmal werden e-mails nur in kryptischen chinesischen Zeichen runtergeladen. Das sieht dann zum Beispiel so aus:
    䡡汬漠乡


    Kann mir jemand was dazu sagen?


    Danke!

  • Hallo,
    ich hoffe du hast schon im Forum nach "Zeichenkodierung" oder "Umlaute" geforscht.
    Ich gehe davon aus, dass dein TB-Profil relativ neu ist (und nicht aus alten Versionen mitübernommen wurde) und keine Änderungen der Zeichenkodierungen gemacht wurden.
    Überprüfe den Quelltext (Strg+U) dieser Mails, ob dort auch schon diese Zeichen vorhanden sind und poste die Deklarierung einer solchen Mail.
    Diese fängt immer mit "content-type" an gefolgt von mehreren Zeilen, die auch den charset (=Zeichensatz/kodierung) und content-transfer-encoding beinhalten.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    ja, ich habe das schon durchsucht, aber die Probleme beziehen sich meist auf Umlaute und bei mir ist der gesamte Text in meist chinesischen Zeichen dargestellt. Ich habe das Profil tatsächlich von meinem alten Rechner vor Kurzem übernommen, aber an den Zeicheneinstellungen habe ich nicht rumgespielt. Wenn ich die Mail öffne und Strg+U drücke öffnet sich ein neues Fenster - wieder mit diesen chinesischen Zeichen!


    Gruß

  • Um die Sache zu vereinfachen - weil Fehlersuche per Ferntherapie zu zeitaufwendig ist - lege mit dem TB Profilmanager ein neues Profil an, starte, damit und lege zunächst testweise ein neues Konto ein. Überprüfe das Verhalten und poste es hier.
    Lies dazu:
    Profile verwalten (Anleitungen)


    Ach ja, du hast ein POP oder IMAP-Konto?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo zusammen,


    ich bin auf meiner Suche auf diesen Thread gestossen, da ich das gleiche Problem habe und gerne Wissen moechte ob es hierfuer vielleicht mittlwerweile eine Loesung gibt.


    Bei einem meiner Accounts werden manche Mails mit "komischen" Schriftzeichen angezeigt, welche ich einfach mal als chinesische Zeichen bezeichne. Wenn ich mir die entsprchenden Mails in der Weboberflaeche meines Anbieters ansehe sind sie jedoch richtig. Erst nach dem Download und dem Anzeigen im Thunderbird werden sie unterschiedlich angezeigt. Das Problem tritt auch bei bestimmten Nachrichten, welche ich periodisch erhalte, immer auf. Bei den meisten jedoch nicht.


    Ich benutze thunderbird 3.1.13 unter Kubuntu. Den Account habe ich mittlerweile schon einige Jahre und er hat auch schon diverse Thunderbird versionen durchgemacht. Ich habe 2 Imap und 3 Pop Accounts eingerichtet und moechte aus diesem Grund und natuerlich wegen den ganzen Nachrichten auch nicht auf ein neues Profil umziehen. Der Fehler tritt auch nur bei einem der Pop Accounts auf. Ich kann euch auch gerne einmal eine solche Nachricht weiterleiten da die Zeichen auch dann erhalten bleiben.


    Gruss squisher

  • Hallo und willkommen im Forum!


    Da du ja sicher unsere Tipps gelesen hast, wirst du uns daher sagen können, ob im Quelltext der Mail diese Zeichen auch vorhanden sind (falls ja, wurden sie auch so verschickt) und was der Test in einem neuen Profil ergab.


    Falls nein, könnte es eine Einstellung in TB sein, aber auch eine falsche Deklarierung durch den Absender.
    Kontrolle der Einstellung:
    Rechtsklick auf einen Posteingang mit einer solchen Mail darin.
    Eigenschaften, Allgemein, 2. Kästchen von oben ist angehakt (sollte nicht)?
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo und Danke fuer die freundliche Aufnahme.


    Wenn ich mir den Quelltext mit Strg+U ansehe, dann sind auch solche Zeichen vorhanden. Allerdings sind diese etwas anders als in der Mail Ansicht. Es sieht z.B. so aus: 䙲潭‭⁍潮⁓数‱㤠ㄹ㨱㤺〹 Allerdings bin ich mir mit dem so verschickt nicht sicher. Wenn ich mir die gleiche Mail im Webbrowser ansehe wird diese ganz normal und richtig dargestellt. Die Zeichen kommen erst nach dem Download und im Thunderbird.


    Mit dem neuen Profil habe ich noch nicht getestet, da ich dann ja alle bisherigen Nachrichten verliere. Ich werde es aber nachholen und dann hier einmal posten.


    Das mit dem Rechtsklick auf den Eingangsordner habe ich gemacht. Du meinst die Checkbox unter dem "default character encoding" die so etwas meint wie "default fuer alle Nachrichten anwenden"? Diese ist nicht selektiert.


    Koennte denn der "Ordner reparieren" Button etwas bewirken?


    Gruss squisher

  • Zitat

    Wenn ich mir die gleiche Mail im Webbrowser ansehe wird diese ganz normal und richtig dargestellt. Die Zeichen kommen erst nach dem Download und im Thunderbird.


    Webmail und Mailklient sind 2 Paar Schuhe und sind manchmal nicht kompatibel. Außerdem sind diese häufig auf Exchange und Outlook getrimmt. Versuche doch mal einen anderen Mailklienten zu verwenden. Etwa Windows Live Mail.
    Aber noch einmal: wenn im Quelltext diese Zeichen auftauchen, kann sie TB nicht richtig darstellen, selbst wenn es richtig eingestellt ist.
    Nein, das Reparieren der Ordner wird nicht helfen, aber du kannst es gerne probieren, schaden tut es nicht.


    2 Fragen: klicke mal bei dieser Mail auf View, character encodings, welcher Zeichensatz wird dort angezeigt.
    Dann überprüfe noch einmal im Quelltext, welcher (charset) dort deklariert ist.
    Das sieht dort etwa so aus:

    Code
    1. Content-Type: text/plain;
    2. charset="iso-8859-1"
    3. Content-Transfer-Encoding: 7bit


    Auf Grund deiner Beschreibung des Quelltextes ist ein neues Profil nicht nötig, das würde dort genau so sein.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi,


    nur so am Rande

    Zitat von "squisher"

    Mit dem neuen Profil habe ich noch nicht getestet, da ich dann ja alle bisherigen Nachrichten verliere.

    ein Blick in die Anleitung bzw. Fragen & Antworten (ist auf dieser Seite ganz oben per Button erreichbar) wird dir zeigen, dass dies Unsinn ist.
    Du kannst in TB beliebig viele Profile erstellen und damit arbeiten, dabei hilft dir der Profilmanager.

  • Hallo rum,


    vielen Dank fuer deinen Tip. Es ist schon klar, dass ich mit beliebig vielen Profilen arbeiten kann. Allerdings sind in einem neuen Profil die Nachrichten, welche per Pop heruntergeladen wurden nicht mehr vorhanden. Das war auch mein Kritikpunkt an dem ganzen.


    Anyway das Problem hat sich aber Dank mrbs letzter Antwort geloest. Zwar war der Einwand mittels Windows Mail nicht anwendbar da es dieses unter Linux einfach nicht gibt. Ich habe aber ein neues Profil angelegt und dort konnte ich die entsprechenden Mails dann auch lesen. Bei dem neuen Profil war das default character encoding auf ISO-8859-1 eingestellt und bei dem alten auf UTF-16. Nach der Aenderung auf ISO-8859-1 konnte ich auch in dem alten Profil die Mails ohne Probleme lesen.


    Im Quelltext war dann auch ersichtlich warum die Nachrichten falsch dargestellt wurden. Die entsprechenden Nachrichten hatten kein charset.


    Danke,
    squisher

  • Zitat

    Bei dem neuen Profil war das default character encoding auf ISO-8859-1 eingestellt und bei dem alten auf UTF-16.


    Eigentlich spielt das überhaupt keine Rolle, welche Zeichenkodierung dort eingestellt ist, denn TB muss diese automatisch erkennen, wenn diese richtig deklariert wurden, darum meine Fragen an dich, um das zu klären.
    Nur wenn die Deklarierung in einer Mails fehlt, verwendet TB den default Zeichensatz.
    Also immer noch der Fehler des Absenders.
    Übrigens kann man bei empfangenen Mails und falscher Darstellung immer versuchen Über Ansicht, Zeichenkodierung, dort einen auszuwählen und zu aktivieren. Du hättest dann gemerkt, dass ISO-8859-1 geklappt hätte. Nur ist diese Einstellung nur temporär und wechselt bei einer anderen Mail zu einer anderen, nämlich der jeweils deklarierten.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Guten Morgen,

    Zitat von "squisher"

    Allerdings sind in einem neuen Profil die Nachrichten, welche per Pop heruntergeladen wurden nicht mehr vorhanden.

    sagen wir, sie sind noch nicht vorhanden, denn man kann sie ja einfach aus dem alten Profil importieren.
    Aber ich wollte auch damit nur klarstellen, dass das

    Zitat von "squisher"

    Mit dem neuen Profil habe ich noch nicht getestet, da ich dann ja alle bisherigen Nachrichten verliere.

    nicht passieren wird ;)