Programmabsturz beim Speichern bzw. Einfügen von Anhängen

  • Hallo,


    ich habe folgendes Problem:
    Wenn ich eine Mail mit beliebigem Datei-Anhang erhalte und diesen in einen Ordner speichern möchte, stürzt Thunderbird ab. Das Programm stürzt ebenfalls ab, wenn ich eine beliebige Datei der Mail anhänge. Es erscheint entweder das Datei-Auswahl-Fenster und dann passiert nichts mehr, oder das Programm wird beendet und es wird ein Fehlerbericht gesendet. Nach diversen Versuchen geht das Anhängen bzw. Speichern von Anlagen dann wieder eine Weile einwandfrei. Manchmal klappt das Anhängen bzw. Speichern auch sofort und mehrmals hintereinander. Ich habe das Problem schon mit diversen unterschiedlichen Konten untersucht, leider mit dem gleichen Ergebnis. Heute Morgen benötigte ich z.B. 6 Anläufe, um einer Mail eine 87KB große PDF anzuhängen.
    Das nervt auf die Dauer. Da das Problem schon länger besteht, habe ich auf ein Update gehofft, welches vielleicht Abhilfe schafft. Zwischenzeitlich habe ich aber schon 2 Updates aufgespielt und das Problem besteht immer noch.


    Meine Konfiguration:
    Thunderbird 5.0 (aktuelle Version)
    Kontoart POP
    Windows 7 64-bit
    Avira Antivir Premium (Unter Guard/Ausnahmen: Ordner C:\Users\XXXXX\AppData\Roaming\Thunderbird\ und C:\Users\XXXXX\AppData\Local\Thunderbird\ ausgenommen)


    Vielleicht hat noch jemand einen Tipp.
    Vielen Dank vorab.


    Gruß
    Wolfi

  • Hallo woprinz69239,


    als erstes einmal ein Hinweis: Bei AntiVir sollte nicht nur im Guard, sondern zusätzlich auch beim Scanner der TB-Profilordner ausgenommen werden.


    Teste mal im abgesicherten Modus von TB. Vielleicht schießt eine Erweiterung quer.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hallo slengfe,


    danke für Deine Antwort.
    Im Scanner habe ich die Ausnahme auch definiert.
    Wie kann ich in TB im abgesicherten Modus testen? Meinst Du etwa im abgesicherten Modus von Windows?

  • hallo,


    ein Blick in die Anleitung erleichtert die Antwortfindung.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Danke für den Tipp.
    Das Problem besteht leider auch beim Start von TB im abgesicherten Modus.


    Hier habe ich einmal die Fehlermeldung des Fehlerreports welcher nach dem Programmabsturz an Mozilla gesendet wird gepostet:


    AdapterDeviceID: 9715
    AdapterVendorID: 1002
    AvailableVirtualMemory: 1802113024
    BuildID: 20110624125636
    CrashTime: 1311665348
    EMCheckCompatibility: true
    FramePoisonBase: 00000000f0de0000
    FramePoisonSize: 65536
    InstallTime: 1310018520
    Notes: AdapterVendorID: 1002, AdapterDeviceID: 9715, AdapterDriverVersion: 8.801.0.0


    ProductName: Thunderbird
    ReleaseChannel: release
    SecondsSinceLastCrash: 142
    StartupTime: 1311665334
    SystemMemoryUsePercentage: 25
    Theme: classic/1.0
    Throttleable: 1
    TotalVirtualMemory: 2147352576
    URL:
    Vendor:
    Version: 5.0
    Winsock_LSP: AVSDA over [MSAFD-Tcpip [TCP/IP]] : 2 : 1 :
    AVSDA over [MSAFD-Tcpip [UDP/IP]] : 2 : 2 : C:\Program Files (x86)\Avira\AntiVir Desktop\avsda.dll
    MSAFD-Tcpip [TCP/IP] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
    MSAFD-Tcpip [UDP/IP] : 2 : 2 :
    MSAFD-Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
    MSAFD-Tcpip [TCP/IPv6] : 2 : 1 :
    MSAFD-Tcpip [UDP/IPv6] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
    MSAFD-Tcpip [RAW/IPv6] : 2 : 3 :
    RSVP-TCPv6-Dienstanbieter : 2 : 1 : %SystemRoot%\system32\mswsock.dll
    RSVP-TCP-Dienstanbieter : 2 : 1 :
    RSVP-UDPv6-Dienstanbieter : 2 : 2 : %SystemRoot%\system32\mswsock.dll
    RSVP-UDP-Dienstanbieter : 2 : 2 :
    AVSDA : 2 : 1 :


    Diese Meldung enthält Informationen über den Status

  • Okay, dann lege mal ein neues (Test-)Profil an und teste damit. Wenn's dann immer noch ist, liegt's wahrscheinlich nicht an TB.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hi,


    ich habe ein neues Konto angelegt und das Problem besteht auch mit diesem.
    Hast Du vielleicht noch eine Idee, an was sich TB sonst stören könnte?
    Was mich stutzig macht, ist das TB zeitweise einwandfrei funktioniert. Wenn ich das Programm dann wieder schließe und öffne, tritt das Problem dann sehr oft wieder auf.
    Ich habe einmal den AVIRA Virenscanner komplett (Guard/MailGuard/WebGuard) deaktiviert, leider auch ohne Erfolg.
    Wenn ich einmal mehr Zeit habe, werde ich das Windwos Mail-Programm aufspielen und damit testen, ob das Problem hier auch auftritt.

  • Hallo,


    wer hat was von neuem Konto gesagt?

    "slengfe" schrieb:

    dann lege mal ein neues (Test-)Profil an und teste damit.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hi slengfe,


    ich wollte zuerst noch ein neues Konto anlegen und schauen, ob das Problem auch da auftritt.
    Ich habe jetzt einmal ein neues Test-Profil angelegt und auch mit diesem stürzt das Programm wie bisher ab.
    Wie gesagt, wenn ich wieder etwas Luft habe, werde ich das Windows Mail installieren und schauen, ob das Problem hier auch auftritt.

  • Dann bleibt erst mal nur:
    Profil Sichern (auf einen neuen Ort)
    TB komplett deinstallieren
    altes Profil, TB-Verzeichnis in "Lokale Einstellungen\Anwendungsdaten\" löschen
    TB-Verzeichnis im Programm-Verzeichnis löschen


    TB neu installieren


    Testen


    Wenn der Fehler immer noch auftritt, hat Dein Windows eine Macke

  • Okay, dann liegt es offensichtlich nicht an TB. Gehen wir noch mal auf den Virenscanner ein: Darf der das Profil scannen. Hast Du, als Du in deaktiviert hast, so aktiviert, dass er erst gar nicht beim Booten geladen wird? Hast Du den Systemstart (ohne Virenscanner) durchgeführt?


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Da das Problem dann aufzutreten scheint (erster Beitrag), wenn der Datei-Öffnen/Speichern-Dialog benötigt wird und dieser tatsächlich eine Windows-Explorer.Komponente ist, könnte es auch sein, daß in Wirklichkeit nicht TB hängen bleibt, sondern nur auf den hängengebliebenen Explorer wartet.


    Ich würde jetzt erst einmal einen Test im abgesicherten Modus von Windows machen, ob das Problem dort ebenfalls vorhanden ist.
    Weiterer Vorschlag: Wenn du mit mehreren Windows-Konten arbeitest (was sehr löblich wäre, Arbeiten ohne Admin-Rechte, Admin-Konto nur zum Administrieren), wäre auch der Test in einem anderen Konto von Interesse.


    OT slengfe :
    Entweder stimmt deine Signatur nicht mehr oder dein FF bedarf der dringenden Aktualisierung.

  • Hallo,


    ich habe nun folgendes ausprobiert:


    1.) Sauberer Neustart von Windows - > negativ
    2.) Windows im abgesicherten Modus starten -> negativ
    3.) Windows Defender Echtzeitschutz deaktiviert -> negativ
    4.) Aivra Antivir Premium komplett deinstalliert -> negativ


    Als ich Avira wieder installiert habe und die Lizenzschlüsseldatei aus dem Ordner auswählen wollte, stürzte die Installationsroutine von Avira ebenfalls permanent ab. Daraus schließe ich, dass mein Problem kein Problem von Thunderbird ist, sondern ein Windows Problem. Da ich meinen derzeitigen PC erst im Januar diesen Jahres neu gekauft und darauf Windows 7 64-bit installiert und konfiguriert habe, dort sich Avira einwandfrei installieren ließ und Thunderbird ebenfalls keine Probleme bereitete, vermute ich das Problem wurde mit irgendeinem Windows-Update eingeschleppt. Ich werde daher einmal in der Richtung weiter forschen.

  • Einig sind wir uns wohl darin, daß dein Windows einen erheblichen Schaden trägt. Daß ein Windows-Update dafür die Ursache ist, ist dagegen eine Hoffnung, an die sich viele Benutzer in einer solchen Situation klammern, die aber erfahrungsgemäß Exoten-Häufigkeit hat.


    Die Erfahrung und die daraus folgende Wahrscheinlichkeit spricht eher dafür, daß entweder das System einen grundlegenden Defekt hat oder kompromittiert ist; das Avira-Problem weist massiv auf die letztere Möglichkeit hin. Insbesondere ist davon auszugehen, falls du ständig mit dem Admin-Konto arbeitest - wovon ich inzwischen ausgehe, da du auf meine Anregung mit dem zweiten Konto nicht eingegangen bist.


    Im Fall eines Defekts könnte eventuell eine Reparaturinstallation von Windows helfen, im anderen Fall nur eine komplette Neuinstallation. Eventuell ein Sicherheitsupdate (!) zu entfernen, um ein Problem zu lösen ist wie das Abschalten eines Brandmelders im Falle eines Brandes, damit der Warnton den Schlaf nicht so sehr stört :shock: .

  • am besten mal mit einer Boot-CD auf Virenjagd gehen - z.B. von Avira:
    http://www.avira.com/en/suppor…ira-antivir-rescue-system


    da ich nicht genau weiß was noch alles dort dabei ist, man kann ebenfalls INSERT dafür nehmen (wird nicht mehr so gut gepflegt wie damals) das ist eine kleine Mini-Linux-Umgebung mit der man zur Not auch noch die Daten sichern kann, bevor man ggf. neu installieren muss. (für Laien sicherlich nicht unbedingt selbsterklärend und intuitiv aber jemand der auch auf dem Terminal zu Hause ist, die erste Wahl)


    http://www.inside-security.de/insert.html


    Beides sollte man am besten von einem sauberen System herunter laden und das jeweilige ISO dann auch von diesem sauberen System auf CD brennen.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo Thomas,


    sorry, Dein Tipp mit dem neuen Benutzerkonto ging bei mir ganz unter.
    Wie Du schon vermutest, arbeite ich mit nur einem Konto, welches Administratorrechte hat.
    Ich habe nun ein neues Benutzerkonto "Test" angelegt und Thunderbird ausgiebig getestet. Zwischendurch habe ich den PC auch einmal neu hochgefahren und siehe da, der Fehler tritt unter diesem Konto nicht mehr auf.
    Meine Frage, kann mein ursprüngliches Konto wieder "repariert" werden bzw. kann man daraus Rückschlüsse ziehen woran es liegen könnte?

  • Vorneweg: Ich bin nach dem bisher geschriebenen sehr skeptisch, was die Vertrauenswürdigkeit deines Rechners angeht. Das Funktionieren in dem neuen Konto könnte(!) ein Hinweis darauf sein, daß das erste Konto einen Defekt (keine Kompromittierung) hat, es kann aber auch bedeuten, daß der Schädling sich dort erst "einarbeiten" muß.


    Unterstellt es handele sich um einen "einfachen" Kontodefekt: Nein, praktisch gesehen ist eine erfolgreiche Reparatur nicht erfolgversprechend möglich. Schneller und sicherer wäre(!) es, mit seinen Daten in das neue Konto umzuziehen. Da auch das einen nicht zu unterschätzenden Aufwand bedeutet, sollte allerdings erst einmal untersucht werden, ob das System wirklich noch vertrauenswürdig ist. Wenn das in Zweifel steht: Daten sichern, Festplatte formatieren, Windows neu installieren und diesmal gleich ein Standardkonto zum Arbeiten einrichten und verwenden.

  • Hallo Thomas,


    das mein PC durch einen Schädling infiziert worden ist, kann ich nicht zu 100% ausschließen. Ein Suchlauf von Avira war negativ. Ich halte mich grundsätzlich von dubiosen Seiten im Web fern, öffne keine Mails von unbekanntem Absender, installiere alle Sicherheitsupdates von Microsoft und habe diverse AddOns im Firefox installiert wie z.B. NoScript. Aber was ist schon absolut sicher?
    Ich glaube eher daran, daß Windows einen Defekt hat, warum auch immer. Daher werde ich in einer ruhigen Stunde Windows komplett neu aufspielen, auch wenn's verdammt weh tut, da ich mit meinem Rechner meine Brötchen verdienen muß. Dabei werde ich auch Deinen Tipp mit dem Arbeitskonto beherzigen.
    Ich danke Dir und allen anderen Helfern hier im Forum für die kompetete Hilfe.


    Gruß
    Wolfi

  • "woprinz69239" schrieb:

    das mein PC durch einen Schädling infiziert worden ist, kann ich nicht zu 100% ausschließen.


    Gut der Mann(?). Das ist allerdings ein verbreiteter Irrglaube, daß man das könne. Lies dir diesen Artikel - ich verweise insbesondere auf den vierten Punkt - von einem (früheren) MS-Sicherheitsexperten durch, warum das unmöglich ist.


    Im übrigen habe ich nicht behauptet, daß dein Rechner kompromittiert sei - ich müßte denn über einzigartige Fähigkeiten verfügen, wenn ich das aus der Entfernung feststellen könnte -, ich habe aber auf einige Aspekte hingewiesen, warum die Wahrscheinlichkeit dafür nicht gering ist. Dabei bleibe ich.


    Dein sonstiges beschriebenes Vorgehen ist lobenswert, doch leider fehlt das Wichtigste und Effektivste: Der Selbstschutz des Systems durch Rechtetrennung.


    Da du darauf hinweist, daß du deinen Rechner zum Brötchen-Verdienen benötigst: Du wirst sicherlich ein belastbares Backup-Verfahren verwenden,mit dem du regelmäßig deine Daten sicherst? Ein Image-Programm, bei dem sich einzelne Dateien später aus dem Image herausziehen lassen und somit im neuen System verwenden lassen, sollte ebenfalls verwendet werden. Wenn man solche Sicherungen - insbesondere solche aus einem früheren Stadium - aufbewahrt, erspart man sich beim Neu-Aufsetzen des Systems viel Arbeit, weil man dann einfach restauriert.