TB Adressbuch - Kontakte mit Bild editieren

  • Hallo erstmal,
    habe folgendes Problem. Ich habe in meinem Adressbuch viele Kontake, den meisten davon habe ich auch ein Anzeigebild hinzugefügt.
    Will ich nun einen Kontakt edieren geht das nur wenn dieser Kontakt kein Kontaktbild hat, ansonsten lässt sich die Änderung nicht speichern (Klick auf "ok" macht nichts). Lösche ich das Kontaktbild wieder heraus kann ich den Kontakt wieder ganz normal bearbeiten.


    Ich hoffe hier kann mir jemand weiterhelfen, in den weiten des wwws habe ich bisher leider noch nichts hilfreiches dazu gefunden.


    Ich hatte das Problem auch schon unter TB 7.x, leider hat das Updaten in der Hinsicht nichts gebracht.
    An den installierten Add-Ons (Lightning + ThunderBirthDay, Display Contact Photo, MoreFunctionsAddressbook, MyPhoneExplorer zum synchen mit dem Androiden) liegts leider auch nicht, denn selbst nach deaktivieren aller AddOns funktioniert leider nicht.


    mfg Earl


    Thunderbird-Version: 8.x
    Betriebssystem + Version: Windows \ Ubuntu


    Des Rätsels Lösung (auch wenn nicht wirklich zufriedenstellend!:
    Unabhängig vom Betriebssystem kommt es zu dem Fehler sobald das Originalbild, dass einem Kontakt hinzugefügt wurde, nicht mehr vorhanden ist. Wird das Originalbild also nicht gelöscht (unbenannt/verschoben ...) kann der Kontakt auch weiterhin problemlos bearbeitet werden. Wird das Original des Kontaktbildes gelöscht muss wieder das generische Bild verwendet werden.
    Keine zufriedenstellende Lösung, aber ab hier kann wohl nur noch das Mozilla Developerteam etwas unternehmen :nixweiss:

  • Da mir hier scheinbar keiner weiterhelfen kann, gehe ich davon aus, dass außer mir keiner ein derartiges Problem hat?
    Und das Problem somit offensichtlich bei mir liegt und nicht an TB?

  • Hallo HausmeisterEarl


    Ich bin leider erst heute wieder mal ins TB-Forum gekommen. Aber ich habe Dein Probleme bei mir (Icedove 8.0 unter LinuxMint Debian Edition) nachgestellt und kein identisches Verhalten mit Deinem gefunden. Auch nicht, nachdem ich den Rechner ausgeschaltet und nach einer Teepause, ca 5 Minuten neu gestartet habe. alle drei Testmutationen sind perfekt geändert angezeigt worden.


    Schade, aber Du hast wahrscheinlich Recht mit Deiner Feststellung im zweiten Beitrag.

  • "HausmeisterEarl" schrieb:

    Da mir hier scheinbar keiner weiterhelfen kann, gehe ich davon aus, dass außer mir keiner ein derartiges Problem hat?
    Und das Problem somit offensichtlich bei mir liegt und nicht an TB?


    Ich hatte mich seit geraumer Zeit gewundert, warum sich manche Adressbucheinträge editieren lassen, andere nicht. Nach dem Lesen deines Beitrags nochmal getestet, ich kann das von dir beschriebene Verhalten bestätigen.


    Es gab mal Probleme mit der Erweiterung "Display Contact Photo", welche ich nutze und die ab der Version 1.2.4 keine Fotos im Adressbuch mehr anzeigt. Inwiefern das zu dem Verhalten beiträgt weiß ich nicht, ich werde mal, sobald ich etwas mehr Zeit habe, ein bisschen weiter testen.

  • Danke für die Antworten, das Problem besteht aber leider auch weiterhin :-/
    Das Addon "Display Contact Photo" hat keine Einfluss auf das Problem, ich habs eben getestet bei mir.
    Unter Ubunutu habe ich den Fehler auch nicht reproduzieren können, auch nach dem Importieren der Adressbücher liefs dort einwandfrei.
    Bliebe zu testen was passieren würde wenn ich meinen gesammten Profilordner in die Ubuntuversion kopieren würde, aber dass kann ich derzeit nicht testen bzw. würde es mir atm zu lange dauern :nixweiss:

  • Hallo HausmeisterEarl,


    danke für den Hinweis auf diesen Thread, eine Information, die ich aus meinem Chaos hier herüber retten möchte:


    Folgendes konnte ich reproduzieren: Beim ersten Editieren eines Kontakts wird offenbar das lokal gespeicherte Foto im Profileordner gelöscht, was beim zweiten Mal das oben beschriebene Problem hervorruft.


    Man kann außer dem generischen Bild auch ein neues Bild laden und speichern, aber das alte Bild ist nicht mehr auffindbar.


    BTW: Bitte editiere doch mal deinen ersten Post und ändere den Titel auf "TB Adressbuch - Kontakte mit Bild editieren", das ist besser lesbar und aussagekräftiger.

  • So habe den Titel mal aktualisiert ;)


    Was ich vergessen hatte dich im anderen Thread zu fragen:

    Zitat

    [...]das lokal gespeicherte Foto im Profileordner gelöscht[...]


    Wird bei dir wirklich das Bild herausgelöscht? Wenn ich in den Profilordner gehe, sind alle Fotos der Kontakte im Ordner "Photos" enthalten und sie werden auch noch im TB angezeigt (was bei dir dann nicht mehr der Fall sein dürfte?).


    Zitat

    [...]Man kann außer dem generischen Bild auch ein neues Bild laden und speichern[..]


    Diese Methode habe ich gerade ausprobiert und es scheint tatsächlich die (dauerhafte?) Lösung zu sein, zumindest konnte ich einen Kontakt dem ich ein zweites mal ein Kontaktbild hinzugefügt habe, auch nach einem TB-Neustart wieder editieren.

  • Also bei mir kommen die Bilder ja ursprünglich vom iPhone und werden über Google mit Thunderbird synchronisiert. Bei Google ist das editieren der Kontakte mit Foto kein Problem.


    Die Bilder liegen bei mir tatsächlich aber mehrfach im Profilordner von TB und das jeweils zugewiesene Bild wird beim Speichern wirklich gelöscht, deshalb geht das erste Speichern. Beim erneuten Öffnen des Kontakts wird das Bild zwar noch angezeigt, aber die Datei existiert nicht mehr und deshalb geht das Speichern auch nicht mehr. Ich kann dann ein neues Bild zuweisen (von den mehrfach vorkommenden), aber das Spiel wiederholt sich mit jedem Speichern des Kontakts.

  • Damit wäre das Thema wohl erledigt. Ich habe meinen ersten Beitrag um die gesammelten Informationen ergänzt.


    Also bleibt nur noch offen den Thunderbird Support auf die Nerven zu gehen, damit möglichst schnell ein Bugfix geliefert wird :mrgreen:

  • Nun, als erledigt würde ich den Thread nicht bezeichnen, da er ja eine Lösung schuldig bleibt. Lass den Thread doch einfach offen stehen...


    BTW: Hast du den Fehler in Bugzilla gepostet?

  • Hallo Zusammen,


    habe das selbe Problem, wäre allerdings nie auf die Idee gekommen, dass dies mit den Bildern zusammenhängt.


    Eine Lösung ist das zwar nicht aber so kann man das Symptom bekämpfen :) 
    Danke.


    Gruß Tifi