Sammeln trotz mail.collect_email_address_incoming = false

  • Thunderbird-Version: 9.01
    Betriebssystem + Version: Windows XP SP 3
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX):1und1


    Alle Adressen von ankommenden Mails werden bei mir in "Persönliches Adressbuch" gesammelt, was zur Folge hat, dass sich dort im Laufe der Zeit viel Müll ansammelt, weil man viele dieser Adressen ohnehin nicht benutzen kann (z.B. Newsletter). Es spielt dabei keine Rolle, ob "mail.collect_email_address_incoming" auf "false" steht oder überhaupt nicht vorhanden ist- ich kann Thunderbird das Sammeln der nutzlosen Adressen nicht abgewöhnen.


    Wie kann ich das erreichen? Mit einer Lösung, dass die Adressen in "gesammelte Adressen" abgelegt werden, könnte ich auch auskommen, denn "gesammelte Adressen" liegt am Ende der Adressbuch-Sortierung, die sinnlosen Adressen würden nicht bei jedem Neuöffnen des Adressbuches als erstes angezeigt und hin und wieder könnte ich dessen Inhalt löschen.

  • Hallo ebuerjes und willkommen im Thunderbird-Forum,


    es gibt dafür in den Einstellungen eine Möglichkeit, das auszustellen und auch das Adressbuch festzulegen. Den genannten Conifg-Eintrag kenne ich nicht, daher kann ich dazu keine Aussage machen.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hallo,


    die Einstellung, die slengfe meint, befindet sich unter Verfassen -> Adressieren (dort kann auch das Adreßbuch festgelegt werden, in dem gesammelt wird - und standardmäßig ist hier "Gesammelte Adressen" (sic) eingestellt; da wurde also etwas geändert.
    ABER
    das bezieht sich auf gesendete Mails. Auch kenne ich mail.collect_email_address_incoming nicht, wohl aber mail.collect_email_address_outgoing (das entspricht der genannten Einstellung). Ich kenne auch das beschriebene Verhalten nicht und könnte dem auch nichts abgewinnen, denn dann würden alle Absendeadressen von Spammern in dem Adreßbuch landen. Ob dieser Konfigurationswert überhaupt von TB beachtet wir, weiß ich nicht; in jedem Fall muß er entweder manuell oder durch eine Erweiterung angelegt worden sein.


    Teste das Sammeln mal im abgesicherten Modus von TB.

  • "Cosmo" schrieb:

    ABER
    das bezieht sich auf gesendete Mails.


    Ups, Du hast natürlich völlig recht. :redface:


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hallo graba,


    genau das hab' ich ja gemacht. Die Forum-Plattform hat in meiner Anfrage nur das "e" von "false" abgeschnitten und ich habe es nicht bemerkt.


    Also: mail.collect_email_address_incoming steht auf "false".
    mail.collect_email_address_outgoing übrigens auch.

  • "graba" schrieb:

    teste mal das Verhalten im Safe-Mode (--> Abgesicherter Modus).


    Wie ich gestern bereits schrieb. Lesen muß man es, machen muß man es und darüber berichten muß man es.


    Darüber hinaus frage ich mich, woher die incoming-Anweisung stammt (egal mit welchem Wert und ob sie überhaupt beachtet wird), vom Benutzer oder von einer anderen Ursache, zum Beispiel Erweiterung?

  • Hallo Leute, alle zusammen,


    ich hab' die Ursache rausgefunden. Ist aber für heute Nacht zu kompliziert zu erklären. Erläuterung kommt morgen. Vielen Dank an alle, dass Ihr so viele Anregungen gemacht habt.


    Nur soviel noch: mit Safe-Mode hatte das nichts zu tun. Die incoming-Anweisung habe ich vor Wochen schon selbst eingegeben, auf einen Ratschlag hin aus einem anderen Forum und ist in Punkt 7 der Anleitungen "Konfig-Tipps - spezielle manuelle Anpassungen" erlätert.


    Schönen Sonntag
    ebuerjes

  • Das ist ja fast wie Weihnachten: Noch einmal schlafen, dann gibt es die Geschenke. :biggrin:

  • Hallo Leute,


    ich habe noch ein paar Versuche anstellen müssen. Hier meine Ergebnisse:


    1. mail.collect_email_address_outgoing funktioniert.
    true: Adresse nach "gesammelte Adressen"
    false: Adresse wird nicht gespeichert
    2. mail.collect_email_address_incoming ist wirkungslos- egal ob false oder true.
    3. Von Mails ohne externe Inhalte wird keine Adresse nirgendwohin gespeichert.
    Von Mails bekannter Absender mit externen Inhalten ebenfalls nicht. (Die Adresse gibt
    es ja schon im Adressbuch)
    Bei Mails mit unbekanntem Absender mit externen Inhalten hat man zwei Möglichkeiten:
    A: Klicken auf "Externe Inhalte anzeigen": Dann wird diese Mail mit allem Drum und Dran angezeigt,
    kein Eintrag im Adressbuch.
    B: Klicken auf "Externe Inhalte von [absender] immer anzeigen": Dann öffnet sich
    das Eingabefenster für einen Neuen Kontakt. Oben kann man mit einem Pulldown-Menü das
    Adressbuch auswählen (steht leider standardmässig auf "Persönliches Adressbuch", unten gibt es
    eine Checkbox zum Zulassen/ Ablehnen der externen Inhalte.


    Mein Fehler war, dass ich dieses Eingabefenster immer unreflektiert und unbesehen abgenickt habe,
    und schon war wieder eine nutzlose Adresse in meinem "Persönlichen Adressbuch" gelandet.
    Tja- selbst lesen können schütz nicht vor Torheit- man muss es auch tun!


    Nochmals Danke für die rege Beteiligung
    ebuerjes

  • Hallo ebuerjes,


    danke für die Info. Das hilft mir sehr weiter. Endlich weiß ich, woher die Adresssammlung kommt, welche ich doch in den Einstellungen unterbunden habe.
    Allerdings gibt es nun bei mir eine Schwierigkeit, daß sich kein Popup-Fenster öffnet und ich somit keine Einstellung vornehmen kann. Ergo wird jedes mal beim Klicken auf "Externe Inhalte von .... immer anzeigen" die Adresse in Gesammelte Adressen gespeichert.


    Weiß vielleicht jemand Rat?


    Danke
    Schnulli


    PS: TB 13.0.1, IMAP, T-Online.