Zeichenkodierungen

  • Thunderbird-Version:
    Betriebssystem + Version:
    Kontenart (POP / IMAP):
    Postfachanbieter (z.B. GMX):


    Ich erhalte e-mails mit anderen Zeichenkodierungen als ich für mich gespeichert habe - 'Westlich 8859 1. Dann muss ich über "Ansicht" eine andere Kodierung wählen - meistens UTF 8 - um alles lesen zu können. Der Ausdruck und die Weiterleitung kommt wieder in der ursprünglichen Form.
    Wie kann ich das so regeln, dass das nur in meiner Kodierung heraus kommt?

  • Hallo willi 1,


    und willkommen im Forum!


    Garnicht! In der Regel wird die Kodierung beim Sender entschieden und nicht beim Empfänger. Oder richtest Du Dich beim Senden Deiner E-Mails und fragst Deine Empfänger, mit welcher Kodierung Du ihnen Deine E-Mails schicken sollst?


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Nein, aber es gab bei der Einrichtung mal einen Button "Fremde Kodierung zulassen?". Der ist weg.
    Ich hoffte, das Programm stellt automatisch um auf meine Kodierung.


    Aber warum druckt es nicht die umgestellte Version aus, sondern nimmt die alte?

  • Hallo,

    Zitat

    Ich erhalte e-mails mit anderen Zeichenkodierungen als ich für mich gespeichert habe - 'Westlich 8859 1.


    Ich auch, sind die Mails richtig deklariert, ist das für Thunderbird kein Problem, er ändert dann automatisch in der
    Ansicht, Zeichenkodierung auf den in der Mail deklarierten Zeichensatz um.
    Das klappt solange die Deklarierung korrekt ist und du TB so eingestellt hast, dass dieses das auch automatisch machen kann.
    Überprüfen kannst du das leider nur hier:
    erweiterte Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten")
    suche den Eintrag mailnews.force_charset_override, ob dieser auf "false" steht.
    Vorsichtshalber sollte man dann noch die betreffenden Ordner mit Rechtsklick überprüfen, ob dort unter Eigenschaften, Allgemein am zweiten Kästchen nicht fälschlicherweise ein Haken gesetzt ist.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Oh sorry,
    das war unklar von mir formuliert.
    Nein, es muss auf "false" stehen.
    denn bei mailnews.force_charset_override
    möchtest du ja nicht, dass TB den von dir eingestellten Zeichenkodierung die des Versenders überschreibt.
    Heißt: wenn der Versender in UTF-8 versendet hat, dieses richtig deklariert hat, aber Thunderbird durch die Einstellung auf "true" die Mail in Westlich 8859-1 darstellt, kann sie nicht richtig dargestellt werden.
    Das ist in deinem Fall also falsch eingestellt.
    In früheren Versionen gab es für diese Einstellung einen Menüpunkt. Da viele User sich aber so Thunderbird unwissend verstellt hatten und viele Mails dann unlesbar waren, hat man diese Option versteckt.
    Wurde allerdings das Profil bei Updates nie neu erstellt, bleibt die ursprüngliche (falsche) Einstellung dann bis heute erhalten.
    Die default Einstellung ist "false". Du kannst sofort erkennen, ob du eine originale Einstellung geändert hast:
    alles was dort fett geschrieben ist, wurde vom User (oder von einem Add-on) verändert.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • noch eins zur vorsorglichen überprüfung der ordner:


    wenn ich "Posteingang" (und "Gesendet") rechts anklicke, auf Eigenschaften gehe, erscheint unter 'Allgemein' nur 1 Kästchen. text: Standard allen Nachrichten im Ordner zuweisen. (Individuelle Zeichenkodierung und autom. Bestimmung werden ignoriert).


    Da war ein Haken. Den habe ich jetzt gelöscht. Oder gibt es ein anderes Fenster mit 2 Kästchen?

  • Das hast du richtig gemacht.

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw