Signatur - Leerzeichen vor Sonderzeichen

  • Hallo Alle,
    bin mit Thunderbird super zufrieden, aber ein Problemchen habe ich leider.
    In der Signatur wird das Leerzeichen vor dem "&" nicht angezeigt was natürlich sehr schlecht ist.
    Wenn ich die Email schreibe sieht alles schön aus:


    Beispiel:


    Katja & Klaus
    Streberstr.


    Beim Empfänger kommt aber an:



    Katja& Klaus
    Streberstr.


    Kann mir dabei jemand weiterhelfen?


    Liebe Grüße


    Chris


    Thunderbird-Version 10.0.2:
    Betriebssystem Win7:
    Kontenart POP:
    Postfachanbieter eigener Hoster:

  • Hallo!
    Es gibt ja 4 Möglichkeiten, eine Signatur hinzufügen, welche hast du verwendet?


    Signatur direkt in die Konteneinstellungen eingeben
    als
    1) Reintext
    2) Formatiert (HTML)
    als
    3) Externe *.txt Datei
    4) Externe *.html Datei


    Bitte habe Verständnis, dass ich nicht alle Möglichkeiten testen möchte.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Vielen Dank für die Antwort, bzw. die Nachfrage...
    Ich habe es als Reintext ohne Formatierung in den Einstellungen eingetragen.
    Habe gerade auch als Datei als Signatur anhängen versucht (.txt)
    und ist leider das selbe Ergebnis.

    Einmal editiert, zuletzt von CybernooN ()

  • Hi,


    und genau das habe ich gerade mal getestet: Darstellung exakt so, wie es in der Textdatei steht.


    Gibt es Unterschiede bei den Empfängern (bei allen Empfängern? Betriebssystem, Mailclient)?
    Wie sieht es im Quelltext der gesendeten und der empfangenen Mail aus?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Ich habe mir erlaubt, das unnütze Vollzitat zu löschen.
    Mod Pe_e


    Verschicke mir die Email an einen Googlemailaccount und auch auf einen privaten Hoster...
    Bei beidem der gleiche schlechte Erfolg.
    Aufgefallen ist mir es auch nur wenn mir die Leute auf meine Email antworten. Daher wollte ich mich heute mal damit befassen.

  • Und was sagt der Quelltext der gesendeten und der empfangenen Mail?


    Ich weiß nicht, ob es was bring, aber es kost ja nix: Mal das Sonderzeichen "maskieren" => ein "/" oder auch mal ein "\" unmittelbar davor setzen. Ist wie gesagt, nur ein Versuch.


    Noch eine Frage: Die Textdatei ist wirklich mit einem Texteditor und nicht etwa per Word erstellt und dann nur als .txt abgespeichert worden?

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Der Quelltext der gesendeten Mail ist:
    Katja& Klaus
    Streberstr.


    Also klar, dass es dann auch so ankommen muss.
    Katja /& Klaus - Das ist dabei raus gekommen.
    Und ja ich nehme einen "echten Texteditor" bzw. Das Eingabefeld in den Einstellungen...

  • Dann muss ich an der Stelle leider passen ... .

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Vom Notebook aus mit Thunderbird genau das gleiche.
    Ich bin ratlos. Die einzige Idee die ich jetzt noch habe, die Sache als html abzuspeichern.


    Nachtrag: als html abspeichern funktioniert es. Es soll aber auch als Reintext ohne Formatierung funktionieren.
    Jetzt fehlt mir wieder der Zeilenumbruch... aber das würde ich sicherlich hinbekommen

    Einmal editiert, zuletzt von CybernooN ()

  • Schuss ins Blaue: Vielleicht stört eine Erweiterung. Versuch's mal im Safe-Mode.

  • Wow, ist ja schon ewig ein Bug...
    Das ist aber echt schlecht :stupid:


    Naja, als html abspeichern und das wars dann, man muss halt hinter jeder Zeile ein <br> setzen

  • In bug Bug 448198 ist ein Workaround genannt:


    Zitat von "Eric Blake 2012-02-10 07:54:46 PST"


    Here is a thunderbird extension from Paolo Bonzini that you can install into "~/.thunderbird/<profile name>/extensions" while waiting for this bug to ever get fixed:


    http://people.redhat.com/pbonzini/format-flawed.tar.gz
    "It just disables format=flowed when replying to non-format=flowed messages. It's ugly as hell, but it does the job."


    oder halt, wie in 541978 beschrieben, f=f komplett deaktivieren:


    Zitat von "rsx11m 2010-02-08 07:41:19 PST"

    Thanks for adding this. Thus, disabling mailnews.send_plaintext_flowed in the Config Editor should suppress the issue (go into Tools > Options > Advanced > Genral tab, click on Config Editor, then copy-paste the preference name into the search bar. Double-click on the remaining entry to set it to "false" and then try again). This makes the formatting less nice but should serve as a workaround until the respective serializer bugs are resolved.

    Einmal editiert, zuletzt von SusiTux ()

  • Hallo zusammen,


    den Fehler kann ich nicht feststellen!


    Signatur mit notepad.exe erstellt, email mit aol.com gesendet auf t-online.de und yahoo.de, das Leerzeichen vor dem & bleibt erhalten!


    Vielleicht kann das bitte jemand überprüfen!


    Gruß Herbert


    PS Email erstellt in Reintext

  • Hallo,
    auch bei mir tritt der Bug weder in TB 10.0 noch 11.0 auf.
    Win XP.
    Er tritt vermutlich nur unter bestimmten Umständen auf (Add-on, Theme, Betriebssystem usw.).


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    Zitat von "mrb"

    Er tritt vermutlich nur unter bestimmten Umständen auf


    ja, laut der Beschreibung in bug 448198 bei Reintextnachrichten dann, wenn man auf eine Nachricht, die nicht mit format=flowed (!(f = f)) formatiert wurde, in format=flowed (f = f) antwortet.


    Gut möglich, dass Erweiterungen/Themes da auch reinspielen können. Ich würde auf jeden Fall mal im Safe-Mode testen.



    Gruß


    Susanne

  • Hallo,
    ja, aber der Fragesteller schreib nichts von einer Antwort, sondern einer neuen Mail.
    Dann dürfte dieser Bug nicht auf ihn zutreffen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Was passiert eigentlich, wenn zwei Leerzeichen vor dem "&" in der Signatur stehen?

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!