Streikt Thunderbird bei zwei Unterschrift-Zertifikaten?

  • Thunderbird-Version: 10.0.2
    Betriebssystem + Version: Linux Ubuntu 11.10
    Kontenart (POP / IMAP): IMAP
    Postfachanbieter (z.B. GMX): privat
    SMIME oder PGP:SMIME


    Ich habe mir nach Anleitung (http://www.thunderbird-mail.de…l%C3%BCsselung_mit_S/MIME) ein Unterschrift-Zertifikat für zunächst eine E-Mail-Adresse erstellt. Dies lief problemlos. Einige Tage später installierte ich ein zweites Zertifiat für eine zweite Mail-Adresse. Beim Versenden von E-Mails ist mir aufgefallen, dass E-Mails von der ersten Mail-Adresse einen Fehler zeigen: "Die E-Mail-Adresse im Zertifikat stimmt nicht mit jener Adresse überein, von der aus die Nachricht geschrieben wurde". Die E-Mails aus den zweiten Zertifikat sind fehlerfrei.


    Problem: Unter Konten-Einstellungen - S/MIME-Sicherheit kann ich unter Auswählen stets nur das Zertifikat für die zweite Mail-Adresse ändern, für die erste wird mir das Zertifikat nicht angezeigt, obwohl es unter "Zertifikate verwalten..." - "Ihre Zertifikate" enthalten ist.


    Frage: Weshalb lässt sich unter Konten-Einstellungen - S/MIME-Sicherheit nicht das erste Unterschrift-Zertifikat auswählen? Ist das ein Bug in Thunderbird oder habe ich was Falsch gemacht?

  • Hallo sdw934jy92a,


    ja, ich kann dieses von dir beschriebene Problem im Zusammenhang mit Zertifikaten vom TC Hamburg bestätigen. Es gibt dazu auch bereits einige ältere Threads im Forum. Suche bitte mal in der Forensuche nach "s/mime zwei Zertifikate".


    Ich selbst nutze ein gekauftes Zertifikat und insgesamt 12 Zertifikate meiner eigenen "Privat-CA". Bei keinem der Zertifikate tritt dieses Problem im Thunderbird auf.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,

    Zitat von "Peter_Lehmann"


    ja, ich kann dieses von dir beschriebene Problem im Zusammenhang mit Zertifikaten vom TC Hamburg bestätigen.


    ich schließe mich der Bestätigung an. Allerdings lassen sich aufgrund von kleinen "Manipulationen" durchaus mehrere Zertifikate o. g. Firma einsetzen: :arrow: Re: TB 3.0 nutzt falsches S/MIME Zertifikat
    Ob dies allerdings im Sinne des Erfinders ist... :gruebel:

  • Zitat von "Peter_Lehmann"

    Hallo sdw934jy92a,
    ja, ich kann dieses von dir beschriebene Problem im Zusammenhang mit Zertifikaten vom TC Hamburg bestätigen. Es gibt dazu auch bereits einige ältere Threads im Forum. Suche bitte mal in der Forensuche nach "s/mime zwei Zertifikate". Ich selbst nutze ein gekauftes Zertifikat und insgesamt 12 Zertifikate meiner eigenen "Privat-CA". Bei keinem der Zertifikate tritt dieses Problem im Thunderbird auf.


    Dann liegt das Problem wohl eher beim Trust Center Hamburg? Meinst Du mit Privat-CA selbst erstellte digitale Unterschriften? - Das würde mich auch interessieren. Welche Anleitung sollte ich dazu am besten zuerst darüber lesen?