Umwandlung des €-Zeichens in das ¤-Zeichen

  • Thunderbird-Version: 16.0.1
    Betriebssystem + Version: Windows XP Home SP 3
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): Strato


    Hallo,


    ich habe folgendes Problem: Ich habe den Entwurf für eine abzusendende E-Mail im Ordner "Entwürfe" abgespeichert. Der Text enthält an verschiedenen Stellen das €-Zeichen. Wenn ich den Text später wieder aufrufe, um daran weiterzuschreiben, sind alle €-Zeichen in das ¤-Zeichen umgewandelt. Wie kann ich dies vermeiden?


    Gruß feuerfelix

  • Hallo,
    anscheinend benutzt du einen Zeichensatz (=Zeichenkodierung), in der das €-Zeichen nicht vorhanden ist.
    Poste mir mal, welche Zeichenkodierung du für das Senden verwendest Extras > Einstellungen > Ansicht > Formatierung > Erweitert
    Dann überprüfe im Entwurf unter Ansicht > Zeichenkodierungen was dort gerade angezeigt wird.
    Ist das unterste Kästchen angehakt?
    Rechtsklick auf den Ordner Entwürfe > Eigenschaften , welches Kästchen ist dort angehakt?
    In der
    erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten")
    suche den Eintrag mailnews.force_charset_override , welchen Wert hat dieser?
    Hattest du die Mail neu entworfen oder sind Teile einer empfangenen Mail darin?


    Gruß


    Kann erst spät am Abend wieder antworten

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo, mrb,


    sowohl für ein- als auch für ausgehende Mails ist unter Einstellungen die Zeichenkodierung "Westlich (ISO-8859-15)" eingestellt.
    Im Ordner Entwürfe ist unter "Eigenschaften" das Kästchen für "Standard allen Nachrichten im Ordner zuweisen (individuelle Zeichenkodierung und autom. Bestimmung werden ignoriert)" nicht angehakt.


    mailnews.force_charset_override hat den Wert "false".


    Die Mail habe ich selbst entworfen ohne Fremdtext.


    Gruß feuerfelix

  • Einen vergessen hatte mich aber auch falsch ausgedrückt:


    Überprüfe im Entwurfsordner unter Ansicht > Zeichenkodierungen, was dort gerade angezeigt wird.
    Also dort die Mail markieren und dann unter Ansicht nachschauen.
    Oder den Entwurf öffnen und unter Optionen > Zeichenkodierung den Eintrag ablesen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo, mrb,


    im Entwurfsordner wird unter Zeichenkodierung "Westlich (ISO-8859-1)" angezeigt.


    Gruß feuerfelix

  • Eigentlich enthält Westlich (ISO-8859-1) nicht das €-Zeichen, aber mich wundert, dass Thunderbird dieses nicht automatisch korrigiert (müsste auf windows-1252 ändern).
    Ändere mal auf ISO-8859-10 oder auf UTF-8. Bleibt dann das Problem?
    Außerdem ändere unter Ansicht > Zeichenkodierung > auf "automatisch bestimmen" > "universell".
    Untersuche mal den Quelltext (Strg+U) der versendeten Mail, welche Zeichenkodierung genommen wird.
    Ursache könnte u.a. dein altes Betriebssystem sein. Daher haben weitere Tests hier auf Win7 keinen Zweck.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo, mrb,


    die Zeichenkodierung "Westlich ISO-8859-10" bietet mir TB nicht an, aber "Westlich ISO-8859-15". Wenn diese Kodierung gewählt wird, wird das €-Zeichen korrekt angezeigt.
    "Unicode (UTF-8)" wandelt das €-Zeichen dagegen in das ¤-Zeichen um.


    Wenn ich die Mail verschicke, zeigt mir der Quelltext das ¤-Zeichen an, obwohl angegeben wird "charset=ISO-8859-15". Die empfangene Mail wiederum zeigt das €-Zeichen korrekt an.


    Gruß feuerfelix

  • Nein nein, ich meinte ISO-8859-15.
    Werde das gleich in meinem Beitrag ändern.

    Zitat

    Wenn diese Kodierung gewählt wird, wird das €-Zeichen korrekt angezeigt.
    "Unicode (UTF-8)" wandelt das €-Zeichen dagegen in das ¤-Zeichen um.


    UTF-8 enthält alle Zeichen.
    Ich vermute einen Konflikt zwischen 16.0 und Windows XP. Die scheinen nicht mehr zusammenzuarbeiten.
    Ich kann dir leider keine Lösung anbieten - außer auf eine Uraltversion etwa 3.0 zurückzukehren - da ich mit XP nicht mehr arbeite.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:


    Ich vermute einen Konflikt zwischen 16.0 und Windows XP. Die scheinen nicht mehr zusammenzuarbeiten.


    Hallo :)


    das kann ich hier nicht bestätigen und widerspricht auch den offiziellen Systemvoraussetzungen. Btw, dabei frage ich mich, warum das SP2 noch unterstützt wird.


    Zitat


    Ich kann dir leider keine Lösung anbieten - außer auf eine Uraltversion etwa 3.0 zurückzukehren


    Wenn schon, dann würde ich statt einer mehr als angestaubten 3er die aktuelle ESR empfehlen.


    Zitat


    da ich mit XP nicht mehr arbeite.


    Aber ich ;)


    Gruß Ingo

  • schlingo ,
    ich meinte nicht unbedingt einen generellen Konflikt. Ich weiß nur, dass sich nach einigen Jahren Benutzung nach und nach selbst "auflöste", und immer mehr Sachen nicht mehr liefen. Es genügt dabei ein winziger Fehler in den Zeichensätzen von Windows und sofort klappen diese auch nicht mehr in Thunderbird.
    Auch wenn ich die alte v. 3.0 noch hätte, könnte ich vermutlich nicht helfen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw