Hilfe, kein Zugriff auf lokale Mails [erl.]

  • Thunderbird-Version 3.0.1:
    Windiws 7, SP1:
    Kontenart: POP:
    Postfachanbieter: GMX:


    Hallo,


    nach einem Systemausfall habe ich den TB notgedrungen neu installieren müssen (wie auch den kompletten Rest der Kiste).
    Meine gesamten Mails hatte ich auf einem NAS im Heimnetzwerk liegen.
    Ich habe dann zwischenzeitlich auch das alte Profil aus dem "Windows.old"-Ordner in den aktuellen AppData\Roaming\TB kopiert. Es sind auch die alten "Pfade in den Einstellungen sichtbar:
    Server-Einstellungen: N:\...\thunderbird\local folders\pop.gmx.net
    Lokale Ordner: N:\...\thunderbird\local folders
    Nur zeigt er mir weder die alten Ordner an noch lädt er die Mails.
    Ich hab jetzt 2 Stunden mit dem TB gekämpft und dementsprechend völlig genervt. :wall: 
    Wäre schön, wenn mir jemand auf die Sprünge helfen könnte und mir sagen kann, wie ich meine alten Ordner mit den Mails wieder bekomme.


    Viele Grüße


    Durion

  • Hallo Durion und willkommen im Thunderbird-Forum,


    bist Du sicher, dass Du das Profil- und nicht einen Systemordner kopiert hast? Soweit ich mich erinnere ist im Ordner Windows.old das Altsystem gespeichert. Aber es kann sein, dass ich mich irre.


    Überprüfe, ob Du vielleicht zwei Profilordner hast. Starte den Profilmanager und lege ein neues Profil an. Du findest dabei eine Schaltfläche "Ordner wählen". Wenn Du da drauf klickst und den alten Profilordner auswählst, verbindet TB das neu angelegte Profil mit diesem.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hallo Durion


    und willkommen im Thunderbird-Forum!


    Erkläre doch bitte mal genauer, was du wie auf den NAS ausgelagert hast, wie bist du genau vorgegangen, welche Pfade hast d wo geändert?

    "Durion" schrieb:

    Server-Einstellungen: N:\...\thunderbird\local folders\pop.gmx.net
    Lokale Ordner: N:\...\thunderbird\local folders


     :?:



    Btw:

    "Durion" schrieb:

    ....habe ich den TB notgedrungen neu installieren müssen...Thunderbird-Version 3.0.1:

    damit hast dir eine uralte, mit Sicherheitslücken und Fehlern bewehrte Version neu installiert..
    Oben per Button "Herunterladen" findest du die aktuellen Versoinen 10.x esr und 16.x

  • Der Grund für den Systemausfall? Die Existenz des Ordners Windows.old zeigt an, daß du die Festplatte nicht neu formatiert hast. Es ist also möglich, daß das für den Ausfall ursächliche Problem noch Nachwirkungen zeigt.

  • Hallo,


    den Grund für den Systemausfall kann ich leider nicht genau spezifizieren. Dazu müßte ich schauen, ob er irgendwo die Dumps abgelegt hat. Ich hatte damals keine Lust, die Dinger durchzusuchen. Ich hab das C-Laufwerk damals absichtlich nicht formatiert, da ich noch einige historische Ordner darauf liegen hatte und nicht die Zeit hatte, das auszusortieren.


    Zu den Pfaden: Ich habe ein NAS im LAN, was ich über ein Script auf den LW-Buchstaben N mappe. Damit taucht es im Explorer wie jedes andere Laufwerk auch auf. Bei der Profil-Konfiguration des TB habe ich einfach einen Ordner auf dem NAS ausgewählt. Da gibt es ja die 2 Menus ( Server-Einstellungen bzw. Lokale Ordner), dort hab ich das eingestellt. Hätte auch d:\TB oder c:\temp nehmen können, aber seit einem HW-Crash mit Totalverlust habe ich alle wichtigen Daten auf redundaten Platten liegen (also nicht mehr auf c oder d...).


    Der kopierte Ordner stammt aus AppData\Roaming\TB\Profiles...


    Gruß


    Durion

  • Hallo Durion,

    "slengfe" schrieb:

    Überprüfe, ob Du vielleicht zwei Profilordner hast. Starte den Profilmanager und lege ein neues Profil an. Du findest dabei eine Schaltfläche "Ordner wählen". Wenn Du da drauf klickst und den alten Profilordner auswählst, verbindet TB das neu angelegte Profil mit diesem.


    was ist damit?


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hallo,


    da

    "Durion" schrieb:

    Bei der Profil-Konfiguration des TB habe ich einfach einen Ordner auf dem NAS ausgewählt. Da gibt es ja die 2 Menus ( Server-Einstellungen bzw. Lokale Ordner), dort hab ich das eingestellt.

    liegt vermutlich der Haken.
    Nach dem Neuaufsetzen passen wahrscheinlich die Pfade nicht.
    Es ist nicht sinnvoll, auf diese Weise das Profil zu zerreißen, besser ist es, mit dem Profilmanager das gesamte Profil zu verlegen. Im Systemordner bleibt dann nur die profiles.ini, in der TB den Pfad zum Prfoil ablegt.
    Siehe dazu in der Anleitung denArtikel Profile verwalten.

  • Hi,


    nein, ich hatte nur einen Profilordner, habs geprüft.


    So. der nächste Schritt:
    Wenn ich die alten Dateien Trash + Trash.msf in das aktuelle Profil ins Verzeichnis pop.gmx.net kopiere, kann er damit was anfangen, ich sehe meinen Mülleimer (circa 100 MB).
    Wenn ich das gleiche mit der alten "Inbox mache, dann sehe ich die Mails, die noch in der Inbox rumlagen, das sind so 20 Stück. Die Datei "Inbox" ist aber knapp 700 MB groß, so das ich vermute, das dort auch die Mails drinstecken, die ich in einer separaten Ordnerstruktur abgelegt hatte. Wie komme ich da wieder dran?
    Auf meinem NAS gibt (oder gab) es nur einen Ordner "Lokale Mails" und dort drin die lokale Ordnerstruktur mit mehrere Ebenen. Allerdings finde ich dazu keine .msf-Dateien o.ä. sondern lediglich Ordner.sbd-Verzeichnisse.


    Ach ja, noch eine Anmerkung. Ich habe mich seit der Version 1.x durch alle Versionen gearbeitet, also so grob seit 10 Jahren. Und genauso lange lief das ganse System völlig problemlos. Sogar als ich immer mal wieder neue Rechner bekommen habe. Rechner neu installiert, Pfade geändert, Glücklich gewesen. Bis jetzt!


    Update:
    Ich habe noch eine alte Version meines TB-Ordners im Backup gehabt und darin befanden sich die benötigten .msf-Dateien, so das meine Ordnerstruktur und die darin befindlichen Mails zumindest teilweise schon mal wieder da sind. Tja, aber leider nur "FAST" alle. Es gab einen alten Ordner, der dummerweise "Inbox" hies.
    Meine Inbox.msf ist 660 MB groß, kopiere ich sie nach pop.gmx.net, dann kann ich die 23 Mails lesen, die noch im Posteingang lagen (Anhänge: 12 MB). Kopiere ich sie nach local Folders, sehe ich nix. Wie komme ich denn jetzt an die Mails die dort drin lagen?


    Gruß


    Durion

  • Hallo Durion,


    wenn Du eine MBox-Datei hast, kannst Du sie mit der Erweiterung ImportExportTools wieder importieren.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hallo,


    wie genau gehst Du vor? Öffne die Datei mit einem Editor Deines Vertrauens und schaue nach, ob Du den Inhalt lesen kannst. wenn ja gut, wenn nein sind die Daten verloren.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hi,


    ich hatte mal versucht mit Wordpad die Datei zu öffnen, sie ging auf und ich konnte auf der ersten Seite eine Mail sehen.
    Weiterblättern ging dabei allerdings nicht mehr, da machte WP als Editor schlapp. Ich schau nochmal mit einem anderen Edotir, was da sonst noch drin ist.
    Kann es ein Problem damit geben, das die alte Offline-Mbox damals "Inbox" hiess? Der TB weigert sich beharrlich mir einen OFFline-Ordner mit diesem Namen anzuzeigen, sondern bindet den Offlineordner "Inbox" als "Posteingang" ein.


    Gruß


    Durion

  • Hallo,


    die Namen INBOX und Posteingang sind Synonyme und letzterer nur die Darstellung in TB. Die Datei sollte INBOX heißen.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hi,


    ich hab jetzt die Datei "Inbox" (660MB) mit jujuedit (danke für den Tip) aufgemacht.
    Da sind alle gesuchten Mails drin. Ich hab mal spordisch nach einem Absender gesucht, den ich definitiv nur in dem gesuchten Ordner abgelegt hatte. Da sind alle dazu gehörenden Mails.


    Wenn ich diese Datei importiere oder auch einfach in pop.gmx.net schiebe, zeigt er mir immer nur die 25 Mails an, die damals in der Thunderbird-Inbox lagen. Aber nicht die anderen zahllosen Mails, die in dem Offline-Ordner "Inbox" lagen. Zugegebn die Namensdopplung war bescheuert. Wie heisst es immer so schön: historisch gewachsen. ;)


    Ich habe mal ein neues Profil angelegt und die "Inbox" da rein importiert. Ändert sich auch nichts.
    Nachdem er lange arbeitet, um die Datei zu importieren, taucht plötzlich ein Ordner auf der Inbox 537 o.ä. heisst. Klicke ich drauf, läuft unten "Zusammenfassung erstellen" los und braucht relativ lange. So als würde er jetzt wirklich versuchen, die Datei darzustellen. Am Ende klicke ich drauf und er zeigt mir die oben genannten 25 Mails, aber nicht den Rest.


    Hab den TB auf Version 17 geupdated, hat aber nicht geholfen. :(


    Gruß


    Durion

  • Wie viele Mails soll er denn darstellen, wenn nur 25 drin waren. Schau doch mal, ob dort noch andere MBox-Dateien vorhanden sind (-> Unterordner).


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 64 Bit | Thunderbird 32 Bit | Firefox 64 | Avira Free Security Suite

  • Hi,


    nein, da waren mehr drin.
    Ich hatte 25 Stück noch im Standard-Inbox-Ordner und hatte daneben einen weiteren Offline-Ordner, der leider den gleichen Namen hatte. Im Offline-Ordner waren mehrere hundert oder noch mehr Mails. Die sehe ich auch, wenn ich mir die Datei mit jujuedit anschaue.
    Oder anders gesagt, ich sehe mit juju Mails, die ich nicht angezeigt bekomme, wenn ich die Datei importiere.

  • Hi,


    werd ich ausprobieren und berichten.


    Noch eine andere Frage: Wenn ich die MBox-Datei mit jujuedit in mehrere Teile aufteilen würde, müßte ich die einzelnen Teile dann auch problemlos importieren können?
    Wenn das grundsätzlich gehen müßte, würde ich das mal ausprobieren, um sicherzugehen, das TB nicht einfach nur ein Problem mit der Dateigröße hat. :gruebel: