Kann eigene gesendete Mails nicht entschlüsselt lesen

  • Thunderbird-Version 17.0.8/b]:
    [b]Win 7 64bit
    :
    IMAP:
    Postfachanbieter privat:
    Gpg4Win 2:


    Hallo!


    Ich verschicke verschlüsselte Mails an einen Freund, welcher sie lesen kann (grün: entschlüsselt und korrekte Unterschrift). Ich selbst kann die mail aber unter "Gesendet" nicht lesen (rot: Fehler - geheimer Schlüssel wird zur Entschlüsselung benötigt). Der Freund kann mir auch verschlüsselte Mails senden, welche ich lesen kann (grün). Woran liegt das? :cool:


    Nick

  • "metalive" schrieb:

    Woran liegt das? :cool:


    Hallo Nick,


    na ich wette daran, daß Du nicht auch zu Deinem Standard-key verschlüsselt hast! :wall:


    Ist dem so, dann kann natürlich nur der die message lesen, mit wessen public-key die mail verschlüsselt wurde {hier eben Dein Freund!}.
    Für Dich ist das Verschlüsselte jetzt (logischerweise) nicht mehr lesbar. :schlaumeier: [Denk mal mit!]


    Ggfs. liest Du Dir noch einmal eine der haufenweise existierenden Anleitungen durch - da ist für JEDEN etwas dabei! ;)


    MfG ... Vic

  • Hallo,


    ich kann ebenfalls nicht meine verschlüsselten Mails lesen. Ich habe OpenPGP auf Thunderbird mit dieser Anleitung installiert: http://goo.gl/5dSrJB


    Quis custodiet custodes? (Wer bewacht die Wächter?)


    Da stand, man müsse ein Häkchen setzen bei OpenPGP → Einstellungen → Senden → »Beim Senden von Nachrichten ........... zusätzlich mit eigenem Schlüssel verschlüsseln.


    Genau dieses Häkchen ist gesetzt! :eek:


    Trotzdem lassen sich die Nachrichten nicht mehr öffnen. Was kann da los sein?


    Vielen Dank


    Mit Grüßen
    thomobe



    --
    Thunderbird 17.0.8

  • Hallo,


    na wähle doch mal probeweise die keys *manuell* aus, dann sehen wir ja ob's klappt.


    Ist dem so, so werden die angeklickten Einstellungen (s.o.) nicht übernommen.
    (Stichwort: gpg-agent)


    MfG ... Vic


    BTW: Der Link geht nicht. [ Berichtigung: Geht doch! - s.u. ]

    Einmal editiert, zuletzt von Vic~ ()

  • ... oha!!!


    Der PC ist (hoffentlich) in Ordnung! - aber mein Firefox ist recht *paranoid* eingestellt ---> kein Öffnen eines downloads.


    Aber in Opera klappt es - habe gleich mal die Anleitung heruntergeladen.


    Danke für den Hinweis - da sieht man mal wieder, man sollte doch stets zwei Browser ausprobieren. ;)


    MfG ... Vic

  • Sehr geehrte Forumsteilnehmer,


    ich habe mir dies alles durchgelesen, da ich auch meine versendeten Nachrichten nicht mehr lesen kann.


    Leider finde ich das Häkchen mit der Verschlüsselung
    OpenPGP → Einstellungen → Senden → »Beim Senden von Nachrichten ........... zusätzlich mit eigenem Schlüssel verschlüsseln


    nicht.


    Habe auch die Kontoeinstellungen durchsucht, nichts.


    Kann es sein daß eine Fehlinstallation vorliegt?


    MfG

  • danke,


    ich denke schon, das ist aber nicht in der Konteneinstellung sondern direkt oben in enigmail.


    Trotzdem kann ich nirgends das Häkchen finden.

  • Hallo woopwoop,


    der Menüpunkt scheint (mit der 1.7?) tatsächlich nicht mehr vorhanden zu sein, zumindest nicht unter dem Tab "Senden". Ich kann aber meine versendeten E-Mails nach wie vor lesen. Ich vermute daher, dass man diese Einstellung mit der Umstellung des Konfigurationsmenüs standardmäßig aktiviert und aus der dem GUI herausgenommen hat.
    Wenn Du in der erweiterten Konfiguration des TB nach Einträgen von Enigmail suchst, findest Du hoffentlich den Boolean


    extensions.enigmail.encryptToSelf


    Der klingt sehr danach, als sei es der richtige. Schau also mal, ob dieser bei Dir auf true steht.


    Zum Verständnis noch eine Nachfrage:



    da ich auch meine versendeten Nachrichten nicht mehr lesen kann.


    Was bedeutet in diesem Zusammenhang "nicht mehr"? Betrifft das E-Mails ab einem bestimmten Ereignis, z.B. des Upgrades auf Enigmail 1.7?


    Gruß


    Susanne

  • Vielen dank,


    aber wo soll ich suchen ob etwas auf true steht?


    Ich konnte noch nie etwas lesen, habe enigmail erst vor einem Monat eingerichtet und erst jetzt überprüft, da ich kaum jemanden finde, der ebenfalls verschlüsselt übermitteln will.

  • Moin,
    ach ja, die verschlimmbesserte Enigmail-Oberfläche.

    Zitat

    aber wo soll ich suchen ob etwas auf true steht?


    Je nach deinem nicht erwähnten Betriebssystem, bei Windows unter "Extras", bei Linux unter "Bearbeiten", dann Einstellungen->Erweitert->Allgemein->Konfiguration bearbeiten, evtl. die Mahnung, vorsichtig zu sein, wegklicken, bei "Suchen" encrypttoself eintippen, und wenn da nicht true in der Spalte Wert steht, doppelklicken.
    HTH, muzel

  • vielen Dank, das hätte ich ohne Anleitung niemals gefunden.


    Jetzt muß ich es nur einmal austesten.


    Bin gespannt, ob meine gesendeten mails dann noch lesbar sind.


    Beim Test mit Adele hat es zumindest funktioniert.

  • Hallo woopwoop,


    bitte nochmal für das "Protokoll", weil es für künftige Anfragen wichtig werden könnte. Mich interessiert der Ausgangszustand bei eine frischen Installation von Enigmail 1.7. . Ich habe irgendwann ein Update auf Enigmail 1.7. gemacht. Dabei sind die alten Einstellungen sicher erhalten geblieben. Deshalb habe ich keinen Vergleich.


    Was genau hast Du ausprobiert? Hast Du, wie empfohlen, den oben genannten Parameter extensions.enigmail.encryptToSelf auf true gesetzt? Heißt das, er stand zuvor auf false oder war er gar nicht vorhanden? Hattest Du Enigmail in der Vergangenheit schon einmal installiert?
    Ich habe gestern die Menues durchgeklickt. Ich habe keinen Punkt gefunden, unter dem man diese doch sehr wichtige Funktion aktivieren könnte. Sollte dafür also wirklich kein Konfigurationspunkt mehr vorhanden sein und sollte diese Funktion nach Installation standardmäßig nicht aktiviert sein, dann wäre das schon ziemlich ärgerlich. Insbesondere, weil es Anwendern möglicherweise erst sehr spät auffällt.


    Gruß


    Susanne

  • Hallo,


    vielen Dank für den sehr hilfreichen Hinweis bzgl. des Settings extensions.enigmail.encryptToSelf!


    Ich möchte an dieser Stelle vermerken, daß das Problem heute - März 2016! - immer noch besteht. Bin gerade gestartet mit Enigmail 1.9.1, gnupg2 in TB 38.6.0 unter Linux (Xubuntu 14.04.4) und mit dem diskutierten Problem auch vor die Wand gelaufen.


    Ich betrachte es als bösen Bug, daß diese Variable über die GUI nicht erreichbar ist und defaultmäßig unsinnig falsch gesetzt ist. Was soll diese Option überhaupt? Was für einen Sinn macht es, Mails im ‚Gesendet-Ordner‘ so abzulegen, daß man nie wieder darauf zugreifen kann?


    gruß wolf

  • Hallo Wolf,

    Ich möchte an dieser Stelle vermerken, daß das Problem heute - März 2016! - immer noch besteht.

    Das kann ich nach wie vor nicht bestätigen. Der Virtualbox sei Dank, habe ich zum Testen gerade eine ganz frische Installation unter Windows xp aufgesetzt. Der Parameter extensions.enigmail.encryptToSelf steht auf true. Man erkennt auch, dass dies der Standardwert ist. Ansonsten würde er fett markiert als "vom Benutzer verändert" dargestellt.


    Da @woopwoop offenbar keine Lust hatte, weiter nach der Ursache dafür zu suchen, dass dieser Schalter bei ihm umgestellt war, wissen wir nach wie vor nicht, wie es dazu kommen kann.


    Du hast die Chance, der Ursache weiter auf den Grund zu gehen. Wenn Du diesen Schalter nicht selbst umgestellt hast, welche Möglichkeiten gibt es dann noch? Für am wahrscheinlichsten halte ich immer noch Überbleibsel einer früheren Installation von Enigmail - und sei es einer längst vergessenen Testinstallation.


    Gruß


    Susanne

  • Hallo Susanne,


    Asche auf mein Haupt ... ich widerrufe meine Behauptung!


    Ja, Enigmail hatte ich bereits vor längerer Zeit mal installiert, aber eigentlich nix (oder kaum was) mit gemacht. Ich kann es nicht mehr nachvollziehen ...


    Parallel zu meinem Produktivsystem habe ich ein bis dato ‚Enigmail-freies‘ Testsystem installiert. Dort habe ich jetzt Enigmail nachgerüstet, und ich bestätige hiermit, daß dort nun defaultmäßig extensions.enigmail.encryptToSelf=TRUE gesetzt ist, und die Vermutung, daß mein Produktivsystem unter einem alten, verkorksten Setting gelitten hat, wie und warum auch immer.


    Sorry für die Unachtsamkeit ...


    gruß wolf
    (vom Gestade von Vater Rhein Höhe Bonn)