Schaltfläche Schriftfarbe teilweise außer Funktion

  • Thunderbird-Version: 24.0.1
    Betriebssystem + Version: Win 7
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): T-Online


    Hallo,


    Seit meinem Update auf 24.0 funktioniert die Schaltfläche "Schriftfarbe ändern" nicht mehr korrekt. Wird TB neu geöffnet und eine Mail beantwortet, klappt alles bestens. Bekommt man jedoch später eine Mail oder Direkt eine Remail, kann man die Schriftfarbe nicht mehr nach anklicken der Schaltfläche ändern sondern nur noch über den Zwischenschritt "Format Textfarbe". Ich hatte gehofft der Fehler wäre mit dem Update auf 24.0.1 behoben, er existiert aber weiter.


    Was kann ich ändern?


    Danke und Grüße


    Thunderfoxx

  • Mich würde eine Antwort auf dieses Problem auch interessieren, bitte. :flehan: :flehan: :flehan:

  • Guten Tag,


    nachdem das Problem weiterhin besteht, würde mich interessieren, ob hier im Forum wirklich niemand (außer ango) eine Ahnung davon hat. Würde mich über eine Rückmeldung freuen, auch wenn ihr keine Probleme habt.


    Vielen Dank

  • Hallo


    du schreibst, dass das Problem erst auftritt, nachdem du bereits erfolgreich eine Nachricht erstellen konntest. Bringt das Ändern von "mail.compose.max_recycled_windows" auf "0" in about:config ("Extras -> Einstellungen -> Erweitert -> Allgemein -> Erweiterte Konfiguration -> Konfiguration bearbeiten") Abhilfe?


    Viele Grüße,
    tempuser

    Entwickler des Add-ons Mail Merge (Thunderbird / SeaMonkey) und Mitwirkender des Add-ons Cardbook (Thunderbird)

  • "tempuser" schrieb:


    Bringt das Ändern von "mail.compose.max_recycled_windows" auf "0" in about:config ("Extras -> Einstellungen -> Erweitert -> Allgemein -> Erweiterte Konfiguration -> Konfiguration bearbeiten") Abhilfe?


    Hallo tempuser,
    genau diese Lösung wurde in dem oben von mir verlinkten Thema vom Themenersteller ts-d selber gefunden und beschrieben.
    Um es mundgerecht für Thunderfoxx zu machen, hätte ich natürlich die bewusste Änderung direkt kopieren und einfügen können, aber ich wollte lieber die Quelle der Lösung angeben ! ;)


    Gruß

  • Hallo tempuser,


    die Einstellung: "mail.compose.max_recycled_windows" war auf 1, habe sie dann auf 0 geändert.
    Bei 2 Testmails hat die Schalfläche Schriftfarbe wieder funktioniert.


    Vielen Dank also für Deine ausführliche Beschreibung mit der mundgerechten Anleitung, alleine aus der Quelle hätte ich das Problem als Laie nicht lösen können, da mir für tiefere Änderungen an einem Programm die Kenntnisse fehlen.


    Mapenzi : genau wegen solcher, nicht über "normale" Einstellung zu lösender Probleme, habe ich mich an dieses Forum gewandt, und ja auch eine gute Lösung erhalten.


    Schönes Wochenende


    Thunmderfoxx

  • Hallo,


    zunächst mal ist es natürlich fein, dass der Weg,


    Code
    1. ("mail.compose.max_recycled_windows", 0)


    funktioniert hat. Ich weiß nicht genau welchen Zweck diese Variable hat, aber etwas rätselhaft scheint mir, dass dieser Wert standardmäßig "1" steht. So auch bei mir und ich bin aber trotzdem nicht von dem hier beschriebenen Problem betroffen.
     
    Ferner ist mir beim Lesen diese Fadens aufgefallen, dass User t.sd in dem oben verlinkten Thread einen anderen Parameter verändert hat, nämlich


    Code
    1. ("browser.display.use_document_colors", true)


    Dieser Wert steht ebenfalls standardmäßig auf "true."


    Da ich HTML in E-Mails meide, wo ich nur kann, habe ich jetzt nicht weiter experimentiert. Doch scheint mir beides ein Hinweis darauf zu sein, dass es entweder verschiedene Ursachen für dieses Verhalten gibt oder dass die darunterliegende gemeinsame Ursache noch nicht gefunden ist. Eine Frage, sie wurde in dem anderen Thread natürlich auch gestellt, wäre natürlich die, wäre die, wodurch z.B. "browser.display.use_document_colors" zuvor auf "false" geändert wurde. Wenn es der Anwender selbst nicht war, dann vielleicht eine Erweiterung.


    Sollte jemand auf ein ähnliches Problem stoßen, würde ich daher empfehlen, zunächst die Erweiterungen zu prüfen und


    "Mapenzi" schrieb:

    einen Test im Abgesicherten Modus


    machen.


    Gruß


    Susanne

  • Hallo Susanne,


    beim Erstellen einer neuen Nachricht oder beim Antworten bzw. Weiterleiten erstellt Thunderbird ein neues Verfassen-Fenster. Damit nicht jedes Mal ein neues Fenster erstellt werden muss, wird das Fenster beim Schließen nicht komplett geschlossen, sondern bleibt für eine spätere Wiederverwendung intern gespeichert. Das Ganze dient wohl einer Geschwindigkeitssteigerung beim Verfassen weiterer Nachrichten.


    Die Einstellung '"mail.compose.max_recycled_windows" legt jetzt fest, wie viele dieser alten Fenster für eine spätere Wiederverwendung vorgehalten werden. Und "0" deaktiviert diese Funktion.


    Viele Grüße,
    tempuser

    Entwickler des Add-ons Mail Merge (Thunderbird / SeaMonkey) und Mitwirkender des Add-ons Cardbook (Thunderbird)

  • Hallo tempuser,


    danke für die Erläuterung, wieder etwas dazu gelernt :-).


    Die Standardeinstellung für die recycleten Fenster ist "1". Das ist sicher schon sehr lange so und bei den meisten Anwendern auch unverändert geblieben. Diese Einstellung allein kann daher nicht die Ursache für den geschilderten Fehler sein. Auch wenn das Deaktivieren für Thunderfoxx das Problem gelöst hat, da muss noch etwas "verstellt" sein.


    Gruß


    Susanne

  • Hallo Susanne,


    ich stimme dir zu, dass die Einstellung sicher nicht die Ursache des Problems ist. Ob zusätzlich noch etwas verstellt ist, das das Problem auslöst? Möglich... Es kann aber auch mit einer internen Änderungen in Thunderbird 24 zusammenhängen. Zum Beispiel war ich von einem Bug des Wörterbuchs im Verfassen-Fenster betroffen, der sich auch mit dem Abschalten des Wiederverwendens des Verfassen-Fensters vermeiden lässt - jedenfalls bis der Bug in Thunderbird behoben worden ist.


    Zurück zu diesem Problem:
    Im offiziellen Bugtracker von Thunderbird gibt es diese Bugs: Bug 925273 und Bug 927197


    Viele Grüße,
    tempuser

    Entwickler des Add-ons Mail Merge (Thunderbird / SeaMonkey) und Mitwirkender des Add-ons Cardbook (Thunderbird)

  • "Mapenzi" schrieb:


    Hallo tempuser,
    genau diese Lösung wurde in dem oben von mir verlinkten Thema vom Themenersteller ts-d selber gefunden und beschrieben.


    Hallo tempuser,


    ich hatte die von dir zitierte Einstellung "mail.compose.max_recycled_windows" verwechselt mit der Einstellung "browser.display.use_document_colors", deren Änderung in dem von mir verlinkten Thread Schriftfarbe wird im Mailfenster nicht angezeigt [erl.] das Problem der fehlenden Schriftfarbe gelöst hat.
    Meine obige Antwort auf deinen Beitrag beruhte also auf einem bedauerlichen Irrtum infolge fehlender Aufmerksamkeit.

    Einmal editiert, zuletzt von Mapenzi ()

  • Hallo,


    neben einigen anderen Themen, die hier im Zuge der Version 24 für zahlreiche Beiträge sorgen, findet sich auch dieses Thema in den hier von graba verlinkten FAQ:


    Zitat


    Composition window doesn't behave well when replying or opening it a second time


    Various issues are related to "recycling" if composition windows. For example, inline spell check occasionally didn't work in 24.0 but should be fixed in 24.0.1, and you may see other issues like UI elements being disabled or misbehaving.


    If that's the case, set mail.compose.max_recycled_windows to a value of 0 (zero) and restart Thunderbird.


    Gruß


    Susanne

  • "SusiTux" schrieb:

    Die Standardeinstellung für die recycleten Fenster ist "1". Das ist sicher schon sehr lange so und bei den meisten Anwendern auch unverändert geblieben. Diese Einstellung allein kann daher nicht die Ursache für den geschilderten Fehler sein. Auch wenn das Deaktivieren für Thunderfoxx das Problem gelöst hat, da muss noch etwas "verstellt" sein.


    Hallo Susi,


    bei mir tauchte der Fehler mir dem Update auf 24.0 auf. Ich selbst habe bis gestern nie in das System eingegriffen, da mir hierzu die Kenntnisse fehlen.
    Ein bisschen konnte ich aber durch den Faden hier lernen, vielen Dank dafür.

  • Hallo Thunderfoxx,


    "Thunderfoxx" schrieb:

    Ein bisschen konnte ich aber durch den Faden hier lernen ...


    Dann hat es sich ja schon mal gelohnt. Ich freue mich auch stets, wenn ich dazulernen kann.


    "Thunderfoxx" schrieb:

    ... bei mir tauchte der Fehler mir dem Update auf 24.0 auf.


    Damit hast Recht. Die Version 24 hat leider noch ein paar mehr solch kleiner Macken. Wobei "klein" relativ ist. Wer von den Problemen mit dem Kalender betroffen ist, mag wohl eher andere Worte wählen.


    Gruß


    Susanne