dir. Öffnen von Anhängen funktioniert nicht [erl.]

  • Edit: Es ist nicht sinnvoll, sich an einen Thread zu hängen, der eine nur ähnliche oder sogar andere Thematik behandelt bzw. bezüglich der Ausgangsvoraussetzungen veraltet ist ( :arrow: Erstellen neuer Themen). Ich habe deshalb mit deinem Beitrag diesen neuen Thread eröffnet. Ursprünglicher Thread: Anhänge werden beim Öffnen oder Speichern gelöscht.Mod. graba


    Thunderbird-Version: 24.4.0
    Betriebssystem + Version: Windows 7 32-Bit
    Antivir


    Hallo,
    habe hier ein fast identisches Problem:
    Anhang-Datei (JPG, PDF...) manuell "Speichern unter..." und anschließend mit Bildprogram, Reader... öffnen funktioniert.


    Aber das direkte Öffnen aus Thunderbird funktioniert nicht.
    Man sieht das Downloadfenster.
    Das richtige Bildprogramm, Reader,... wird geöffnet.
    Anschließend kommt die Meldung:
    "Fehler beim Öffnen der Datei C:\Users\(mein Benutzername)\AppData\Local\Temp\(Dateiname.richtige Dateiendung)
    Habe den entsprechenden Zielordner in einem 2.Fenster geöffnet. Da wird augenscheinlich nichts hineingeschrieben.
    ---
    Mir ist aufgefallen:
    1. In meiner deutschen Win7-Version gibt es den Ordner C:\Users\... nicht, sondern der Ordner heisst: C:\Benutzer\...
    2. Der Ordner C:\Benutzer\(mein Benutzername) ist schreibgeschützt.
    Win 7 lässt scheinbar auch nicht zu, den Schreibschutz zu ändern.
    Mehrfach auch über den Überordner probiert. Läuft durch, danach sind die Ordner leider wieder schreibgeschützt.


    Ich habe den Eindruck, daß die Dateien aus irgendeinem Grund erst garnicht im Zielordner gespeichert werden, von dem aus das Bildprogramm, Reader... die Datei öffnen soll.
    Also nicht 1.speichern und 2. sofortiges Löschen, sondern schon Punkt: 1."Speichern im Zielordner" ist nicht möglich.
    ---
    Firefox hat in den gleichen Ordner div. Downloads abgelegt. Da funktioniert der Zugriff problemlos.

  • Hallo und willkommen im Forum!


    Zitat

    1. In meiner deutschen Win7-Version gibt es den Ordner C:\Users\... nicht, sondern der Ordner heisst: C:\Benutzer\...


    Ich habe auch eine deutsche Version und dort steht: C:\Users\User\AppData\Local\Temp\
    Dort werden die Anhänge bei direktem Öffnen zwischengespeichert.

    Zitat

    2. Der Ordner C:\Benutzer\(mein Benutzername) ist schreibgeschützt.


    Dass dem so ist, habe ich seit Windows 95 niemals gehört oder erlebt.
    Aber wenn es bei dir so ist, kann Thunderbird die Datei gar nicht zwischenspeichern, da hast du schon Recht.
    Du hast Admin-Rechte und befindest dich auch in einem Admin-Konto? Welche Sicherheitssoftware hast du?


    Normalerweise kann man ein derartiges Problem so lösen:
    1) durch neu installieren der Programme, mit denen die Dateien geöffnet werden sollen
    oder
    2) durch Löschen der Datei mimetypes.rdf im Thunderbird-Profil. Thunderbird muss dabei vorher beendet werden.


    Auf Grund deiner Beschreibung allerdings befürchte ich, dass das bei dir nicht greifen wird.
    Trotzdem ausprobieren.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    2 Mal editiert, zuletzt von mrb ()

  • Hallo,


    "mrb" schrieb:

    Ich habe auch eine deutsche Version und dort steht: C:\Users\ ...


    Ich habe, um sicher zu gehen, Windows gebootet und nachgeschaut. Das ist bei mir ebenso. Der Ordner C:\Benutzer sollte meines Wissens auch gar nicht existieren. Es ist lediglich eine Übersetzung für die Anzeige im Explorer und wird über die Desktop.ini festgelegt.
    Dort sollte dann so etwas stehen wie:


    Code
    1. [.ShellClassInfo]
    2. LocalizedResourceName=@%SystemRoot%\system32\shell 32.dll,-irgendeine schwindelige Nummer


    Im Dateisystem heißt der Ordner stets "Users".


    otto-bs


    Kann es sein, dass Du Dir selbst einen Symbolischen Link auf "C:\Users" namens "Benutzer" erzeugt hast? Das würde auch den "Schreibschutz" erklären.


    Gruß


    Susanne

  • Hallo,


    ich habe mit Windows 7 Home 64-bit folgende Anzeigen im Explorer:


    C:\Benutzer
    D:\Users (Ordner selbst erstellt, dort liegen alle Daten, Bibliotheken und Profile)


    Windows 7 verwendet intern die englischen Bezeichnungen, übersetzt aber im Explorer ins Deutsche!


    C:\Programme
    C:\Programme (x86)


    Gruß
    Herbert

  • Na, da kommen wir dem eigentlichen Problem vielleicht näher:


    "hsproedt" schrieb:

    ich habe mit Windows 7 Home 64-bit folgende Anzeigen im Explorer:
    C:\Benutzer
    D:\Users (Ordner selbst erstellt, dort liegen alle Daten, Bibliotheken und Profile)


    Ich will es nicht beschreien, aber das sieht aus der Ferne so aus, als hättest Du Dir Dein Windows "verkonfiguriert". Hast Du versucht, das Benutzerverzeichnisse auf D:\ auszulagern, indem Du einfach einen Ordner D:\Users angelegt hast?


    Wenn Du im Explorer auf C:\Benutzer gehst und dann in die Adresszeile klickst, welcher Pfad wird Dir dann angezeigt?


    Nachtrag: Du hattest die Frage nach dem symbolischen Link nicht beantwortet. Könntest Du einen Screenshot vom Explorer hochladen, welcher den Ordner "C:\Benutzer" zeigt? Ich würde gern sehen, ob es sich um den übersetzten Ordner "users" handelt oder um einen Link.

    Einmal editiert, zuletzt von SusiTux ()

  • "graba" schrieb:

    dir ist bewusst, dass obiges Zitat nicht vom TE stammt?


    Upps, jetzt ja :redface:

  • Danke für die Rückmeldungen.
    Zwischenbericht:
    Ein neuer Ordner C:\Users lässt sich nicht erstellen, da er schon existiert.
    Users gibt es aber nicht. Nur "Benutzer" ist vorhanden.
    -->Ordner C:\Benutzer ...ist lediglich eine Übersetzung für die Anzeige!


    "mrb" schrieb:

    Normalerweise kann man ein derartiges Problem so lösen:
    1) durch neu installieren der Programme, mit denen die Dateien geöffnet werden sollen
    Habe probeweise ein weiteres Bildbearbeitungsprogramm installiert--> keine Veränderung
    oder
    2) durch Löschen der Datei mimetypes.rdf im Thunderbird-Profil. Thunderbird muss dabei vorher beendet werden. 2x gelöscht -->keine Veränderung


    ---
    Habe mit meinem Laptop verglichen (WIN 7, Thunderbird, Antivir)
    Dort als Standardbenutzer funktioniert das direkte öffnen unter Thunderbird.
    Auch die Ordner sind genau wie auf dem Desktop-PC schreibgeschützt (Symbol Vorhängeschloss)
    Nebenbei: Auf dem Laptop ist der Windows Defender (Burgsymbol) vorhanden und lässt sich öffnen (ein- und ausschalten)


    Auf meinem Problem-Desktop-PC lässt sich als Administrator der Defender zwar noch halbwegs finden( kein Burgsymbol, sondern nur ein weisses Kästchen!)
    Der Defender lässt sich auf dem Desktop-PC nicht starten und ist vermutlich beschädigt.


    Wie mir zusätzlich gerade auffällt, konnten in den letztenTagen Windows-Updates -auch manuell- nicht erfolgreich durchgeführt werden.

  • "otto-bs" schrieb:

    Der Ordner C:\Benutzer\(mein Benutzername) ist schreibgeschützt.
    Win 7 lässt scheinbar auch nicht zu, den Schreibschutz zu ändern.
    Mehrfach auch über den Überordner probiert. Läuft durch, danach sind die Ordner leider wieder schreibgeschützt.


    Hallo Otto und willkommen im Forum :)


    Die Attribute "Schreibgeschützt" und "System" von Ordnern können in Windows Server 2003, Windows XP, Windows Vista oder Windows 7 nicht angezeigt oder geändert werden


    Gruß Ingo

  • Hallo Otto,


    auch wenn ich vohin nicht bemerkt hatte, dass Du nicht Herbert bist, kann Du bitte folgendes trotzdem liefern:


    "SusiTux" schrieb:

    Wenn Du im Explorer auf C:\Benutzer gehst und dann in die Adresszeile klickst, welcher Pfad wird Dir dann angezeigt?


    "SusiTux" schrieb:

    Könntest Du einen Screenshot vom Explorer hochladen, welcher den Ordner "C:\Benutzer" zeigt? Ich würde gern sehen, ob es sich um den übersetzten Ordner "users" handelt oder um einen Link.


    Gruß


    Susanne

  • Die Ordner sind meiner Meinung nach genau da, wo sie sein sollen.
    Auf dem funktionierenden Laptop sind sie mit gleichen Namen, an den gleichen Stellen und die Ordner sind ebenfalls mit "Vorhängeschloss" als schreibgeschützt gekennzeichnet.
    Ich denke es liegt nicht an den Zielordnern.



    Mein Gefühl sagt, da passt irgendwas mit dem Virenprogamm nicht, daß nach dem Download auf Viren überprüft.
    Das beauftragte Virenprogamm beschädigt/ gelöscht/ unvollständig deinstalliert, ungenügende Rechte...

  • Hallo Otto,


    ich habe jetzt gerade wenig Zeit, habe mitr aber den Screenshot auf die Schnelle angeschaut. Dass Dein Benutzer "User" heißt, macht die Sache nicht übersichtlicher. Ich schau's mit aber morgen genauer an.
    Das Bild zeigt noch nicht ganz das, wonach ich gefragt hatte. Insbesondere fehlt mir dies:


    "SusiTux" schrieb:

    Wenn Du im Explorer auf C:\Benutzer gehst und dann in die Adresszeile klickst, welcher Pfad wird Dir dann angezeigt?


    So kannst Du überprüfen, ob der Pfad wirklich auf C:\Users zeigt. Dazu bitte oben in die Adresszeile reinklicken. Wäre es möglich, dass Du das Explorer-Bild in der Baumansicht zeigst?


    Gruß


    Susanne

  • Das Schloss auf den Ordnern hat nichts damit zu tun, ob du Zugriff darauf hast oder nicht, sondern hat etwas mit den Netzwerkfreigaben zu tun.
    Ich zitiere mal eine Erklärung:

    Zitat

    das hat ewas mit dem eigenen Netzwerk zu tun.


    Auf dem Ordner mit der rechten Maustaste klicken und dann freigeben für / niemand oder Heimnetzgruppe lesen oder Heimnetzgruppe lesen / schreiben wählen.


    bei niemand bleibt das Schloss und Heimnetzgruppe lesen/schreiben verschwindet das Schloss.


    Das waren auch meine bisherigen Beobachtungen. So erkenne ich sofort, welche Ordner ich im Heimnetzwerk freigegeben habe (für "jeder").


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hoffe, daß ich jetzt die richtige Darstellung habe.


    =============================================================================================================

    "otto-bs" schrieb:

    Wie mir zusätzlich gerade auffällt, konnten in den letztenTagen Windows-Updates -auch manuell- nicht erfolgreich durchgeführt werden.
    ...
    Mein Gefühl sagt, da passt irgendwas mit dem Virenprogamm nicht, daß nach dem Download auf Viren überprüft.
    Das beauftragte Virenprogamm beschädigt/ gelöscht/ unvollständig deinstalliert, ungenügende Rechte...


    Das Problem besteht etwa schon so lange, wie sich das Windows-Update KB2847927 nicht installieren lässt.
    Seit 12.07.2013 ist nur dieses Update alle 2-3 Tage Fehlgeschlagen.
    Wir haben im letzten halben Jahr massiv in der Wohnung umgebaut, deshalb konnte ich mich nicht eher darum kümmern.


    Das scheint zum Windows Defender (Microsoft Antivirenprogramm) zu gehören, der sich auf meinem Desktop-PC nicht öffnen lässt.
    Habe heute den Nachfolger "Microsoft Security Essentials" (MSE) mit integriertem Defender installiert, um den Defender zu reparieren.
    Nun lässt sich für den MSE auch kein Update installieren.

  • Hallo Otto,


    was den Ordner "Users" betrifft, so sieht für mich, bis auf das Schlosssymbol an dem Ordner Deines eigenen Users, alles normal aus.
    Bei den anderen im Baum sichtbaren Ordnern erscheinen bei Dir sowohl "Dokumente und Einstellungen" als auch "Documents and Settings". Das scheint mir etwas merkwürdig. Letztendlich sollten beide nur einen Link, genauer eine Verzeichnisverknüpfung (junction), nach "C:\Users" darstellen.
    Das kannst Du mit


    Code
    1. dir c:\ /AD /AL


    überprüfen.
    Dass die bei Dir doppelt auftauchen, wundert mich, hat aber vielleicht auch nichts zu sagen. Vielleicht kann das jemand anderes hier erklären.


    Zum Problem mit dem Schreibzugriff. Hast Du ausprobiert, ob Du unter "C:\Users\User" und unter "C:\Users\User\AppData\Local\Temp\" schreiben kannst? Wenn Du dort hineinschreiben kannst, dann sollte es auch der TB können.
    Wenn Du dort tatsächlich ein "Zugriff verweigert" bekommst, dann kannst Du das Problem am einfachsten lösen, indem Du Dich zum Besitzer machst. Das solltest Du allerdings längst sein - ist ja schließlich Dein Benutzerkonto. Das ist mir etwas rätselhaft.


    Was den Sicherheitspatch KB2847927 und das Verhalten des Defenders betrifft, so kann es sich dabei grundsätzlich auch um ein Rechteproblem handeln. Ebenso kann aber auch Maleware ursächlich sein. Vielleicht ist Dir aber irgendetwas anderes total durcheinander geraten. Das kann ich aus der Ferne nicht beurteilen, vielleicht kann aber jemand aus der Windowsfraktion weiterhelfen. Zur Not, wende Dich mal an ein Windowsforum.


    Ernstnehmen würde ich das allemal. Denn erstens ist das kein normales Verhalten und zweitens geht es um einen Sicherheitspatch. Interessant dabei: laut dem zugehörigen MS13-058 behebt der Patch ein Sicherheitsrisiko in Windows Defender, wodurch eine Rechteerweiterungen möglich war bzw. bei Dir noch ist. Das passt ein wenig zu Deinen Beobachtungen bzgl. des Defenders.


    Gruß


    Susanne

  • Danke für die Wortmeldungen


    schlingo :
    gelegentlich kommt nach dem fehlgeschlagenen Windows-Update KB2847927 die Fehlermeldung Fehler 0x80070005.
    Das "Microsoft-Fixit" konnte das Problem nicht lösen.



    Gerade jetzt lasse ich den Microsoft Safety Scanner drüberlaufen. --> Bisher 3 infizierte Dateien gefunden! Muss noch zuende laufen.
    Mal sehen, was da noch kommt.


    Inzwischen ist mit wieder eingefallen, daß ich am 02.07.2013 einen Virusbefall hatte.
    Damals hatten anschließend Kaspersky-Rescue-CD und Antivir-Rescue-CD "Virus gefunden" und nach Virusentfernung "vollständig desinfiziert" gemeldet.
    Aus heutiger Sicht wurde wohl doch nicht alles entfernt oder es ist etwas beschädigt geblieben.


    Wie auch immer, Anlass genug, um das System nochmal komplett neu zu installieren.


    LG
    otto-bs

  • Hallo Otto,


    "otto-bs" schrieb:

    Einige Anwendungs-Programme schreiben bei der Installation in den deutschen Ordner, einige in den englischen Ordner.


    Ja, das ist mir schon klar, ebenso, dass einige alte Ordnerbezeichnungen aus Kompatibilitätsgründen zu xp noch mitgeschleppt werden. Allerdings ging ich bisher davon aus, das diese Altlasten über die erwähnten Links (Junctions) gehandhabt werden und dass systemrelevante Ordner stets nur die Englische Bezeichnung tragen und lediglich über die desktop.ini übersetzt angezeigt werden. So ist das bei Dir ja für den Ordner Users/Benutzer der Fall.
    Wie bereits geschrieben gibt es den Ordner "Dokumente und Einstellungen" auf keiner der Windows 7 Installationen bei uns in der Familie - weder in Deutsch noch in Englisch. Es existiert lediglich eine gleichnamige Junction, die auf c:\users zeigt.
    In Deinem Screenshot scheinen es aber reguläre Ordner zu sein, zumindest zeigen die Ordnersymbole nicht, dass es sich um eine Junction handeln würde.
    Es kann gut sein, dass diese Ordner, wie Du vermutest, von Programmen angelegt wurden, die noch nicht sauber mit den Gepflogenheiten in Windows 7 umgehen. Komisch finde ich es aber dennoch, denn so neu ist W7 ja nun auch nicht mehr ... .


    Sei's drum. In Anbetracht der von Dir geschilderten "Begleitumstände" stimme ich Dir eh zu, dass Du das System neu aufsetzen solltest.


    Schönes Wochenende


    Susanne

  • "otto-bs" schrieb:


    Inzwischen ist mit wieder eingefallen, daß ich am 02.07.2013 einen Virusbefall hatte.


    Hallo Otto :)


    :(


    Zitat


    Damals hatten anschließend Kaspersky-Rescue-CD und Antivir-Rescue-CD "Virus gefunden" und nach Virusentfernung "vollständig desinfiziert" gemeldet.
    Aus heutiger Sicht wurde wohl doch nicht alles entfernt oder es ist etwas beschädigt geblieben.


    Das kommt mir bekannt vor: Computersicherheit - Virenscanner.


    Zitat


    Wie auch immer, Anlass genug, um das System nochmal komplett neu zu installieren.


    Was tun bei Kompromittierung des Systems?


    Gruß Ingo

  • So,
    Microsoft Safety Scanner hat einen Trojaner erkannt und entfernt.
    Die Probleme sind aber immernoch da:
    - Das Windows-Sicherheitsupdate KB2847927 lässt sich nicht installieren.
    - Mein urprüngliches Problem "direktes Öffnen von Anhängen unter TB" funktioniert nicht.


    Werde jetzt die System-Festplatte wipen und das System neu aufsetzen.


    Danke für die Unterstützung
    LG
    otto-bs