Seltsames Verhalten von pdf-Anhängen[erl.]

  • Seltsames Verhalten mit Anhängen.
    Windows XP
    TBirdvers: 24.4.0
    Kontenart: POP
    Anbieter: 1und1
    Beim direkten Öffnen von Anhängen (pdf, docx, html und manchmal auch jpg) kommen div. Fehlermeldungen:
    "Kann Datei nicht finden". Manchmal wird auch eine Liste eingeblendet: 'Gespeicherte Datien',
    deren Elemente man aber nicht öffnen kann.
    Workarounds:
    1. bereits hier erwähnt: Man kann die Anhangangabe auf den Desktop ziehen
    2. Man kann 'Weiterleiten' anklicken und dann die Anzeige oben rechts im Weiterleitungs-Formular
    zum Öffnen benutzen.
    Aus den verschiedenen Fehlermeldungen ist erkennbar, dass der im Quelltext integrierte Anhange
    beim Anzeigeversuch in einem 'Temp'-Verzeichnis vergebens gesucht wird.
    Der Fehler ist anscheinend im Zusammenhang mit Installationen und/oder Profiländerungen entstanden.
    Wäre für Aufklärung dankbar.. :confused:

    2 Mal editiert, zuletzt von graba () aus folgendem Grund: Beitrag verschoben und Titel angepasst

  • Anhänge melden beim direkten Öfnen versch. Fehler:
    Kann \Temp\Dateiname nicht finden
    Kann Dateiheader nicht lesen.
    Die Anhänge kann man auf den Desktop kopieren, dann funktionieren sie normal
    Auch aus einer Weiterleitung kann man sie lesen/kopieren


    Betriebssystem: Windows XP SP.3
    Thunderbird Vers. 24.4.0
    Profiles unter C:\Dokumente und Einstellungen\Inge\Anwendungsdaten\Thunderbird\Profiles
    Mail-Daten unter: F:\Mail_recovery\Mail...

  • Hallo,


    ich habe deine Beiträge mal in einen neuen Thread zusammengeführt.


    Zitat von "Grabtiefer"

    Profiles unter C:\Dokumente und Einstellungen\Inge\Anwendungsdaten\Thunderbird\Profiles
    Mail-Daten unter: F:\Mail_recovery\Mail...

    du hast damit das Profil "zerrissen" und vermutlich liegt da der Hund begraben...


    Was genau hast du in F:\, die gesamten Kontenordner?

  • Vereinfacht sieht das so aus:
    F:\Mail_recovery\Mail\Local Folders\Outlook Express-Import.sbd
    oder
    F:\Mail_recovery\Mail\Local Folders\Dauerablage.sbd
    Profiles ist so:
    C:\Dokumente und Einstellungen\Inge\Anwendungsdaten\Thunderbird\Profiles\qbs2uzs2.INGE\Mail\pop.1und1.de
    Ich sollte ergänzen, dass neue Mails ankommen in F:\Mail_recovery\Mail\pop.1und1.de.
    Das entsprechende Verzeichnis in C:\..\Profiles ist unbenutzt.

  • Damit ist meine Befürchtung zur Gewissheit geworden.
    Installiere das Addon ImportExportTools (Mboximport enhanced)
    Mache zur Sicherheit eine Kopie von
    C:\Dokumente und Einstellungen\Inge\Anwendungsdaten\Thunderbird\Profiles\qbs2uzs2.INGE und
    F:\Mail_recovery\Mail bzw. auch F:\Mail_recovery\Imapmail so vorhanden.
    Starte TB und importiere (nur) die endungslosen Dateien aus den Ordnern in die jeweiligen Kontenorddner und passe die Pfade in Extras>Konten-Einstellungen>%Accountname%>Server-Einstellungen bei Lokaler Ordner wieder an.


    Alternativ: erstelle ein neues Profil und importiere dann die Adressbücher und Mails. Du kannst TB dazu mit dem Profilmanager starten und dann auch bis zur endgültigen Umstellung beide Profile parallel betreiben.


    Natürlich macht es Sinn, das Profil nicht auf der Systemplatte zu führen. Aber du kannst den gesamten Profilordner qbs2uzs2.INGE auf F:\ kopieren und dann mit dem Profilmanager über Profil erstellen>Ordner wählen darauf verweisen. In C: bleibt dann nur C:\Dokumente und Einstellungen\Inge\Anwendungsdaten\Thunderbird\profiles.ini damit TB den Weg findet.



    Btw: wenn du die Möglichkeiten deines Providers nutzen und deine Mails per IMAP verwalten würdest, hättest du das Problem wohl nicht. Wichtige Mails kann man ja lokal in TB speichern.


    Schau mal in unsere Anleitung bzw. Fragen & Antworten (ist auf dieser Seite ganz oben per Button erreichbar) zum Thema POP<>IMAP

  • Danke für den Hinweis bez. der profiles ini; ich habe mich nun entschlossen komplett
    auf die Partition F:\ umzuziehen; und das hat auch - anders als bisherige Versuche geklappt.
    Dann habe ich von einer Mail einen JPG-Anhang aufgemacht, das ging auch prima; dann habe
    ich ein PDF versucht: das ging voll auf Fehler. Dann Habe ich noch einmal das JPG versucht,
    und das ging nun auch wieder nicht. Das Erlebnis, dass es einmal und nicht wieder geht, hatte ich früher auch schon genauso.
    Sollte ich einmal alle *.msf Dateien löschen?
    Inzwischen vielen Dank

  • Ich muß mir leider hier selbst antworten:
    Leider läuft nach vielen Stunden mit Neuinstalation, Abschalten/Kaspersky, Protected-Mode, etc.
    TB noch immer nicht - ALLE ATTACHMENTS (docx, pdf, jpg und andere) kann man nur durch "Abtrennen" öffnen. Manche haben die Fehlermeldung:
    "Diese Datei wurde nicht gefunden. C:\...\Temp\<Dateiname>.docx).
    Für einen Hinweis Diagnose zur Diagnose wäre ich sehr dankbar!!
    GrabTiefer

  • Hallo,
    schau mal in der Systemsteuerung unter Standardprogramme und dann "Dateityp oder Protokoll..." und überprüfe die Zuordnung von *.docx. Steht dort "unbekannt" - wie bei mir - klicke doppelt auf das betr. Programm (bei mir Microsoft Office Word)


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Vielen Dank mrb,
    aber in meinem XP gibt es kein "Standard Programme" in der Systemsteuerung,
    aber Sie denken sicher, dass TB kein passendes Programm zum Anzeigen findet.
    Dafür gibt es aber ein Einstellfenster in TB unter 'Anhänge'; darin kann man das passende Programm aussuchen. Das habe ich gemacht für die Typen pdf, jpg, docx, http, https. Für http habe ich einmal
    mit verschiedenen Browsern getestet. Alles leider ohne Erfolg.
    Nun habe ich mit Outlook Express (ist ja noch da trotz Entfernung aus 'Software' ) versucht, Anhänge
    anzuzeigen. Da geht es auch nicht mehr.
    Grüße

  • Zitat

    aber in meinem XP gibt es kein "Standard Programme" in der Systemsteuerung,


    Nein, dort befindet sich die Option in den Ordernoptionen > Dateitypen.

    Zitat

    Dafür gibt es aber ein Einstellfenster in TB unter 'Anhänge'; darin kann man das passende Programm aussuchen. Das habe ich gemacht für die Typen pdf, jpg, docx, http, https.


    Die nützen dir nichts, wenn sie nicht mit Windows abgestimmt sind.
    Das bringt mich aber auf eine Idee:
    Beende Thunderbird, suche das Thunderbird-Profil auf und lösche dort die Datei mimetypes.rdf.
    Nach Neustart die Zuordnungen für die Dateitypen neu erstellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für die Hinweise.
    Natürlich lege ich im Windows Explorer die Programme fest zu den Dateitypen; das ist ja wohl gemeint?
    Und das passte wohl auch zusammen mit der Angabe in TB.
    Nun habe ich MimeTypes gelöscht und sitze vor dem leeren Eingabefenster 'Dateityp'.
    Ich dachte, dass durch Aufrufen von Anhängen da etwas auf der linken Seite ankommt; das geht aber wohl anders ??
    Wenn Sie mir dazu bitte auch noch was schreiben könnten, dann stürze ich mich morgen hoffnungsvoll darauf.
    Übrigens habe ich heute auch den kaspersky vorübergehend ganz entfernt: der ist es nicht!
    Mir scheint, dass die Anhänge verstümmelt an das Anzeigeprogramm gegeben werden (Vermutung);
    sie kommen richtig an, wenn man sie aus dem Fenster 'Weiterleiten' kopiert oder einfach auf den Desktop schiebt??
    Nochmals besten Dank.

  • Zitat

    Natürlich lege ich im Windows Explorer die Programme fest zu den Dateitypen;


    Normalerweise machst das aber nicht du sondern Windows.

    Zitat

    Mir scheint, dass die Anhänge verstümmelt an das Anzeigeprogramm gegeben werden (Vermutung);
    sie kommen richtig an, wenn man sie aus dem Fenster 'Weiterleiten' kopiert oder einfach auf den Desktop schiebt??


    Das wird häufig hier berichtet.
    Oft hilft das Neuinstallieren des ausführenden Programm (z.B. den Adobe Reader), dann werden die Zuordnungen neu gesetzt. Fehlt nämlich nur eine von mehreren, kannst du das Problem bekommen.
    Es kann auch mit deinem alten vermutlich nicht mehr ganz einwandfreien System zu tun haben.
    Du kannst ja testweise ein neues Thunderbird-Profil anlegen mit nur einem Konto und es dort testen.
    Ist das Ergebnis gleich, glaube ich nicht an die Schuld von Thunderbird.


    4 Ein neues Profil erstellen


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo,
    habe alle Vorschläge befolgt und immer noch nur Fehler; dh. manchmal geht es doch (JPG, PDF),
    aber ohne dass ich herausfinden konnte 'Wann/Wieso'.
    Herausgefunden habe ich nun, dass TB immer das Anzeigeprogramm vorschlägt, dass in den
    Dateitypen eingestellt ist. Das führt dazu, dass jetzt MANCHMAL *.docx.doc Dateien vergeblich
    gesucht werden.
    Ich hatte nach der anfänglich erfolgreichen Installation von TB OE aus Systemsteuerung\Software
    gelöscht. Das war natürlich Unsinn, denn es ist ja noch da und läßt sich auch nicht eliminieren, was
    ich vergessen hatte. Sollte ich dazu eine Reinstallation/Download versuchen??
    Gruß

  • Zitat

    Sollte ich dazu eine Reinstallation/Download versuchen??


    Du meinst von Outlook Express?
    Warum? Was möchtest du damit erreichen?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Es gibt möglicherweise einen zeitlichen Zusammenhang zwischen dem OE Deinstallationsversuch und
    dem Anhangproblem. Da wir ohnehin 'Schwarzer Kasten' spielen, dachte ich daran und habe auch schon einen ersten mislungenen Versuch mit einem Download hinter mir: so ohneweiters kann man
    das nicht drüberinstallieren.
    ??
    Gruß

  • Nun versuche ich tiefer zu graben; es gibt ja eine Fehlerkonsole. Dafinden sich unterschiedliche Fehlerangaben. Hier ein Beispiel, mit dem ich so ohneweiters aber nichts anfangen kann.
    Fehlerkonsole:


    (?)Sicherheitsfehler: Inhalt auf moz-nullprincipal:{5d944ff5-947b-452e-b01d-1fd2b9096d82} darf about:blank nicht laden oder verlinken.


    Zeitstempel: 12.04.2014 10:27:31
    Fehler: TypeError: this._taskbar is null


    Quelldatei: resource://gre/modules/DownloadTaskbarProgress.jsm
    Zeile: 189
    if (aWindow) {
    // Get the taskbar progress for this window
    let docShell = aWindow.QueryInterface(Ci.nsIInterfaceRequestor).
    getInterface(Ci.nsIWebNavigation).
    QueryInterface(Ci.nsIDocShellTreeItem).treeOwner.
    QueryInterface(Ci.nsIInterfaceRequestor).
    getInterface(Ci.nsIXULWindow).docShell;
    let taskbarProgress = this._taskbar.getTaskbarProgress(docShell);


    Bitte weiterhin um Hinweise.
    Danke und Gruß

  • Leider können nur die Entwickler den Code lesen und verwerten.
    Tut mir Leid, damit kann ich nicht helfen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo Inge,


    Zitat von "mrb"

    Tut mir Leid, damit kann ich nicht helfen.


    Ich ebenfalls nicht. Wenn ich aber diesen Faden insgesamt verfolge, dann habe ich den Eindruck, dass da im Windows und/oder den Programminstallationen etwas ziemlich verwurschtelt ist. Das sieht man auch hier:


    Zitat von "Grabtiefer"

    Nun habe ich mit Outlook Express ... versucht, Anhänge anzuzeigen. Da geht es auch nicht mehr.


    Vielleicht wärst Du in einem guten Windowsforum besser aufgehoben.


    Bis auf das temporäre Speichern/Öffnen von Anhängen funktioniert der TB einwandfrei, oder? Was ich noch versuchen würde, das wäre, den Temp-Ordner zu leeren und den Kasperski für einen Test zu deinstallieren. Sollte dann immernoch diese Fehlermeldung kommen, schau doch mal nach, ob die zugehörige Datei unter Temp überhaupt existiert und ob Du sie von dort aus per Hand öffnen kannst.


    Gruß


    Susanne

  • Hallo,


    das klingt alles ungewöhnlich. Da ist wohl zuviel verstellt worden, möglicherweise haben neben dem manuell zerstörten TB-Profil auch noch "Aufräumprogramme" wie Regcleaner, TuneUp Utilities und ähnliche ihren Teil beigetragen. Da auf dem Rechner aber anscheinend noch Windows XP läuft, würde ich das Choas als Anlass nehmen, auf ein moderneres Betriebssystem zu wechseln und dort dann alles sauber zu installieren. Ich sehe keinen großen Sinn darin, auf der verkorksten XP-Kiste noch viel Mühe zu investieren, zumal der Support für XP ausgelaufen ist und auch keine Sicherheitsupdates mehr dafür kommen werden.


    Die Daten und fast alle Einstellungen kann man umziehen, einer der netten Helfer hier kann sicher auch den Link beisteuern zum Umzug des TB-Profiles auf einen neuen Computer.


    MfG
    Drachen

  • ABSCHLIESSEND:
    Mit dem Einspielen eines Images der Systempartition aus der Zeit vor kaspersky war
    wieder alles OK. Es gab ja noch andere Schwierigkeiten mit Kaspersky, z.B.:
    Aufrufen eines Batch-Files (.cmd) bringt eine Sythaxfehlermedung. etc.
    Ohne Kaspersky geht Thunderbird gut. :D