Welche Zeichencodierung-Problem mit Umlauten

  • Thunderbird-Version: 31.1.1
    Betriebssystem + Version: Win8.1
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): Arcor


    Hallo Freunde,


    welche Zeichencodierung sollte man eigentlich am besten auswählen, damit man mit E-Mails und den darin enthaltenden Umlauten keine Probleme bekommt. Ich hatte diue ganze Zeit Westlich ISO 8859-15 eingestellt und keine Probleme gehabt. Bis ich eine Mail von einem netten ct-Redakteur erhielt. Da waren die Umlaute komplett mit merkwürdigen Zeichen geschrieben. Nach Rückfrage konnte er mit nur mitteilen, dass das Problem bei mir zu finden sein muss. Ich habe nun nach Tipps auf Unicode UTF-8 umgestellt und siehe da, die Umlaute bei diesem einem o.g. Mail waren nun korrekt. Aaaaber eine neues von dem Herrn war wieder was die Umlaute betrifft falsch. Mmh, was mache ich da ggf. falsch, oder was sollte ich einstellen? MIt dem Senden über HTML oder NurText hat das doch nichts zu tun, oder?


    LG

  • Hallo,


    Zitat

    Ich hatte diue ganze Zeit Westlich ISO 8859-15 eingestellt und keine Probleme gehabt.


    Das ist absolut OK. UTF-8 wäre genauso OK, ist aber viel universeller, wenn man in anderen Sprachen kommuniziert.
    Zu deinen weiteren Fragen:


    Egal, welcher Zeichensatz (auch Zeichenkodierung) du bekommst, bei richtiger Deklarierung der Mails und den richtigen Einstellungen in Thunderbird sollte dieser automatisch den richtigen finden.
    Die Änderungen unter Ansicht > Zeichenkodierung sind immer nur temporär und verstellen sich bei erneutem Aufruf der Mail.
    Zunächst mache dieses:
    in der erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten") gibt ins Suchfeld ganz oben mailnews.force_charset_override ein und stelle den Wert auf "false", falls er nicht schon so dort steht.
    Dann überprüfe alle in Frage kommenden Ordner mit Rechtsklick > Eigenschaften > Allgemein, ob dort im unteren Kästchen ein Haken ist. Falls ja, entferne diesen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi,
    Danke für Dein Feedback.
    Ich habe den Befehl in der erweiterten Konfig ausgeführt und hier stand bereits "false". Soweit so gut. Bei meinen meinen Ordnern war auch alles in Ordnung, nirgends war im unteren Bereich ein Haken, nur im oberen.
    Also scheint hier alles in Ordnung zu sein.


    Weitere Ideen?
    Ich meine, es waren bisher diese drei Mail mit falschen Umlauten, sonst ist mir nie (bis vielleicht bei einem oder zwei Mails vor Monaten) so etwas aufgefallen.


    Andere weitere Frage:
    Warum eigentlich funktioniert bei eigegangenen E-Mails der Zeilenumbruch nicht korrekt?


    Grüße

  • Zitat

    MIt dem Senden über HTML oder NurText hat das doch nichts zu tun, oder?


    Absolut nichts.

    Zitat

    Bis ich eine Mail von einem netten ct-Redaykteuer erhielt.


    Auch der kann Fehler machen, ohne dass er sie merkt.


    Könntest du mir die Mail als *.eml Datei zusenden (Datei > Speichern als)?
    Falls ja, schreibe mir eine PN.
    Ohne den Header der Mail zu überprüfen und das Verhalten in meinem Thunderbird kann ich keine genaue Aussage machen.
    Es ist durchaus möglich, dass die Mail falsch deklariert ist oder dein Thunderbird beschädigt.
    Letzteres kann man ausschließen, indem man ein neues Profil einrichtet und dort testet.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Nachricht ist unterwegs zu Dir. Jetzt wo Du es sagst, ich glaube es kam mal was wegen meinem Profil, also das da was nicht stimmen würde. Ist aber länger her, habe nichts auffälliges entdeckt und das auch wieder vergessen. Wenn es am Profil liegt, könnte das auch ein Grund sein, warum die Zeilenumbrüche nicht immer funktionieren?


    Ich glaube, ich habe es schonmal geschrieben, aber ich habe es eben wieder die Zeichencodierung auf Westlich gestellt und auf einmal sind in einem Mail die Umlaute wieder korrekt, aber dafür in dem anderen Mail diese wieder nicht Ordnung. Nur der vollständigkeithalber.

  • So, habe die beiden Mails analysiert und kann nur mit dem Kopf schütteln.


    Beide Mails sind überhaupt nicht deklariert, heißt, es fehlen wichtige Angaben im Quelltext.


    Normalerweise müsste eine solche Mail folgende Angaben haben:


    Code
    1. Content-Type: text/plain; charset=ISO-8859-15
    2. Content-Transfer-Encoding: quoted-printable


    oder

    Code
    1. Content-Type: text/plain; charset=ISO-8859-15
    2. Content-Transfer-Encoding: 7bit


    Code
    1. Content-Type: text/plain; charset=UTF-8
    2. Content-Transfer-Encoding: 8bit


    oder
    hat eine Mail Anhänge oder ist in HTML geschireben sieht es noch anders aus:

    Code
    1. Content-Type: text/plain; charset=UTF-8
    2. Content-Transfer-Encoding: 8bit
    3. xxxxxxxx
    4. --------------020305050503080609050700
    5. Content-Type: text/html; charset=UTF-8
    6. Content-Transfer-Encoding: 8bit


    Also liegt der Fehler eindeutig beim Absender, der Quelltext beweist es und es wird für den Redakteur schwer sein, das zu widerlegen.
    Schicke ihm doch einfach den Link zu diesem Thread.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für das Recherchieren. Gut, dass bei mir erst einmal alles korrekt eingestellt ist.


    Kannst Du mir noch einen Tipp wegen den Zeilenschaltungen geben oder hat dies auch mit Deinen Rechercher zu tun, dass auch diese dadurch nicht korrekt sein können? Wobei, wie gesagt, dies ist mir aber schon von anderer Stelle aufgefallen.


    Grüße

  • Zitat

    Warum eigentlich funktioniert bei eigegangenen E-Mails der Zeilenumbruch nicht korrekt?


    Auch hier ist Thunderbird oft nicht die Ursache, besonders dann, wenn Mails über Webseiten oder anderen Programmen geschrieben und versendet werden.
    I deinem Fall benutzt der Absender ja X-mailer: Pegasus Mail for Windows (4.63, DE v4.63 R1).
    Eins ist aber klar:
    gibt es im Quelltext (Strg+U) der Mail ebenfalls keinen Umbruch, liegt es wieder am Versender.


    Ich nehme an, dass dein Thunderbird nach 72 Zeichen umbricht.
    Kontrolle:
    erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten")
    mailnews.wraplength dort müsste der Wert auf 72 stehen.
    Eine weitere Möglichkeit könnte das sog. format=flowed sein, welches in Thunderbird by default eingestellt ist.
    http://www.holgermetzger.de/mailundnews.html#33


    Einen korrekten Zeilenumbruch kann ein Mailklienten aber nur in Reintextmails haben, da in HTML Thunderbird umbricht, wenn es das Fensterende erreicht hat. Das ist aber kein Umbruch sondern ein Darstellungsfeature.
    Beachte, dass Mails auch auf kleinen Monitoren wie Smartphones einigermaßen komfortabel gelesen werden muss.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Also im Quellcode sind die Zeilen korrekt, also ohne Umbruch. Auch mein Thunderbird ist auf 72 Zeilen eingestellt.


    Nun ist mir noch was aufgefallen: Ich habe hier, vielleicht vollkommen falsch, ja davon gesprochen, dass manche Zeilenumbrüche nicht korrekt sind. Aber dies ist ausschließlich im rechten Fenster (also da wo die Leseseite rechts ist) falsch. Wenn ich auf antworten in dem Mail klicke, dann sind die Zeilenumbrüche korrekt dargestellt.


    Habe ich mich da ggf. falsch ausgedrückt, dann sorry.


    Ist das ein Anhaltspunkt?


    LG

  • Du hattest mal format=flowed für Empfang und Versenden abgestellt? Siehe mein obiger LInk?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich habe drei Profile, aber wohl den richten Ordner entdeckt. Also unter dem Profilordner eine user.js nach Anleitung (also mit der Befehlszeile) erstellt. Auch nach dem Neustart von Thunderbird habe ich eben immer noch bei diesen besagten wenigen Mails auf der rechten Fensterseite Zeilenumbrüche. Und nur da. Also das flowed zu deaktivieren hat wohl nicht geholfen.