Konten-Einstell. u. Mail-Ordner werden nicht angezeigt[erl.]

  • Thunderbird-Version: 31.1.1
    Betriebssystem + Version: Windows 8.1
    Kontenart (POP / IMAP): POP3
    Postfachanbieter (z.B. GMX): Arcor


    Hallo,


    Ich benutze Thunderbird ein halbes Jahr lang und hat immer tadellos funktioniert.


    Seit heute zeigt TB keine Mail-Ordner mehr an und die Konten-Einstellungen sind ebenfalls alle weg. Und das auch nach einer Neuinstallation von TB.
    Im TB-Anwendungsordner sind aber die Mails und Konten-Einstellungen vorhanden.


    Was tun?

  • Hallo,

    Zitat von "dafne2"


    Seit heute zeigt TB keine Mail-Ordner mehr an und die Konten-Einstellungen sind ebenfalls alle weg.


    TB öffnet sich also wie beim Erststart und lädt dazu ein, ein Konto zu erstellen?

    Zitat

    Und das auch nach einer Neuinstallation von TB.


    Die Neuinstallation des Programms Thunderbird hilft in den allerwenigsten Fällen, da das Problem meistens im Profil liegt.

    Zitat

    Im TB-Anwendungsordner sind aber die Mails und Konten-Einstellungen vorhanden.


    Das ist schon mal sehr wichtig.

    Zitat

    Was tun?


    Wahrscheinliche Ursache deines Problems ist eine defekte Datei "pref.js" (die u. a. deine Konten-Einstellungen enthält) oder vielleicht eine defekte Datei "profiles.ini".


    Gibt es ein nicht allzu altes Backup des Thunderbird-Anwendungsordners oder des Profilordners "xxxxxxxx.default"?
    Kannst du uns den Inhalt der Text-Datei "profiles.ini" (befindet sich im Ordner "....\AppData\Roaming\Thunderbird\...) einstellen und den exakten Namen des Profilordners "xxxxxxxx.default" mitteilen?


    Gruß

  • Hallo

    Zitat

    TB öffnet sich also wie beim Erststart und lädt dazu ein, ein Konto zu erstellen?


    Ja.


    Zitat

    Gibt es ein nicht allzu altes Backup des Thunderbird-Anwendungsordners oder des Profilordners "xxxxxxxx.default"?


    Ja, etwa drei Wochen alt ist das Backup des TB-Anwendungsordners.


    Der Name ist "tfjo3loe.default".



    (Vielleicht ist das wichtig: Ich habe in der Zwischenzeit ein Konto angelegt. Hat funktioniert und die zugehörigen Mailordner werden angezeigt.)



    Die Datei profiles.ini des momentanen Anwendungsordners hat diesen Inhalt:


    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/tfjo3loe.default

  • Zitat von "dafne2"


    Die Datei profiles.ini des momentanen Anwendungsordners hat diesen Inhalt:
    ......
    Path=Profiles/tfjo3loe.default
    Der Name ist "tfjo3loe.default".


    An der Datei "profiles.ini" scheint es nicht zu liegen.
    Aber ich muss jetzt doch noch genauer fragen:
    hast du vor der Neuinstallation nur das Programm Thunderbird entfernt oder auch den Anwendungsordner "Thunderbird"?
    Deine Antwort auf diese Frage entscheidet, wie weiter vorgegangen werden muss.


    Zitat

    (Vielleicht ist das wichtig: Ich habe in der Zwischenzeit ein Konto angelegt. Hat funktioniert und die zugehörigen Mailordner werden angezeigt.)


    Jetzt wird es etwas unübersichtlich.
    Werden alle Ordner dieses neu erstellten Kontos angezeigt, und wenn ja, enthalten sie Nachrichten?
    Meiner Einschätzung nach enthält das neu erstellte Konto nur einen leeren Posteingang und einen leeren Papierkorb.
    Ist das richtig?


    Zitat

    Ja, etwa drei Wochen alt ist das Backup des TB-Anwendungsordners


    Hat der Profilordner im Backup den selben Namen "tfjo3loe.default" ?

  • Hallo,


    Vor der Neuinstallation habe ich nur das Programm TB entfernt, den Anwendungsordner nicht.

    Zitat

    Hat der Profilordner im Backup den selben Namen "tfjo3loe.default" ?


    Ja.


    Zitat

    Jetzt wird es etwas unübersichtlich.
    Werden alle Ordner dieses neu erstellten Kontos angezeigt, und wenn ja, enthalten sie Nachrichten?
    Meiner Einschätzung nach enthält das neu erstellte Konto nur einen leeren Posteingang und einen leeren Papierkorb.
    Ist das richtig?


    Deine Einschätzung ist richtig.

  • Zitat von "dafne2"


    OK. Offenbar ist beim Erstellen des Kontos ein zweites Profil geschaffen worden.
    Kannst jetzt du bei beendetem TB überprüfen, ob sich im Ordner ...\Roaming\Thunderbird\Profiles\... neben dem Profilordner "tfjo3loe.default" ein zweiter Ordner "yyyyyyyy.default" befindet?


    Wenn ja, gehe in "tfjo3loe.default" -> "Mail" -> "pop.arcor.xx" und überprüfe, ob der pop-Ordner deine alten Mail- (Mbox-) Dateien wie Inbox, Sent, Drafts, .. etc mit Größen von mindestens einigen MB enthält.
    Falls dem so ist, kopiere den Ordner "pop.arcor.xx" und setze ihn anstelle des gleichnamigen Ordners in "yyyyyyyy.default" -> "Mail" ein.
    Kopiere ebenfalls die Adressbuch-Dateien "abook.mab" und "history.mab" aus "tfjo3loe.default" und ersetze die gleichnamigen Dateien in "yyyyyyyy.default" durch die Kopien.
    Beim Start von TB müsstest du deine alten Ordner, Nachrichten und AB wieder finden.


    Falls sich nur ein Profilordner in "Profiles" befindet, überprüfe, ob er etwa zwei Kontenordner im Ordner "Mail" enthält, z. B. "pop.arcor.xx" und "pop.arcor-1.xx".
    In diesem Fall würde ich später am Abend eine andere Lösung geben.

  • Zitat

    dafne2 hat geschrieben:
    (Vielleicht ist das wichtig: Ich habe in der Zwischenzeit ein Konto angelegt. Hat funktioniert und die zugehörigen Mailordner werden angezeigt.)


    Zitat

    Mapenzi hat geschrieben:
    Jetzt wird es etwas unübersichtlich.


    Zitat

    Mapenzi hat geschrieben:
    OK. Offenbar ist beim Erstellen des Kontos ein zweites Profil geschaffen worden.


    Jetzt merke ich selbst, dass ich es durch meinen oben zitierten Text unübersichtlich gemacht habe.
    Das Anlegen dieses Kontos ist nicht die Ursache des Problems, weil ich es erst nach dem Auftreten des Problems angelegt habe.

  • Zitat von "dafne2"


    Das Anlegen dieses Kontos ist nicht die Ursache des Problems, weil ich es erst nach dem Auftreten des Problems angelegt habe.


    Ich weiß, dass das Anlegen des Kontos nicht das Problem verursacht hat.
    Kannst du trotzdem die Frage beantworten, die ich im letzten Absatz meiner vorigen Antwort gestellt habe?
    Die beiden ersten Absätze kannst du vergessen, da sie einer Fehleinschätzung entsprangen (du hast sicherlich nur einen Profilordner).
    Ich brauche einige Informationen und kann deinen Bildschirm leider nicht sehen, sonst geht es nicht weiter.


    NACHTRAG:
    Ich habe gerade einen Test gemacht: die prefs.js-Datei in einem meiner Profile entfernt und TB in diesem Profil gestartet. Ergebnis wie bei dir: TB öffnet wie beim Erststart und fordert zum Anlegen eines Kontos auf.
    Konto angelegt, TB beendet , entsprechenden Profilordner geöffnet.
    Im Ordner "Mail" befinden sich jetzt zwei Kontenordner, einmal "pop.free.fr" (der alte mit meinen Nachrichtendateien) und noch "pop.free-1.fr" (der neue mit noch leeren Nachrichtendateien).
    Außerdem wurde ein zweiter Ordner "Local Folders-1" erstellt.


    Analog dazu müsstest du bei dir jetzt im Ordner "Mail" zwei pop-Kontenordner sehen:
    "pop.arcor.xx" und "pop.arcor-1.xx"
    Kannst du das also bitte überprüfen?
    Außerdem: kannst du derzeit deine Adressbücher anzeigen, wenn du TB öffnest?

  • Auch bei mir wurde ein zweiter Ordner "Local Folders-1" erstellt und ich sehe ebenfalls die zwei Ordner pop.arcor.xx und pop.arcor-1.xx.


    Die Adressbücher kann ich anzeigen.

  • Gehe jetzt in Extras -> Konten-Einstellungen -> Server-Einstellungen -> Nachrichtenspeicher und klicke auf "Ordner wählen".
    Navigiere zum Profilordner "tfjo3loe.default" -> "Mail" -> , markiere den Kontenordner "pop.arcor.xx" und klicke auf "Öffnen", dann in den Konten-Einstellungen auf "OK"
    Danach fordert TB zum Neustart auf, und nach dem Neustart müsstest du dein Konto mit allen alten Ordnern und Nachrichten sehen.


    Führe die gleich Manipulation in den Konten-Einstellungen für "Lokale Ordner" -> Nachrichtenspeicher durch und wähle diesmal im Ordner "Mail" den Unterordner "Local Folders" an, ..etc.


    Wenn bis dahin alles geklappt hat, kannst du im Profil im Ordner "Mail" die beiden Unterordner "pop.arcor-1.xx" und "Local Folders-1" löschen, da sie nur leere Mbox-Dateien enthalten.


    Zum Schluss möchte ich dich noch bitten, den Profilordner "tfjo3loe.default" darauf zu untersuchen, ob er mehrere "prefs."-Dateien enthält, z. B. "prefs.js" und eine zweite "prefs.js.bak" oder "prefs-1.js".
    Wenn das der Fall ist, überprüfe ob die Datei "prefs"js" das Erstellungsdatum 21.09.2014 hat.
    Falls ja, kannst du die andere(n) prefs-Datei(en) zunächst entfernen und bei einem erneuten Start von TB testen, ob alles OK ist.

  • Zitat

    Führe die gleich Manipulation in den Konten-Einstellungen für "Lokale Ordner" -> Nachrichtenspeicher durch und wähle diesmal im Ordner "Mail" den Unterordner "Local Folders" an, ..etc.


    Das hat geklappt. Ich sehe jetzt in "Lokale Ordner" alle Ordner mit Mails, die auch vorher dort waren. Den Ordner "Local Folders-1" habe ich gelöscht.
    Da ich Mails nur hier gespeichert habe, werden jetzt alle meine Mails wieder angezeigt.


    Zitat

    Gehe jetzt in Extras -> Konten-Einstellungen -> Server-Einstellungen -> Nachrichtenspeicher und klicke auf "Ordner wählen".
    Navigiere zum Profilordner "tfjo3loe.default" -> "Mail" -> , markiere den Kontenordner "pop.arcor.xx" und klicke auf "Öffnen", dann in den Konten-Einstellungen auf "OK"
    Danach fordert TB zum Neustart auf, und nach dem Neustart müsstest du dein Konto mit allen alten Ordnern und Nachrichten sehen.


    Dieser Teil hat nicht funktioniert. Es hat sich dabei nichts verändert.
    Bei mir steht nicht "Öffnen" auf der Schaltfläche, sondern "Ordner wählen".




    Es ist nur eine Datei "prefs...." vorhanden.

  • Zitat von "dafne2"


    Das hat geklappt. Ich sehe jetzt in "Lokale Ordner" alle Ordner mit Mails, die auch vorher dort waren. Den Ordner "Local Folders-1" habe ich gelöscht.
    Da ich Mails nur hier gespeichert habe, werden jetzt alle meine Mails wieder angezeigt.


    Du benutzt also offenbar den "globalen Posteingang" und nicht den Ordner des POP-Kontos für das Speichern deiner Nachrichten.
    Das ging aber aus deinen bisherigen Beiträgen nicht hervor.
    Hauptsache ist, dass deine Ordner und Nachrichten wieder da sind.


    Zitat

    Dieser Teil hat nicht funktioniert. Es hat sich dabei nichts verändert.


    Das dürfte normal sein, wenn deine Nachrichten in den Lokalen Ordnern gespeichert sind (s. o.).


    Zitat

    Bei mir steht nicht "Öffnen" auf der Schaltfläche, sondern "Ordner wählen".


    Möglicherweise ein Unterschied zwischen unseren Schnittflächen: ich benutze Mac OS X.

    Zitat

    Es ist nur eine Datei "prefs...." vorhanden.


    Etwas frustrierend, damit bleibt die Ursache deines Problems weiterhin völlig unklar.



    Gern geschehen ;)

  • Hallo


    Die Ordner mit den Mails sind natürlich das aller wichtigste.
    Ganz herzlichen Dank für die schnelle Hilfe. :):):)



    Die Konten, die jetzt fehlen kann ich wieder neu mit allen ihren Einstellungen erstellen.

    Schön wäre es, wenn man sie auf einfache Weise aus dem vorhandenen wieder sichtbar machen könnte, denn es sind insgesamt 6 Stück: "pop.arcor.xx", "pop.arcor-1.xx", "pop.arcor-2.xx", "pop.arcor-3.xx", "pop.arcor-4.xx", "pop.arcor-5.xx" und das neu erstellte Konto, das jetzt sichtbar ist "pop.arcor-6.xx".


    Gibt es da eine Möglichkeit?

  • Zitat von "dafne2"


    Die Konten, die jetzt fehlen kann ich wieder neu mit allen ihren Einstellungen erstellen.


    Ich hatte es doch irgend wie geahnt, wollte dich auch schon in einer meiner Antworten fragen, ob du mehr als ein POP-Konto benutzt hattest. Jetzt kommt es allmählich heraus, es waren derer sogar sechs!

    Wenn ich das von Anfang an gewusst hätte, hätte ich sofort eine andere Lösung vorgeschlagen, aber inzwischen hattest du ein neues Konto erstellt, und ich dachte es sei das einzige.


    Man kann es trotzdem noch versuchen (ist in jedem Fall schneller als alle Konten neu einrichten):
    kopiere die Datei "prefs.js" aus deinem Backup und setze sie bei beendetem TB in den aktuellen Profilordner ein anstelle der schon vorhandenen Datei pref.js, die du zuvor an einen anderen Ort verschiebst.
    Starte TB und überprüfe, ob alle sechs Konten und Mail-Ordner vorhanden sind, inklusive der Lokalen Ordner.
    Wenn das der Fall ist, überprüfe ebenfalls für alle sechs Konten in den Konten-Einstellungen -> Server-Einstellungen -> Nachrichtenspeicher -> Button "Erweitert", ob der "globale Posteingang (Lokale Ordner)" eingestellt ist.

  • Hat funktioniert. Alles ist da und richtig eingestellt.
    Vielen, vielen Dank, auch für den Umweg, den du mit mir gegangen bist.
    :D:D:D


    Bei eventuellen zukünfigen Problemen werde ich versuchen, meine Situation umfänglicher darzustelllen.

  • Zitat von "Mapenzi"


    Inzwischen habe ich folgende Dateien gefunden:


    Invalidprefs.js
    cookies.sqlite.bak
    SESSIO~1.JSO
    SESSIO~2.JSO
    VIRTUA~1.DAT
    xpunge-extension-prefmigration-old-prefs.txt
    xpunge-extension-prefmigration-existing-new-prefs.txt


    Die ersten fünf wurden am 20.9.14 geändert, und nur die.
    Die letzten beiden wurden am 21.9.14 geändert.


    Ich gehe davon aus, dass ich die ersten 6 löschen kann.
    Ist das richtig?

  • Zitat von "dafne2"


    Inzwischen habe ich folgende Dateien gefunden:
    Invalidprefs.js
    .......


    Vielen Dank für die Rückmeldung!
    Das ist ein wichtiger Fund, ich konnte es mir einfach nicht vorstellen, dass sich keine alte, irgend wie umbenannte prefs.js-Datei im Profilordner befindet.
    Genau das war das Problem: die prefs.js-Datei wurde am 20.09. beschädigt und umbenannt, konnte also beim Start von TB am 21.09. nicht mehr von TB benutzt werden, worauf TB eine neue, jungfräuliche prefs.js-Datei erstellt hat.
    Und mit der jungfräulichen prefs.js-Datei hat TB sich natürlich wie bei einem Erststart verhalten und zum Erstellen eines Kontos aufgefordert.
    Mit dem Ersetzen dieser neuen prefs.js-Datei durch die prefs.js-Datei aus dem Backup wurde der alte Stand wiederhergestellt, und alle deinen Konten wurden wieder angezeigt


    Zitat

    Ich gehe davon aus, dass ich die ersten 6 löschen kann.
    Ist das richtig?


    Ja, du kannst sie bei beendetem TB aus dem Profilordner entfernen.


    Gruß