Riesenärger! Thunderbird hängt unbemerkt private Videos dran

  • Thunderbird-Version: 31.1.1
    Betriebssystem + Version: Windows 7 + SP1
    Kontenart (POP / IMAP): POP3
    Postfachanbieter (z.B. GMX): arcor.de
    Speicherdienst (z.B. Dropbox): negativ


    Hallo Community!


    Ich habe mich extra angemeldet, um diesen schweren Bug zu melden. Ich nutze Thunderbird seit über 10 Jahren. Aber das ist mir noch nicht passiert. Ich habe eine Geschäftsmail verschickt und mich gewundert, warum es für Text solange dauert. Es war kein Anhang an der E-Mail. Ich habe den Versand deshalb mehrmals abgebrochen und immer wieder neu gesendet. Es wurde immer ein Anhang mitgesendet, der aber nicht sichtbar war.


    Ich habe den Versand dann durchgehen lassen und festgestellt, dass ein kurzes privates Video mit der E-Mail versendet wurde. Ich bin froh, dass keine Menschen darauf zu sehen waren. Aber jetzt fürchte ich mich, Thunderbird weiter zu nutzen. Was ist da los?


    LG
    Mark

  • Hallo und willkommen im Forum!


    Zitat

    Ich habe mich extra angemeldet, um diesen schweren Bug zu melden


    Nun stelle dir bitte mal vor, dass wäre wirklich ein Bug und alle User von Thunderbird hätten das gleiche Problem...
    Natürlich ist das für dich schon sehr ärgerlich.
    Passiert das bei jeder Mail, die du versendest, also auch bei denen, die du an dich selbst verschickst?
    Wenn du eine Mail verschickst, benutze testweise immer anstatt "Senden" das Menü Datei > "Später senden".
    Dadurch gelangt die Mail in den Postausgang.
    Dort kontrolliere den Quelltext (Strg+U) dieser Mail.
    Einen Anhang erkennt man sofort an den sehr langen unendlich erscheinenden und scheinbar wirren Buchstaben/Zeichensalat.
    Untersuche, ob nicht ein externes Programm oder gar ein Virenscanner dafür in Frage kommen können.
    Von einem solchen Verhalten habe ich noch niemals gehört.
    War dieses Video evtl. in deinen Mails schon irgendwo vorhanden?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:


    Nun stelle dir bitte mal vor, dass wäre wirklich ein Bug und alle User von Thunderbird hätten das gleiche Problem...


    Deshalb melde ich dieses Verhalten hier. Damit dieses Problem ergründet und gelöst werden kann.


    Zitat

    Passiert das bei jeder Mail, die du versendest, also auch bei denen, die du an dich selbst verschickst?


    Ich kann den Fehler leider nicht reproduzieren. Ich habe die original Mail "als neu bearbeitet" und an mich selbst geschickt. Es wurde kein Anhang mitgesendet. Der Quellcode der Mail enthält aber den von dir genannten langen Code. Ich sag es nur nochmal zur Klarstellung. Die Email sollte keinen Anhang haben.


    Zitat

    Wenn du eine Mail verschickst, benutze testweise immer anstatt "Senden" das Menü Datei > "Später senden".
    Dadurch gelangt die Mail in den Postausgang.
    Dort kontrolliere den Quelltext (Strg+U) dieser Mail.


    Das ist aber schon unkomfortabel?! Machst Du das immer so?


    Zitat

    Einen Anhang erkennt man sofort an den sehr langen unendlich erscheinenden und scheinbar wirren Buchstaben/Zeichensalat.
    Untersuche, ob nicht ein externes Programm oder gar ein Virenscanner dafür in Frage kommen können.


    An dem System habe ich seit Wochen, wenn nicht Monaten, nichts verändert.


    Zitat

    Von einem solchen Verhalten habe ich noch niemals gehört.
    War dieses Video evtl. in deinen Mails schon irgendwo vorhanden?


    Ich auch nicht. Und das ist mir sehr unangenehm gegenüber meinem Geschäftspartner. Die Suche nach dem Dateinamen in Thunderbird ergab keine Treffer.

  • Zitat

    Das ist aber schon unkomfortabel?! Machst Du das immer so?


    Nein, nie, außer bei Problemen. Ich schrieb ja auch "testweise".

    Zitat

    er Quellcode der Mail enthält aber den von dir genannten langen Code


    Hmm, und wie wurde die Mail deklariert?
    Ich vermute, dass hier die Kodierung des Anhangs in Text vorhanden ist, aber nicht als Anhang deklariert wurde.
    Der Anhang kann nur angezeigt werden, wenn der Quelltext einen bestimmten Code enthält, einschließlich des Dateinamens
    z.B.

    Code
    1. Content-Type: multipart/mixed;
    2. Content-Type: video/x-ms-wmv;
    3. name="bluehorizon.wmv"
    4. Content-Transfer-Encoding: base64
    5. Content-Disposition: attachment;
    6. filename="bluehorizon.wmv"


    Könntest du mal einen Teil des Quelltextes (bis zum Beginn des kodierten Anhangs) hier posten?
    Mache bitte alle Passagen, die privat oder geschäftlich sind, unkenntlich.
    Du kannst sie auch gerne über eine PN an mich schicken.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für die PN.


    Das Video wurde nicht korrekt deklariert:


    Code
    1. Content-Type: video/mp4
    2. Content-Transfer-Encoding: base64
    3. Content-ID: <part5.zensiert@arcor.de>


    Korrekt müsste es heißen:


    Code
    1. Content-Type: video/mp4
    2. name=: "video.mp4"
    3. Content-Transfer-Encoding: base64
    4. Content-Disposition: attachment;
    5. filename=: "video.mp4"


    Folge ist, dass - zumindest Thunderbird - den Anhang nicht anzeigt, er also nur als Leiche im Quelltext vorhanden ist.


    Das heißt aber nicht, dass sich das Video nicht anschauen lässt.
    Man erstellt eine neu Mail, kopiert den schon kodierten Teil des Videos mit richtiger Deklarierung ein und schon hat man einen Anhang.
    Ich kann mir auch gut vorstellen, dass andere Mailprogramme keine Deklarierung brauchen, die Datei erkennen und als Anhang in der Mail sofort darstellen können.
    Was deiner Darstellung entsprechen würde: Bei dir kein Anhang - aber bei anderen schon.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich verstehe deine Antwort nicht. Deine Antwort klingt nach einer Lösung, wie ich den Anhang sichtbar mache und dann anschauen kann. Ich wollte in der Email aber keinen Anhang einbinden. Dass hat das Programm selbstständig gemacht.

  • Nein, eine Lösung sollte das nicht sein nur eine Erklärung für das merkwürdige Verhalten.


    Die Frage ist also: wie kommt das Video in die Mail - offensichtlich ohne Deklarierung?
    Und darauf kann ich dir keine schlüssige Antwort geben, weil ich deine Mails, dein Thunderbird und dein System nicht kenne.
    Möglichkeit: der Anhang ist in deiner Mailsammlung schon vorhanden und Thunderbird ist durch einen beschädigten Ordner - genauer einer Indexdatei (*.msf) durcheinandergekommen. Das kann bei solchen Problemen vorkommen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für Deine Hilfe. Wenn es für das Problem allerdings keine Erklärung oder Lösung gibt, und es damit nicht vermeidbar ist, geht mit der Nutzung ein Risiko einher. Das kann es doch nicht sein.


    Wie gehe ich jetzt weiter vor? Wem kann ich diesen Fehler melden? Wer untersucht das?

  • Du kannst einen Bugreport posten und zwar hier:
    https://bugzilla.mozilla.org/
    Bevor du das machst, würde ich das Verhalten aber in einem neuen Profil überprüfen (ein Konto genügt), so dass interne Einflüsse auszuschließen sind.


    Wie ich aber schon sagte: ich glaube nicht an einen Bug sondern nur an eine bestimmte Konstellation auf deinem System und in Thunderbird.
    Das Problem wird sein, dass du im Report den Fehler reproduzierbar schildern musst und ich bezweifele, dass dir das gelingt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:

    Das Problem wird sein, dass du im Report den Fehler reproduzierbar schildern musst und ich bezweifele, dass dir das gelingt.

    Da hast Du Recht.


    Ich werde mich von Thunderbird verabschieden. Da führt wohl kein Weg dran vorbei.


    Danke nochmal.

  • Hallo Feierfuchs,


    in Deinem Eröffnungsbeitrag dieses Fadens schreibst Du unter anderem


    "Feierfuchs" schrieb:

    Ich nutze Thunderbird seit über 10 Jahren.


    Und da verabschiedest Du Dich lieber ganz vom Thunderbird, statt wenigstens maximal eine halbe Stunde Zeit zu investieren, um den Vorschlag mrbs umzusetzen:


    "mrb" schrieb:

    Bevor du das machst, würde ich das Verhalten aber in einem neuen Profil überprüfen (ein Konto genügt), so dass interne Einflüsse auszuschließen sind.


    Das verstehe wer will. Ich verstehe es jedenfalls nicht.


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Hallo Feuerdrache!


    Ich habe über 2000 Emails in meinem Thunderbirdprofil und habe den Luxus, in alten Emails offline suchen zu können, immer sehr geschätzt. Ganz zu schweigen, dass eine Veränderung Geld und Zeit kostet. Da ich aber keine Idee habe, wie ich den Fehler reproduzieren soll, sehe ich da keine Wahl.


    Ich habe bereits versucht, den Fehler zu reproduzieren, indem ich die E-Mail "als neu bearbeitet" an meine eigene Adresse geschickt habe. Der Anhang wurde aber in diesem Fall nicht gesendet.


    Für Hilfe bin ich weiterhin dankbar. Ich habe Thunderbird vielen Kollegen empfohlen und müsste sie sonst eher warnen.

  • Hallo Feierfuchs,


    also, wenn mir das passiert wäre, wäre ich sicher auch erstmal blass geworden - keine Frage. Das ist schon gravierend.
    Wie mrb teile ich die Ansicht, dass Du den Fehler so einfach nicht wirst reproduzieren können. Ich weiß nicht, welche Zehnerpotenz man benötigt, um die Anzahl der E-Mails zu benennen, die weltweit bereits mit dem TB verschickt wurden. Von einem ähnlichen Phänomen habe ich bisher allerdings erst zweimal gehört, siehe hier.
    In beiden Fällen war es so, dass ein falscher Anhang gesendet wurde, zumindest in einem Fall aufgrund eines defekten Indexes.
    Auch wenn es das Problem nicht reproduzierbar macht, wären folgende Angaben doch hilfreich. Und sei es nur, den Fehler weiter einzukreisen, sollte er nochmals auftreten:


    • Betraf das eine neue E-Mail oder eine Antwort/Weiterleitung?
    • Hattest Du die E-Mail zuvor als Entwurf gespeichert?
    • Hattest Du vielleicht zuvor einen Anhang ausgewählt und ihn wieder verworfen?
    • Stimmt der Dateiname in der E-Mail mit dem realen Dateinamen überein?
    • Befand sich dieses Video in einer der anderen TB-Ordner (auch die zugehörige E-Mail längst gelöscht wurde)? Mit anderen Worten: hast Du dieses Video jemals per E-Mail verschickt oder zugeschickt bekommen?
    • Kannst Du irgendeinen anderen Zusammenhang zwischen dem Video und TB herstellen? Hast Du z.B. eine andere Datei aus diesem Verzeichnis als Anhang gesendet?
    • Hattest Du das Video kürzlich betrachtet, sodass es vielleicht noch im Cache oder Temp-Verzeichnis lag?
    • Wie alt ist Dein Profilordner? Sind darunter Mailboxen, deren Dateigröße sehr groß ist (> 1 GB)? Hast Du die Mailboxen jemals "gewartet" also komprimiert und repariert?
    • Hast Du kürzlich andere, auffällige Beobachtungen auf Deinem Rechner gemacht?


    Gruß


    Susanne

  • Hallo SusiTux!


    Der Link war sehr interessant!


    SusiTux schrieb:

    Hallo Feierfuchs,

    Betraf das eine neue E-Mail oder eine Antwort/Weiterleitung?


    Es betraf eine Antwort-E-Mail. Die E-Mail beinhaltete einen kleinen E-Mailverlauf.


    Zitat

    Hattest Du die E-Mail zuvor als Entwurf gespeichert?


    Nein. Ich habe direkt auf eine E-Mail geantwortet. Nachdem Thunderbird versucht hatte, einen Anhang hochzuladen, habe ich den Versand abgebrochen und es noch 2-3 Mal mit dem Senden versucht. Währenddessen speichert TB aber automatisch meine E-Mails standardmäßig als Entwurf.


    Zitat

    Hattest Du vielleicht zuvor einen Anhang ausgewählt und ihn wieder verworfen?


    Nein. Nicht für diese E-Mail.


    Zitat

    Stimmt der Dateiname in der E-Mail mit dem realen Dateinamen überein?


    Der Dateiname ist Teil 1.2.2 -> .2 soll laut Dateieigenschaften dabei die Dateiendung sein. Den Dateinamen finde ich auf meinem PC nicht.


    Zitat

    Befand sich dieses Video in einer der anderen TB-Ordner (auch die zugehörige E-Mail längst gelöscht wurde)? Mit anderen Worten: hast Du dieses Video jemals per E-Mail verschickt oder zugeschickt bekommen?


    Über die Thunderbird-Suchfunktion konnte ich den Dateinamen nicht finden. Wie das Video original heißt, weiß ich nicht.


    Zitat

    Hattest Du das Video kürzlich betrachtet, sodass es vielleicht noch im Cache oder Temp-Verzeichnis lag?


    Nein. Aufgrund des Videoinhalts eher unwahrscheinlich. Im Temp-Ordner liegt kein Video.


    Zitat

    Wie alt ist Dein Profilordner? Sind darunter Mailboxen, deren Dateigröße sehr groß ist (> 1 GB)? Hast Du die Mailboxen jemals "gewartet" also komprimiert und repariert?


    Ich habe die Ordner ab und zu, also eher sporadisch komprimiert. Und auch nur dann manchmal, wenn ich eine Aufforderung bekommen habe. Der Profilordner ist sicher über ein Jahr alt. Der Profiles-Ordner im Benutzerordner enthält zwei Profile mit insgesamt ca. 100 MB. Insgesamt dürften um die 10.000 E-Mails in meinen beiden Profilen gespeichert sein.


    Zitat

    Hast Du kürzlich andere, auffällige Beobachtungen auf Deinem Rechner gemacht?


    Nein. Ich bin auch sehr vorsichtig beim Surfen und öffne unbekannte Anhänge z. B. nur in einer Sandbox. Die E-Mails werden von Avast immer geprüft.




    Ich beantworte gerne alle Fragen. Wenn mrb den E-Mail-Code so einschätzt, dass er keine privaten Daten mehr enthält, kann ich ihn hier auch gerne veröffentlichen. Den Code kann ich leider nicht verstehen.

  • Hallo Feierfuchs,


    jetzt muss ich mal dumm fragen: Bist Du Dir absolut sicher, dass das Video nicht schon vorher in der von Dir weitergeleiteten E-Mail enthalten war und Du es vielleicht nur übersehen hast? Ich frage, weil es mich etwas wunder, dass Du nicht weißt, wie das Video im Original heißt. Wenn es von Deinem Rechner stammt, dann müsstest Du es doch kennen.(?)
    Oder anders gefragt, wenn das Video nicht von Dir stammt, von wem dann, wenn nicht aus der originalen E-Mail?


    Gruß


    Susanne

  • "SusiTux" schrieb:

    Bist Du Dir absolut sicher, dass das Video nicht schon vorher in der von Dir weitergeleiteten E-Mail enthalten war und Du es vielleicht nur übersehen hast? Ich frage, weil es mich etwas wunder, dass Du nicht weißt, wie das Video im Original heißt. Wenn es von Deinem Rechner stammt, dann müsstest Du es doch kennen.(?)
    Oder anders gefragt, wenn das Video nicht von Dir stammt, von wem dann, wenn nicht aus der originalen E-Mail?


    Also es handelt sich bei dem Video um eine Smartphoneaufnahme von einem Wintertag letzten Jahres. Auf dem Video hätten aber theoretisch ebenso meine Kinder beim Baden zu sehen sein können. Das Video habe ich mit Sicherheit nicht in den vergangen 12 Monaten gesehen, geschweige denn als Anhang verschickt. Meine Videos und Fotos sind auch in ganz anderen Ordnern gespeichert, als meine geschäftliche Dokumente. Ich verstehe nicht, warum das Video im Anhang einen anderen Namen als das Originalvideo hat. Aufgrund meiner vielen Bilder und Videos habe ich das Video auch nicht finden können - obwohl ich es vor dem Schreiben meines letzten Beitrags manuell durch Betrachtung der Screenshots gesucht habe. Möglicherweise befindet es sich tatsächlich auch nur noch in einer Thunderbird-E-Mail und garnicht mehr in einem Medienordner. Ich weiß es nicht. Wie kann ich denn nach Dateinamen in Anhängen bei TB suchen?

  • "Archaeopteryx" schrieb:

    Vermutlich handelt es sich um ein Problem mit Bezug zu Bug 581515 (und darin verlinkte Bugs).


    Thunderbird 31.1.2-candidates ist auch schon da, vielleicht behebt er diesen BUG.


    MfG
    EDV Oldi

  • Wirft man einen Blick auf die Änderungen, so hat sich bei comm-esr31 nichts getan, nur bei mozilla-esr31. Dass dort Bug 1064636 ohne Beschreibung ist und man auf ihn nicht ohne besondere Recht zugreifen kann, lässt auf die Behebung eines Sicherheitsproblems schließen. Dass es sich laut den Änderungen um Update der Bibliothek zu Verifizierung von Zertifikaten handelt, spricht dafür.

  • Hallo,


    danke, Archaeopteryx, für das erfolgreiche Suchen und den Hinweis auf die bugs. Ich verstehe insbesondere den Meta-Bug 877159 so:


    Da der TB zunächst nur einen Verweis auf den jeweiligen Anhang hält, den Anhang selbst aber erst beim Speichern bzw. Senden anhängt oder aktualisiert, kann es zu falschen Anhängen kommen, wenn sich zwischenzeitlich etwas geändert hat.
    Diese zwischenzeitliche Änderung kann z.B. dadurch geschehen, dass das Dokument tatsächlich geöffnet, bearbeitet oder verschoben wurde, aber auch dadurch, dass im TB ein Komprimieren stattgefunden hat oder der Index irgendwie "verrutscht" ist. Ursachen können also also Änderungen in der Datei, im Temp, in der Mailbox oder der *.msf sein.


    Anhänge sind in diesem Fall auch eingebettete Bilder. Das heißt beim Weiterleiten kann der Fehler auch dann auftreten, wenn man selbst gar keinen Anhang zugefügt hat.


    Wenn das so richtig ist, dann hoffe ich, dass man die Empfehlung von Thomas D. und WADA folgt:


    Zitat


    [...] folks like WADA, rsx11m and me keep coming to the same conclusion all over again: It's a general design problem which can only be addressed by taking an *immediate snapshot* of all things as soon as they get embedded or attached (at least as a *default behaviour*).


    Die bugs dazu, die ich mir angeschaut habe, haben noch den Status "new". Es gibt also offenbar zumindest offziell noch niemanden, der aktiv daran arbeiten würde.


    Meine Empfehlungen für den Moment wären daher:


    • Eigene Anhänge erst unmittelbar vor dem Senden hinzufügen. Darauf achten, dass die zugehörige Datei nicht noch in einem anderem Programm geöffnet ist.
    • Automatisches Komprimieren deaktivieren. Beim manuellen Komprimieren darauf achten, dass kein Verfassen-Dialog offen ist und möglichst auch keine E-Mails im Entwurfsordner liegen.
      Ebenso beim Reparieren von Ordnern.
    • Wenn man sensible Dateien per E-Mail erhält, trennt man die Anhänge besser ab, speichert sie getrennt außerhalb des TB und komprimiert anschließend die Inbox.
    • Eigene Anhänge besser nicht per Drag$Drop aus anderen E-Mails übernehmen sondern aus dem Filesystem.
    • Bei der Benutzung von Entwürfen und/oder Vorlagen, die Anhänge oder eingebettete Grafiken enthalten, vor dem Senden besser nochmals überprüfen, z.B. über "später senden".
      Das würde ich insbesondere dann empfehlen, wenn der Entwurf schon etwas länger liegt oder die darin enthaltenen Anhänge zwischenzeitlich geöffnet oder verschoben wurden, die Ordner komprimiert oder repariert wurden.
      Gleiches gilt für das Weiterleiten schon "betagter" E-Mails.
    • Wo möglich, Verzicht auf HTML und bunte Bildchen.


    Der Fehler tritt ja offenbar nur sehr selten auf. Wie die meisten, war auch ich in all den Jahren zum Glück noch nie davon betroffen. Dennoch, die Vorstellung, dass eine E-Mail plötzlich von Geisterhand einen falschen Anhang bekommen kann, beunruhigt mich schon. Mich wundert, dass bei Mozilla nicht die Alarmglocken läuten, auch wenn TB dort nur noch ein Nebenprodukt ist.


    Gruß


    Susanne