Titelleiste nach Update wieder entfernen

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 31.3.0
    * Betriebssystem + Version: Windows 7 Prof, 64 Bit
    * Kontenart (POP / IMAP): beides
    * Postfachanbieter (z.B. GMX): mehrere


    Nach dem Update auf die 31.3.0 wird bei mir plötzlich die Titelleiste wieder eingeblendet und ich bekomme sie nicht mehr los.
    Wird sowohl im Standard-Theme als auch im von mir verwendeten Walnut angezeigt. Aktuell ist alles. Über die Funktion "mail.tabs.drawInTitlebar" hab ich es schon probiert (bleibt ohne Wirkung). Eine andere Möglichkeit habe ich jetzt nicht finden können.


    Aus Platzgründen hätte ich das gern wieder so kompakt wie möglich. Kann mir da jemand helfen?
    Seit der Einrichtung dieser Funktion vor zig TB-Versionen hatte ich damit nie Probleme. Und jetzt sehe ich plötzlich aus dem Nichts nach einem Update wieder die Windowsleiste. Was ist da passiert?

  • Nach dem Update auf die 31.3.0 wird bei mir plötzlich die Titelleiste wieder eingeblendet und ich bekomme sie nicht mehr los.


    Du meinst die Menüleiste mit Datei, Bearbeiten, Ansicht,... Dann klick mal auf Ansicht > Symbolleisten -> Menüleiste, damit das Häkchen weg geht.

  • Na, das wär dann doch ein bisschen zu einfach ;)
    Ich meine schon die Titelleiste [sic!], die den Schriftzug "Mozilla Thunderbird" und die drei Windows-Schaltflächen "Minimieren", "Maximieren" und "Schließen" enthält. Bis zum Update waren hier wunderbar platzsparend statt des besagten Schriftzugs die Inhalte der Menüleiste untergebracht, so wie auch bei den aktuellen Versionen des Firefox.

  • Hallo,


    erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten")
    nach mail.tabs.drawInTitlebar suchen und den Wert auf "false" stellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hi,


    siehe Post 1 dieses Threads. Schon probiert, true-false-true-false durchgeschaltet, Themes geswitched, TB neugestartet, keine Veränderung. Bin auch die Config schon durchgegangen.


    Ich sag ja... wenn's so einfach wäre, würde ich mich hier nicht melden. Irgendwas muss sich mit dem Update neulich geändert haben und ich komme einfach nicht dahinter. Was Windows-eigenes kann's auch nicht sein, denn im Firefox habe ich dieses Darstellungsproblem nicht.

  • Hallo DarkS3th,


    dann starte mal Thunderbird im "Abgesicherten Modus" (mit deaktivierten Add-ons). Vielleicht liegt es ja an einer Erweiterung, die Dir da dazwischen funkt.


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Ergänzung:
    in meinem aktuellem Thunderbird-Profil klappt die Umstellung übrigens auch nicht.
    In einem anderen neuen aber problemlos. Und deswegen habe ich auch meine erste Antwort geschrieben. Ich gebe keine Tipps, die ich nicht vorher getestet habe.
    Mit anderen Worten: was Feuerdrache schon vermutet: es liegt an deinen Add-ons oder Profil.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Sooo.
    Weiteres Testen hat mir jetzt folgendes gebracht:
    - Selbes Verhalten im Abgesicherten Modus mit deaktivierten Addons
    - Korrekte Darstellung aber nach dem Anlegen eines neuen Profils. Auch mit meinem Walnut-Theme klappt es


    Es liegt also nicht am Programm selber, an einer Kollision mit Addons oder am Theme, sondern hängt tatsächlich am verwendeten TB-Profil.

  • Zitat

    Es liegt also nicht am Programm selber


    Das konnte man von vorne herein ausschließen, weil sich (fast) alle Fehler im Profil befinden.

    Zitat

    Es liegt also nicht.... an einer Kollision mit Addons oder am Theme,


    Das ist eine Vermutung von dir, ich glaube eher, dass es schon daran liegt, weil solche Fehler besonders nach Upgrades, die tiefe Veränderungen mit sich bringen, vorkommen.
    Ich selbst hatte erhebliche Probleme, weil ich viele Änderungen in der userChrome.css mache. Fast regelmäßig werden aber bei Updates die Codes geändert, so dass die alten nicht mehr greifen bzw. Thunderbird ganz zur Funktionsunfähigkeit bringen.
    Ich nehme an, dass du dein Thunderbird-Profil schon eine geraume Zeit hast und dieses so einige Updates mitgemacht hat.
    Irgendwann ist dann Schluss und man muss das Profil erneuern. I.R. sollte man alle 1-2 Jahre die Profile erneuern.
    Leider müssen dabei die Konten und Identitäten neu eingerichtet werden und da ich 10 Konten und ca. 30 Identitäten habe (so viele haben die meisten User aber nicht), kann das schon mal eine halbe Stunde dauern. Die meisten Einstellungen und auch die Add-ons kann man zumindest größtenteils aus dem alten Profil übernehmen. Da sich aber einige Add-ons in die prefs.js eintragen, muss man evtl. dort Teile aus der alten Datei einkopieren - wenn man weiß, welche es sind.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Das hatte ich befürchtet.
    Ist für mich aber keine praktikable Lösung.


    Ich pflege mein Profil seit 2005 und hatte im Grunde nie ernsthafte Probleme damit. Da ich von Natur aus ein Sturkopf bin, gebe ich mich auch nicht damit zufrieden, dass mir irgend so ein kleines Update von 31.2.0 auf 31.3.0 mein Design zerschießt und ich aus diesem Grund alles neu machen soll. Bei Technik gibt's ja immer eine konkrete Ursache für einen auftretenden Fehler. Ich werde mich daher mal weiter reingraben und schauen, ob ich was finde.


    Ich hab's jedenfalls erstmal hier beschrieben und freue mich weiterhin über Denkanstöße und Vorschläge. Das muss doch zu lösen sein...


    mrb : Einen Gedankengang müsstest du mir mal noch erklären. Ich starte den TB mit deaktivierten Addons und im Standard-Theme und bekomme diesen Darstellungsfehler. Und du meinst, es liegt dennoch an Addons und/oder Theme. Wie kann das sein?

  • Du hattest das also im "abgesicherten Modus" überprüft und nicht nur bei "deaktivierten Add-ons"?
    Hast du evtl. inkompatible Add-ons? Das kann nach einem Update ganz schnell passieren, denn die Add-on-Entwickler brauchen eine gewisse Zeit zum Nachbessern.
    Und wie ich schon sagte, Add-on tragen sich manchmal in mehrere Dateien ein und ob die alle zurückgesetzt werden?
    Wie ich schon schrieb, habe ich das Problem ja auch, nur ist es keins für mich, weil in der Titelbar bei mir ja das aktuelle aktive Konto angezeigt wird, die aktuelle TB-Version und der Profilname und darauf möchte ich nicht verzichten. Also brauche ich die Titelleiste.
    Wäre das anders, würde ich nicht zögern, das Profil komplett zu erneuern, denn u.U. ist ja der Fehler nur einer unter anderen, den man aber noch nicht erkannt hat.
    EIne evtl. Fehlersuche wäre Zeitverschwendung und anschließend hast du ja dann immer noch ein uraltes Profil.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Genau.


    Ich hab mir mal das Changelog der Version 31.3.0 genauer angesehen, denn ich kann den Fehler ja genau auf dieses Update eingrenzen. Und in der Tat findet sich dort eine Änderung bzgl. der Titlebar. Der "Bug 953204 - Use the Fx Australis titlebar styling" sei demnach gefixed. Kann nur vermuten, dass sie damit irgendwas ausgelöst haben, was bei mir die Funktion "mail.tabs.drawInTitlebar" wirkungslos gemacht hat...
    DENN...
    Ich habe jetzt mal die Version 31.2.0 drüber installiert. Und sieh an, das Umschalten der oben beschriebenen Funktion zeigt jetzt wieder Wirkung und ich kann die Inhalte wie gewollt nach oben in die Titlebar schieben.


    Ich bleibe jetzt also wohl oder übel erstmal bei dieser Programmversion und hoffe, dass sich das Problem in folgenden Updates regelt. Danke auf jeden Fall fürs Begleiten auf dem Weg bis hier hin :)

  • Hallo DarkS3th,


    falls es tatsächlich mit der Kombination eines fast 10 Jahre alten Profils und den jüngsten Änderungen bzgl. Australis zusammenhängt, ist die Wahrscheinlichkeit hoch, dass sich das Problem nicht durch ein Update in Luft auflösen wird.


    Ich gehöre auch zu denjenigen, die ihr Profil sehr lange mitschleppen. Hin und wieder ist es aber an der Zeit, es neu anzulegen. Erweiterungen, Themes, manuelle Anpassungen, sie aller hinterlassen Spuren in den Konfigurationsdateien. Früher oder später führt das zu Problemen, möglicherweise auch zu schwerwiegenden.


    Nach fast 10 Jahren darf es also ruhig mal erneuert werden. Da ist besser als die nächsten Jahre mit einer alten Version zu arbeiten.


    Gruß


    Susanne

  • Ist klar, hängt aber natürlich auch extrem viel Arbeit dran, wissen wir alle.


    Ich werde das erstmal alles weiter beobachten. Es handelt sich momentan ja auch nur um einen Unterschied von einer Versionsnummer und dürfte sich in Bezug auf Sicherheitsbedenken noch im Rahmen halten. Spätestens mit den nächsten großen Versionssprüngen muss ich mir Gedanken machen, wenn der Fehler weiterhin bestehen sollte. Aber aktuell bin ich da noch ganz entspannt und glaube an eine auszumerzende Panne.

  • Du könntest auch mal versuchen, ob das Löschen der localstore.rdf etwas bringt, danach sind deine Fenstereinstellungen zwar wieder Standard, aber du kannst es ja erst mal in einem geklonten Profil testen.

  • Gute Idee.
    Hab's gerade mit einer Profilkopie in einem TB-portable probiert. Es bleibt allerdings auch dort dabei.

  • Sorry, du kopierst ein altes kaputtes Profil in ein anderes Thunderbird-Profil und wunderst dich, dass sich nichts ändert?
    Wie sollte es, denn du kopierst die Fehler gleich mit.
    Deine Versuche, das Profil wieder hinzubiegen haben bestimmt schon so viel Zeit gekostet, dass du schon längst ein funktionierendes neues hättest.
    Die vergeudete Zeit wollte ich dir ersparen. Und eine halbe Stunde istnun wirklich nicht viel.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • @mrb
    Der Ton scheint mir rauer zu werden, daher erlaube auch mir mal ein paar deutlichere Worte, ohne dass das hier - zumindest von meiner Seite aus - die sachliche Ebene verlässt.
    Liest und verstehst du überhaupt meine Posts?
    Ich versuche hier ein Problem mitzuteilen, zu ergründen und Schritt für Schritt zu lösen. Deine Beiträge beschränken sich ausschließlich auf Punkte, die ich bereits probiert habe (siehe dein und mein erster Post), oder das Umschiffen des Fehlers per Work-Around ("Mach's neu"). Was ist denn das bitte für ein Ansatz? Ich schätze speziell an der Open Source Entwicklung, dass man sich mit Problemen beschäftigt und diese auch für zukünftige Versionen löst. Ich habe den Eindruck, dass wir in diesem Punkt nicht auf einer Wellenlänge liegen. Wenn du hier nichts beitragen möchtest, dann verkneife dir doch bitte deine Posts. Ich bleibe jedenfalls weiter dran und dokumentiere mein Vorgehen, sodass auch andere User mit ähnlichen Problemen darin u.U. einen Ansatz finden (ich bin ja offensichtlich nicht der einzige). Mit dieser Form der Forenkultur bin ich zumindest aufgewachsen. Aber vielleicht hat sich das Klima mittlerweile geändert.


    Mir geht es einzig und allein um das Lösen des Problems! Die Darstellung der Titlebar ist mir im Grunde egal. Ich kann Mails empfangen, Mails schreiben und Mails archivieren, prima. Zur Not mach' ich mein Profil neu, auch kein Ding. Der Fehler ist aber weiterhin im Programm und genau das wurmt mich.


    Und jetzt zurück zum Thema:
    Ich habe bereits dargelegt, dass ich mit dem selben Profil (was nach mrb's Meinung kaputt sei) in der vorherigen Programmversion 31.2.0 den beschriebenen Fehler nicht habe und über die Funktion "mail.tabs.drawInTitlebar" die alte Titlebar wieder herstellen kann. Ich kann also einen direkten Zusammenhang zwischen dem Fehler und der Programmversion (nicht des Profils) herstellen und konnte dies sogar mit einem Eintrag im aktuellen Changelog nachweisen. Das ist hier also alles keine Spinnerei von mir.
    Nun bin ich noch einem Hinweis von Fux nachgegangen und habe es mit dem Löschen der localstore.rdf versucht. Das zeigt, wie beschrieben, keine Wirkung. Das Auftreten des Fehlers hängt also weiterhin an der eingesetzten Programmversion.


    Ich grabe weiter...

  • Hallo DarkS3th,


    jetzt möchte ich mich doch noch mal einmischen. In einem Punkt hast Du schon Recht. Es ist immer interessant, die Ursache für ein Problem herauszufinden. Ich selbst beiße mich ebenfalls manchmal gern an einer Ursachenforschung fest, rein akademisch, allein um des Verstehens willen. Insofern kann ich verstehen, dass Du weiter graben willst.


    In diesem Fall würde ich es aber nicht machen. Ich bin mir nicht einmal sicher, ob es sich hier streng genommen überhaupt um einen Bug handelt. Der von Dir verlinkte bug bezieht sich ja auf eine gewollte Änderung.
    Da der Fehler mit einem neuen Profil nicht auftritt, ist es gut möglich, dass dieser Fehler auf einer Altlast im Profil beruht, die sich nicht mit dieser Neuerung verträgt. Ob diese Altlast durch den TB oder z.B. eine Erweiterung zustande kam, wissen wir gegenwärtig nicht. Darauf wollte ich oben hinweisen: Es kann gut sein, dass dieser "Fehler" gar kein Fehler im TB ist und somit auch nicht behoben werden kann.


    Unter dieser Prämisse wäre das Neuanlegen des Profils nicht nur die schnellste sondern auch die einzige Lösung. Aus Deiner Beschreibung wissen wir, dass das alte Profil in jedem Fall beteiligt ist. Deshalb war auch zu erwarten, dass der Fehler beim Kopieren des Profils mitwandert und bestehen bleibt. In diesem Punkt hat mrb eindeutig Recht.


    Allen Anwender, die dieses Problem sehen und lediglich an einer schnellen Lösung interessiert sind, würde ich genau wie mrb empfehlen, ein neues Profil anzulegen.


    Gruß


    Susanne


    Edit: Typo korrigiert

    Einmal editiert, zuletzt von SusiTux ()

  • @DarkS3th,


    ich habe keine Lust mehr, dir noch weiter zu antworten. Nur so viel:
    Meine Antworten und Hilfen hier im Forum stützen sich auf eine Erfahrung von mehr als 8 Jahren mit Thunderbird. Ich kenne folglich alle Macken von Thunderbird, nicht nur aus dem Forum sondern aus eigener Erfahrung mit Thunderbird.
    Ich habe außerdem mehrere Testprofile, mit denen ich fast jeden von mir gemachten Tipp vorher überprüfe.
    Ich könnte deinen Fall vielleicht per Fernwartung temporär lösen - was wir hier aber nicht anbieten - trotzdem würde ich es nie selbst so machen, sondern immer ein neues Profil bevorzugen, glaube mir, ich weiß warum.
    Natürlich bin ich selbst auch daran interessiert einer Fehlerursache auf den Grund zu gehen, aber nur wenn es im vertretbaren Rahmen geschieht. Alle Helfer hier im Forum arbeiten schließlich umsonst und opfern ihre Freizeit.
    Übrigens lese ich deine Antworten sehr wohl und mache dazu auch meine Überlegungen.
    Kommentare zu meiner Ansicht nach falschem Vorgehen anderer lasse ich mir aber nicht verbieten, auch wenn diese gelegentlich etwas überspitzt formuliert sind.


    @ Susanne,


    vielen Dank für deine Unterstützung, die braucht man wirklich gelegentlich hier im Forum. Außerdem sehe ich so, dass ich mit meiner Meinung nicht alleine dastehe.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw