Nachrichten im Posteingang immer ausgeklappt, trotz Sortierung

  • Hallo,
    zunächst die Randbedingungen:
    - TB 31.3.0
    - Mac OSX 10.10.1
    - IMAP
    - Postfach auf eigenem Server


    - Ansicht im Posteingangsordner: Sortieren nach --> Datum / Aufsteigend / Gruppiert nach Sortierung
    - für den Posteingangsordner aktiviert: Spamfiler und noch ein paar Sortierungsfilter die Mails in verschiedene lokale Ordner schieben.


    Folgendes Problem:
    Beim Start von TB werden sämtliche Nachrichten einzeln angezeigt. D.h. sie sind zwar sortiert, aber die Sortierungen sind ausgeklappt. Ich sehe also keine schöne, übersichtliche Sortierung die ich dann ausklappen kann, um nach einzelnen Mails zu schauen.
    Klappe ich die Sortierung nun ein, gehe in einen anderen Ordner und dann wieder in den Posteingang, habe ich wieder den selben Salat.


    Das wäre alles kein großes Problem, wenn ich in dem Ordner nur dreieinhalb Mails hätte, es sind aber mehr als tausend (...und: nein, das möchte ich auch nicht ändern).



    Das ist jetzt leider kein neues Verhalten von TB, sondern leider schon ewig so. Ich habe keinen Bock mehr Sortierungen auf- und zu zuklappen.


    Was tun?



  • Hallo,


    das nenne ich eine präzise Problembeschreibung ! ;)


    Ich habe noch nie die Ansicht "Gruppiert nach Sortierung" benutzt, kann aber dein Problem hier unter Mac OS X nachstellen.
    Es ist in der Tat überraschend, dass TB das manuelle Zuklappen der Gruppierungen "Heute", "Gestern", ... usw. nicht memorieren kann.
    Trotz intensiver Suche habe ich bislang weder eine Lösung noch einen entsprechenden Bug Report gefunden.
    Offensichtlich war das Standard-Verhalten bei dieser Ansicht in früheren TB-Versionen umgekehrt, d. h. die Gruppierungen waren automatisch zugeklappt:
    How to auto expand the "Grouped by sort"?
    Two problems with grouped by sort
    In einer späteren Version ist der Standard offenbar geändert worden, aber dann müsste der Änderung eigentlich ein Bug Report vorausgegangen sein.


    Als Alternative könntest du die Gruppierung nach Themen wählen, bei der die Themenbäume über das Menü oder per Tastenkürzel auf- oder zugeklappt werden können. Die vom Nutzer veränderte Ansicht wird in diesem Fall von TB memoriert.


    Gruß

  • Hallo Mapenzi,


    besten Dank für Deine Antwort. Hoffnungsvoll klingt das ja nicht gerade...


    Die Sortierung nach Themen bringt mir nichts, da für mich zeitliche Abfolgen wichtig sind.


    Schönen Gruß


    Hat sonst noch jemand ne Idee?

  • Ich habe inzwischen noch mal ausführlich getestet, nachdem ich meinen Posteingang bis nach oben durch gescrollt und entdeckt hatte, dass es noch eine Gruppierung "Ältere Nachrichten" gibt.
    Wenn ich jetzt alle Gruppierungen zuklappe oder eine oder zwei beliebige Gruppierungen aufklappe, dann bleiben diese Einstellungen erhalten, auch wenn ich zwischenzeitlich einen anderen Ordner anzeige oder TB schließe und neu starte.
    Wenn es anders wäre, hätte die Ansicht "Gruppiert nach Sortierung" auch keinen großen Vorteil gegenüber "Nicht gruppiert" für Nutzer, die hunderte oder Tausenden von Nachrichten in einem Ordner aufbewahren.
    Ich muss dazu noch anfügen, dass ich meine Tests mit der Ansicht -> Ordner -> "Alle" gemacht habe.


    Wenn du das nicht nachvollziehen kannst, empfehle ich einen Test im abgesicherten Modus (= mit deaktivierten Add-ons) von TB:
    die Alt- (Option) Taste drücken beim Start von TB.

    Einmal editiert, zuletzt von Mapenzi ()

  • Hi Mapenzi,
    ich habe auch Ansicht -> Ordner -> "Alle" eingestellt.
    Als ein- und ausklappbare Sortierungsbalken habe ich: Ältere Nachrichten - Vorletzte Woche - Letzte Woche - Gestern - Heute


    Habe gerade Deinen Tip (abgesicherter Modus + Addons deaktiviert) getestet: keine Änderung bei mir.


    Ist Dein Posteingang auch ein IMAP-Konto?

  • Bislang hatte ich nur den Posteingang meines Hauptkontos (POP) in TB 31.3.0 und 34 beta getestet.
    Jetzt habe ich auch noch ein IMAP-Konto und POP-Konten in weiteren Versuchsprofilen getestet mit immer dem gleichen Ergebnis:
    nach der Umstellung auf "Gruppiert nach Sortierung" sind die Gruppierungen standardmäßig zugeklappt, und manuelle Änderungen werden memoriert, d. h. nach Neustart die selbe Ansicht wie im Augenblick des Schließens.


    Ich bin noch auf der Suche nach der Datei im Profil, in der diese Einstellungen gesichert werden, habe sie aber noch nicht identifizieren können.

  • Soooo, angeregt durch Deine Tips und Versuche, habe ich jetzt eine Lösung gefunden, die -zumindest für mich- zu funktionieren scheint:
    Ich habe einen neuen Ordner "Eingang" in dem Mail-Account erstellt und einen neuen Filter für den normalen Ordner "Posteingang" definiert. Dieser verschiebt lediglich sämtliche Mails in den neuen Ordner "Eingang" und in dem funktioniert die Sortierung.
    Das ist jetzt zwar ein Fall von Workaround, statt Lösung, aber wat solls.


    Ich hatte vorher noch ein paar andere Ordner des selben Kontos gestestet, die waren alle OK, auch der "Papierkorb", nur der "System"-Ordner Posteingang will nicht.

  • Salut graba,

    schau mal bei panacea.dat oder auch msf-Dateien nach


    ich hab schon so ziemlich alle Text-Dateien im Profil durchsucht und test-halber entfernt, darunter auch panacea.dat und Inbox.msf.
    Die letzteren sind es nicht.
    Das Ganze wird noch mysteriöser, weil ich inzwischen ein Versuchsprofil entdeckt habe, in dem im IMAP-Konto die Gruppierungen zugeklappt (oder so wie ich sie manuell einstelle) bleiben und im POP-Konto immer wieder aufgeklappt sind, auch im safe mode!

  • Ich hatte vorher noch ein paar andere Ordner des selben Kontos gestestet, die waren alle OK, auch der "Papierkorb", nur der "System"-Ordner Posteingang will nicht. .


    Interessant, danach hätte ich gleich zu Anfang fragen sollen ;)
    Versuch doch mal, den Ordner "Posteingang" zu reparieren über R-Klick -> Eigenschaften.
    Bei über 1000 Mails würde mich nichts wundern.
    Bei gleicher Gelegenheit: wird der Posteingang regelmäßig komprimiert?

  • schau mal bei panacea.dat oder auch msf-Dateien nach


    Du hattest Recht mit der .msf-Datei!! ;)
    Nur dort kann die Einstellung "Gruppiert nach Sortierung" gespeichert sein.
    Inzwischen habe ich in meinem Arbeits-Profil, in dem noch die Ansicht "Gruppiert nach Sortierung" aktiv war, die Inbox.msf Datei entfernt, und beim nächsten Start war die Ansicht wieder "Nicht gruppiert"!


    Die vorigen Tests mit Entfernen der Inbox.msf Datei hatte ich in einem Versuchs-Profil durchgeführt, in dessen Posteingang die Gruppierungen widerspenstig waren und immer aufgeklappt erschienen, ohne Erfolg.
    Dies ist auch weiterhin das einzige Profil, in dem der Posteingang resistent bleibt gegen das Entfernen der Inbox.msf Datei, da nach Neustart immer wieder die Ansicht "Gruppiert nach Sortierung" mit aufgeklappten Gruppierungen auftaucht.
    Möglicherweise hängt es damit zusammen, dass ich in diesem Profil gestern das Add-on "SortPref" installiert und getestet hatte.

  • Jau, der goldene Donnervogel geht an: Mapenzi.
    "Versuch doch mal, den Ordner "Posteingang" zu reparieren über R-Klick -> Eigenschaften."
    Das wars.
    Habe das klitzekleine Knöpfeleinelchen erst mal suchen müssen, aber es funzt.


    Prima, besten Dank. Fall erledigt.

  • Jau, der goldene Donnervogel geht an: Mapenzi.


    Danke, aber ich möchte ihn mit graba teilen, der mir mit seinem Hinweis auf die .msf-Datei den Denkanstoß gegeben hat ;)
    Das "Reparieren" eines Ordners hat ungefähr die selbe Funktion wie das Löschen der dem Ordner zugehörigen .msf-Datei (= Index-Datei der im Ordner befindlichen Nachrichten) im Profil-Ordner von TB.
    Bloß hatten meine ersten Tests mit dem Löschen dieser Datei in einem bestimmten Versuchsprofil keinen Erfolg, wie ich zuvor schon berichtet hatte.

  • [OT]

    sei nicht so bescheiden!


    Ja schau, jetzt sind sie beide so bescheiden. Da wäre gar unser Pfarrer ganz entzückt ;-)


    Ernsthaft, ich mag dieses Forum auch gerade deshalb, weil es hier auch seitens der Administration und der alten Hasen meist bescheiden zugeht. Anstand und Vernunft kommen vor Testosteron und Gernegroß. Das ist ja nun leider nicht in allen Foren so.
    [/OT]