MBOX-Datei groß trotz gelöschter Mails aus IMAP

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 31.3.0
    * Betriebssystem + Version: Win 7 Pro
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): GMAIL


    Ich habe soeben große Mails aus meinem Thunderbird gelöscht und mich gewundert, dass dadurch die MBOX-Dateien nicht kleiner werden. Ich habe dann gesehen, dass die Option "Nachrichten dieses Kontos auf dem PC bereit halten" aktiviert war. Dann habe ich die Option rausgemacht. Doch trotzdem sind die MBOX-Dateien noch groß und wurden nicht kleiner. Warum werden die nicht kleiner, wenn die Originalmails doch gar nicht mehr da sind?

  • Hallo,
    wenn ich mal bei einer Kontenneuerstellung vergesse, dass "Bereithalten von Nachrichten" zu deaktivieren, beende ich Thunderbird und lösche im Thunderbird-Profil alle Dateien des Kontos manchmal den kompletten Kontenordner. Das geht aber nur bei IMAP.
    Auf die Mails auf dem Server hat das keinen Einfluss.
    Man kann nur schwer verhindern, dass nach dem Erstellen eines IMAP-Kontos, beim ersten Abruf ( der meistens automatisch geschieht) Mails auf die Festplatte gespeichert werden.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Super! Vielen vielen Dank für eure Antworten! Das mit dem Komprimieren habe ich in der Vergangenheit eigentlich schon ohne Erfolg gemacht (auf Ordnerebene), heute gings dann problemlos über "Datei" und "Alle ordner des Kontos komprimieren". Wunderbar!


    Obwohl die lokale Bereithalten-Funktion nun aus ist, werden jedoch nach wie vor die neuen Mails in die Ordner "Gesendet.mozmsgs" bzw. "INBOX.mozmsgs" gespeichert, wenngleich die MBOX-Dateien nun nicht mehr größer werden. Ist dieses Verhalten so gewollt, um zumindest den Textbestandteil von IMAP-Mails auch offline lesen zu können?

  • Hallo tempala,


    das sind zwei unterschiedliche Dinge. Die mozmsgs- und wdseml-Dateien legt der TB an, damit E-Mails auch von der Windowssuchfunktion gefunden werden können. Wenn Du dieses Feature nicht benötigst, kannst Du es abstellen. Da ich diesen Punkt Linux nicht habe, muss ich jetzt mal raten: Schau unter Exras -> Einstellungen -> Allgemein.


    Gruß


    Susanne

  • Hi Susanne (und alle anderen),


    vielen vielen Dank. Genau so war es! Nun legt mein TB keine Dateien für jede IMAP-Mail an. Bleiben jetzt noch 2 Fragen, die mich interessieren würden:


    1. Ist demzufolge der Speicherplatz, der von TB als Cache verwendet wird, nur für das lokale Bereithalten zuständig und hat in meinem Fall nun keine Bedeutung mehr?
    2. Was hat es in den Konten-Einstellungen unter "Synchronisation & Speicherplatz" mit der Einstellung unter "Speicherplatz" zu tun? Hier kann ich ganz abgesehen vom lokalen Bereithalten wohl einstellen, wie groß die Mails maximal sein dürfen, die vom IMAP-Server heruntergeladen werden. Offenbar gibt es also noch ein zweites "Herunterladen", neben dem lokalen bereithalten, das bei mir ja aus ist. Was meint diese Einstellung? Kann mir auch nach einer google-Suche keinen Reim drauf machen ...


    Freue mich über klärende Antworten :-)

  • Hi tempala,


    zu deinen Fragen:
    1.) Bei IMAP ist das ja so, dass die E-Mails bei jedem Aufruf erneut heruntergeladen und dann nach den Schließen des TB wieder "vergessen". Aus diesem Grund ist der Datenbestand eines IMAP-Kontos auf dem Rechner auch bei Tausenden auf dem Server gespeicherter Mails winzig klein (im Vergleich zu einem POP3-Konto). Es wird ja nur die Indexdatei lokal gespeichert.


    Bei diesem, für stationär betriebene Rechner IMHO sinnfreien, "Lokalen Bereithalten" werden wie bei einem POP3-Konto ebenfalls mbox-Dateien angelegt. Nur im Unterschied zu POP3 wird der Inhalt der darin gespeicherten Mails ständig mit dem Server abgeglichen. Löschst du also (mit dem TB oder auch per Webmail) eine Mail, wird diese sowohl auf dem Server als auch in dieser lokalen mbox-Datei gelöscht.
    Da du, wie ich ja oben beschrieben habe, diese mbox-Datei normalerweise nicht benötigst, kannst du sie nach dem Abschalten der Option einfach aus deinem Profil löschen. Du kannst sogar, wenn der TB mal "spinnt" auch die dort befindlichen Indexdateien (.msf) löschen. Sie werden beim nächsten Einschalten des TB wieder neu angelegt.
    Fazit: IMAP benötigt innerhalb des Ordners \imapmail\<IMAP-Konto> überhaupt keine lokal gespeicherten Daten. Und die notwendige Indexdatei kommt immer wieder neu.


    Ich möchte es aber nicht unerwähnt lassen: So mancher bequeme Nutzer, der zu <zensiert> ist, regelmäßig eine Datensicherung zu machen, hat sich schon gefreut, dass in den o.g. mbox-Dateien seiner IMAP-Konten zumindest noch ein Teil seiner E-Mails gefunden und gerettet werden konnten. Aber verlassen solltest du dich nicht darauf!


    2.) Stell dir mal vor, du nutzt unterwegs ein Notebook mit einem kastrierten UMTS-Zugang von meinetwegen mickrigen 100MB Datenvolumen. Jetzt schickt dir dein bester Kumpel (der noch nicht kapiert hat, dass E-Mail kein Transportmittel für Massendaten ist!) ein "kleines" Weihnachtsvideo von 50MB Größe ... . Spätestens jetzt weißt du, warum der TB die sinnvolle Option mitbringt, von einer E-Mail nur die ersten paar 100KB herunterzuladen. Den eigentlichen Mailtext kannst du lesen, und den "wichtigen" Rest liest du dann eben zu Hause. Auch hier gilt natürlich das, was ich in meinem allerersten Satz gesagt habe: herunterladen > anzeigen > vergessen.
    OK?



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hi Peter_Lehmann und alle anderen,


    erstmal wünsche ich euch ein schönes Weihnachtsfest und besinnliche Tage (auch wenn es jetzt schon wieder vorbei ist).


    Danke für deine ausführliche und gut verständliche Antwort in sehr bildhafter Sprache, Peter :-) Zu deinen Antworten:


    Zu 1: Wenn du schreibst, dass IMAP an sich keine lokal gespeicherten Daten benötigt, ist die Einstellung unter "Cache-Größe" also völlig irrelevant in meinem Fall?


    Zu 2: Verstehe sehr gut, wie du das meinst. Doch bei meinem Versuch, wo ich das nachgestellt habe, hat sich TB nicht so verhalten:


    Versuch 1: Mailgröße, die maximal heruntergeladen wird, ist 500 KB. Ich schicke mir eine Mail mit einem Anhang von 100 KB. Ich kann den Anhang dabei sofort auf meinem Rechner speichern, ohne, dass dieser heruntergeladen werden muss (es kommt kein "Downloadfenster" nach Klick auf "Speichern") --> TB hat also automatisch heruntergeladen, wie gewünscht.


    Versuch 2: Mailgröße, die maximal heruntergeladen wird, ist 500 KB. Ich schicke mir eine Mail mit einem Anhang von 3 MB. Ich kann den Anhang auf meinem Rechner speichern, nachdem ein Downloadfenster erschienen ist (klar, denn die Mail ist zu groß und wird nicht automatisch geladen). Wie gewünscht.


    Versuch 3: Keine Beschränkung in der Mailgröße die heruntergeladen wird. Erwartet hätte ich, dass ich den Anhang sofort ohne Downloadfenster speichern kann (da TB ihn ja herunterladen müsste, da ja keine Beschränkung eingestellt ist). Tut er aber nicht. Es erscheint trotzdem ein Downloadfenster nach Klick auf "Speichern".


    Fazit: Auch wenn keine Beschränkung eingestellt ist, scheint TB die Nachrichten trotzdem erst dann "herunterzuladen", wenn man diese explizit und manuell speichern möchte.
    Frage: Was bringt dann die Einstellung? Wo ist mein Denkfehler?


    Klärt mich auf :-)

  • Hallo tempala,


    Frage: Was bringt dann die Einstellung? Wo ist mein Denkfehler?


    Klärt mich auf


    also, ausprobiert habe ich es nicht. Doch denke ich, dass es die Checkbox für "Nachrichten nicht herunterladen, die größer sind als ..." sich allein auf den Offline-Cache bezieht. Schließlich befindet sich der Menüpunkt ja explizit unter "Speicherplatz ... ". Es geht also um das Sparen von lokalem Speicherplatz,
    Du könntest das testen, indem Du Dir erneut einen zu großen Anhang schickst und dann offline gehst. Der Anhang sollte dann unter den oben genannten Einstellungen nicht verfügbar sein, weil er nicht lokal zwischengespeichert wurde.


    Gruß


    Susanne

  • Hallo SusiTux,


    das mit dem Offline-Speicher wäre eine logische Alternative. Doch ich habe das lokale Bereithalten deaktiviert, weshalb ich offline eigentlich überhaupt nichts angezeigt bekommen sollte. Es wird ja nichts "bereitgehalten". Die Ausführungen von Peter_Lehmann bezogen sich - glaube ich - schon auf die Tatsache, dass ein Herunterladen im online-Modus reglementiert wird. Doch die Einstellung bewirkt bei mir offenkundig eben nichts, da in jedem Fall der Anhang erst durch manuelles speichern "heruntergeladen" wird - egal, ob ich die Größenbeschränkung aktiviert habe oder nicht. Vielleicht könntest du das ausprobieren und meine Ergebnisse bestätigen?


    Gruß


    tempala

  • Hi tempala,


    das, was du angezeigt bekommst, ist der Inhalt der Indexdateien. Genau gesagt, der entsprechende Teil davon. Das kannst du IMHO auch nicht verhindern. Warum auch?


    Wenn du keinen Eintrag in dieser Liste doppelklickst, wenn du die Mailvorschau ("Dokumentenansicht") nicht aktiviert hast und natürlich auch nicht das "Lokale Bereithalten ...", dann wird außer der Liste der auf dem Server vorhandenen Mails auch nichts heruntergeladen. Und das sind ja pro Mail nur sehr wenige Byte. Letztendlich wird jedesmal die Indexdatei aktualisiert.


    Der Anhang einer E-Mail ist keinesfalls eine zusätzlich herunterzuladende Datei, sondern integrierter Bestandteil der betreffenden E-Mail. Das Mailsystem sieht eben einfach nur eine entsprechend große E-Mail. Du kannst auch einfach eine halbe Stunde lang tippen - und die fMail ist entsprechend "fett", ohne dass sie einen Anhang mitbringt. Und das vollständige Hersunterladen einer E-Mail kannst du eben (im Interesse der Nutzer mit knappem oder teuerem
    "Internet"!) nach einer bestimmten Datenmenge abbrechen.
    Selbstverständlich gibt der der Mailclient die Möglichkeit, bewusst (!) die komplette Mail herunterzuladen. Also deine Entscheidung. Die Mail wird heruntergeladen, und dann erkennt der Mailclient, dass sich in der Mail ein Anhang verbirgt und er bietet dir an, diesen lokal abzuspeichern.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,
    Ergänzung:
    in der erweiterten Konfiguration bietet Thunderbird die Möglichkeit, das Verhalten beim Herunterladen größerer Mails seinen Bedürfnissen anzupassen.
    Allerdings nur auf Englisch:
    http://kb.mozillazine.org/Enti…n_opening_an_IMAP_message
    Stichwort "parts_on_demand".


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für eure Antworten!


    @ Peter_Lehmann: Ich habe jetzt mal genau das nachgestellt, was du gesagt hast und bin deiner Aussage gefolgt, dass Text und Anhang einer Mail eines sind - sagen wir ein Paket mit einer bestimmten Größe. Ich habe eingestellt, dass Nachrichten nicht "heruntergeladen" werden sollen, die größer als 10 KB sind (habe mich dazu loremipsum bedient). Lokales Bereithalten ist sowieso aus. Der so aneinanderkopierte Text hat eine Größe von rund 350 KB (als .txt). Diesen Text habe ich als Mail an mich selbst geschickt.


    Erwartung: In der Dokumentvorschau oder auch nach Doppelklick auf die neue Nachricht sollte ein "STOP"-Signal kommen --> Mail über 10 KB ... fast 30 mal so groß!!!
    Realität: Nachricht wurde ohne Murren komplett "heruntergeladen" - Beschränkung hat also nicht gewirkt, am Ende gingen die vollen 350 KB über meine Leitung.


    Also entweder ich blick grad irgendwo überhaupt nicht mehr durch, was es mit der Funktion auf sich hat, oder irgendwas anderes passt nicht ...

  • Hallo tempala,


    schau Dir am besten mal den Artikel genauer an, den mrb verlinkt hat. Dort ist beschrieben, unter welchen Bedingungen E-Mails trotz Größenbeschränkung doch vollständig heruntergeladen werden (müssen). Wenn bei Dir keiner der offensichtlichen Gründe zutrifft, dann aktiviere das IMAP-Logging, wie dort ebenfalls beschrieben. Vielleicht lässt sich daraus etwas erkennen.


    Gruß


    Susanne

  • Hallo SusiTux,


    erste Erfolge stellen sich ein :-)


    Habe mit den angegebenen Parametern experimentiert und voila - klappt.


    Bei Mails mit Anhang unter dem eingestellten Threshold wird die Dateigröße des Anhangs angezeigt (für mich ein Zeichen: der Anhang wurde automatisch heruntergeladen).


    Bei Mails mit Anhang über dem eingestellten Threshold wird die Dateigröße des Anhangs mit "Größe unbekannt" angezeigt, zumindest bis man ihn manuell heruntergeladen hat (für mich ein Zeichen: der Anhang wurde nicht automatisch heruntergeladen).


    Teilsieg. Doch warum greifen anscheinend Einstellungen in den Tiefen von Thunderbird und die Einstellung namens "Nachrichten nicht herunterladen, die größer sind als ... KB" hat überhaupt keine Auswirkung? Auch sie scheint sich nur auf den Anhang zu beziehen, da im Link von mrb steht, dass "Normally, if you open an IMAP message with an attachment and read just the message, Thunderbird only fetches the headers and message body". Egal wie viel Text in der Mail steht, wird also Kopfzeile und auch Text immer geladen.


    Doch warum hat die offensichtlichere Einstellung in TB keine Bedeutung bei Anhängen gegenüber der sehr versteckten?

  • Hallo tempala,


    ich habe mich mit dem Thema bisher nie eingehender beschäftigt. Ich bin mir daher nicht einmal sicher, ob der in dem Artikel genannte Schlüssel nicht eh genau derselbe ist, den man auch über den Einstellungsdialog ändert.
    Wie Du dem Artikel entnehmen kannst, spielen einige weitere Faktoren eine Rolle, z.B. ob der Server das überhaupt unterstützt, der Junkfilter, ob Anhänge eingebunden sind oder nicht, das lokale Bereithalten usw. .
    Einige dieser Faktoren sind externe Faktoren können nicht vom Empfänger beeinflusst werden. Das heißt für mich, dass man nicht garantieren kann, dass diese Einstellung bei jeder E-Mail funktioniert. Wenn Du also genau wissen willst, wie TB sich in welchem Fall verhält, musst Du wohl das Logging einschalten und einige Tests fahren.



    Gruß


    Susanne

  • Hallo SusiTux,


    nach weiteren Test verhält sich Thunderbird nun wie erwartet. Es scheint wohl so zu sein, dass die Einstellung "Nachrichten nicht herunterladen, die größer sind als ... KB" sich in meinem Fall nicht auswirkt. Vermutlich greift sie nur im Falle von offline-Lesen bzw. lokalem Bereithalten. Was jedoch greift ist die Einstellung in "about:config". Die Frage war ja auch mehr aus persönlichem Interesse gestellt. Ein akkutes Problem hatte ich ja nicht. Deshalb lasse ich das mit dem Logging. Aber danke für den Hinweis :-)


    Was mich jetzt zum Schluss noch interessieren würde - wieder aus Interesse und nicht auf Basis eines akuten Problems: Was wird in dem Cache gespeichert, den ich unter "Einstellungen", "Erweitert", "Netzwerk & Speicherplatz", "Speicherplatz" finde?


    Gruß


    tempala

  • Hallo tempala,


    Was wird in dem Cache gespeichert, den ich unter "Einstellungen", "Erweitert", "Netzwerk & Speicherplatz", "Speicherplatz" finde?


    Sicher weiß ich es nicht. Ich vermute, dass dies der Cache ist, indem heruntergeladene IMAP-Mails für eine Session zwischengespeichert werden. Du kannst das daran erkennen, dass sich kein Download-Balken zeigt, wenn Du eine E-Mail anklickst, die Du kurz zuvor bereits betrachtet hattest. Wenn Du den TB beendest und wieder neu startest, wird die E-Mail erneut heruntergeladen. Ist die E-Mail größer als der eingestellte Cache, funktioniert das natürlich nicht.


    Gruß


    Susanne


    Nachtrag: Hab' mich gerade daran erinnert, dass Peter sich auch schon einmal so seine Gedanken über den Cache gemacht hat. Siehe Der Thunderbird und sein Cache ...


    Offenbar ist er doch nicht so flüchtig, wie ich dachte. Jetzt muss ich mal schauen, weshalb ich keinen Ordner "Cache" habe. Möglicherweise habe ich dazu vor (zu) langer Zeit eine Einstellung verändert.

  • Hi SusiTux,


    danke für deine Bemühungen! Ich kann bei diesem Cache - es gibt ja, wenn man deinem Link folgt, mehrere davon - auch nur maximal 1024 MB einstellen. Habe mir gerade testweise große Anhänge geschickt und den folgenden Ordner beobachtet:


    C:\Users\XXX\AppData\Local\Thunderbird\Profiles


    Der wuchs kontinuierlich an, mit jeder großen Mail die reinkam und deren Anhang ich geöffnet habe, so dass TB die Mail heruntergeladen hat. Auch nach Beenden von TB war der Ordner noch groß. Nach Klick auf "Cache jetzt leeren" war er wieder kleiner. Es scheint also so zu sein wie du sagtest, nur dass dieser Ordner eben nicht automatisch geleert wird, sondern dies manuell geschehen muss. Ist das auch deine Erfahrung? Wo ist dein Cache-Ordner? :-)


    Viele Grüße


    tempala

  • Hallo tempala,


    ich habe das Cashing im TB noch nicht durchschaut. Ich kann in meinem Profil keinen Ordner "Cache" finden, auf den ersten Blick auch keine Datei, die von der Größe her dem Cache entsprechen würde.
    Wenn ich die Zeit finde schaue ich mir das in den nächsten Tagen noch etwas genauer an und mache ein paar Tests. Ich weiß nicht, ob das ohne eine richtige Doku seitens Mozilla viel bringen wird. Peter hat ja ebenfalls schon einiges dazu unternommen.
    Für heute bin ich aber erst einmal offline und verschwinde in die Berge. Vielleicht wäre es sinnvoll, weitere Erkenntnis in dem Faden von Peter zu dokumentieren? Ich denke, aus diesem Grund hat er ihn eröffnet.


    Guten Rutsch euch allen!


    Susanne