Umlaute werden beim Verschicken in ? umgewandelt

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 31.3.0
    * Betriebssystem + Version: Windows 7
    * Kontenart (POP / IMAP): POP
    * Postfachanbieter (z.B. GMX): register.it
    Hallo,
    ich habe seit einiger Zeit das Problem, dass in meinen e-mails auf dem Weg zum Empfänger alle Umlaute und Sonderzeichen in Fragezeichen umgewandelt werden. (Das sieht dann so aus: liebe Gr????e) In meinem eigenen Postfach der gesendeten e-mails werden die Umlaute hingegen richtig dargestellt.
    Ich arbeite mit einer italienischen Version von Thunderbird und sende über einen italienischen Anbieter, allerdings glaube ich nicht, dass es daran liegt, denn bis vor einiger Zeit hat alles ohne Probleme funktioniert.
    Falls jemand eine Idee hat, woran es liegen könnte, wäre ich für eine Antwort sehr dankbar.
    Herzlichen Dank
    Emma

  • Hallo und willkommen im Forum!

    Zitat

    In meinem eigenen Postfach der gesendeten e-mails werden die Umlaute hingegen richtig dargestellt.


    Daraus schließe ich, dass der Empfänger mit der Zeichenkodierung in deiner Mail nicht klarkommt.
    Welche hast du den für das Versenden eingestellt, Unicode oder Westlich?
    Schau mal in den Quelltext (Strg+U) der gesendeten Mail, sind dort die Umlaute noch in Ordnung und was steht unter "content-type" und neben "charset"?
    Mit welchem Mailprogramm arbeitet der Empfänger oder vielleicht mit gar keinem?
    Liest er die Mails auf einer Webseite oder in einem Smartphone?

    Zitat

    Ich arbeite mit einer italienischen Version von Thunderbird und sende über einen italienischen Anbieter, allerdings glaube ich nicht, dass es daran liegt, denn bis vor einiger Zeit hat alles ohne Probleme funktioniert.


    Nein, daran liegt das nicht.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,
    herzlichen Dank für die schnelle Antwort! Es ist nicht ein Empfänger, sondern alle, die die Fragezeichen kriegen. Nicht eine mail kommt ordentlich an. Das Problem liegt eindeutig bei mir. Auch wenn ich mir selber eine email mit Sonderzeichen schicke, kriege ich nur Fragezeichen. Mein Mann sagt mir gerade, dass auch e-mails, die bei mir ordentlich ankommen und die ich an ihn weiterleite, mit Fragezeichen statt Sonderzeichen ankommen (und dass sind dann nicht deutsche Umlaute, sondern italienische Sonderzeichen wie z.B. è, ù usw. (und damit müsste das italienische Programm ja eigentlich klarkommen - also liegt es tatsächlich nicht an dem italienischen Thunderbird oder Server).
    Im Quelltext sind die Umlaute nicht als Fragezeichen, sondern mit anderen Zeichen dargestellt: z.B. für statt für (das scheint mir noch 'normaler' zu sein).
    unter content-type einer gesendeten mail steht: Content-Type: text/plain; charset=iso-8859-15; format=flowed
    Die Zeichenkodierung ist als unicode eingestellt.
    Ich verstehe nur Bahnhof, aber hoffe, dass ich die wichtigsten Fragen beantwortet habe.
    Grazie mille
    Emma

    2 Mal editiert, zuletzt von Emma ()

  • Könnte es sein, dass es nichts mit Thunderbird zu tun hat sondern mit Windows, nur so eine Idee?
    Welche Sprache ist denn bei euch gerade aktiviert?
    Schaut mal in der Systemsteuerung > Region und Sprache > Tastaturen und Sprachen > Tastaturen ändern.
    Was steht dort unter "Standardeingabesprache"?
    Das ist ein Falldownmenü, klick mal recht auf das kleine Dreieck, was wird dann angezeigt?


    Zitat

    content-type einer gesendeten mail steht: Content-Type: text/plain; charset=iso-8859-15; format=flowed
    Die Zeichenkodierung ist als unicode eingestellt.


    Jetzt wird es lustig. Wo ist die Zeichenkodierung auf Unicode eingestellt? Bitte das genaue Menü nennen.


    Weiterhin poste mir deine Einstellungen in Extras > Einstellungen > Ansicht > Formatierung > Schriftarten > Erweitert
    Es reicht, wenn du mir schreibst: 1. Kästchen angehakt usw. und die Standard-Zeichenkodierung für ausgehende Nachrichten.
    Du kannst auch einen Screenshot machen und hier einfügen.

    Zitat

    für


    Ja, das ist normal, wenn die Mail als Unicode eingestellt ist, dass Mailprogramm macht das aber wieder automatisch lesbar.
    Und bitte diese Einstellung überprüfen:
    erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten"),
    dort den Eintrag
    mailnews.force_charset_override suchen, steht der auf false oder true?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • So, ich hoffe, ich habe alle meine Hausaufgaben gemacht; ich musste etwas suchen, weil natürlich alle Menus in Italienisch anders heißen - und auch anders aufgebaut sind ? - (aber ich hoffe, ich habe die richtigen gefunden):
    Ich habe gerade noch einmal einen Test gemacht und mir an meine eigene Adresse eine Mail mit Umlauten zugesandt; sehr witzig: in der Betreffzeile kommen die Umlaute richtig an, aber nicht in der mail selbst.... (vielleicht hilft das ja für die Diagnose)

    Zitat

    Schaut mal in der Systemsteuerung > Region und Sprache > Tastaturen und Sprachen > Tastaturen ändern. Was steht dort unter "Standardeingabesprache"?


    Die Standardeingabe ist tedesco (Germania) also wohl richtig

    Zitat

    Jetzt wird es lustig. Wo ist die Zeichenkodierung auf Unicode eingestellt? Bitte das genaue Menü nennen.


    Die Zeichenkodierung ist unter Ansicht (Visualizza) > Zeichenkodierung (Codifica caratteri) auf Unicode eingestellt.

    Zitat

    Weiterhin poste mir deine Einstellungen in Extras > Einstellungen > Ansicht > Formatierung > Schriftarten > Erweitert Es reicht, wenn du mir schreibst: 1. Kästchen angehakt usw. und die Standard-Zeichenkodierung für ausgehende Nachrichten.


    Ich kriege den Sceenshot hier nicht eingesetzt - stelle mich dumm an - also schreibe ich, was ich dort zur Zeichenkodierung gefunden habe (und übersetze so gut ich kann):
    Zeichen für: Occidentale
    Erlaube, dass die Nachrichten andere Zeichen benutzen - kein Häkchen
    Benutze Zeichen in festgelegter Breite (?) für Nachrichten mit einfachem Text - Häkchen
    Postausgang: Occidentale (ISO-8859-15)
    Posteingang: Occidentale (ISO-8859-15)
    Wenn möglich, benutze die Kodifizierung voreingestellter Zeichen in den Antworten - kein Häkchen

    Zitat

    Und bitte diese Einstellung überprüfen:erweiterte Konfiguration (Extras > Einstellungen > Erweitert > Allgemein > "Konfiguration bearbeiten"),dort den Eintrag mailnews.force_charset_override suchen, steht der auf false oder true?


    steht auf false
    Herzlichen Dank und Gruß
    Emma

  • Zitat

    So, ich hoffe, ich habe alle meine Hausaufgaben gemacht;


    Perfekt! Genauso stelle ich mir die vor.


    Welche Sicherheitssoftware verwendest du?
    Du hast ein deutsches oder italienisches Windows?
    Du hast eine deutsche oder italienische Tastatur?
    Die verfassten Mails wurden im Ordner Entwürfe oder Vorlagen gespeichert?
    Es handelt sich um keine Antworten oder Weiterleitungen?


    Zitat

    Die Zeichenkodierung ist unter Ansicht (Visualizza) > Zeichenkodierung (Codifica caratteri) auf Unicode eingestellt.


    Die Übersetzung ins Deutsche kannst du dir sparen, da ich selbst einen italienischen Thunderbird zusätzlich habe, und auch ganz passabel Ital. spreche.


    Wie der Name "Ansicht" schon sagt, ist hier keine richtige Einstellung möglich. Die Zeichenkodierung ändert sich ständig mit der jeweiligen Mail, weil hier nur das wiedergegeben wird, was im Quelltext unter charset steht.
    Allerdings: steht im Quelltext eine andere Zeichenkodierung als neben "charset" ist etwas faul.
    Wenn du also wie du sagst im Quelltext charset=iso-8859-15 stehen hast und unter Ansicht Unicode, wird der Nachrichtentext meistens falsch dargestellt.


    Da alles korrekt eingestellt ist, habe ich im Moment keine Idee, was noch die Ursache seien könnte. Darum warte ich deine Antworten ab.
    Eins könntest du aber schon machen: die "codicfica carattere" für "posta in uscita" auf Unicode (UTF-8) stellen.
    Jetzt musst du testen, ob die Mails bei deinen Freunden korrekt ankommen.
    Ich biete dir aber an (um deine Freunde nicht mehrfach zu belästigen), diese Testmail an mich zu schicken. Wenn dir das Recht ist, schicke mir eine Nachricht, indem du auf meinem Name links klickst, und dann ganz oben auf "Konversationen". Ich sende dir dann meine Mailadresse für diese Zwecke.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,
    danke nochmal für die viele Zeit, die du dir nimmst!
    Vielleicht fange ich mit einer der letzten Aufgaben an, da es hier vielleicht ein Problem gibt:

    Zitat

    Eins könntest du aber schon machen: die "codificca carattere" für "posta in uscita" auf Unicode (UTF-8) stellen.


    Ich finde in der Liste keinen Eintrag Unicode (UFT-8) - oder muss ich vielleicht woanders suchen? Ich finde di "codifica carattere" nur unter "posta in arrivo", aber wo ist "posta in uscita"?
    (Wenn ich auf "scrivi" klicke, wird das "codifica carattere" unter "visualizza" nicht mehr angezeigt. Ich weiß nicht, ob das normal ist.)
    Die Sicherheitssoftware ist AVG Antivirus Free Edition 2015.
    Mein Windows ist italienisch (aber damit hat es früher funktioniert).
    Ich habe eine italienische Tastatur (aber auch damit hatte ich vorher keine Probleme).
    Die verfassten mails werden im Ordner "posta inviata" korrekt abgelegt.
    Es ist egal, ob ich die emails verfasse, antworte oder weiterleite - immer gibt es Kuddelmuddel.
    Danke für das Angebot der email-Sendung. Bisher schicke ich die mails immer an mich selber zur Prüfung, da muss ich niemanden belästigen.
    Grazie mille e buona Befana
    Emma
    P.S. Vielleicht ist das auch noch eine nützliche Info: wenn ich mich auf meinem Server einlogge und dort die emails schreibe, geht alles klar
    P.SS. Mir fällt gerade ein, dass ich vor einiger Zeit tatsächlich eine neue Tastatur gekauft habe, weil meine alte (deutsche) hin war... Könnte es daran liegen? Ich versuche jetzt mal, sie auf Italienisch einzustellen und sehe, ob sie dann wenigstens die italienischen Sonderzeichen kann... Nein, daran liegt es auch nicht: auch die italienischen Sonderzeichen kommen als Fragezeichen rüber, wenn ich mit italienischer Tastatur und italienischer Einstellung der Tastatur schreibe.

    3 Mal editiert, zuletzt von Emma ()

  • Ricapitoliamo,
    du schreibst eine Mail und nur bei einem einzigen Empfänger werden die Umlaute falsch dargestellt, d'accordo?
    Dieser Empfänger befindet sich Deutschland oder Italien?


    Zitat

    Nein, daran liegt es auch nicht: auch die italienischen Sonderzeichen kommen als Fragezeichen rüber, wenn ich mit italienischer Tastatur und italienischer Einstellung der Tastatur schreibe.


    Wo hast du das außer in Thunderbird noch getestet. Versuche es auch in einem Texteditor.

    Zitat

    Vielleicht ist das auch noch eine nützliche Info: wenn ich mich auf meinem Server einlogge und dort die emails schreibe, geht alles klar


    Nein, das sind zwei Paar Schuhe, kann man nicht vergleichen.

    Zitat

    Mir fällt gerade ein, dass ich vor einiger Zeit tatsächlich eine neue Tastatur gekauft habe, weil meine alte (deutsche) hin war...


    Und das hast du ohne Änderung in der Systemsteuerung gemacht?

    Zitat

    Bisher schicke ich die mails immer an mich selber zur Prüfung, da muss ich niemanden belästigen.


    Sorry, das ist kein Test, weil du ja gar nicht weiß, welchen Mailklienten und welche Einstellungen der Empfänger hat.
    Denn

    Zitat

    In meinem eigenen Postfach der gesendeten e-mails werden die Umlaute hingegen richtig dargestellt.


    Mit "Postfach" meinst du das in Thunderbird?


    Um einen Fehler mit der Tastatur auszuschließen, mache bitte Folgendes:
    Drücke Win-Taste +R und gibt dort osk ein .
    Dann erscheint eine virtuelle Tastatur. Diese stellst du auf Deutsch und zwar geht das nur, wenn du Deutsch unter "Region und Sprachen" als zweite Sprache eingestellt hast. Unter "Tastatur und Sprachen" drücke auf den Button "Tastaturen ändern", dort müssen wenigstens 2 Sprachen aufgeführt sein, wenn nicht, hole das nach und stelle auf Deutsch. In den weiteren Menüs(Sprachenleiste und Erweiterte Tastatureinstellungen) kann man Einstellungen vornehmen, mit denen man
    1) in der Taskleiste die gerade eingestellte Sprache angezeigt wird
    2) mit einer bestimmten Tastenkombination, die man einstellen kann, die Sprache gewechselt wird. Bei mir ist das Umschalt+Alt.
    Die Umstellung in der virtuellen Tastatur erfolgt erst nach dem Klick auf alle OK.
    Jetzt tippst du in einer Mail mit der virtuellen Tastatur deutsche Wörter mit Umlauten ein und schickst diese an den Empfänger, der Probleme hat und fragst ihn, ob dort immer noch ????? stehen.

    Zitat

    Ich finde in der Liste keinen Eintrag Unicode (UFT-8) - oder muss ich vielleicht woanders suchen? Ich finde di "codifica carattere" nur unter "posta in arrivo", aber wo ist "posta in uscita"?


    Weil du im falschen Menü bist.
    Gehe nach > Strumenti > Opzioni > Visualizzazione > Formato > Avanzate... und ändere das wie beschrieben.


    Zitat

    immer gibt es Kuddelmuddel.


    Aber doch nicht bei dir, oder? In deinem Ausgangsbeitrag war das ja anders.

    Zitat

    (Wenn ich auf "scrivi" klicke, wird das "codifica carattere" unter "visualizza" nicht mehr angezeigt. Ich weiß nicht, ob das normal ist.)


    Nein, das existiert dort nicht für die visualizzazione , wohl aber für das Versenden unter "Opzioni".


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo Emma,
    Du arbeitest offensichtlich von Italien aus. Kennst Du dort PEC-Mail (Posta Elettronica Certificata). Zu diesemThema suche ich Hilfe.


    Vielleicht kannst Du mir weiterhelfen


    Vielen Dank im Voraus


    Ernst


    Edit: Um Auswirkungen eines Doppelpostings zu vermeiden, auf diesen Beitrag bitte hier PEC-Mail nach Italien (Posta Elettronica Certificata) antworten!  S-Mod. graba

    Einmal editiert, zuletzt von graba ()