Geschützte Leerzeichen in einer Text-Mail mit Thunderbird?

  • * Thunderbird-Version: 31.5.0
    * Betriebssystem + Version: Xubuntu Trusty Tahr 14.04
    * Kontenart (POP / IMAP): POp
    * Postfachanbieter (z.B. GMX): EWEtel
    * Eingesetzte Antivirensoftware: —
    * Firewall (Betriebssystem-intern/Externe Software): —


    Hallo!


    Ist es inzwischen möglich, in einer Email bei TB (ohne HTML) geschützte Leerzeichen zu verwenden?


    Es gibt dazu einen Thread von 2011, dem zufolge es anscheinend nicht geht; aber inzwischen sind ja ein paar Jahre vergangen.

    Liebe Grüße
    Krino

    Einmal editiert, zuletzt von Krino ()

  • Hallo,


    reine Textmails nutzen m.W. nur den ASCII-Zeichensatz und der enthält auch nach ein paar Jahren keine geschützten Leerzeichen. Das hat also nichts mit dem Thunderbird zu tun, sondern mit dem Zeichensatz, und betrifft daher alle Mailclients, die Reintext-Mails versenden können.


    MfG
    Drachen

  • Hallo Drachen!


    Danke für Deine Rückmeldung.


    Bei meinem TB habe ich die Wahl, ob ich die Mail als »Text« oder HTML verfasse bzw. sende. Für Textmails nehme ich standardmäßig UTF8 (Unicode). Darin sind ja eine Menge Zeichen enthalten, die über reinen ASCII weit hinausgehen, wie z. B. ¼, №, ☺. Diese werden – auch im Textmodus – von TB anstandslos akzeptiert.


    Nur das geschützte Leerzeichen wird ungefragt als ungeschütztes Leerzeichen wiedergegeben, übrigens gleichermaßen im Text- und auch im HTML-Modus.


    Nun ja, ich werde mir deswegen nichts antun :D — aber ärgerlich ist es schon.


    Übrigens – Off-Topic — Wieso habe ich vom TB-Forum keine Email-Benachrichtigung über Deine Antwort bekommen, obwohl das in meinem Profil bei »Einstellungen« angehakt ist?

    Liebe Grüße
    Krino

    2 Mal editiert, zuletzt von Krino ()

  • Hallo Krino,


    nun habe ich dank dir zwar meinen Wissensstand aktualisiert (UTF-8), aber einen Tipp habe ich leider trotzdem nicht für dich. da müssen die Spezis ran. Ob der TB das UTF-8 noch nicht sauber umsetzt oder ob bestimmte Zeichen beusste ausgespart sind oder ersetzt werden oder ob das schlicht ein Fehler (neudeutsch: bug) ist, da könnte ich bestenfalls raten.


    MfG
    Drachen

  • Hallo,
    zur Info:
    ich gehöre zwar nicht zu den Betroffenen (noch nie geschützte Leerzeichen verwendet), trotzdem weckt so etwas m eine Neugier.
    Leider ist das Ergebnis recht traurig: ich habe bei Bugzilla mindestens 2 fast uralte Threads (einer begonnen 2005) gefunden, die dieses Thema beschreiben.
    Trotz regelmäßigen Pushens hat sich dazu aber nichts getan. Offensichtlich wissen die Entwickler nicht, wie sie den Bug fixen sollen oder sie haben andere Prioritäten.
    Mit anderen Worten: eine Lösung dieses Problems wird es wohl kaum geben.


    https://bugzilla.mozilla.org/show_bug.cgi?id=218277
    https://bugzilla.mozilla.org/show_bug.cgi?id=290565


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke, mrb, für Deine Recherche.


    Es geht mir halt nur darum, daß Ausdrücke wie »2000 €« oder »A. Müller« zusammenbleiben und nicht in zwei verschiedenen Zeilen landen, wenn man nachträglich Text einfügt.


    Da TB wie gesagt mit UTF8 an sich kein Problem hat, wundert es mich, daß ausgerechnet der geschützte Leerschritt Schwierigkeiten macht.


    Es gibt auch noch den schmalen geschützten Leerschritt; damit scheint TB klarzukommen, wie ich gerade erstaunt feststelle.


    Wenn man den doppelt verwendet, hätte man ein wunderbares Workaround… :)

    Liebe Grüße
    Krino