IMAP Konto synchronisieren sich nicht automatisch

  • Hallo,


    derzeit habe ich 5 verschiedene Mailkonten in Thunderbird. Vor einigen Tagen habe ich 3 dieser Konten von POP3 auf IMAP umgestellt.
    Alle Ordner und Unterordner sind abonniert, einmal pro Minute auf neue Nachrichten prüfen ist angehakt, max. Serververbindungen steht auf 2.
    Die Synchronisation ist prinzipiell möglich. Wenn ich die jeweiligen Posteingangsordner anklicke, werden neue Eamils von den Servern geladen.


    Leider funktioniert dies aber nicht automatisch oder nur sehr unregelmäßig und vielleicht so alle paar Stunden mal. Als ich noch Pop3-Konten hatte, haben sich die IMAP-Konten
    auch stets automatisch aktualisiert, jetzt passiert das nicht mehr.


    Was kann ich tuen, in diesem Zustand kann ich Thunderbird nicht benutzen.



    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:

    * Thunderbird-Version: 38.2.0
    * Betriebssystem + Version: Win 8.1
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): verschiedene
    * Eingesetzte Antivirensoftware: Antivir
    * Firewall (Betriebssystem-intern/Externe Software): Betriebssystemintern

  • Hallo stepper_m,
    und willkommen im Forum!



    Wie hast du denn überprüft, ob sich das IMAP-Konto richtig synchronisiert? Oder anders gefragt, war denn "vielleicht so alle paar Stunden mal" auch immer eine Mail auf dem Server?



    Bei IMAP ist das ja nicht so, dass der Client ab und an beim Server nachsehen muss, ob neue Mails angekommen sind, sondern der Client hält ständig einige wenige Verbindungen zum Server aufrecht, auf denen der Server von sich aus dem Client mitteilt, ob neue Mails vorliegen. Diese Information wird also gepuscht.



    Richtiger Test: eine Mail an dich selbst schicken - und die muss dann innerhalb weniger Sekunden angezeigt werden.



    OK?





    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo und willkommen im Thunderbird-Forum!

    Alle Ordner und Unterordner sind abonniert, einmal pro Minute auf neue Nachrichten prüfen ist angehakt, max. Serververbindungen steht auf 2.

    Die Intervallangabe ist bei IMAP nur interessant, wenn der Server nicht von sich aus pusht.
    Aber du sagst, du hast die Serververbindung auf 2 stehen. Welche Einstellungen sind in dem Fenster denn noch, kannst du uns das am Besten per Screenshot, mal mitteilen?

  • Hallo Peter, hallo rum,



    Richtiger Test: eine Mail an dich selbst schicken - und die muss dann innerhalb weniger Sekunden angezeigt werden.

    hatte ich schon gemacht, die Mail kommt komischerweise erst dann an, wenn ich den Posteingang von einem auf ein anderes Konto umschalte. Anscheinend wird sie eben nicht gepusht und auch nicht nach einer Minute automatisch abgerufen. Vom Gefühl her döst Thunderbird eher so vor sich hin, und wenn ich dann was mache, zb den Posteingang umschalte, wird es aktiv und synchronisiert.


    Hallo und willkommen im Thunderbird-Forum!

    Die Intervallangabe ist bei IMAP nur interessant, wenn der Server nicht von sich aus pusht.Aber du sagst, du hast die Serververbindung auf 2 stehen. Welche Einstellungen sind in dem Fenster denn noch, kannst du uns das am Besten per Screenshot, mal mitteilen?

  • Meine Einstellungen sind so wie im Screenshot.
    Hast du auf dem Server Filter eingerichtet, welche die Mails schon "vor dem Thunderbird" auf die einzelnen Mailordner verteilen? => Da ist schnell mal die max. Anzahl der zu haltenden Verbindungen überschritten.
    Und hast du geprüft, ob deine uns verheimlichten Provider überhaupt IDELING anbieten?


    MfG Peter

  • Ich habe alle serverseitigen Einstellungen jetzt überprüft, da sind nirgendwo Filterregeln hinterlegt (ein Konto bei Gmx, eins bei Web.de und mehrere Konten bei Kontent).


    Ich habe jetzt versuchsweise die "Maximale Anzahl der aufrecht erhaltenen Serververbindungen" für jedes Konto auf 10 gesetzt, wobei ich dazu irgendwo gelesen hatte, dass niedrigere Einstellungen Probleme eher reduzieren.


    Nach ein paar versendeten Testmails scheint das Hochsetzen der maximalen Verbindungen geholfen zu haben, mal sehen, ob das so bleibt. Nur das Konto von web.de scheint noch ein bißchen träge zu sein, das ist aber nicht so schlimm, da kommt eh nur Spam.


    Also vielen Dank erst mal für die Tipps !

  • Hast du die Einträge bez. der Namensräume gemacht oder der Provider?


    Ändere sie mal testweise auf die in Peters Screenshot gezeigten ab.

  • An den Namensraumeinstellungen habe ich nichts geändert, die waren schon so...


    Aber wie gesagt, das Hochsetzen der maximal erlaubten Verbindungen scheint geholfen zu haben.

  • das Hochsetzen der maximal erlaubten Verbindungen scheint geholfen zu haben.

    Hinweis zu diesem Thema:


    Jede dieser ständig offen zu haltenden Verbindungen kosten dem Provider Traffic, Rechenleistung (= Energie) und natürlich auch bereit zu haltenden RAM usw. Sicherlich ist das pro Nutzer verschwindend wenig, aber manche Großprovider haben mehr als drei Nutzer ;-)
    Da ist es zu verstehen, dass die Provider diese Zahl an Verbindungen die sie jedem ihrer Nutzer (vermutlich je IP) zubilligen auf ein vernünftiges Maß begrenzen. Leider habe ich noch nirgend wo bei einem Provider gelesen, wie viele Verbindungen sie uns geben.


    Mehr einstellen bringt nichts. Das ist eher kontraproduktiv. Austesten ist eher möglich und da scheinst du wohl Glück gehabt zu haben.


    OK?



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Die Lösung, die tatsächlich alle Aktualisierungsprobleme beseitigt hat, war nun:


    "Idle-Befehl verwenden, falls der Server ihn unterstützt" ABWÄHLEN (obwohl der Server dies unterstützt, unter Konteneinstellungen -> Server -> Erweitert)
    (Maximale Serververbindungen zurückgestellt auf 5)
    "einmal die Minute auf neue Mails prüfen" eingestellt


    Jetzt werden alle Konten wieder zuverlässig aktualisiert.