Buchstabensalat bei PDF Dateien im Anhang

  • Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 38.2.0
    * Betriebssystem + Version: Mac OS X, Version 10.7.5
    * Kontenart (POP / IMAP): IMAP
    * Postfachanbieter (z.B. GMX): Strato
    * Eingesetzte Antivirensoftware:
    * Firewall (Betriebssystem-intern/Externe Software): Mac OS interne Firewall


    Seit kurzem werden mir alle E-mails mit PDF Dateien im Anhang zerschossen. Bei mir sieht es gut aus, die E-mails werden auch verschickt, beim Empfänger ist jedoch ein übler Buchstabensalat, die PDFs im Anhang werden als beliebige Bilddateien gewertet, also nicht mal automatisch mit Acrobat geöffnet. - Wobei sich die Empfänger ja sowieso erschrecken, wenn sie diese Emails bekommen!
    Ich denke, es muss an den Einstellungen in Thunderbird liegen, aber wo??




    Danke für die Hilfe

  • Hi,
    hast du dir selbst mal eine mail mit PDF-Anhang gschickt? Läßt die sich öffnen?
    Wie sieht der Quelltext der empfangene Mail aus (Strg+U drücken)? Also vor allem die Zeilen mit

    Code
    1. Content-Type: ...
    2. Content-Transfer-Encoding ...
    3. Content-Description: ...
    4. Content-Disposition:

    Sind die kodierten Textblöcke jeweils mit den durch boundary="..." definierten Trennzeilen eingeschlossen?


    cu frog

  • ich weiß nicht genau, was Du meinst. So wie ich das sehe, sind die Einzelteile durch die "-------0123456789" getrennt. Sind das die Trennzeilen? Wenn es dann zu Content-Type geht, steht da text/richtext beim pdf. Ist das der Grund? Ich bin Genie, wenn es darum geht, mit Quelltexten zurecht zu kommen, sorry...

  • Hallo,


    bei mir sieht der Quelltext einer Mail, die ich mit einer von mir erstellten PDF-Datei im Anhang versandt habe, folgendermaßen aus:


    Gruß


    Nachtrag:
    das Problem beim Versenden von PDF-Dateien mit TB unter Mac OS X wurde hier schon mehrfach behandelt.
    Gehe mal in Einstellungen > Anhänge > Empfang: gibt es dort Einträge für "Portable Document Format", und wenn ja, welche?

  • Bei mir auch,
    Content-Type: application/pdf;
    text/richtext kommt mir sehr verdächtig vor.
    Und wird das PDF bei DIR trotzdem geöffnet?

  • text/richtext kommt mir sehr verdächtig vor.

    Solange da Content-Type: text/plain; steht, sollte es kein Problem bedeuten, den m. E. gilt dies nur für den Nachrichten-Text selber.


    Der darunter folgende Content-Type: application/pdf; ist wichtig, da auf Mac häufig irrtümlich der Content-Type: application/applefile; verwendet wird
    s. Empfänger kann PDF-Dateien nicht öffnen
    Daher meine Frage nach den Einträgen in den Einstellungen > Anhänge.

    Und wird das PDF bei DIR trotzdem geöffnet?

    Ja, ich habe den im screen shot gezeigten PDF-Anhang an eine Zweit-Adresse geschickt und kann die danach empfangene Datei problemlos öffnen und lesen.

  • Guten Morgen, schön dass Ihr mir helft! Also, bei mir sieht es folgendermassen aus:



    Lösche ich dann den ersten Dateityp Adobe PDF document (text/richtext: .pdf) einfach raus?
    Es ist so: wenn ich mir die Email an meine eigene 2. Adresse auf dem MacBook schicke, sehe ich überhaupt keinen Fehler. Schicke ich es aber an eine andere Adresse, die sogar auch mit Thunderbird arbeitet, sehe ich das Desaster. Ich wurde auch erst darauf aufmerksam, als mich jemand anrief und meinte, ich lege seinen Computer lahm.
    Auf dem befreundeten Mac läuft noch immer TB 31.7, da gibt es keine Probleme mit PDF verschicken, aber meine verschickten PDFs kommen folgendermassen an: Screenshot von befreundetem Mac:

    Ich habe inzwischen bei "Empfang" alles umgestellt: von "öffnen mit Acrobat Pro" auf "jedes Mal nachfragen", aber das hat auch nicht geholfen.
    Auf dem befreundeten Mac sind auch die 3 Acrobat PDF Document Einstellungen identisch, auch das richtext Teil, allerdings sind sie in einer anderen Reihenfolge gelistet. Aber das kann´s doch nicht sein!
    Was mir auch auffällt:
    1. bei Mapenzi steht: multipart/mixed, bei mir multipart/alternative,
    2. fehlt bei mir im Quellcode der Part mit Content-Type: application/pdf, da steht nur:
    This is a multi-part message in MIME format.
    --------------070403000404020200030502
    Content-Type: multipart/alternative;
    boundary="------------090105090209030800010800"




    --------------090105090209030800010800
    Content-Type: text/plain; charset=utf-8; format=flowed
    Content-Transfer-Encoding: 8bit

    2 Mal editiert, zuletzt von juma ()

  • Ich würde einfach probehalber bei beendetem TB die Datei "mimetypes.rdf" aus dem Profil entfernen und erneut testen.
    Den Profilordner von TB findest du über das Menü "Hilfe" > Informationen zur Fehlerbehebung > Profilordner > im Finder öffnen, danach TB beenden.


    Gruß

  • Danke, ich probier´s


    Hat leider nicht geholfen!! Sieht genauso aus.


    44Min später: irgendetwas hat sich doch getan: jetzt ist bei den "globalen Einstellungen - Empang" alles leer, die pdfs kommen bei dem befreundeten Mac normal an. Ich hatte inzwischen das "mimetypes.rdf" erst mal aus dem Ordner gezogen, dann später, als alles nichts half, wieder nach Beenden und Neuaufrufen von TB in den Profilordner -in alphabetischer Reihenfolge - zurückgelegt.



    Hat also doch geholfen?!
    Wie weiß ich denn, dass das jetzt so bleibt?

    2 Mal editiert, zuletzt von juma ()

  • Hat leider nicht geholfen!! Sieht genauso aus.


    44Min später: irgendetwas hat sich doch getan: jetzt ist bei den "globalen Einstellungen - Empang" alles leer, die pdfs kommen bei dem befreundeten Mac normal an.

    Du hattest vermutlich TB nicht beendet, bevor du mimetypes.rdf aus dem Profilordner verschoben hast.
    Der Vorschlag des probeweisen Entfernens dieser Datei steht auch in dem von zuvor mir verlinkten Thema ;)


    Von meinen fünf TB-Profilen enthält übrigens nur eines eine mimetypes.rdf-Datei, und die ist leer!
    Ich benutze TB seit der ersten Version, aber bei mir ist dieses Problem der verschickten und nicht lesbaren PDF-Anhänge noch nie aufgetreten.

    Hat also doch geholfen?!
    Wie weiß ich denn, dass das jetzt so bleibt?

    Wenn deine mimetypes.rdf Datei jetzt leer ist, sollte das Problem behoben sein.
    Das bedeutet allerdings nicht, dass es nicht irgend wann erneut auftritt.
    Das Problem mit dem Dateityp "Portable Document Format (application/applefile: .pdf)" in Einstellungen > Anhängen tritt sogar so häufig auf, dass jemand ein Add-on dafür entwickelt hat:
    "No application/applefile 0.1" addons.mozilla.org/fr/thunderb…/no-applicationapplefile/
    Lies mal die interessanten Informationen des Entwicklers zu den Ursachen und der Behebung des Problems.

  • Nochmal danke,
    freu mich über Deine Hilfe. Auch wenn ich nichts verstehe. Cool, dass es Euch gibt. LG :)