Filter gelöscht - Mail wird trotzdem in falschen Ordner geschoben

  • Hallo an die Gemeinschaft!


    Ich erhalte relativ viele EMails und habe eine entsprechende Anzahl von Ordnern. Für die jeweiligen Mails sind "einfache" (Absender in den Ordner) Filter angelegt.
    Bis zum Update vor 3 oder 4 Tagen funktionierte das korrekt. Seitdem aber schiebt mir TB eine einzige Mail (kommt jeden Tag) in einen völlig anderen Ordner. Absender der Mail hat sich seit Jahren nicht geändert. Ich habe also den Filter für diesen Absender gelöscht und daraufhin landete sie ganz normal im Posteingang. Dann habe ich einen neuen Filter erstellt und beim "Jetzt ausführen" wurde die Mail in "ihren" Ordner verschoben :)
    Am nächsten Tag fand sich dieser Absender aber wieder im vorherigen falschen Ordner. Gleiches Spiel - gleiches Ergebnis :(


    Ich habe daraufhin all meine Filter gelöscht und erstaunlicherweise wurden die eingehenden Mails, obwohl keine Filter mehr vorhanden waren, zu ca. 60% in die richtigen Ordner verschoben; was ich merkwürdig finde. Der Rest landete im normalen Posteingang und ich konnte die Filter wieder neu anlegen. Das klappte alles prima, nur ...... diese eine Mail landet immer wieder im falschen Ordner :(


    Hat jemand vielleicht das gleiche Problem und kann mir einen Tipp geben, wie ich die Mail wieder in ihren gewohnten Ordner bekomme?


    Und noch eine Frage: Bleiben die gelöschten Filter irgendwo im System und wo sind diese zu finden?
    Die Antwort müsste ja lauten, denn woher weiß TB sonst, wohin die Mails verschoben werden sollen - es gibt ja keine Filter mehr und dennoch landen sie in den richtigen Ordnern ?(


    Ich bedanke mich schon mal im Voraus recht herzlich.


    Floh



    Um Rückfragen vorzubeugen, bitten wir um folgende Angaben:
    * Thunderbird-Version: 38.4.0
    * Betriebssystem + Version: Windows 7 64 bit
    * Kontenart (POP / IMAP): POP
    * Postfachanbieter (z.B. GMX): Telekom, web.de
    * Eingesetzte Antivirensoftware: AVG
    * Firewall (Betriebssystem-intern/Externe Software): Intern

  • Hallo,


    derartiges habe ich noch nicht gehört.
    Daher nur ein Versuch:
    beende Thunderbird,
    suche das Thunderbird-Profil auf auf
    Profile verwalten (Anleitungen)
    suche in allen "Kontenordnern im Überordner "Mail" nach der Datei msgfilterrules.dat, sichere sie(etwa durch umbenennen) und lösche sie.
    Nach Neustart das gleiche Problem?
    Die Sicherung deshalb, weil die Datei im Klartext geschrieben ist, welches die Rekonstruktion der Filter vereinfacht.
    Außerdem kann man diese Dateien ja - falls sie nicht defekt sind - ja auch wiederverwenden.
    Aber biite: bei Arbeiten im Profil immer Thunderbird schließen, weil sonst neue Dateien in Thunderbird nicht erscheinen, sondern die alten erhalten bleiben.



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    schon mal danke vorab.


    Ich werde das ausprobieren, kann aber erst übermorgen sagen, ob das Problem noch da ist. Da die Mail immer nur 1x am Tag kommt und morgen vermutlich im normalen Posteingang zu finden ist, muss ich erst wieder den Filter erstellen und auf Sonntag warten.


    Ich werde aber auf jeden Fall berichten.


    Wenn ich diese Datei lösche, sind dann alle Filter weg?


    Gruß Floh

  • So, ich habe alles nach Anweisung erledigt und eines kann ich jetzt schon beantworten:


    Die Filter sind nach dem Löschen der msgfilterrules.dat noch vorhanden. Alle bisher angekommenen neuen Mails landen ordnungsgemäß in ihren Ordnern :-) und TB hat eine neue msgfilterrules.dat erstellt.


    Die Filter müssen also noch irgendwo anders gespeichert sein.
    Es gibt da noch eine html-Datei namens filterlog, die ordentlich "gefüllt" ist. Ich kann mir aber nicht vorstellen, dass die irgendetwas damit zu tun hat.


    Ich warte morgen meine "besondere" Mail ab, aber ich befürchte, dass die auch wieder im falschen Ordner landen wird :-(

  • Hallo,


    du hast ja mehrere Konten und TB legt die Filter Kontenbezogen an, somit gibt es in jedem Kontenordner eine msgfilterrules.dat


    Wenn du auf Extras>Filter gehst, kannst du oben das Konto auswählen und unten rechts das Filterprotokoll ansehen, dass versteckt sich in der Datei filterlog.html ;)

  • Nun verstehe ich die Welt nicht mehr =O


    Obwohl für diese "besondere" Mail kein Filter mehr eingerichtet war/ist, hat TB sie heute ordnungsgemäß in ihren ursprünglichen Ordner verschoben :D


    Im Prinzip ist ja jetzt alles wieder ok thumbsup.png, es sei denn, sie landet morgen wieder im falschen Ordner ?(


    Wenn sich irgendjemand findet, der mir diesen Ablauf erklären kann - ich habe ein großes offenes Ohr :rolleyes:


    @'rum


    Danke, das habe ich eben ausprobiert und von allen Konten die Filterprotokolle gelöscht und wieder neu aktiviert.
    Unklar ist mir aber noch die Funktion der msgfilterrules.dat, da ja trotz Löschen dieser Datei noch alle Filter vorhanden sind ?(


    Auf jeden Fall ein Danke an die Gemeinschaft!


    VG Floh

  • Kaum zu glauben. Du hast wirklich alle Dateien gefunden, Thunderbird beendet und die Dateien entfernt.
    Es gibt auch eine in den loocal folders.
    Du hast wirklich keine IMAP-Konten?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Und auch heute wurde die Mail in den richtigen Ordner verschoben, obwohl ich keinen Filter erstellt habe :) Aber das soll mir jetzt egal sein - die Hauptsache, es funktioniert wieder ;)


    @mrb


    Nein, es sind definitiv POP-Konten. In den local folders war ich bisher nicht, werde es aber ins Auge fassen, wenn das Problem noch einmal auftreten sollte.


    VG Floh

  • Hallo,


    um es noch mal zu fragen: hast du für jedes Konto einen Posteingang etc. oder nutzt du den Posteingang im Lokalen Ordner?
    Sind also links in der Hauptansicht die Konten einzeln aufgeführt?

  • @ rum


    Ich habe 5 EMailkonten und 4 davon habe ich zusammengefasst, so dass die Mails im Posteingang des Lokalen Ordners landen - nur 1 Konto hat einen separaten Posteingang. Dieses ist aber nicht die Adresse für diese spezielle Mail.


    VG Floh

  • Hallo,



    @mrb


    Nein, es sind definitiv POP-Konten. In den local folders war ich bisher nicht,

    4 davon habe ich zusammengefasst, so dass die Mails im Posteingang des Lokalen Ordners landen -

    für diese Konten musst du aber den Filter des Lokalen Ordners (auf Dateiebene ...\mail\local folders) ansehen!

  • @ rum


    Das mache ich, wenn das Problem noch einmal auftritt.


    Das Löschen der msgfilterrules.dat hat, so wie es aussieht, ausgereicht :) , denn bis jetzt "wandern" alle Mails dahin, wo ich sie haben möchte. Die wenigen Filter, die ich jetzt wieder neu anlegen muss, sind schnell erstellt und ich bin wieder fein zufrieden ^^


    Vielen Dank für eure Hilfe!


    Eine schöne Adventszeit und ein frohes Fest wünscht
    Floh