Bild von externer URL lokal einbinden

  • Hallo!


    Ich habe in meiner HTML-Mailsignatur eine JPG-Datei eingesetzt. Diese beziehe ich mit <img src="[Dateipfad]"> von meinem eigenen Webserver.

    Nun ist mir seit Thunderbird 52 aufgefallen, dass die Datei nicht mehr in jede E-Mail eingebunden wird, sondern, dass im Quelltext der Mail auch auf die Datei auf dem Server verwiesen wird. Dies hat zur Folge, dass meine Mails in diversen E-Mail-Programmen mit Mitteilungen wie "Externe Inhalte wurden blockiert" angezeigt werden.


    Ich vermute, dass ich das Bild durch <img src="[Dateipfad]" moz-do-not-send="false"> bei jeder Mail im Anhang versenden könnte.

    Allerdings habe ich recht viele Konten mit einer solchen Signatur im Thunderbird (auch auf verschiedenen Computern). Daher würde ich es gerne vermeiden, für jedes Konto die Signatur mit diesem Tag zu ändern. Gibt es eine allgemeine Thunderbird-Einstellung?


    dapr




    • Thunderbird-Version: 52.1
    • Betriebssystem + Version: Win 10
  • Hallo,


    manche Leute lassen nunmal externe Inhalte nicht automatisch laden, das geänderte Tag wird daran wohl nichts ändern. Halte das Logo möglichst klein (in KB) und schicke es mit den Mails mit. Dann sollten diese Probleme nicht mehr auftreten.


    MfG

    Drachen

  • Wie schicke ich es denn mit den Mails mit?

    Sorry, aber ich glaube, Du hast meine Frage etwas falsch verstanden :-)


    Mir geht es ja um Folgendes:

    Mit dem Tag moz-do-not-send… bezwecke ich ja eigentlich, dass das Bild mitgeschickt wird und nicht beim Empfänger von der Serveradresse bezogen wird.

    Meine Frage war eigentlich, ob es hierzu noch eine Alternative gäbe, außer eben diesen Tag mit in <img> einzufügen.

    Oder liege ich da jetzt irgendwo falsch…?

  • Hallo,


    tatsächlich verstehe ich das Gebastel mit diesem Flag oder Argument nicht. Bild einfügen in die Mail(signatur) und gut is'

    Und wenn der Empfänger kein Klicki-Bunti mag, kriegt er das Bild als normalen Anhang mit.


    Ich gestehe aber, dass hier ohnehin nicht gut mitreden kann, da ich seit Jahren lieber auf gut strukturierten Text setze und nicht auf Bildchen. Im Gegensatz zu primär auf Design setzende Mails kommt das nämlich auch dann sauber an und schaut nicht völlig katastrophal bis unleserlich zerrissen und zerklüftet aus, wenn der Empfänger nur Textmails akzeptiert. Sogar sparsam eingesetzte Hervorhebungen sind möglich, was will man mehr.


    MfG

    Drachen

  • Bild einfügen in die Mail(signatur) und gut is'

    Wie genau füge ich das Bild von einer externen URL denn jetzt eigentlich ein, sodass die Datei auch mitgesendet wird und nicht nur im Quelltext auf die URL verwiesen wird?

    Wenn ich nämlich einfach <img src="[Dateipfad]"> einfüge, wird nur auf diese URL verwiesen und das Bild wird nicht an die Nachricht angehängt.

  • Hallo,


    du musst dich schon entscheiden zwischen Link auf externes Bild ODER Bild mitgeschickt in der Mail - und wenn der Empfänger alles nur als Reintextmal anzeigen lässt, ist das Bild eh nur im Anhang und die Verlinkung hinüber.


    Verlinktes externes Bild in der Mail mitschicken ist ein Widerspruch, also entweder oder. Aber vielleicht habe ich dich auch nur missverstanden, in dem Fall sorry vorab.


    Mit freundlichen Grüßen

    Drachen

  • Hallo,


    also…

    Ich meine, wenn ich jetzt in meine Mail-Signatur den HTML-Text <img src="http://meine-domain.de/images/mail-signatur.jpg"> schreibe, wird diese Datei seit Version 52 nicht mehr an die Mail angehängt, sondern das Bild wird stattdessen beim Empfänger immer von der URL http://meine-domain.de/images/mail-signatur.jpg abgerufen.

    Ich möchte dieses Bild nicht etwa mit <a href="…"> verlinken, nur dieses in meine Mail einbinden.

    Wie kann ich bewirken, dass dieses von einer URL eingebundene Bild an jede Mail angehängt wird (im Anhang)?


    Ich hoffe, dass meine Frage nun etwas präziser dargestellt ist. :-)


    Gruß

    dapr

  • Hallo,

    ich werde mal testen, ob ich das bei mir nachvollziehen kann.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,

    gemach, gemach, ich musste mir gerade mal einen Account fürs FTP-Webhosting anschaffen. Jetzt habe ich dorthin 2 Bild er hochgeladen und im Verfassenfenster unter Einfügen--> Grafik die Url eingetragen, wobei das Bild sofort angezeigt wird, keinen Haken bei dem Kästchen gemacht und einen Alternativtext angegeben habe.

    Diese Mail habe ich versendet. Sowohl im Ordner "Gesendet" als auch im Posteingang wurde das Bild korrekt angezeigt.

    Bitte update Thunderbird auf 52.1.1 damit wird die gleiche Ausgangsbasis haben.

    Erkläre ebenfalls genauestens, wie du deine Signatur erstellt hast. Der einzig sichere Weg ist nämlich nur, es über Thunderbird selbst zu machen. Also im Verfassenfenster die Signatur anfertigen und von dort unter Datei --> Speichern als --> Datei --> Dateityp HTML abspeichern. Diese Datei in den Konteneinstellungen einfügen.

    Solltest du die Signatur mit einem externen Programm erstellt haben, vergiss es! Das klappt nur selten.

    Hier der HTML-Code :


    Zitat


    Ich vermute, dass ich das Bild durch <img src="[Dateipfad]" moz-do-not-send="false"> bei jeder Mail im Anhang versenden könnte.

    Nein, du vermutest falsch, der Parameter muss auf "True" stehen, denn sonst sendet Thunderbird die Datei als Anhang, nachdem er sie automatisch heruntergeladen hat. Das möchtest du aber nicht, oder? Siehe meinen HTML-Code.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    3 Mal editiert, zuletzt von mrb ()

  • Hallo,


    wenn du ein Bild von einer externen URL verlinkst, dann ist das ein Link. Ich kenne kein Mailprogramm o.ä., was sozusagen von sich aus eine verlinkte Datei herunterlädt und in die Mail einbaut und dann auch noch den Link zum Bild entsprechend anpasst. Das wirst du schon selber machen und dafür deine HTML-Zeile ändern und anpassen müssen. Wie genau, weiß ich leider nicht, da ich weder HTML-Mails schicke noch privat Signaturen nutze.


    Mit freundlichen Grüßen

    Drachen

  • Diese Mail habe ich versendet. Sowohl im Ordner "Gesendet" als auch im Posteingang wurde das Bild korrekt angezeigt.

    Bitte update Thunderbird auf 52.1.1 damit wird die gleiche Ausgangsbasis haben.

    Erkläre ebenfalls genauestens, wie du deine Signatur erstellt hast. Der einzig sichere Weg ist nämlich nur, es über Thunderbird selbst zu machen. Also im Verfassenfenster die Signatur anfertigen und von dort unter Datei --> Speichern als --> Datei --> Dateityp HTML abspeichern. Diese Datei in den Konteneinstellungen einfügen.

    Hallo!


    Die aktuelle Thunderbird-Version habe ich.


    Stammt Dein HTML-Quelltext aus Deiner "verfassten" E-Mail oder aus der bereits empfangenen Mail?


    Ich füge einen Text in die Signatur-Einstellungen direkt ein, verweise also auf keine HTML-Datei:


    <head><style type="text/css">
    .html, body
    {font-family: Calibri;}
    </style>
    </head>


    Name<br>

    <a href="mailto:mail@meine-domain.de">mail@meine-domain.de</a><br>

    Adresse<br>


    <a href="http://www.meine-domain.de/">http://www.meine-domain.de</a><br><br>


    <img src="http://www.meine-domain.de/mail-signatur.jpg" moz-do-not-send="false">




    Gruß

    dapr

  • Stammt Dein HTML-Quelltext aus Deiner "verfassten" E-Mail oder aus der bereits empfangenen Mail?

    Ja. Ob es aber die gesendete Mail oder die empfangene war, weiß ich nicht mehr.

    Wo willst du im Verfassenfenster dir den momentanen Quelltext anschauen? Das ginge nur mit einem Add-on (EditHtml.

    Und ich hatte dir ja gesagt das "false" falsch ist, warum versuchst du es damit noch einmal? Und ich hatte dir den Tipp gegeben die Signatur mit einer HTML-Datei zu erstellen als mit dem behelfsmäßigen Textfeld für die Signaturen.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb () aus folgendem Grund: Sigantur Signatur Sigantur Signatur

  • Siehe https://www.mozilla.org/en-US/thunderbird/52.0/releasenotes/


    Zitat

    IMPORTANT: The way images are included in a compose window has changed. Images are now included as data URIs
    and not as references to parts of other messages or operating system files. This allows better interoperability with office packages such as MS Office or LibreOffice. Images linked from locations on the internet will no longer be downloaded and attached to the
    message automatically. This can be changed for each image individually via the Image Properties dialog or globally by setting the preference mail.compose.attach_http_images.



  • Hallo Susanne,

    Danke für die Info. Allerdings verstehe ich sie nicht so ganz. Das würde ja nur dann zutreffen, wenn ich den Haken bei dem Kästchen "and die Nachricht anhängen" betätige. Aber gerade das wäre ja bei remote Anhängen nicht erwünscht, um die Mailgröße klein zu halten. Ich werde gleich mal testen.


    Ergebnis: Setze ich den besagten Haken kommt eine Nachricht, "haben Sie vergessen einen Anhang einzufügen?".

    Wäre meiner Ansicht besser gewesen, die Option des Anhängens in dem besagten Menü ganz zu streichen, dann könnte auch der Code "moz-do-not-send" verschwinden, weil er nicht mehr gebraucht wird.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    2 Mal editiert, zuletzt von mrb ()

  • Hallo mrb,


    ich wollte nur darauf hinweisen, dass es hier eine Änderung im Code gegeben hat. Ich habe es nun selbst ausprobiert, mit einer Grafik hier aus dem Forum:


    Das funktioniert, wie bei Dir.

  • Jetzt sind wir natürlich sehr interessiert zu wissen, wie sich dein Problem gelöst hat, denn unsere Arbeit lebt vom Feedback.

    Es wäre nett, wenn du ein paar Zeilen dazu schreiben würdest.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • ich wollte nur darauf hinweisen, dass es hier eine Änderung im Code gegeben hat. Ich habe es nun selbst ausprobiert, mit einer Grafik hier aus dem Forum:

    Hallo Susanne,

    durch das Ausprobieren habe ich den Sinn der Änderung jetzt schon verstanden bzw. welche Auswirkungen sie hat. Die sind aber minimal.

    Aber du warst mal wieder schlauer als ich und hast dir so viel Arbeit erspart, indem du keine eigene Datei irgendwo hochgeladen hattest, sondern einfach schon vorhandene genommen hast. Tja, das Alter...

    Vorteil ist aber, dass ich jetzt wieder einen FTP-Account habe, der war nämlich bei mir wegen Untätigkeit abgelaufen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Jetzt sind wir natürlich sehr interessiert zu wissen, wie sich dein Problem gelöst hat, denn unsere Arbeit lebt vom Feedback.

    Es wäre nett, wenn du ein paar Zeilen dazu schreiben würdest.

    Gruß

    Sagen wir mal, dass sich mein Problem halb gelöst hat.

    Nun kann ich durch die von Mozilla genannte Einstellung allgemein die Bilder wieder automatisch in die Mails einfügen, sodass sie nichts mehr mit der URL zu tun haben.


    Mein noch vorhandenes Problem:

    Ich verschicke Vorlagen durch Filter automatisch auf eingehende Mails, quasi als Empfangsbestätigungen.

    Da ich diese Vorlagen nun schon mit der "neuen" Einstellungen erstellt habe, werden diese Bilder als cid-Part eingebunden.

    Das Problem ist, dass jetzt beim Empfänger

    Code
    1. This is a multi-part message in MIME format.--------------CA6C9DF86C6DE54E8B2B00AFContent-Type: text/html; charset=utf-8Content-Transfer-Encoding: 8bitam Anfang der Mail angezeigt wird.

    Zum Ende hin kommt dann

    Code
    1. --------------CA6C9DF86C6DE54E8B2B00AFContent-Type: image/jpeg; name="mail-signatur.jpg"Content-Transfer-Encoding: base64Content-ID:
    2. Content-Disposition: inline;
    3. filename="mail-signatur.jpg"
    4. /9j/4AAQSkZJRgABAQEASABIAAD/4QD2RXhpZgAATU0AKgAAAAgABwESAAMAAAABAAEAAAEa
    5. AAUAAAABAAAAYgEbAAUAAAABAAAAagEoAAMAAAABAAIAAAExAAIAAAAeAAAAcgEyAAIAAAAU
    6. AAAAkIdpAAQAAAABAAAApAAAAAAAAABIAAAAAQAAAEgAAAABQWRvYmUgUGhvdG9zaG9wIENT
    7. NSBNYWNpbnRvc2gAMjAxNoiafd8OU78879861OjEyOjMxIDEzOjU5OjM2AP/h
    8. EedodHRwOi8vbnMuYWRvYmUuY29tL3hhcC8xLjAvADw/eHBhY2tldCBiZWdpbj0i77u/IiBpZD0iVzVNME1wQ2VoaUh6cmVTek5U…

    Meiner Meinung nach hängt dass damit zusammen, dass solche automatische Antworten sich irgendwie nicht mit der Thunderbird-Einstellung mail.compose.attach_http_images versteht, bzw. diese "lokal" gespeicherten Bilder nicht richtig gesendet werden.

    Wie würden Sie das sehen?


    Gruß

    dapr

    Einmal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Hallo,

    das ganze ist recht schwierig für mich nachzustellen.

    Da diese Funktion ja neu ist, kann ich mir gut vorstellen, dass sie noch nicht perfekt funktioniert. Ich würde an deiner Stelle bei Https://bugzilla.mozilla.org/ Bugreport erstellen. Da dein Vorgehen recht selten ist, glaube ich kaum, dass so ein Fehler - wenn überhaupt - schon entdeckt worden ist.

    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw