Nach Übertragen des Profils von Win 7 auf Win 10 startet Thunderbird 68 mit leerem Fenster

  • Ich habe jetzt die Datei addonStartup.json.lz4 im Profil als die schuldige bei Molder heraus gefunden.

    Nochmals: welchen Profilordner meinst du? Den in Local oder den in Roaming?

    Das müsst noch klargestellt werden, denn wenn hier im Forum vom Profilordner (ohne nähere Erklärung) die Rede ist, meint man immer den in Roaming....

  • welchen Profilordner meinst du? Den in Local oder den in Roaming?

    Ich rede vom "echten" Profil, welches im Regelfall unter %appdata% in Roaming zu finden ist - also dort, wo wirklich die Daten und Einstellungen des Benutzer gespeichert sind. Alles was ich gerade (auch mit Cache-Ordnern) gesagt hatte, befindet sich wirklich im "echten" Profilordner.

  • Meinst du damit ein Sprachpaket (z. B. langpack-en-US@thunderbird.mozilla.org.xpi)? Und falls ja, um welche Sprache handelt es sich?

    Ich meinte (mit falschem Ausdruck ;) ) genau das, was Du hier nennst, nur eben die deutsche Sprache. Stellt sich die Frage, was Molder für eine Sprachversion des Thunderbird installiert hat (ob es en-US statt de-DE ist)? Das dürfte aber letztlich keine Rolle spielen.


    Dieser liegt bei mir nicht im "normalen" Profilordner, sondern im Cache von Thunderbird (bei Windows dürfte es sich um den Ordner ...\AppData\Local\Thunderbird\Profiles\xxxxxxxxx.default\ handeln) :

    Bei mir unter Win 10 Pro 64-Bit liegt der Ordner (wie bereits gesagt) im "echten" Profilordner und nicht in dem üblichen verdächtigen Cache-Ordner, dessen Pfad Du hier gezeigt hast.

  • Ich rede vom "echten" Profil, welches im Regelfall unter %appdata% in Roaming zu finden ist - also dort, wo wirklich die Daten und Einstellungen des Benutzer gespeichert sind.

    Das habe ich jetzt auch gesehen, wenn du von der Datei addonStartup.json.lz4 sprichst. Die liegt im echten Profilordner.

    Alles was ich gerade (auch mit Cache-Ordnern) gesagt hatte, befindet sich wirklich im "echten" Profilordner.

    Das verstehe ich nicht. Der Ordner startupCache befindet sich bei mir im Cache und nicht im echten Profilordner, wie in meinem Screenshot sichtbar. Kannst du einen Screenshot mit dem Ordner startupCache machen?

  • Kannst du einen Screenshot mit dem Ordner startupCache machen?

    Du könntest mir zwar auch so glauben, aber hier ist er aus dem "defekten" Profil von Molder nachdem ich das Profil bei mir gestartet habe.:



    In meinen sämtlichen Profilen ist es genauso (60er, 68er, Beta 71, Daily, ...) - und unter /local/ habe ich diesen "startupCache"-Ordner gar nicht.

  • Hallo Zusammen,


    bin wieder da. Da habe ich wohl in ein Wespennest gestochen?

    Ich habe zwar alles gelesen, aber nicht alles verstandenX(

    Der aktuelle Stand bei mir ist das ich TB neu gemacht habe und weiter nichts. Kein Konto angelegt und kein Profil importiert.

    Für eine Schritt-für-Schritt Anweisung wäre ich sehr dankbar.


    Vielen Dank an alle die mit geholfen haben!

  • Für eine Schritt-für-Schritt Anweisung wäre ich sehr dankbar.

    Öffne in Windows den Ordner Deines alten Profils und lösche dort die Datei addonStartup.json.lz4. Anschließend öffnest Du mit dem Profil-Manager Thudnerbird mit diesem alten Profil und kannst hoffentlich einfach damit weiter arbeiten. Falls Du gefragt wirst, ob Du das Sprachpaket installieren willst, dann verneinst Du diese Nachfrage.

  • Stellt sich die Frage, was Molder für eine Sprachversion des Thunderbird installiert hat (ob es en-US statt de-DE ist)?

    Da ich seit Jahren die englischen und deutschen Sprachpakete in den französischen Versionen von TB benutze, ist es mir häufiger passiert, dass nach einem Update ( z. B. von TB 52 nach TB 60) meine Sprachpakete nicht mehr kompatibel waren. Wenn ich sie dann nicht vor dem Update deaktiviert oder entfernt hatte, stürzte TB bei jedem Start ab, nachdem er mir ganz kurz ein kleines Fenster mit einem roten Text angezeigt hatte. Ich habe das dann so bereinigt, dass ich TB im safe mode gestartet habe und die *.xpi Sprachpakete gelôscht habe. Danach konnte ich TB normal starten.


    Das dürfte aber jetzt nicht mehr auftreten, denn soweit ich verstanden habe, werden die Sprachpakete inzwischen automatisch aktualisiert. Ich habe z. B. derzeit die Sprachpakete de.xpi und en-US.xpi für TB 68.0 und die müssten mit allen TB 68.x.x Versionen funktionieren.

  • Die Datei ist gelöscht. Wenn ich den Profilmanager aufrufen will muß ich doch TB starten?

    Habe ich gemacht und wieder das kleine Fenster kurz gesehen. Also wie vorher.

  • Das dürfte aber jetzt nicht mehr auftreten, denn soweit ich verstanden habe, werden die Sprachpakete inzwischen automatisch aktualisiert.

    Mhhh, da kommt aber der unlösbare Bug (vielen Dank ans Firefox-Team) in die Quere. Thunderbird kann nämlich seit dem 68er erst nach dem Start bzw. beim nächsten Programm-Start die Add-ons aktualisieren. Wenn er davor womöglich schon versagt, dann wird's schwierig. Ich kann die Tragweite aber noch nicht richtig einschätzen: https://bugzilla.mozilla.org/show_bug.cgi?id=1574183 Vielleicht führt es aber auch nur zu vorübergehend/kurzzeitig deaktivierten Add-ons.

  • Habe ich gemacht und wieder das kleine Fenster kurz gesehen. Also wie vorher.

    Dann lösche bitte im Profil sowohl den Ordner "startupCache" und die zuvor genannte Datei, falls beides vorhanden ist.

  • In den Einstellungen -Sprachen- von Win10 sind bei mir außer deutsch noch englisch UK und englisch US aufgeführt. Nur mal so weil ihr euch über Sprachpakete ausgetauscht habt.

  • Du könntest mir zwar auch so glauben, aber hier ist er aus dem "defekten" Profil von Molder nachdem ich das Profil bei mir gestartet habe.:

    Als du schriebst, du hâttest den startupCache Ordner aus dem Profil entfernt, hatte ich das so verstanden, dass ganz allgemein unter Windows sich dieser Ordner im echten Profilordner befindet. Ich habe erst jetzt mitbekommen, dass er sich in Molders Profilordner befand, wo er nicht hin gehört. Wie er dort hinein geraten ist, ist mir allerdings schleierhaft. War das nun die Ursache für das Problem beim Start? Der Faden ist inzwischen so unübersichtlich, dass ich Schwierigkeiten habe, die entscheidende Maßnahme zur Bereinigung des Profils zu erkennen.

  • Sprachpakete

    Es geht um ein Sprachpaket als Add-on innerhalb von Thunderbird. Das ist in Deinem (einen) Thunderbird-Profil installiert gewesen (wenn auch vielleicht deaktiviert).


    Weder der Ordner noch die Datei ist im Profilordner.

    Dann schau bitte bei Dir mal in dem Pfad mit \Local\ , den Mapenzi gezeigt hat, ob dort der Ordner "startupCache" drin ist: ...\AppData\Local\Thunderbird\Profiles\xxxxxxxxx.default\


    Beachte, dass dies im Grunde versteckte Ordner dort sind.

  • Ich habe im Profil- Manager 2 Profile: default-release und default

    Wenn ich default einstelle dann startet TB normal leer ohne Konten

    Wenn ich default-release nehme kommt wieder das kleine Fenster

  • Ich habe erst jetzt mitbekommen, dass er sich in Molders Profilordner befand, wo er nicht hin gehört. Wie er dort hinein geraten ist, ist mir allerdings schleierhaft.

    Falsch verstanden. Ich hatte dies ja direkt einen Beitrag weiter genauer beschrieben, dass der Ordner bei mir erst erstellt wurde, dann aber dennoch eine Absturz-Ursache ist, wenn man vorher nicht die genannte Datei entfernt hatte. Die Datei erzeugt also etwas in dem Ordner, was zum Absturz führt.

  • Wenn ich default einstelle dann startet TB normal leer ohne Konten

    Wenn ich default-release nehme kommt wieder das kleine Fenster

    "default" ist auch leer. Dort sind keine Konten definiert. Das hatte ich oben auch beschrieben.

    "default-release" ist der Ordner in dem circa 11 POP-Konten drin sind und mit dem ich dann alle Tests weiter gemacht habe. Mit diesem Ordner sollst Du "alles" machen. Dort musst Du bspw. die genannte Datei löschen.

  • Wow, geht! In dem -lokal- Ordner waren 9 Profilordner mit 6 -default-releare- Ordnern.

    Alle gelöscht und nun geht's.

    Vielen Dank noch mal, hoffentlich geht's morgen noch.

    Im -lokal- Ordner brauche ich doch nur das Verzeichnis das auch in -roaming- ist. Die anderen kann ich doch löschen?