[TIPP] Automatisches Backup und Restore per Batch - mit 7Zip

  • Wenn man nur die 7z.exe hat hilft einem das wenig, aber habe nun das komplette Paket heruntergeladen :P.


    Dia

  • Quote from "Diapolo"

    Wenn man nur die 7z.exe hat hilft einem das wenig, aber habe nun das komplette Paket heruntergeladen :P.

    Das stimmt. Aber es sollte auch nur ein Tipp sein, wo es auf jeden Fall eine gute Hilfe gibt. Auf der HP habe ich auf der schnell nämlich nichts gefunden.


    Gruß,
    Robert

  • Erst mal hallo und schon mal vorab vielen Dank fuer die Antwort.
    Ich arbeite staendig mit zwei Computern - einen hier zu Hause, einen zweiten im Buero. Nun wuerde ich gernde meine emails staendig auf beiden Compus aktuell haben mit allen Antworten usw.


    Ein Problem bei dieser Batch: Mein Compu zu Hause ist in Deutsch, der im Buero in Spanisch, d.h. die Pfade lauten total anders. Auch ist der Username im Buero anders als bei mir zu Hause. Ich steh vollkommen auf dem Schlauch.


    Wie krieg ich denn das hin??? Und zwar moeglichst einfach - bin naemlich KEIN Computerfreak, KEIN Programmierer, sondern einfach nur e-mail-Beantworter.


    Sonnige Gruesse aus der Dominikanischen Republik und Danke fuer Hilfe

  • Überschreibe auf deinen Sicherungsmedium (USB-Stick?) die "spanischen" Dateien Profilpfad.txt und Installationsverzeichnis.txt mit denen deines "deutschen" Rechners - dann daddelt das "spanische" Backup über das "deutsche", weil ja in den beiden Dateien nun die Pfade stimmen.

  • Hallo,


    habe den Patch ausgeführt und soweit auch alles gesichert bekommen. Wenn ich jetzt jedoch versuche den ganzen Kram auf meinem Laptop - auf dem Windows Xp Home läuft - wieder mit restore zu entpacken bekomme ich
    error messages. Fehler: Kein instalationspfad gefunden.


    Folgende Dateinen oder ordner sind in meinem Backupverzeichnis:


    02.08.2006
    Mi
    7z
    about.txt
    Profilverzeichnis
    Programmverzeichnis
    restore
    restore
    Thunderbird_backup


    vielleicht fehlt ja irgendwas ??? Was auch ein Problem sein könnte:
    Ich habe in meinem Xp keinen Pfad wie hier im forum beschrieben


    C:\Dokumente und Einstellungen\DEIN_Windows_Username\Anwendungsdaten\Thunderbird


    bei mir gibts nur


    C:\Dokumente und Einstellungen\DEIN_Windows_Username\Application data


    und keinen Thudnerbird ordner, obwohl installiert. Wäre wirklich für jede Hilfe dankbar.


    grüsse
    kenyada[/img]

  • Deine Sicherung sieht bereits falsch aus - welche Batchversion genutzt auf welchem Betriebssystem?

  • die neueste Batch Version....von deiner Homepage und Windows 2000 professional.

  • Hallo,


    ich bin begeistert von dem kleinen Script :)


    Meine Frage:


    Ich nutze auf meinem Server IMAP (alle Mails werden auf dem Server gespeichert) - wenn ich nun per Script meine Thunderbirdeinstellung backupe, werden dann die E-Mails mit ins zip-Archiv gepackt oder im Falle von imap nicht?


    Danke

  • was könnte denn dann schiefgelaufen sein. das gibts doch wohl nicht.
    hab alles wie beschrieben ausgeführt und bekomm andere files.

  • schon einmal überprüft, wo dein profil unter win2000 liegt?

  • das thunderbird wird ja eigentlich gefunden. .....sonst wär die profildatei auch nicht 900mb gross oder?

  • Wenn in der Batch laut meinen Informationen die Pfade richtig angepasst werden, dann dürfte eigentlich nichts schiefgehen. In Ermangelung an Windows 2000 kann ich es leider nicht testen.


    Hat hier jemand mit Windows 2000 Probleme?

  • Hi!


    Ich finde das Ding klasse. Nur funktionierts leider bei mir nicht! Ich hab TB auf einem U3-USB-Stick, daher die seltsamen Pfade. Seh ich das richtig, dass das Installationsverzeichnis der Ordner ist, in dem die thunderbird.exe liegt und das Profilverzeichnis, der Ordner ist, in dem z.B. virtualFolders.dat liegt?


    Ich versteh auch nicht ganz, warum das Ding 7z.exe nicht findet!


    Ich muss die Batchdatei doch nicht in das Installationsverzeichnis von TB kopieren oder? Sonst noch ne Idee?


    Was rauskommt seht ihr unten.


    Danke, Julius


  • Gibts irgendne Software, die U3 emuliert, damit ich das mal testen kann?

  • Nicht das ich wüsste!
    Eigentlich wird der U3-Stick ja als normales Laufwerk erkannt, daher dürften doch durch U3 keine besonderen Probleme entstehen, oder?


    Meine Pfadangaben:

    Code
    1. ::---------------PFADE ANGEBEN-----------------------
    2. ::Thunderbird Installationsverzeichnis
    3. set SOURCE_DIR="K:\System\Apps\FEFECB84-0E05-42d8-B044-F2D0FCFF8C15\Exec\thunderbird\"
    4. :: Thunderbird Profilverzeichnis
    5. set SOURCE_MAIL_DIR="K:\System\Apps\FEFECB84-0E05-42d8-B044-F2D0FCFF8C15\Data\profile\"
    6. :: Wo sollen die gesicherten Daten abgelegt werden?
    7. set TARGET_DIR="E:\Sicherungen\Thunderbird\"
    8. ::---------------PFADE ANGEBEN ENDE------------------


    müsste doch so gehen, oder?


    Julius

  • Welche Dateien meinst du denn? Die zu deiner Batch-Datei gehören? Ich habe alle Dateien an einen Platz entpackt. Müssen die Dateien im TB-Ordner liegen?


    Hab ich jetzt was falsch verstanden?
    Julius

  • In meiner Batch überprüfe ich die richtige Angabe der von euch eingetragenen Pfade:
    :: Thunderbird Installationsverzeichnis korrekt?
    if not exist %SOURCE_DIR%\thunderbird.exe goto nothunderbird
    :: Thunderbird Profilverzeichnis korrekt?
    if NOT exist %SOURCE_MAIL_DIR%\profiles.ini goto noprofil
    Liegen diese Dateien in deinen Pfaden?