explorer-Verknüpfung mit *.eml

  • Hallo Leute


    Wie bring ich Thunderbird bei bei einem Doppelklick auf eine *.eml-Datei diese Datei anzuzeigen?


    Wenn TB bereits läuft passiert garnichts, und wenn TB nicht läuft wird er zwar gestartet - dann kommt die Profilabfrage , und dann erscheint eine Warnmeldung "e ist kein registriertes Protokoll" wobei "e" meinWindows-Laufwerk ist. Kollege bekommt d3 meldung mit "c ist kein ..."?!
    Wenn man die Meldung mit dem einzigen Knopf [OK] weg klickt sehe ich TB normal ohne das er mir den Inhalt des Eingangsordners anzeigt.


    WinXP/Win2K
    TB1.5.07 Cyrus Imapserver im Lan unter Linux


    Bin ich zu blöd?


    Wir brauchen die Funktion um E-Mails aus einem DMS-System anzuzeigen.


    Danke und viel Gruesse
    Leiner

    Einmal editiert, zuletzt von leiner ()

  • So ich schon wieder


    So hartnäckige Tests haben ergeben das die Mail-Dokumente aus dem DMS als "*.EML".


    Wenn ich nun das EML nach eml umbenene klappt das öffnen und die Mail wird angezeigt.


    Giebts da eine Schraube an der ich TB beibrigen kann das *.EML auch nur Anzeigen soll.


    -- hatte ich schon gesagt das ich EDV liebe , grrr ---


    Leiner

  • Einzige Lösung die ich bisher fand, Thunderbird schon Vorher offen haben.


    Wenn Thunderbird beim Doppelklick auf eine .eml datei bereits gestartet war, gehts reibungslos (Zumindest bei mir).
    :roll: Aber das kann doch keine Endlösung sein :roll:


    PS.: Bekomme bei mir sowohl bei ".eml" als auch bei ".EML" Dateien diesem Fehler.


    mfg.
    Kikinak

  • Hallo,
    ich kann mir nur vorstellen, dass euer TB nicht ordnungsgemäß als Standardmailklient definiert ist, da bei mir bei Doppelklick sowohl TB als auch das Mailfenster geöffnet wird.
    Kontrolliert zunächst, ob in TB unter Extras, Einstellungen, Allgmein, Standards bei E-Mail ein Haken steht.
    Falls ja kontrolliert unter Start, Ausführen, Programmzugriff und -standards, Benutzerdefiniert, Doppelpfeil anklicken, "E-Mailstandardprogramm" ob dort TB als Standard steht.
    Kontrolliert weiter in den Ordneroptionen, Dateitypen, ob es dort die Endung EML gibt. Falls ja, funkt ein anderes Programm etwa Outlook dazwischen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Bei mir funktioniert das so:


    Beim Klicken auf die *.eml-Datei im "explorer²" (viel besser als der Windows Explorer) öffnet sich der "explorer²"-interne Editor "editor²".


    Beim Rechtsklick auf auf die *.eml-Datei habe ich dann die Auswahl (bei mir ua Thunderbird, "editor²" und der normale Windows Editor, etc). Wenn ich dann auf TB klicke öffnet sich der TB mit diesem Text.


    Es ist also eine Frage, wie Du öffnest. Du hast ja auch die Möglichkeit in Windows festzulegen, mit welchem Programm Du Deine *.eml-Dateien öffnen willst.

    2 Mal editiert, zuletzt von Arran ()

  • Es gibt jedoch auch noch ein schnellerer Weg:


    Im TB: >> Datei öffnen >> Datei suchen und anklicken. Dann öffnet sich ein neues TB-Fenster. Wenn Du die Mail weiterleiten oder beantworten willst, klickst Du einfach auf den entsprechenden Knopf.


    Hat das geholfen?

  • Arran ,
    warum ist das bei mir anders als bei mir? Bei Doppelklick sollte sich der Standardklient öffnen, also TB.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:

    Arran ,
    warum ist das bei mir anders als bei mir? Bei Doppelklick sollte sich der Standardklient öffnen, also TB.
    Gruß


    Hallo mrb


    Das kann ich Dir auch nicht sagen, ich kenne Deine Maschine ja nicht ... :razz: :mrgreen: ::roll:


    Allerdings öffnet mein explorer alle Dateien in seinem Editor wenn ich auf diese klicke. Ist sehr praktisch, um schnell was zu lesen. Sonst gibts eben einen Rechtsklick und - sofern die Datei nicht verbunden ist - die Auswahl der zur Verfügung stehenden Programme. Eigentlich habe ich nur wenige Endungen mit Programmen verbunden, ich finde diesen Rechtsklick nicht unbedingt aufwendig.

  • Schön das dieses Thema doch nich nicht eingeschlaffen ist ...


    Also TB ist bei mir Standart-Mailclient. Wenn es sich um *.eml-Dateien (extension kleine buchstanben) handelt klappt es ja auch. Nur wenn EML in grossen Buchstanben verwendet wird kommt TB durch einander. Die Systemumgebung (WinXP/explorer) weiss schoin das es die Mail-Datein an TB übergeben soll, der Fokus wechselt zu TB!


    Habe mal zu Kontrolle den Mailclient von Tobit-Faxware als Standart Mailclient eingetragen -> funkt :(


    Problem ist nachwievor aus meiner sicht die unterschidliche behandlung duch TB bei gross/kleinschreibung der Extension.


    Guten Rutsch und dann ein Frohen Neues !!!
    Leiner

  • Wer oder Was schreibt denn "EML" statt "eml"?


    Und kanns man in XP nicht selber Datei-Endungen anlegen und mit einem Programm verknüpfen? Das wäre ja die beste Lösung für dich. Alerdings must Du das schon selbst herausfinden, dazu habe ich keine Lust.


    Da dieses Problem bisher offenbar noch nie aufgetaucht ist, scheint es mir auch nicht ein grosses, allgemeines Problem zu sein.

  • "Arran" schrieb:


    Da dieses Problem bisher offenbar noch nie aufgetaucht ist, scheint es mir auch nicht ein grosses, allgemeines Problem zu sein.


    Das würde ich nicht sagen.!
    Dieses Problem tritt bei Vielen auf, aber nur bei Leuten die .eml dateien nutzen. (ich denke mal ca. 20% alle TB-User)


    PS.:
    Thunderbird ist als Standard Mail-Client Eingerichtet.
    eml Dateien sind Ordnungsgemäß mit TB verknüpft.
    Problem besteht auch mit neuem Profil
    Thunderbird Version ist die Aktuellste ....


    Hab schon viel Probiert, und für mich handelt es sich hierbei um einen Bug.
    Wahrscheinlich auch schon in Bugzilla aufgelistet.


    EDIT: gefunden
    https://bugzilla.mozilla.org/show_bug.cgi?id=313457


    mfg. & Frohes Neues Jahr
    Kikinak

  • Kikinak ,
    also ich benutze gelegentlich *.eml und bei mir tritt der Fehler nicht auf.
    Das Kuriose dabei ist, mache ich TB zum Standard verschwindet die vorher unter Dateitypen eingetragene Endung EML (dort immer groß geschrieben) dort.
    Trotzdem öffnet TB korrekt bei Doppelklick die *.eml Datei.


    Allerdings erscheint auch bei mir die Meldung "c ist keine registriertes Protokoll", wenn TB geschlossen war. Weiter passiert aber auch nichts.
    Zugegeben, wer oft so verfährt, für den könnte es nervig sein.
    Der Fehler ist bei Bugzilla oft zu finden, also bekannt. Abhilfe:keine.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "Arran" schrieb:

    Wer oder Was schreibt denn "EML" statt "eml"?


    Und kanns man in XP nicht selber Datei-Endungen anlegen und mit einem Programm verknüpfen? Das wäre ja die beste Lösung für dich. Alerdings must Du das schon selbst herausfinden, dazu habe ich keine Lust.


    Da dieses Problem bisher offenbar noch nie aufgetaucht ist, scheint es mir auch nicht ein grosses, allgemeines Problem zu sein.


    Hallo Ihr da draussen


    Erstmal wünsch ich euch ein Frohes Neues


    zum Thema:


    Die "*.EML" werden von einem Dokumenten-Management-System erzeugt wenn man eine gespeicherte E-Mail wieder aus dem Archiv zieht :(.
    Das Systemhaus lässt beim Softwarehaus prüfen ob es ein schnelle Möglichkeit giebt in der Software einzustellen das die Daten mit kleinen Buchstaben ausgegeben werden. Aber das ist ja nur der Zweitbeste weg - wenn es überhaupt klappt.


    Es ist ja schon so das TB sich für die *:EML-Datei zuständig fühlt -der Fokus wechselt zu TB bei einem Doppelklick auf eine *.EML bzw wenn TB noch nicht läuft wied es gestartet zeigt dann aber ein Fenstern mit einer Sinnlosen Warnung die man nur wegklicken kann.
    Von daher nütz mir eine weitere Verknüpfung im Windows leider nicht


    Nochmal das Problem tritt nur auf wenn die Eweiterung (eml) grosse Buchstaben verwendet.


    So weit erstmal


    Leiner