Nach Neuinstallation werden Mails in TB2006 nicht angezeigt

  • Hallo Board,


    ich hoffe Ihr könnt mir helfen. :?:


    Ich habe auf meinem PC eine Neuinstalltion von WinXP Prof. durchgeführt und vorher den Ordner Thunderbird in C:\Dok..\Benuter..\Anwendungsdaten\Thunderbird auf eine externe Festplatte gesichert. 8) 
    Nach der Neuinstallation habe ich den Ordner wieder an die richtige Stelle zurückkopiert und dann TB installiert.


    Nun mein Problem alle Mails sind nicht mehr sichtbar obwohl die Inbox-Datei im Explorer > 250MB anzeigt. :?


    Hat irgendjemand dieses Problem auch gehabt und wie kann ich es lösen.
    Neue Mails werden heruntergeladen und angeeigt. :(


    Für eure Hilfe schon mal im vorraus vielen Dank.


    Spradel

  • Moin,


    Thunderbird erkennt nach einer Neuinstallation keine kopierten Profile. TB legt nach der Neuinstallation ein neues Profil an, das eventuell auch anders heißt, als das Bisherige.
    Am besten den Profilmanager starten und auf das "alte" Profil verweisen oder den Inhalt der Kopie in das neue Profilverzeichnis kopieren.

  • Hi!


    "lbm1305" schrieb:

    Thunderbird erkennt nach einer Neuinstallation keine kopierten Profile.


    Seit wann das denn nicht? Nee nee lbm1305, Spradel hat das schon ganz richtig gemacht.


    Spradel, ich gehe davon aus, dass du beim Zurückkopieren des gesicherten Profilverzeichnisses vor der Neuinstallation von Thunderbird wirklich die richtige Stelle getroffen hast und dass in TB die Ansicht auf "Alle" steht. Hast du es denn schon mit einer Wiederherstellung der Indexdatei versucht ("Rechtsklick auf den Posteingangsordner >> Eigenschaften >> Index wiederherstellen")? Für andere Ordner, in denen Mails nicht angezeigt werden, gilt Entsprechendes.


    Gruß, Sünndogskind_2

  • Wie?


    Wenn ich nach einer Neuinstallation des Betriebssystems das gesicherte Profil kopiere und TB installiere, findet das Prgramm das Profilverzeichnis?

  • "lbm1305" schrieb:

    Wie?


    Wenn ich nach einer Neuinstallation des Betriebssystems das gesicherte Profil kopiere und TB installiere, findet das Prgramm das Profilverzeichnis?


    Er hat nicht nur das Profil gesichert, sondern richtigerweise:

    "Spradel" schrieb:

    Ordner Thunderbird in C:\Dok..\Benuter..\Anwendungsdaten\Thunderbird auf eine externe Festplatte gesichert. 8)


    Zur Lösung des eigentlichen Problems sollte der Tipp von Sünndogskind_2 daher helfen.

  • Und TB erstellt das "neue" Profilverzeichnis mit dem gleichen Namen wie vor der Neuinstallation? Ich dachte, die haben so verwirrende Namen :-)

  • "lbm1305" schrieb:

    Und TB erstellt das "neue" Profilverzeichnis mit dem gleichen Namen wie vor der Neuinstallation?


    Nein, TB erstellt kein neues Profilverzeichnis, sondern verwendet ganz normal das angemeldete Profilverzeichnis, das hineinkopiert wurde. Warum sollte auch etwas anderes passieren?

  • Entweder verstehe ich was nicht.
    Wenn ich ein BS neu aufsetze, das gesicherte Profil wieder ins neue System zurück kopiere, dann TB installiere und starte, nimmt er das gesicherte zurück kopierte Profil?


    Wenn ich mein Profil zurück kopiere und TB neu gestartet habe, dann ist bzw. war TB jungfräulich, wie es nach dem ersten Start immer ist. Ich muss dazu sagen, mein Profil liegt auf einer anderen Partition und liegt nicht im Standardverzeichnis, da wo TB sonst das Profil erstellt.

  • C:\Dokumente und Einstellungen\meine\Anwendungsdaten\Thunderbird\Profiles\zy1p1r47.default\


    Das ist doch z.B. ein Profilpfad, den TB anlegt, wenn es das erste Mal gestartet wird? Oder liege ich da falsch?
    Und wenn ich nach einer Neuinstallation TB wieder installiere und starte, ist dann der Pfad der gleiche?


    Woher weiß der frisch installierte Thunderbird denn, wo er die Profiles.ini findet?

  • "lbm1305" schrieb:

    Woher weiß der frisch installierte Thunderbird denn, wo er die Profiles.ini findet?


    Die liegt immer an derselben Stelle.

  • Jepp! :) 
    Die Datei "profiles.ini" sucht TB immer am Standardort für das Profilverzeichnis (siehe"Das Profil-Verzeichnis finden"). Genau dort muss diese Datei also auch sein und ihr entnimmt TB dann, wo der Rest der Profildaten zu finden ist. Anders kann die Sache nicht klappen.

  • wahrscheinlich hat Spradel genau diese Datei aber nicht mit kopiert... wobei das eigentlich nicht sein kann


    "Spradel" schrieb:

    C:\Dok..\Benuter..\Anwendungsdaten\Thunderbird auf eine externe Festplatte gesichert. Cool
    Nach der Neuinstallation habe ich den Ordner wieder an die richtige Stelle zurückkopiert und dann TB installiert.


    wenn er also ab Thunderbird kopiert und auch wieder zurück gespielt hat, sollte TB das alte Profil anstandslos übernehmen. Also entweder ist es nicht genau da wo das alte Profil war oder die Profiles.ini wurde nicht mitkopiert.
    Man kann das ja auch so machen... Erst installieren einmal kurz starten und dann gleich TB wieder schließen. Danach das angelegte Profil im Explorer löschen und das gesicherte Profil in das .\Profiles - Verzeichnis kopieren. Danach muss man nur in der Profiles.ini die Path-Zeile leicht anpassen und gut ist... So hab ich das gemacht da ich einige Bastel-Profile hatte(die ich nicht mehr brauchte) und diese Methode mir schneller erschien, als aus meinem Backup die Profiles.ini heraus zu suchen.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Das TB auf die Profiles.ini zugreift ist mir schon klar. Da ich aber von Haus aus das Profil nicht dort anlege, wo TB es standardmäßig hinschreibt, nämlich auf C:\, war mir nur der Punkt mit dem Namen des Verzeichnisses nicht klar. Hier, ob TB bei einer Neuinstallation (nach einem Format C:\ ) den gleichen Namen für das Profil verwendet.
    Denn wenn TB ein neues Profil mit einem anderen Namen und damit auch eine neue profiles.ini anlrgt, kann er lange nach dem zweite kopierten Profil suchen.

  • daher sollte man die Profiles.ini beim Backup und Restore ja auch immer mitkopieren. Wenn der Laufwerksbuchstabe in deinem Fall der gleiche bleibt wird das Profil ja über die Profiles.ini gefunden. Und wenn schon ein Profil in der Profiles.ini drin steht wird auch keins angelegt.


    da sich bei mehreren Laufwerken die Laufwerksbezeichnungen nach einer Neuinstallation auch mal ändern können, sollte man in diesem Fall lieber noch mal nachgucken(in der Profiles.ini) - andernfalls kommt die irreführende Fehlermeldung das Thunderbird bereits läuft. :roll:


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo zusammen,


    der Lösungsvorschlag von Sünndogskind_2 hat die Mail wieder erscheinen lassen. :D


    Vielen Dank für eure Hilfe.


    Gruß
    Spradel