signatur wird mitgequotet. soll aber nicht.

Am 24.09.2018, werden in der Zeit zwischen 21:00 Uhr und 09:00 Uhr des folgenden Tages Wartungsarbeiten am Server durchgeführt. Daher wird die Webseite in dieser Zeit nur eingeschränkt erreichbar sein.
  • hallo,
    eine eigentlich einfache sache:


    ich möchte, das die signatur einer mail (ordentlich getrennt vom mailtext mit --) nicht bei einem reply gequotet wird.


    wie/wo stelle ich das sein? welche plugins brauche ich? wie bekomme ich diesen wunsch erfüllt?


    grüße,
    thunderpopander


    p.s.
    ein beispiel:


    alte mail:

    Code
    1. [...]
    2. dann machs mal jut,
    3. thunderpopander
    4. --
    5. tolle signatur


    wird zu

    Code
    1. >[...]
    2. >dann machs mal jut,
    3. >thunderpopander
    4. >--
    5. >tolle signatur


    soll aber:

    Code
    1. >[...]
    2. >dann machs mal jut,
    3. >thunderpopander
  • Hi,


    du schreibst: (ordentlich getrennt vom mailtext mit --)
    hast du auch an das Leerzeichen hinter den beiden Strichen gedacht? Also: "-- "


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • "Peter_Lehmann" schrieb:

    hast du auch an das Leerzeichen hinter den beiden Strichen gedacht? Also: "-- "


    ja.
    funktioniert das etwa bei dir?

  • Bei mir funktioniert das eigentlich immer, es sei denn, es gibt aus irgendeinem Grund 2 Sigtrenner, wie z. B. bei Mailinglisten manchmal, dann wird der letzte azeptiert und der vorhergehende ignoriert.

  • "Rothaut" schrieb:

    Bei mir funktioniert das eigentlich immer, es sei denn, es gibt aus irgendeinem Grund 2 Sigtrenner, wie z. B. bei Mailinglisten manchmal, dann wird der letzte azeptiert und der vorhergehende ignoriert.


    bei mir fast nie :-)
    aber es ist wirklich zeitintensiv herauszufinden, wieso, bzw. an welchen mails es liegt.


    ich habe bisher herausgefunden, das, wenn leute mir über yahoo-webmail antworten und irgendetwas unter meine signatur schreiben (ihre signatur z.b, aber ohne "-- ") meine signatur in tb nicht gestripped wird.
    die mail, die dann bei mir ankommt sieht dann etwa so aus:



    wobei die zeile "Tel.: 1234/12345678" nicht zu meiner signatur gehört, sondern vom sender angehängt wurde (evtl. yahoo-webmail, nehme ich an)


    wenn ich also nun auf reply klicke, wird die signatur mitgequotet, obwohl die immer noch sauber mit "-- " beginnt und somit von tb erkannt werden müsste.


    es muss wohl auch damit zusammenhängen, ob in der mail schon mal gequotet wurde oder nicht, und wenn ja, wie oft und wie tief.


    ich habs bis dato nocht wirklich reproduzierbar machen können.


    es ist zum mäuse melken :-)

  • Thunderpopander schrieb:
    blafaselsülz
    --
    toller aphorismus.
    (irgendwas in klammern)
    Tel.: 1234/12345678
    wobei die zeile "Tel.: 1234/12345678" nicht zu meiner signatur gehört,


    Hmm, ich sehe bei Deinem Beispiel im Signaturtrenner nach den beiden Bindestrichen kein Leerzeichen. Ich glaube nicht, dass mein Screenreader mir das vorenthält, weil er zeigt es sonst immer brav an bei Sigtrennern.
    Aber allerdings habe ich schon erlebt, dass Webmailer oder Outlook Express die Sigtrenner gern verstümmeln.
    Möglicherweise sind es bestimmte Webmailer oder eben mit OE geschriebene Mails, die Deinen Sigtrenner beleidigen.
    In einer Zeit, da ich sehr viel mit Webmail arbeiten musste, habe ich ihn immer von Hand gesetzt, das half manchmal, dass er korrekt blieb.

  • "Rothaut" schrieb:

    Hmm, ich sehe bei Deinem Beispiel im Signaturtrenner nach den beiden Bindestrichen kein Leerzeichen. Ich glaube nicht, dass mein Screenreader mir das vorenthält, weil er zeigt es sonst immer brav an bei Sigtrennern.


    nein, der signaturtrenner ist ok.
    in meinem vorherigem posting ist er gesetzt und auch in jeder mail, die probleme machte, war er korrekt. (zwei striche, ein leerzeichen. absatz.) das ist das einzige, was ich bis dato nachvollziehen konnte :-)
    von hand ist leider keine option für mich :-) dann kann ich ja auch briefe auf papier schreiben.

  • Hab es nicht ganz verstanden, aber vielleicht passt das trotzdem:


    Wenn du in Thunderbird beim Antworten deine Antwort über dem zitierten Text schreibst und deine Signatur unter deiner Antwort, aber ebenfalls über dem zitierten Text schreibst - dann wird bei nochmaliger Antwort die Signatur und alles darunter nicht abgeschnitten. Das wäre fatal, netterweise denkt Thunderbird mit. Daher fehlt in diesem Fall das Leerzeichen hinter den beiden Abtrennstrichen.


    Alles aus Erinnerung niedergeschrieben ;).

  • "allblue" schrieb:

    Alles aus Erinnerung niedergeschrieben ;).


    danke für die idee. meine einstellung "start my reply above the quote" ist bei allen konten gesetzt und auch so nach meinem wunsch :-) es muss also mit den mails an sich, also dem body der mails zu tun haben.

  • thunderpopander
    am 13. Dez 2007, 16:20
    Rothaut hat geschrieben:
    Hmm, ich sehe bei Deinem Beispiel im Signaturtrenner nach den beiden Bindestrichen
    kein Leerzeichen. Ich glaube nicht, dass mein Screenreader mir das vorenthält, weil
    er zeigt es sonst immer brav an bei Sigtrennern.
    nein, der signaturtrenner ist ok.
    in meinem vorherigem posting ist er gesetzt und auch in jeder mail, die probleme
    machte, war er korrekt. (zwei striche, ein leerzeichen. absatz.) das ist das einzige,
    was ich bis dato nachvollziehen konnte :-)


    Öhm sorry, Da bin ich wieder ordentlich auf die Nase gefallen. Für mich wird das nämlich erst korrekt angezeigt, wenn ich den Link "alles auswählen" nehme, mit STRG C in die Zwischenablage kopiere und mit STRG v in den Editor, dann konnt auch das Leerzeichen und er Absatz zum Vorschein, aber da muss halt auch erst mal draufgekommen werden, ich hatte das bis jetzt noch nie :-(


    Aber an Diskussionen in einigen Mailinglisten, dass Outlook Express beim Antworten Signaturtrenner verstümmelt
    erinnere ich mich recht gut.


    Nochmal sorry, vielleicht sollte ich das Greenhorn in der Signatur rot unterstreichen, wenn ich es könnte *grummel*.