signatur erstellen mit eingebundener grafik

  • hallo wissende,


    ich habe meinen rechner neu aufgesetzt, alles neu installiert, arbeitsweisen verändert etc. pp. mein tb-profil habe ich erfolgreich eingebunden.


    nun funktionieren meine signaturen nicht mehr. der text der signature wird ordnungsgemäß angezeigt, jedoch das als verlinkte grafik eingebundene logo wird nicht mehr angezeigt. (jaaa, ich weiß, über das verfahren kann man streiten ;)... )


    ehemals habe ich die signatur mit dem alten mozilla composer erstellt, aber nun ist mozilla nicht mehr installiert. gibt es eine alternative? das add-on signature funktioniert nicht.


    danke!
    grüße von jacqueline

  • hallo graba,


    weil das programm "signature" wie ein editor verfährt, d. h. keine grafische schrift zulässt und keine grafik einbinden kann. und ich möchte halt gerne mein logo als wiedererkennung in der signatur haben.


    danke für die links, guck ich mir gleich mal an....

  • Zitat

    ehemals habe ich die signatur mit dem alten mozilla composer erstellt, aber nun ist mozilla nicht mehr installiert. gibt es eine alternative?


    Ja, die Signatur in TB selbst erstellen und dann als *.html abspeichern. Dazu braucht man kein Add-on.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • daaanke! hat funktioniert. :)


    ich hatte bisher eine email noch nie als datei gespeichert geschweige denn ausprobiert, was sich hinter dieser option verbirgt.... jetzt weiß ichs. man lernt halt nie aus ;)


    grüße jacqueline

  • haaalt, nein, zu früh gefreut! :|


    es funktioniert, wenn ich eine email neu schreibe, aber nicht, wenn ich auf eine email antworte. ??? was nun?

  • hallo wolf,
    habe mich durchgewühlt. die anweisungen im 2. thread habe ich überprüft: eingebunden ist jeweils angestellt und ebenso auch html-nachricht.


    habe die neueste 2.0.0.12 version und mit meinen alten signaturen lief alles ganz wunderbar.


    die in die signatur eingebundene grafik ist da wenn ich eine email neu schreibe, verschwindet, wenn ich auf eine email antworte oder diese abgespeichert wird in entwürfe. auch wenn ich im offenen "email-verfassen-fenster" zwischen den konten hin- und hergehe, erscheint bei dem entsprechenden konto auch die grafik.


    was nun?

  • Hallo,
    war nicht gerade genial, deine Frage in 2 Threads loszuwerden.
    Manchmal antworte ich dann gar nicht mehr.
    Hier noch mal meine Frage aus dem anderen Thread:


    ich muss da mal etwas nachfassen:
    Die Grafik ist zusammen mit einem Text? Falls ja, der wird auch nicht angezeigt?
    Die Trennzeichen für die Signatur also die beiden Minuszeichen und ein Leerzeichen direkt danach, sind vorhanden oder wurden sie gelöscht?
    Wann genau verschwindet sie, schon im Versendefenster?
    Welche Einstellung hast du unter Extras, Einstellungen, Verfassen, Allgemein, Sendeoptionen? Dort sind 4 Optionen.
    Alle deine Konten sind auf HTML gestellt?
    Die HTML-Mail wurde von welchem Mailklienten erstellt?
    Ein Ausschnitt des Quelltextes (strg+U) bis zum Beginn des kodierten Teils, wäre nicht schlecht. Privates unkenntlich machen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • hallo mrb,


    bitte entschuldige das doppelposting, aber aus meiner sicht hatte sich die problemlage geändert, weshalb ich dachte, das sei sinnvoll.


    Zitat

    Die Grafik ist zusammen mit einem Text? Falls ja, der wird auch nicht angezeigt?


    nein, der text wurde ordnungsgemäß angezeigt, für das logo ein platzhalter. besonders strange war, dass das logo bei mir im verfassen-modus ordnungsgemäß angezeigt wurde, sobald jedoch die email abgesendet war der alternativtext anstatt der grafik angezeigt wurde, also auch kein platzhalter.


    Zitat

    Die Trennzeichen für die Signatur also die beiden Minuszeichen und ein Leerzeichen direkt danach, sind vorhanden oder wurden sie gelöscht?


    die trennzeichen waren ordnungsgemäß da. signatur begann eine zeile darunter mit der grafik bzw. mit dem alternativtext bzw. mit dem platzhalter.


    Zitat

    Wann genau verschwindet sie, schon im Versendefenster?


    die grafik verschwindet 3 x:
    1. beim/nach dem versenden, im versendefenster ist sie noch zu sehen. 2. wenn ich auf eine eingegangene email mit dem antworten-modus arbeite.
    3.wenn ich die signatur kopiere.


    Zitat

    Welche Einstellung hast du unter Extras, Einstellungen, Verfassen, Allgemein, Sendeoptionen? Dort sind 4 Optionen.


    "fragen, wie gesendet werden soll" und ich gebe dann zu 99 % "als reinen text und html" an.


    Zitat

    Alle deine Konten sind auf HTML gestellt?


    ja


    Zitat

    Die HTML-Mail wurde von welchem Mailklienten erstellt?


    thunderbird im verfassen-modus. zum ersten mal. die vorherigen signaturen hatte ich immer über den alten mozilla-composer erstellt und das hat immer gefunzt.


    Zitat

    Ein Ausschnitt des Quelltextes (strg+U) bis zum Beginn des kodierten Teils, wäre nicht schlecht. Privates unkenntlich machen.


    ich weiß nicht genau, was du mit "kodierten teil" meinst, ich habe mal alles reingepackt und persönliches ge-xxxt.



    From - Tue Apr 15 11:18:29 2008
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00800000
    X-Mozilla-Keys:
    Message-ID: <xxx@xxx.de>
    Date: Tue, 15 Apr 2008 11:18:21 +0200
    From: xxx <xxx@xxx.de>
    User-Agent: Thunderbird 2.0.0.12 (Windows/20080213)
    MIME-Version: 1.0
    To: xxx <xxx@xxx.de>
    Subject: link
    Content-Type: multipart/alternative;
    boundary="------------090805000904070403040302"


    This is a multi-part message in MIME format.
    --------------090805000904070403040302
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit


    http://www.xxx.de/xxx/


    --
    logo
    xxx xxx Straße x _ xxxxx xxx
    Telefon xxx _ Telefax xxx
    xxx@xxx.de _ http://www.xxx.de


    --------------090805000904070403040302
    Content-Type: text/html; charset=ISO-8859-15
    Content-Transfer-Encoding: 8bit


    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    </head>
    <body bgcolor="#ffffff" text="#666666">
    <a class="moz-txt-link-freetext" href="http://www.xxx.de/xxx/">http://www.xxx.de/xxx/</a><br>
    <br>
    <div class="moz-signature">-- <br>
    <title></title>


    <font face="Helvetica, Arial, sans-serif"><img alt="logo"
    src="file:///C:/Dokumente%20und%20Einstellungen/user/Eigene%20Dateien/1_xxx/vorlagen%20neu/xxx.jpg"
    moz-do-not-send="true" height="18" width="102"><br>
    </font><big><font style="font-weight: bold; font-family: sylfaen;"
    size="-1">xxx</font><font style="font-family: sylfaen;"
    size="-1"><big> xxx Straße
    x _ xxxxx xxx<br>
    Telefon xxx _ Telefax xxx<br>
    <a class="moz-txt-link-abbreviated"
    href="mailto:xxx@xxx.de">xxx@xxx.de</a>
    _ <a class="moz-txt-link-abbreviated"
    href="http://www.xxx.de">http://www.xxx.de</a></big></font></big><br>


    </div>
    </body>
    </html>


    zurzeit ist das problem gelöst! ich habe einen freund gebeten, eine html-datei für meine signatur zu erstellen, weil das all die zeit vorher auch funktioniert hat. er hat diese in dreamweaver erstellt, ich habe diese bei mir abgespeichert und eingefügt. ergebnis: alles in ordnung. hier der quelltext dazu:


    From - Tue Apr 15 12:41:05 2008
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00800000
    X-Mozilla-Keys:
    Message-ID: <xxx@xxx.de>
    Date: Tue, 15 Apr 2008 12:41:04 +0200
    From: xxx <xxx@xxx.de>
    User-Agent: Thunderbird 2.0.0.12 (Windows/20080213)
    MIME-Version: 1.0
    To: xxx <xxx@xxx.de>
    Subject: test signatur 1
    Content-Type: multipart/alternative;
    boundary="------------090009010504020902050902"


    This is a multi-part message in MIME format.
    --------------090009010504020902050902
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit



    --


    Logo xxx
    xxx xxx Straße x _ xxxxx xxx
    Telefon xxx _ Telefax xxx
    xxx@xxx.de <mailto:xxx@xxx.de> _
    http://www.xxx.de <http://www.xxx.de/>



    --------------090009010504020902050902
    Content-Type: multipart/related;
    boundary="------------050201040603000501040605"



    --------------050201040603000501040605
    Content-Type: text/html; charset=ISO-8859-15
    Content-Transfer-Encoding: 8bit


    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    </head>
    <body bgcolor="#ffffff" text="#666666">
    <br>
    <div class="moz-signature">-- <br>
    <meta http-equiv="Content-Type" content="text/html; ">
    <title>Untitled Document</title>


    <style type="text/css">
    <!--
    .style1 {
    font-size: 12px;
    font-family: Arial, Helvetica, sans-serif;
    }
    -->
    </style>
    <p><img src="cid:part1.01030500.07090204@xxx.de"
    alt="Logo xxx" height="19" width="110"><br>
    <span class="style1">xxx xxx Straße x _ xxxxx xxx<br>
    Telefon xxx _ Telefax xxx<br>
    <a href="mailto:xxx@xxx.de">xxx@xxx.de</a>
    _ <a href="http://www.xxx.de/">http://www.xxx.de</a></span></p>
    </div>
    </body>


    </html>


    --------------050201040603000501040605
    Content-Type: image/jpeg;
    name="xxx.jpg"
    Content-Transfer-Encoding: base64
    Content-ID: <part1.01030500.07090204@xxx.de>
    Content-Disposition: inline;
    filename="xxx.jpg"




    nun weiß ich, dass jetzt das logo nicht mehr eingebunden ist sondern von meiner homepage runtergezogen wird. also, ein anderes verfahren als früher. aber früher ging mit der signatur auch, deshalb zum schluss noch ein quellcode von einer alten email:


    From - Wed Mar 12 16:40:58 2008
    X-Mozilla-Status: 0001
    X-Mozilla-Status2: 00800000
    X-Mozilla-Keys:
    Message-ID: <xxx@xxx.de>
    Date: Wed, 12 Mar 2008 16:40:52 +0100
    From: xxx <xxx@xxx.de>
    User-Agent: Thunderbird 2.0.0.12 (Windows/20080213)
    MIME-Version: 1.0
    To: xxx <xxx@xxx.de>
    Subject: xxx
    Content-Type: multipart/alternative;
    boundary="------------020209080402060403020906"


    This is a multi-part message in MIME format.
    --------------020209080402060403020906
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit


    xxx


    --
    Logo xxx
    xxx xxx Straße x _ xxxxx xxx
    Telefon xxx _ Telefax xxx
    xxx@xxx.de _ http://www.xxx.de


    --------------020209080402060403020906
    Content-Type: multipart/related;
    boundary="------------080408040609030307060803"



    --------------080408040609030307060803
    Content-Type: text/html; charset=ISO-8859-15
    Content-Transfer-Encoding: 8bit


    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    </head>
    <body bgcolor="#ffffff" text="#666666">
    <font face="Helvetica, Arial, sans-serif"> xxx
    <br>


    <br>
    </font>
    <div class="moz-signature">-- <br>
    <meta content="text/html; charset=ISO-8859-15" http-equiv="content-type">
    <title>signatur-xxx.html</title>
    <img src="cid:part1.03060004.06050809@xxx.de"
    alt="Logo xxx" style="width: 110px; height: 20px;"><br>
    <big><font style="font-weight: bold; font-family: sylfaen;" size="-1">xxx</font><font
    style="font-family: sylfaen;" size="-1"><big> xxx Straße
    x _ xxxxx xxx<br>
    Telefon xxx _ Telefax xxx<br>


    <a class="moz-txt-link-abbreviated" href="mailto:xxx@xxx.de">xxx@xxx.de</a> _ <a class="moz-txt-link-abbreviated" href="http://www.xxx.de">http://www.xxx.de</a></big></font></big>
    </div>
    </body>
    </html>


    --------------080408040609030307060803
    Content-Type: image/jpeg;
    name="xxx.jpg"
    Content-Transfer-Encoding: base64
    Content-ID: <part1.03060004.06050809@xxx.de>
    Content-Disposition: inline;
    filename="xx.jpg"


    ich hoffe, meine erläuterungen helfen, das problem einzukreisen für künftige fälle. vielleicht gibst du mir nochmals kurz rückmeldung, obwohl ich mir jetzt schon geholfen habe?


    auf jeden fall vielen herzlichen dank für deine - eure - mühe hier.


    schönen tag noch, jacqueline

  • Hallo,
    man kann in TB bein Einfügen der Grafik Fehler machen in der Art, dass aufgrund falsch gesetzter Haken entweder die Grafik-Datei nicht mitgesendet wird oder umgekehrt, TB sie im Netzt sucht aber dort nicht findet und sie nicht in der Mail enthalten ist, wie in deinem Fall.
    Du wunderst dich, keinen kodierten Teil in der Mail zu gehabt zu haben. Das ist logisch, wenn die Grafik nicht mitgesendet wurde. Wurde sie mitgesendet, wäre sie i.R. so lang, dass du sie hier gar nicht hättest posten können. Denn jeder Anhang oder eingebundene Grafik (ohne Nachladen aus dem Netz) wird in reinen Text kodiert, was man sofort erkennt.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    2 Mal editiert, zuletzt von mrb ()

  • hallo mrt,


    ach, diese langen kryptischen zahlen-/buchstabengebilde habe ich nicht mit einkopiert, weil ich dachte, dass das was mit dem html-/textformat zu tun hat, in denen ich jeweils eine email sende. :redface:


    also glaube mir, bei den eben geposteten 3 codes sind im 2. und 3. die eingebundene grafik, dargestellt durch diesen zahlen-nummernblock nach z. b.


    --------------050201040603000501040605
    Content-Type: image/jpeg;
    name="xxx.jpg"
    Content-Transfer-Encoding: base64
    Content-ID: <part1.01030500.07090204@xxx.de>
    Content-Disposition: inline;
    filename="xxx.jpg"


    vorhanden.


    lg jacqueline

  • Hallo,
    eine Signatur mit Grafik für TB zu erstellen ist so eine Sache. Die html-Signatur muss mit TB erstellt werden!!!
    Ich habe
    1. TB ohne Signatureinbindung (siehe Extras-->Konten) aufgemacht
    2. das "Verfassen"-Fenster geöffnet
    3. in das große Feld für den Text geklickt
    4. Menueleiste -->Einfügen und den Ort der Grafik gesucht --> Öffnen
    (Achtung: auf vollständige Pfadangabe achten!)
    5. darunter meine Textinformationen geschrieben (Anschrift, Tel. etc.)
    6. dann dies mit Datei-->gespeichert als -->Datei als html-Datei in das Verzeichnis, wo auch die Grafik liegt
    7.Diese html-Signatur-Datei eingebunden in TB : Extras --> Konten
    Es funktioniert!
    Hilfreich wäre bei der TB-Hilfe nicht nur das Erstellen einer reinen Text-Signatur, sondern auch das Erzeugen einer html-Signatur darzustellen.
    Fragen:
    Für einen Hinweis, wo man die html-Datei und die Grafik-Datei am zweckmäßigsten speichert z. B. unter C:\Dokumente und Einstellungen\User\Anwendungsdaten..... wäre ich dankbar.
    Wo muss die Signatur und Grafik liegen, wenn über das WEB auf mein Postkonto zurückgreifen und eine Mail mit Signatur verschicken will?
    Gruß Peter

  • Hallo und willkommen im Forum.

    Zitat

    eine Signatur mit Grafik für TB zu erstellen ist so eine Sache. Die html-Signatur muss mit TB erstellt werden!!!


    Richtig, das habe ich ja auch schon zigmal im Forum gepostet.
    ich würde aber lieber sagen [b]sollte]/b], denn manchmal klappt es auch mit Fremdanwendungen.

    Zitat

    Hilfreich wäre bei der TB-Hilfe nicht nur das Erstellen einer reinen Text-Signatur, sondern auch das Erzeugen einer html-Signatur darzustellen.


    Du hättest nur im Forum danach suchen müssen.
    Es wurde auch beschrieben, wie man Grafiken als Link herstellt und wie man Grafiken in der Signatur aus dem Internet von einem Webhoster herunterlädt, die Grafiken also nicht mit versendet werden und trotzdem in der Signatur erscheinen.


    Z.B.
    http://www.thunderbird-mail.de…ghlight=signatur&start=15
    http://www.thunderbird-mail.de…topic.php?p=122589#122589
    http://www.thunderbird-mail.de…&t=33225&p=171078#p171078


    Wenn du aber nichts dagegen hast, würde ich deine Schritt-für-Schritt-Anleitung gerne verwenden und sie in der Dokumentation für alle bereit halten.
    Da das aber viel Zeit kostet, kann es auch mal etwas dauern, bis sie dort erscheint, zumal ich dort keine Voll-Rechte habe.
    Gleichzeitig möchte ich wir aber auch sagen, dass es kaum Freunde von HTML hier im Forum gibt (ich übrigens auch nicht), da es keiner aus Sicherheits- und anderen Gründen benutzt.
    Es gibt nämlich keinen Standard für HTML in Mails und niemand weiß, wie eine solche Mail beim Empfänger dargestellt wird.
    ich lese prinzipiell mit einigen Ausnahmen nur in Rein-Text, deine Mühe wäre also umsonst gewesen, vermutlich hätte ich die Mail nicht mal gelesen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    am sichersten ist es das Logo / die Grafik per Inline als Base64 Code einzubinden:


    • Die Grafik mit einem Base64 Encoder umwandeln
    • Code als Inline Grafik einbinden
      Code
      1. <img src="data:image/gif;base64,HIER DER BASE64 BILDER CODE" />


    Davon die Bilder von einer externen Quelle zu laden würde ich abraten, funktioniert noch seltener als das anzeigen von HTML.

  • Zitat

    Davon die Bilder von einer externen Quelle zu laden würde ich abraten, funktioniert noch seltener als das anzeigen von HTML.


    Funktioniert bei mir immer, seitdem ich mit TB arbeite. Einzige Ausnahme: der Webhoster ist down.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw