Thunderbird reagiert nicht

  • Hallo zusammen,


    ich habe das Problem, das Thunderbird immer wieder verzögert reagiert und immer wieder Aussetzer zwischen 3 und 10 Sekunden hat.


    Thunderbird Version 2.0.0.21(20090302)
    Betreibssystem : WinXP Professional SP3
    Computer : Pentium 4, 3.6 GHz, 4 GB Ram
    AddOns: Inzwischen alle deaktiviert (ohne Erfolg)
    Netzwerk mit Win2003-Domänen-Server, Novell-Server, Linuxserver
    Mailserver : IMAP im lokalem Netzwerk 172.20.x.x Port 143, Persönlicher Namensraum "INBOX."
    Virenscanner : Trend Mirco Office Scan


    Die Aussetzer kommen unregelmäßig mal länger mal kürzer und haben nichts mit dem Intervall "Alle x Minuten auf neue Nachrichten prüfen" zu tun. Zum Teil verschwindet auch einfach das Symbol in der Taskleiste und taucht dann nach ein paar Sekunden wieder auf, obwohl das Fenster von Thunderbird die ganze Zeit auf dem Desktop zu sehen ist. Auch z.B. beim Schreiben einer EMail reagiert Thunderbird manchmal einfach nicht mehr, d.h. die Tastaturangaben werden nicht mehr angenommen bzw. es werden nach dem Aussetzer die Zeichen aus dem Tasterturpuffern dann noch geschrieben.


    Wir haben ein Netzwerk mit Userprofilen welches es uns ermöglicht an jedem beliebigen Arbeitsplatz mit unseren Daten zu arbeiten. Deshalb habe ich Thunderbird - unabhängig vom Userprofil - in mein Userverzeichnis auf dem Server installiert, damit ich Thunderbird auch nutzen kann wenn ich mal an einem anderen Rechner sitze (z.B. im Meetingraum). Auch das "Lokale Verzeichnis" in welchem die *.sbd und die *.msf Dateien liegen ist auf dem Server im Userverzeichnis. Wir haben vor kurzem erst auf XP umgestellt und die gleiche Installation hat vorher unter WinNT mit Thunderbird 1.5 auch einwandfrei funktioniert.


    Ich habe auch noch einen Laptop mit der gleichen Konfiguration XP Pro, Thunderbird 2.0.0.21 (s.o.) mit installierten AddOns und da läuft Thunderbird mit dem gleichen IMap-Server einwandfrei und ohne Aussetzer.


    Ich kann mir jetzt eigentlich nur noch vorstellen, dass es an irgend welchen Registry-Einträgen oder Zugriffsrechten hängt, da das der aus meiner Sicht einzige Unterschied zwischen dem Laptop und dem Desktop ist. Auf dem Laptop hat der angemeldete Win XP User sicher mehr Rechte als auf dem Desktop welcher in der Domäne ist und dort Richtlinien bezieht.


    Auch eine Konsultation des Task-Managers während eines solchen Aussetzers hat mich nicht weiter gebracht. Die maximale CPU-Auslastung die der Task verursacht liegt bei 3% wenn auf neue Mails geprüft wird. Während eines Aussetzers bleibt die CPU-Auslastung bei 0%. Die aktuelle Speicherauslastung liegt bei 28 MB und Virtueller Speicher bei 16 MB, also alles zu vernachlässigen.


    Auf mich macht es den Eindruck als würde Thunderbird während so eines Aussetzers versuchen irgend eine Verbindung aufzubauen oder eine Datei zu öffnen oder in die Registry zu schreiben und bekommt dann einen TimeOut und macht dann ganz normal weiter. Ich habe deshalb auch schon alle Updates in den Einstellungen ausgeschalten, ohne Erfolg. Würden hier eh nicht funktionieren, da wir hinter einer Firewall sitzen, auf welcher mittels PW vom User erst einen Verbindung zu Internet freigeschalten werden muss.


    Deshalb hier meine Frage: Kann es an mangelnden Rechten (evtl. auch schon während der Installation) liegen und wenn ja auf welche Verzeichnisse oder Dateien muss Thunderbird Zugriff haben? Oder hat sonst jemand eine Idee woran das liegen könnte.


    Vielen Dank im voraus!

  • Hallo Iceman03 und willkommen im thunderbirdfoum!


    Auf mich macht Deine Schilderung den Eindruck, dass einfach die Mailordner zu groß geraten sind und das Thunderbird lähmt. Ich würde mal alle Mails, die Du aufheben willst, in andere Ordner speichern bzw. exportieren und dann das Konto bzw. die Konten, wenns mehr sind, komprimieren. Das könnte Deinen Vogel wieder schneller fliegen lassen. Zudem sollte der Virenscanner nicht auf das Profilverzeichnis zugreifen können, das könnte auch helfen.

  • Hallo Rothaut,


    vielen Dank für Deinen Tipp. Aber erstens habe ich ganz viele Verzeichnisse und so viele Mails sind da auch nicht drinnen, zweitens ist das ein IMap-Server, d.h. die Mails werden ja gar nicht "lokal" gespeichert, sondern nur die Index-Files (*.msf -> Ich habe Offline deaktiviert) und die haben gerade einmal 1,6 MB und last but not least funktioniert das auf meinem Laptop mit dem gleichen Server auch einwandfrei ohne time-lag.


    Was den Virenscanner betrifft, den kann ich als Problem eigentlich auch ausschließen. Der gleiche läuft auch auf dem Laptop und das Serververzeichnis wird von dem sowieso nicht gescannt.

  • Hallo Iceman03
    und willkommen im Thunderbird-Forum!


    Hast du denn Feeds oder Kalender die Abfragen verursachen könnten am Laufen?
    Entsteht in der Zeit denn überhaupt Traffic und wohin?
    TB muss auf den gesamten Profilordner (der mit den 8 Buchstaben und meist .default) mit allen Rechten zugreifen können.

    Zitat

    Auch das "Lokale Verzeichnis" in welchem die *.sbd und die *.msf Dateien liegen ist auf dem Server im Userverzeichnis.

    das verlegen der Pfade auf diesem Weg ist nicht empfehlenswert und es kann durchaus ursächlich sein, wobei ich das hier jetzt nicht annehme, da ja der Lap. funzt.
    Hast du es mal im TB-SafeMode (Abgesicherter Modus) getestet?

  • Hallo rum,


    nein es laufen keine Feeds o.ä.


    nein es läuft kein Traffic soweit ich das beurteilen kann.


    Ich habe in dem User-Verzeichnis auf dem Server in welchem Thunderbird und das Profilverzeichnis liegt Vollzugriff.


    Hier noch mal was um mein Problem zu verdeutlichen:


    Thunderbird läuft, aber in der Taskleiste -> Fehlanzeige. Es taucht dann zwar auch wieder auf und ist auch die meiste Zeit in der Taskleiste zu finden, aber...


    Auf dem Laptop habe ich zwar ein lokales Profilverzeichnis, da ich hier auch mit "offline" arbeite wenn ich mal unterwegs bin. Ich habe aber eben mal auf dem Laptop das Profilverzeichnis auf den Server verlegt auf das gleiche Verzeichnis wie bei dem Desktop. Der Laptop kann mit den *.msf vom Desktop prima arbeiten und es gibt auch keine time-lags. Ich kann also ausschließen, dass es an der Verlegung des Profilverzeichnisses liegt.

    Auch den Abgesicherten Modus habe ich eben mal probiert -> gleiches Problem.


    Iceman03 alias "Rudi Ratlos"

  • Erstelle mal mit dem Profilmanager ein neues Profil und teste.

    Zitat


    Was den Virenscanner betrifft, den kann ich als Problem eigentlich auch ausschließen.

    deaktiviere ihn trotzdem mal, verhindere dazu den Start mit Windows und dann den PC neu starten, nur abschalten bringt nichts.

  • Jetzt finde ich das selber langsam wieder lustig. Habe eben mal das Konto komplett gelöscht, sodass quasi ein komplett jungfräuliches Thunderbird läuft und siehe da genau das gleiche Problem. Wenn ich nur Versuche zwischen Postausgang und Papierkorb zu welchseln dauert das manchmal bis zu 8 Sekunden, dann geht es wieder 10-15 mal ohne Problem und dann kommt wieder ein time-lag.



    Ich kann jetzt also sogar ausschließen, dass das Problem in irgend einer Art mit dem IMAP-Server zusammenhängt. Auch mit dem Profil auf dem Server kann das nicht zu tun haben.


    Ich werde jetzt mal deinstallieren, neu installieren, mal zum Test auf C:\ -> Wäre doch gelacht, wenn ich den Vogel nicht zum fliegen bringe. :flehan:


    Nachtrag: Auch eine Neuinstallation auf C:\ brachte nicht den gewünschten Erfolg. -> Gleiches Problem besteht nach wie vor. Ich hatte allerdings das Problem, dass ich Thunderbird nicht unter dem vorgeschlagenem Pfad C:\Programme\Mozilla Thunderbird\ installieren konnten, weil ich da keine Rechte habe. Ich habe dann kurzerhand auf C:\Mozilla Thunderbird\ installiert was auch einwandfrei funktioniertet. Da aber die Probleme immer noch da sind verstärkt sich mein Verdacht, dass Thunderbird irgend welche Rechte auf C:\ oder in der bzw auf die Registry braucht die es nicht bekommt, weil unser System ziehmlich dicht gemacht wurde (siehe Installation unter C:\Programme\ nicht möglich). Auch Änderungen unter C:\Windows\system32\ werden soweit ich weiß von unserem System nicht zugelassen.


    Gibt es irgendwo eine Liste welche Rechte für eine Installation von Thunderbird benötigt werden bzw welche Dateien in welchen Systemverzeichnissen bei der Installation angelegt werden? Und welche Schreib und oder Leserechte braucht Thunderbird dann im laufenden Betrieb?


    Ich (= DAU :mrgreen: ) bin ja mal davon ausgegangen, dass die Anforderungen nicht all zu hoch sein können, weil ich mal was von einer Installation von Thunderbird auf einem USB-Stick gelesen habe. Das würde für mich im Umkehrschluß bedeuten, wenn Thunderbird auf Systemverzeichnisse angewiesen ist, wie soll das dann mit dem USB-Stick funktionieren, wenn ich den auf einem Rechner reinstecke auf dem kein Thunderbird installiert ist!?


    Bin um jede Hilfe dankbar!

    Einmal editiert, zuletzt von Iceman03 ()

  • @ rum : Der Virenscanner ist nicht das Problem. Ich bin mir sicher dass die Virenscanner im allgemeinen sehr oft das Problem sind. Aber nicht in diesem Fall.


    Problemlösung:
    Nach unzähligen Uninstalls und Installs und verlegen des lokalen Verzeichnis habe ich jetzt einen sauber laufenden Vogel, wenn auch nicht ganz so wie ich das gerne hätte.


    1) Thunderbird direkt im Userverzeichnis, also nicht unter C:\Programme\Mozilla Thunderbird\ sondern unter N:\IRGENDWO\ zu installieren ist kein Problem und funktioniert einwandfrei.


    2) Solltet Ihr das von mir beschriebene Problem haben, dass Thunderbird immer wieder Aussetzer hat, kann ich im Moment nur empfehlen, das "Lokale Verzeichnis" auf C:\ zu lassen. Dann kommt es bei mir nicht mehr zu diesen Aussetzern.


    Hintergrund:
    Da wir mit Roaming Profiles arbeiten wollte ich es eigentlich vermeiden, das Thunderbird das Profil in mein Userprofil (C:\Dokumente und Einstellungen\%USERNAME%\Anwendungsdaten\Thunderbird\Profiles\) speichert. Das Roaming-Profil wird bei jedem Start vom Server geladen und beim beenden wieder auf den Server gespeichert. Damit ist zwar zumindest sicher gestellt, dass wenn ich mich an einem anderen Rechner anmelde mein Thunderbird-Profil da ist. Es hat aber den Nachteil, dass das booten des Rechners entsprechend länger dauert. Der Effekt dürfte zwar bei einem offline IMAP Konto nicht so groß sein, aber hier geht es ums Prinzip. Deshalb wollte ich eigentlich das Profil direkt auf den Server in mein Userverzeichnis legen. Hier zickt Thunderbird aber irgendwie rum. Warum habe ich leider noch nicht rausgefunden. Das Problem tritt bei mir auch nur im Userverzeichnis auf, wenn ich das Lokale Verzeichnis an einen anderen Ort auf der C:\ Platte oder auf ein anderes Netzlaufwerk verlege funktioniert das einwandfrei. -> Ich werde auf jeden Fall noch rausfinden woran das liegt und Euch dann hier informieren.


    Vielen Dank an alle die geholfen haben!!!