Profil wiederherstellen die 1000ste. [erledigt]

  • Hallo zusammen,


    tut mir leid, wenn ich diese Frage hier zum 1000sten Mal wiederholen muss aber ich schaffe es nicht, meine gesichtern TB-Profile in die neue TB-installation zu spielen.


    Was bei meiner Installation von den hier beschriebenen abweicht:
    1. Der Pfad: C:\Programme\Mozilla Thunderbird\Profiles (darunter liegt das berühmte Verzeichnis mit dem kryptsichen Namen: "97uwpq3z.default"
    -> In den Beschreibungen taucht allerdings immer dieser Pfad auf: Dokumente und Einstellungen\%Benutzername%\Anwendungsdaten\Thunderbird
    Frage also: Ist das ein Problem, dass mein Pfad völlig andes heisst?
    2. Was habe ich gemacht?
    Antwort: A. Die Datei profiles.ini in obiges Verzeichnis abgelegt (natürlich habe ich die bisherige Datei dort umbenannt)
    B. Die alte registry-Datei in selbiges Verzeichnis kopiert.
    C. Das "Profiles"-Verzeichnis in das Mozilla-Thunderbrid-Verzeichnis abgelegt.
    Wenn ich jetzt TB starte, fragt mich der Kontenassistent immer noch, ob ich neue Konten anlegen will. Es funktioniert also nicht?


    Was mache ich bloss falsch?


    Würde mich sehr freuen, wenn mir hier jemand auf die sprünge helfen kann, TB wieder zum Luafen zu bringen und die alten Profile wieder nutzbar zu machen.


    VG, Mehler

  • "mehler" schrieb:

    Was bei meiner Installation von den hier beschriebenen abweicht:
    1. Der Pfad: C:\Programme\Mozilla Thunderbird\Profiles (darunter liegt das berühmte Verzeichnis mit dem kryptsichen Namen: "97uwpq3z.default"
    -> In den Beschreibungen taucht allerdings immer dieser Pfad auf: Dokumente und Einstellungen\%Benutzername%\Anwendungsdaten\Thunderbird
    Frage also: Ist das ein Problem, dass mein Pfad völlig andes heisst?


    Ja, du guckst eben an der falschen Stelle nach. Such den angegebenen Pfad aus der Beschreibung, d.h. unserer Anleitung:


    Das Profil-Verzeichnis finden

  • Hallo,

    Zitat

    1. Der Pfad: C:\Programme\Mozilla Thunderbird\Profiles (darunter liegt das berühmte Verzeichnis mit dem kryptsichen Namen: "97uwpq3z.default"


    Schon merkwürdig: den Ordner Profiles habe ich dort noch nie gesehen. Da muss etwas schief gelaufen sein. Ich vermute ein Kopierfehler.

    Zitat

    Antwort: A. Die Datei profiles.ini in obiges Verzeichnis abgelegt


    Du meinst in den Ordner Programme? Das wäre eine Todsünde.Die profiles.ini darf auf keinen Fall verschoben werden, sonst kann TB das Profil niemals finden.

    Zitat

    B. Die alte Registry-Datei in selbiges Verzeichnis kopiert.


    Unwichtig.

    Zitat

    C. Das "Profiles"-Verzeichnis in das Mozilla-Thunderbrid-Verzeichnis abgelegt.


    Der Fehler wäre noch zu verkraften, wenn du die profiles.ini am ursprünglichen Ort belassen und editiert hättest.
    In diesem Fall müsste der Inhalt der profiles.ini so lauten:


    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=0
    Path=C:\Programme\Mozilla Thunderbird\Profiles\97uwpq3z.default
    Default=1


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ja, du guckst eben an der falschen Stelle nach. Such den angegebenen Pfad aus der Beschreibung, d.h. unserer Anleitung:


    Das Profil-Verzeichnis finden[/quote]


    Hallo allblue,


    höchst merkwürdig! Ich habe gerade TB noch einmal installiert und zwar die Version 2.0.0.23. Man sollte doch denken, dass bei der Installation dieser Pfad angelegt wird:
    Dokumente und Einstellungen\%Benutzername%\Anwendungsdaten\Thunderbird
    Interessanter Weise heissen die "Anwednungsdaten" in meiner deutschen XP-Version (wo sonst alles deutsch ist) "Application data. Vielleicht ist die Deutsche TB-Version darüber genauso verwirrt wie ich.
    Auf jeden Fall gibt es weit und breit kein Verzeichnis namens "Thunderbird".


    Was denkst Du soll ich tun?


    VG, mehler

  • Darf man davon ausgehen, dass dein System gemäß dieser Anleitung eingestellt ist:
    http://freenet-homepage.de/rene-gad/invisible.html ??


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb und graba,


    vielen Dank für die sher hilfreichen Tipps. Inzwischen finde ich die TB-Profile in den von Euch beschirebenen Verzeichnissen.


    Allerdings läuft TB immer noch nicht so wie es soll. Wenn ich TB von dem normalen Icon auf dem Desktop starte, sagt TB, dass ich zuerst Email-konten anlegen soll.


    Wenn ich TB über den Profilmanager starte, stehen die beiden Optionen "default" und "Mein Username" bereit. wenn ich TB als "default" starten möchte, sagt TB, dass es "dieses Prfil nicht verwenden kann, weil es bereits benutzt wird." Dies stimmt bloss nicht. Ich habe TB nicht gestartet. Wenn ich TB unter "Mein Username" starte, wird mir (wie oben) gesagt, dass ich erst Emailkonten anlegen soll.


    Was muss ich tun um TB zum Laufen zu kriegen?


    Vielen Dnak im voraus schon mal für Eure Tipps, mehler

  • Poste den Inhalte der Datei profiles.ini. Dann sehen wir klarer.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/o7cjdez2.default


    [Profile1]
    Name=Tido
    IsRelative=1
    Path=Profiles
    Default=1


    |-> hier der Inhalt meiner profiles.ini VG, mehler

  • Hallo Mehler,


    die Profiles.ini sieht aus als wäre versucht worden manuell Änderungen vorzunehmen.


    "mehler" schrieb:

    [Profile1]
    Name=Tido
    IsRelative=1
    Path=Profiles
    Default=1


    bedeutet, dass du ein Profil direkt im selben Verzeichnis betreibst in der sich eigentlich erst die Verzeichnisse der eingerichteten Profile selbst befinden sollten. Das ist höchst gefährlich. Solltest du dieses Profil mit dem Profilmanager löschen, sind alle anderen Profile ebenfalls weg.


    Kopiere alle dateien außer dem Verzeichnis o7cjdez2.default in ein Unterverzeichnis - z.B. Tido und ändere die Profiles.ini für das Profil1 entsprechend ab - in dem Beispiel also


    [Profile1]
    Name=Tido
    IsRelative=1
    Path=Profiles/Tido
    Default=1


    Alles andere ist grob fahrlässig und führt unweigerlich früher oder später zu massiven Problemen.


    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo Toolman,
    vielen Dank für Deine Antwort. Bevor ich das mache, vorab noch ein paar Fragen zum grundsätzlichen Vorgehen.
     
    1. Um meine alten Mails und Emailkonten nach Neuinstalltion des Systems und von TB wieder lesen zu können habe ich folgende sicherung von TB gemacht:
    sie nach Neuinstallation des systems und damit auch von TB wieder aufzuspielen.
    - Profiles
    - 97uwpq3z.default
    - extensions
    + ImapMail
    + Mail
    2. Nach der Neuinstallation des Systems und von TB sieht mein neues TB nun so aus:
    - Profiles
    - o7cjdez2.default
    - extensions
    3. Um die alte Installation nun zum Laufen zu bringen, habe ich das Verzeichnis Profiles in "Profiles-n" umbenannt und die Dateien aus 1
    in den TB ordner kopiert. Offenbar ist das nicht ganz richtige Weg. Aber wie kriege ich jetzt die alte TB installation wieder zum laufen?


    VG, mehler

  • Hallo mehler,


    vielleicht machst du einfach mal ein Bildschirmfoto (ALT+Druck) und zeigst uns mal wie der Profilordner jetzt aussieht..
    Für mich klingt das etwas verwirrend - wahrscheinlich weil da auch einiges durcheinander ist.




    Wie man das Bild hier zur Anzeige bringt habe ich vor einiger Zeit mal in meinem Forum beschrieben...
    http://www.agsm.de/forum/viewtopic.php?f=6&t=99






    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo mehler,


    so wie ich das sehe, kannst du die Dateien so verschieben wie schon im vorherigen Posting beschrieben. Das Profil das sich jetzt unterhalb von Profiles-n befindet, kannst du ebenfalls nach Profiles verschieben.


    deine Profiles.ini änderst du dann einfach wie folgt:


    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/o7cjdez2.default


    [Profile1]
    Name=Tido
    IsRelative=1
    Path=Profiles\tido
    Default=1




    dein Backup-Profil ist dann aber nicht das Hauptprofil - du solltest daher die Zeilen
    StartWithLastProfile=0
    und aus dem Tido-Profil die Zeile Default=1 entfernen.
    Das ganze sieht dann so aus:


    [General]
    StartWithLastProfile=0


    [Profile0]
    Name=Backup
    IsRelative=1
    Path=Profiles/o7cjdez2.default


    [Profile1]
    Name=Tido
    IsRelative=1
    Path=Profiles\tido


    Probiere dann mal das Backup-Profil aus.




    schöne Grüße


    Toolman

    aktuellste TB-Version. ESET Smart Security, Windows 10 Pro

  • Hallo Toolmann,


    vielen Dank für Deine Mail. Habe TB nun endlich zum Laufen gebracht. Meine profiles.ini sieht übrigens jetzt so aus:


    [General]
    StartWithLastProfile=1


    [Profile0]
    Name=default
    IsRelative=1
    Path=Profiles/97uwpq3z.default


    Default=1


    Den Verweis auf das andere Profil habe ich weg gelassen, weil es nur wegen der Neuinstallation entsanden war.


    Vielen Dank für Deine Hilfe, die sehr nützlich für mich war!


    VG, mehler