Nach Wiederherstellung werden keine mails angezeigt

  • Guten Tag,


    nach einigen Stunden an erfolgloser suche versuche ich nun mein Glück hier ;).
    Mein Problem ist folgendes: In meinem Postfach sind etwa von 2 Jahren E-Mails verschwunden davor und danach gibts es noch einige. Gelöscht wurden sie nicht auch wenn man das sofort denkt. Aber das nur zur Vorgeschichte vll kennt jmd so ein Problem.


    Auf jedenfall habe ich dann versucht eine Sicherung Wiederherzustellen. Habe das Profil in den entsprechen Ordner Kopiert währen TB geschlossen war. Nun wird mir allerdings in keinem Ordner eine Mail angezeigt. Darauf hin habe ich die Index Datei gelöscht da dieses öfters erwähnt wurde und auch manuell die Index Generierung gestartet. Leider erfolglos. Als nächstes habe ich versucht nur die inbox Mbox Datei auf einem anderen PC in den /Local Folder/ kopiert und umbenannt.
    Beim Zugriff auf den Ordner sieht man die Lade balken und irgendwann hört er auf, jedoch wird immer nocht nichts angezeigt.


    Ich verwende die TB version 2.0.0.23 mit WinXP Sp3. Ich hatte auch testweise das ganze mit TB3 versucht funktionierte ebenfalls nicht. Die Postfach Datei ist allerdings 3,5 GB groß auch mit durchgeführter Komprimierung.


    Hat irgendwer eine Idee? Ich bin am verzweifeln :(


    Danke schon einmal im vorraus an die jenigen die sich an diesem Problem versuchen.


    Gruß Ted

  • Hallo Ted


    und willkommen im Thunderbird-Forum!


    Zitat


    Die Postfach Datei ist allerdings 3,5 GB groß auch mit durchgeführter Komprimierung.

    du meinst damit die Mail-Datei? Kein Wunder, dass das mal schief geht.
    Besorge dir einen guten Editor und versuche die Datei zu teilen. Eine Mail fängt immer mit From- Datum an und so kannst du eine Reihe von Mails markieren und dann abspeichern ohne Endung. Dann hast du nachher viele Dateien ohne Endung und die kopierst du in ..\mail\local folders und startest dann TB.

  • danke für die schnelle Antwort. Werde ich probieren. Mal sehn ob Notepad++ mächtig genug ist.

  • hmm ich habe nun alles möglich ausprobiert. ´Wenn ich mit einem Editor (egal welcher) die Dateien öffne hab ich nur eine Hexadezimal ansicht und kann somit nicht nach den From_ suchen und trennen. Ich habe auch einmal das Tool GSplit probiert und in 600 MB Dateien gesplittet. Danach habe ich das ganze in den Local Ordner kopiert. TB zeigt zwar ne sehr sehr lange zeit einen Ladebalken jedoch einen Inhalt sehe ich nicht.

  • "Ted" schrieb:

    Wenn ich mit einem Editor (egal welcher) die Dateien öffne hab ich nur eine Hexadezimal ansicht und kann somit nicht nach den From_ suchen und trennen.


    Hallo Ted :)


    das hört sich so an, als ob der Editor (fälschlicherweise?) Binärformat erkennt. Mit welchem Editor hast Du es versucht?


    Da Du ja XP verwendest, mach mal folgendes: öffne über Start - Ausführen (Win-R) - "cmd" (ohne die Anführungszeichen) eine Konsole. Dort gibst Du zunächst


    Code
    1. cd %appdata%


    ein und navigierst dann mit weiteren CD-Befehlen zu dem Ordner, in dem die betreffende inbox-Datei liegt. (Btw, einfacher geht das mit dem Powertoy Open Command Window Here.) Dann


    Code
    1. more < inbox


    Siehst Du jetzt den Anfang einer Mail? Die Ausgabe sollte mit einer Zeile beginnen, die mit "From - " anfängt.


    Zitat


    Ich habe auch einmal das Tool GSplit probiert und in 600 MB Dateien gesplittet. Danach habe ich das ganze in den Local Ordner kopiert. TB zeigt zwar ne sehr sehr lange zeit einen Ladebalken jedoch einen Inhalt sehe ich nicht.


    Unwahrscheinlich dass das funktioniert. Dann müsstest Du die Datei zufällig genau an einem Mailanfang erwischt haben.


    HTH
    Gruß Ingo

  • Habe mit folgenden Editoren es versucht: Notepad++, UltraEdit, HiEdit, Jujuedit.


    Durch das Splitten der Datei wollte ich es einfach nur versuchen eine ansicht zu erlangen und um die Datei besser in den Editoren handhaben zu können. Wenn ich mit dem "more" befehl arbeite erhalte ich ebenfalls keine Ergebnisse. Entweder er bleibt bei ---Fortsetzen 0%---- stehen oder wenn ich nur eine Zeile anzeigen lassen möchte, erhalte ich keine Ausgabe.

  • Hallo und guten Morgen,


    wenn du die Datei nicht mehr im Editor lesen kannst, sieht es halt schlecht aus. Normaler Weise werden die Mais dort im Klartext abgelegt, nur der Anhang ist codiert. Öffne einfach mal eine andere endungslose Datei im Profilordner und sieh dir das an.