vcard Sonderzeichen-Problem [gelöst]

  • Hallo Thunderbird-Fans,


    seit kurzem bin ich zu Hause von Outlook auf Thunderbird 3.01 unter Windows XP umgestiegen und finde es sehr gut :D .


    Im Büro benützen wir nach wie vor Outlook 2003 mit Exchange-Server. Nun muss ich oft vcards aus Outlook an Thunderbird senden. Das klappt auch ganz gut bis auf die Umlaute und Sonderzeichen. So kommt z. B. bei "Württemberg" nach dem W nur noch Schrott in der Zeile an :cry: .


    Welche Einstellungen muss ich in Outlook und Thunderbird vornehmen, damit auch die Umlaute und Sonderzeichen richtig kommen?


    Würde mich freuen, wenn mir jemand helfen könnte.


    Hansjörg

    Einmal editiert, zuletzt von hansjoerg ()

  • Hi,
    wenn du dir das Addon MoreFunctionsforAddressBook installierst, kannst du den Standardzeichensatz für Import unter vCard-Format einstellen. Wenn du dann noch herausfindest, was Outlook verwendet...

  • Das Addon habe ich schon, da bin ich auf dem richtigen Weg. Allerdings den Standardzeichensatz bei Outlook herauszufinden, das ist mir noch nicht gelungen ... . Vielen Dank frog, vielleicht weiss ja zufällig einer noch was zu dem Standardzeichensatz in Outlook, auch wenn das hier ein Thunderbird-Forum ist.

  • Vielen Dank, aber keiner von den dreien funktioniert. Ich habe jedes mal den Zeichensatz geändert, Thunderbird geschlossen und wieder neu gestartet, dann die vcard geöffnet. Ergebnis: Sonderzeichen kommen nicht richtig.


    Wenn ich mit der Maus auf das Männchen-Symbol der vcard gehe, kommt in der Statuszeile etwas von "Version 2.1" und "quoted printable". ist das weiterführend? Hat noch jemand eine Idee?

  • Hallo Thunderbird-Fans,


    habe immer noch das selbe Problem und die unlesbaren vcards türmen sich allmählich ...


    Deshalb habe ich eine von Outlook 2003 gesendete Mail mal im Quelltext angesehen und poste das mal hier:
    ===============================================================
    Return-Path: <x-y.xxxxxx@landkreis-kreis.de>
    X-Original-To: j.g.xxxxxxx@arcor.de
    Received: from mail-in-07.arcor-online.net (mail-in-07.arcor-online.net [151.189.21.47])
    by mail-in-06-z2.arcor-online.net (Postfix) with ESMTP id 88BEC1575AF
    for <j.g.xxxxxxx@arcor.de>; Mon, 5 Jul 2010 10:11:28 +0200 (CEST)
    Received: from mx0.gmx.net (mx0.gmx.net [213.165.64.100])
    by mx.arcor.de (Postfix) with SMTP id 62F8E107DB6
    for <j.g.xxxxxxx@arcor.de>; Mon, 5 Jul 2010 10:11:28 +0200 (CEST)
    X-DKIM: Sendmail DKIM Filter v2.8.2 mx.arcor.de 62F8E107DB6
    Received: (qmail 10117 invoked by alias); 5 Jul 2010 08:11:28 -0000
    Delivered-To: GMX delivery to j.g.xxxxxxx@gmx.de
    Received: (qmail invoked by alias); 05 Jul 2010 08:11:28 -0000
    Received: from M1RRZSMAILOUT2.kdrs.de (EHLO M1RRZSMAILOUT2.kdrs.de) [194.0.93.42]
    by mx0.gmx.net (mx074) with SMTP; 05 Jul 2010 10:11:28 +0200
    Received: from M1RRZSMAIL1.kdrs.de (M1RRZSMAIL1 [10.174.254.26])
    by M1RRZSMAILOUT2.kdrs.de (Postfix) with ESMTPS id D82A1C4172
    for <j.g.xxxxxxx@gmx.de>; Mon, 5 Jul 2010 10:11:27 +0200 (CEST)
    Received: from localhost (unknown [127.0.0.1])
    by M1RRZSMAIL1.kdrs.de (Postfix) with ESMTP id B1CAE4D6D5C
    for <j.g.xxxxxxx@gmx.de>; Mon, 5 Jul 2010 10:11:27 +0200 (CEST)
    X-Virus-Scanned: Debian amavisd-new at M1RRZSMAIL1
    Received: from M1RRZSMAIL1.kdrs.de ([127.0.0.1])
    by localhost (m1rrzsmail1.rzrs.kvnbw.de [10.174.254.26]) (amavisd-new, port 10024)
    with ESMTP id cGd54X+X+PTV for <j.g.xxxxxxx@gmx.de>;
    Mon, 5 Jul 2010 10:11:27 +0200 (CEST)
    Received: from EXCHV02.LRA-LB.DE (exchv02.lra-lb.de [10.177.96.123])
    by M1RRZSMAIL1.kdrs.de (Postfix) with ESMTP id 3F3034D6D47
    for <j.g.xxxxxxx@gmx.de>; Mon, 5 Jul 2010 10:11:27 +0200 (CEST)
    Content-class: urn:content-classes:message
    MIME-Version: 1.0
    Content-Type: multipart/mixed;
    boundary="----_=_NextPart_001_01CB1C19.AA7CE844"
    X-MimeOLE: Produced By Microsoft Exchange V6.5
    Subject: =?Windows-1252?Q?WG=3A_Dr=2E_Albert_R=F6hm_test?=
    Date: Mon, 5 Jul 2010 10:11:27 +0200
    Message-ID: <0EC0429AB3845547908106B9CA230B3A01A195AB@EXCHV02.LRA-LB.DE>
    Thread-Topic: =?Windows-1252?Q?Dr=2E_Albert_R=F6hm_test?=
    Thread-Index: AcsG7ydWq2RYn6bvTxeLU9S84I25RAVKnHpw
    From: "xxxxxxx, x-y" <x-y.xxxxxxx@landkreis-kreis.de>
    To: <j.g.xxxxxxx@gmx.de>
    X-GMX-Antispam: 0 (Mail was not recognized as spam);
    Detail=5D7Q89H36p4L00VTXC6D4q0N+AH0PUCnetdm6+jp8LGPxQjTA5kFyVhx4i9dm8gtEcziC
    yoNz9ye38VygtipsduNRG6pU5d0AXKQszr3XqI1/dhISyfo6w7eu4sv07v5JHX9XzDK1cc=V1;
    X-Resent-By: Forwarder <forwarder@gmx.de>
    X-Resent-For: j.g.xxxxxxx@gmx.de
    X-Resent-To: j.g.xxxxxxx@arcor.de
    X-Antispam: SENDER_IN_WHITELIST


    This is a multi-part message in MIME format.


    ------_=_NextPart_001_01CB1C19.AA7CE844
    Content-Type: multipart/alternative;
    boundary="----_=_NextPart_002_01CB1C19.AA7CE844"



    ------_=_NextPart_002_01CB1C19.AA7CE844
    Content-Type: text/plain;
    charset="Windows-1252"
    Content-Transfer-Encoding: quoted-printable


    Westeurop=E4isch Windows


    ------_=_NextPart_002_01CB1C19.AA7CE844
    Content-Type: text/html;
    charset="Windows-1252"
    Content-Transfer-Encoding: quoted-printable


    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=3DContent-Type content=3D"text/html; =
    charset=3Dwindows-1252">
    <META content=3D"MSHTML 6.00.3790.4639" name=3DGENERATOR></HEAD>
    <BODY>
    <DIV><FONT face=3DArial color=3D#0000ff size=3D2><SPAN=20
    class=3D193581008-05072010>Westeurop=E4isch=20
    Windows</SPAN></FONT></DIV></BODY></HTML>


    ------_=_NextPart_002_01CB1C19.AA7CE844--


    ------_=_NextPart_001_01CB1C19.AA7CE844
    Content-Type: text/x-vcard;
    name="=?Windows-1252?Q?Dr__Albert_R=F6hm=2Evcf?="
    Content-Transfer-Encoding: base64
    Content-Description: =?Windows-1252?Q?Dr__Albert_R=F6hm=2Evcf?=
    Content-Disposition: attachment;
    filename="=?Windows-1252?Q?Dr__Albert_R=F6hm=2Evcf?="


    QkVHSU46VkNBUkQNClZFUlNJT046Mi4xDQpOOlL2aG07RHIuIEFsYmVydA0KRk46RHIuIEFsYmVy
    dCBS9mhtDQpPUkc6SHVMIE1hcmJhY2gNClRJVExFOlRpZXJhcnp0DQpURUw7V09SSztWT0lDRTor
    NDkgKDA3Mzg1KSA5Njk1LTANClRFTDtDRUxMO1ZPSUNFOis0OSAoMDE3MSkgNzY1NDc0Mg0KVEVM
    O1dPUks7RkFYOis0OSAoMDczODUpIDk2OTUtMTANCkFEUjtXT1JLOjs7SGF1cHQtIHVuZCBMYW5k
    Z2VzdPx0IE1hcmJhY2g7R29tYWRpbmdlbjs7NzI1MzI7RGV1dHNjaGxhbmQNCkxBQkVMO1dPUks7
    RU5DT0RJTkc9UVVPVEVELVBSSU5UQUJMRTpIYXVwdC0gdW5kIExhbmRnZXN0PUZDdCBNYXJiYWNo
    PTBEPTBBR29tYWRpbmdlbiA3MjUzMj0wRD0wQURldXRzY2hsYW5kDQpVUkw7V09SSzpodHRwOi8v
    d3d3Lmdlc3R1ZXQtbWFyYmFjaC5kZQ0KUkVWOjIwMTAwNzA1VDA4MTA1OFoNCkVORDpWQ0FSRA0K


    ------_=_NextPart_001_01CB1C19.AA7CE844--
    ========================================================
    Die vcard zeigt beim Öffnen z. B. anstatt Dr. Albert Röhm nur Dr. Albert R=F6hm, ganz schlimm wird es dann bei Wörtern wie Straße , da kommen nach dem scharfen s nur noch Hieroglyphen


    Thunderbird 3.01 habe ich folgendermaßen eingestellt:


    Ansicht / Zeichenkodierung / Westlich (Windows 1252)
    Extras / Addons / MoreFunctionsforAdressBook / Einstellungen / vcardFormat / Exportieren . Version 3.0 und Importieren Windows-1252


    Ich habe die Version 0.5.8.4.1 von MoreFunctionsForAdressBook installiert.


    Ist da noch irgend was falsch bei meinem Thunderbird eingestellt??


    :help: Brauche wirklich dringend Hilfe, sonst bleibt mir nichts anderes übrig, als zu dem ungeliebten Outlook zurückzukehren, und damit wären viele Stunden arbeit in den Sand gesetzt.


    Gruß hansjoerg

  • Hallo ich schaute mal soeben schnell in Outlook 2007 nach in dem ich einen Eintrag mit Sonderzeichen im Namen exportierte dabei Fand ich folgende Angaben in der vcf-Datei



    Kannst du in deinem Tool nicht mehrere Zeichensätze für verschiedene Felder definieren?
    Für den Namen Windows-1252
    Wenn du die Bilder der Vcard vom Import ausschliessen kannst so ersparst du dir viel Ärger.
    Und UTF-8 wird vermutlich nur unter Outlook selber gebraucht um es am Bildschirm schön anzuzeigen, das entnehme ich dem Wert X-MS-OL-DESIGN;CHARSET=utf-8


    Ich hoffe das diese Angaben nun zum Erfolg führen.


  • Hallo ich habe heute diese MoreFunctionsForAdressBook Version auch installiert. Danach wollte ich das gesammte Adressbuch zuerst zur Sicherheit exportieren. Als ich danach die CSV-Datei mit Calc öffnete hatte ich bei den Sonderzeichen auch nur Müll.
    Da diese Erweiterung aber nicht das gesuchte brachte hatte ich sie danach gleich wieder deinstalliert. Thunderbird 3.1.1 neu gestartet und zum Test das Adressbuch mit der Thunderbird eigenen exportfunktion auch wieder in eine CSV Kommagetrente Textdatei exportiert.
    Und beim erneuten öffnen mit Calc hatte ich keinen Zeichensalat.
    Also vergiss dieses Add-on!


    Schau dir doch mal das ad-on LookOut näher an https://addons.mozilla.org/de/thunderbird/addon/4433/
    ich habe es selber noch nicht ausprobiert.

  • Hallo pcfreak,
    habe Deinen Tip gleich ausprobiert, leider ändert dies gar nichts. Ich habe jetzt mal beide Add-ons deinstalliert und bemerkt, dass Thunderbird von sich aus schon die Sonderzeichen falsch darstellt, aber nur in der vcard. Nachdem MorefunctionsforAdressbook ansonsten ganz brauchbar ist (z.B. um vcards von Leuten im Adressbuch zu versenden), habe ich es dann wieder installiert.


    Ich glaube, dass es immer noch an den Einstellungen von Thunderbird liegt. Habe jetzt mal auf Version 3.1 modernisiert, ohne Erfolg. Hoffe immer noch, dass jemand mal mein obiges Posting mit den Einstellungen kritisch durchschaut und mir einen Tip gibt ...


    Gruß hansjoerg

  • kannst du das Outlookadressbuch nicht in einem anderen Format exportieren?
    Menü Datei
    Importieren/exportieren
    Datei exportieren


    (Danach probierst du mal aus unter folgenden Optionen)
    Kommagetrennte Werte (Windows)
    Tabulatorgetrenntewerte (Windows)
    Microsoft Excel


    Danach importierst du die so erstellte Datei in Thunderbird.


    Viel Glück

  • ich glaube, wir reden gerade aneinander vorbei. Die Umstellung zu Hause von Outlook 2000 auf Thunderbird lief problemlos mit den Migrationstools von Tb. Jetzt geht es um folgendes Problem:
    - ich erfasse oder ändere eine EINZELNE Adresse im Büro mit Outlook 2003,
    - speichere sie und
    - sende sie als vcard nach hause
    - öffne die vcard mit Tb und
    - bekomme bei Tb nach einem Umlaut in der Adresse nur noch Kauderwelsch.


    Es geht also um einzelne vcards, die ich vom Büro nach hause sende, nicht um den Export eines gesamten Adressbuchs. Sorry, falls ich das nicht klar genug dargestellt habe ....


    Viele Grüße
    Hansjörg

  • So nun wollte ich es aber genau wissen und machte folgendes:
    ich exportierte einen einzelnen Outlook 2007 Kontakt als vcard
    öffnete danach die vcard mit dem Texteditor Notepad ++ den kannst du hier downloaden http://notepad-plus-plus.org/de/node/56
    Setzte in die Beiden Namensfelder (N:1. und FN:1.) extra noch ein paar Sonderzeichen Natel alt öäü ÖÄÜ ß Test


    Danach installierte ich die neuste Version von morefunctionsforAB-TB3-0.5.8.4.1.xpi
    nach dem Neustart schaute ich mir mal die Einstellungen dieses Add-ons an
    Lasche vCard-Format:
    exportieren Version 3.0
    Standardzeichensatz für Export: Windows-1252
    Standardzeichensatz für Import: Windows-1252


    Bei der Lasche Verschiedenes ist die erste und dritte Option angehackt.


    Meine so importierte vcard wurde mit allen Sonderzeichen wie auch dem + bei der Telefonnummer korrekt importiert.


    Wenn du die Fotos nicht brauchst so könntest du ja vor dem Import mit dem Texteditor die Zeile
    PHOTO;TYPE=JPEG;ENCODING=BASE64:
    und den ganzen Rest des darunterliegenden Zeichesalates löschen, die letzten 3 Zeilen lässt du dann wieder stehen


    So sieht bei mir der Anfang der vcard-Datei aus:
    BEGIN:VCARD
    VERSION:2.1
    N:1. Natel alt öäü ÖÄÜ ß Test
    FN:1. Natel alt öäü ÖÄÜ ß Test
    TEL;CELL;VOICE:+411234567
    X-MS-OL-DEFAULT-POSTAL-ADDRESS:2


    Es klappte bei mir einwandfrei.


    Nachtrag:
    Wenn ich mit der rechten Maustaste auf die vcard klicke und öffnen mit Thunderbird wähle passiert nichts.
    Ich muss Thunderbird starten
    das Adressbuch öffnen
    Menü extras --> Kontakte --> vcard/vcf-Datei importieren



    Ansonsten:
    Ach wenn das nur ein paar wenige Änderungen sind, so drucke sie doch aus und ändere sie zuhause von Hand. Ist natürlich nicht ganz optimal aber immer noch besser als Zeichensalat, den du ja danach auch von Hand anpassen musst.

  • Ich kann´s noch immer nicht begreifen: Wenn ich die vcard in Thunderbird mit einer Mail empfange, wird das "kleine Mänchen" und der Name angezeigt. Und wenn im Namen ein Sonderzeichen oder Umlaut drin ist, dann wird der Namen schon falsch angezeigt. Beim Klicken aufs Männchen wird die vcard geöffnet und nach einem Umlaut oder Sonderzeichen kommt nur Schrott im betroffenen Feld.
    Da muss es doch irgendwo in Tb oder Outlook eine Einstellung geben, um den richtigen Zeichensatz mit Umlauten innerhalb der vcard zu bekommen!?


    Aber trotzdem vielen Dank an pcfreakwin. Vielleicht bleibt doch nur die Lösung "von Hand" bzw. ich verwende im Büro keine Umlaute mehr bei der Adresseingabe.


    Schöne Grüße
    hansjoerg

  • Zitat von "hansjoerg"

    Wenn ich die vcard in Thunderbird mit einer Mail empfange, wird das "kleine Mänchen" und der Name angezeigt. Und wenn im Namen ein Sonderzeichen oder Umlaut drin ist, dann wird der Namen schon falsch angezeigt.


    Schöne Grüße
    hansjoerg


    Hallo Hansjoerg
    Ich hatte natürlich bei meinem Versuch die vcard nicht via Mail gesandt sondern nur auf den Desktop exportiert.
    Versuch mal folgendes. Speichere die angehängte vcard zuerst auf dem Desktop (oder einem anderen Verzeichnis) ab, so wie du das mit anderen angehängten Dateien auch machst.
    Dann öffne mal gespeicherte vcard mit dem Texteditor und sehe dort wie die Angaben sind.
    Entsprechen sie meinen Vorgaben? Stimmt der Zeichensatz Windows-1252?
    Falls es einen anderen Zeichensatz ist z.B. utf-8 überschreibe ihn mit Windows-1252, zum Testen.


    Falls die so gespeicherte vcard i.o. ist, importierst du die gespeicherte vcard ins Adressbuch, wie ich es oben beschrieben habe.


    Mit Outlook gesante Mails haben sowieso manchmal eine exotische Formatierung so das man manchmal eine so komische Datei Winmail.dat im Anhang hat, mit der man nichts anfangen kann.
    Stell doch Outlook mal (probehalber) so ein das es NUR Plaintext-Mails verschickt. Kommt dann die vcard korrekt an?


    Hier noch einen Artikel zur Winmail.dat http://www.thunderbird-mail.de/lexicon/:WINMAIL.DAT


    Zitat von "hansjoerg"

    Thunderbird 3.01 habe ich folgendermaßen eingestellt:


    Soeben sah ich das du von der Version 3.01 sprichst. Das könnte natürlich auch zum Problem beitragen.
    In der Zwischenzeit sind wir bei der Thunderbird Version 3.1.1 win. (ohne eine 0 dazwischen) angekommen. Mit der ich meinen Test auch durchführte. Steig doch bitte auf die neuste Version um.
    Vor dem umsteigen zuerst alle Add-ons updaten und die Ordner komprimieren.
    Zur Sicherheit deinen Profielordner sichern.
    Ich hatte aber keine Probleme mit dem Update von 3.0.5 auf 3.1.1

  • Hallo pcreakwin,
    vielen Dank, dass Du Dir so viel Mühe mit meinem Problem machst!


    Bin inzwischen auf TB 3.1.1, hatte ich am Rande oben mal erwähnt, und habe den Test folgendermaßen gemacht:


    1. Versuch
    alte Mail mit der vcard aufgerufen,
    aufs Männchen Rechtsklick, dann Ziel speichern unter, Verzeichnis ausgewählt
    Name eingegeben und ok gedrückt. Auswahlfenster verschwand auch, aber die vcard wurde nicht gespreichert


    2. Versuch
    alte Mail mit der vcard aufgerufen,
    Rechtsklick im übrigen Teil der Dateianzeige, dann speichern unter, Verzeichnis ausgewählt
    Name eingegeben und ok gedrückt. Ergebnis: vcard wird als .eml-Datei gespeichert, nicht als vcf. Bei Doppelklick auf die Datei meldet sich outlook express (ist noch auf dem Rechner genauso wie Outlook 2000, ist aber nicht mehr als Standard eingestellt).


    Wenn ich die .eml-Datei mit Notepad öffne, sehe ich öfter "iso-8859-1", siehe nachfolgender Text:


    ------_=_NextPart_001_01CB1822.C4717404
    Content-Type: text/x-vcard;
    name="=?iso-8859-1?Q?Dr__Albert_R=F6hm=2Evcf?="
    Content-Transfer-Encoding: base64
    Content-Description: =?iso-8859-1?Q?Dr__Albert_R=F6hm=2Evcf?=
    Content-Disposition: attachment;
    filename="=?iso-8859-1?Q?Dr__Albert_R=F6hm=2Evcf?="


    QkVHSU46VkNBUkQNClZFUlNJT046Mi4xDQpOOlL2aG07RHIuIEFsYmVydA0KRk46RHIuIEFsYmVy
    dCBS9mhtDQpPUkc6SHVMIE1hcmJhY2gNClRJVExFOlRpZXJhcnp0DQpURUw7V09SSztWT0lDRTor
    NDkgKDA3Mzg1KSA5Njk1LTANClRFTDtDRUxMO1ZPSUNFOis0OSAoMDE3MSkgNzY1NDc0Mg0KVEVM
    O1dPUks7RkFYOis0OSAoMDczODUpIDk2OTUtMTANCkFEUjtXT1JLOjs7SGF1cHQtIHVuZCBMYW5k
    Z2VzdPx0IE1hcmJhY2g7R29tYWRpbmdlbjs7NzI1MzI7RGV1dHNjaGxhbmQNCkxBQkVMO1dPUks7
    RU5DT0RJTkc9UVVPVEVELVBSSU5UQUJMRTpIYXVwdC0gdW5kIExhbmRnZXN0PUZDdCBNYXJiYWNo
    PTBEPTBBR29tYWRpbmdlbiA3MjUzMj0wRD0wQURldXRzY2hsYW5kDQpVUkw7V09SSzpodHRwOi8v
    d3d3Lmdlc3R1ZXQtbWFyYmFjaC5kZQ0KUkVWOjIwMTAwNjMwVDA3MDYwOFoNCkVORDpWQ0FSRA0K


    Ich habe dann mal an den entsprechenden Stellen "Windows-1252" eingesetzt und die .eml-Datei zwangsweise in eine .vcf-Datei umbenannt, aber konnte sie über Kontakt-->vcard importieren dann gar nicht ansprechen.


    Könnte es sein, das dies mit dem noch vorhandenen Outlook zusammenhängt?


    Gruß
    hansjoerg


    ------_=_NextPart_001_01CB1822.C4717404--

  • Hallo Hansjörg
    Also irgend was stimmt nicht mit deinem Outlook. Ich kanns nicht ausprobieren da ich das Testoutlook nur zum Adressen mit dem Winmobile-Handy einrichtete und keine Mailkonten dafür eingerichtet habe.
    ich habe jetzt aber in Thunderbird das Adressbuch geöffnet
    mit der rechten Maustaste auf einen Benutzer geklickt und aus dem Kontextmenü den Punkt "als vcard senden"
    sandte mir diese Karte selber zu an eine andere Mailadresse
    Da hatte ich dann auch das eine vcf-Datei mit dem Karten/Mänchensymbol
    mit der rechten Maustaste drauf klicken und speichern wählen
    Dann öffnet sich bei mir das "Speichern in Fenster" Desktop
    Im Namensfenster steht bereits der Dateiname so wie er im Anhang der Mail stand.
    Nur noch auf "Speichern" klicken und die Datei landet auf dem Desktop


    Nach dem öffnen sah die vcf-Datei bei mir so aus


    BEGIN:VCARD
    VERSION:3.0
    N;CHARSET=:Name;
    FN;CHARSET=:1. Name
    TEL;TYPE=HOME,VOICE:+41 ** *** ** **
    EMAIL;TYPE=PREF,INTERNET:****@web.de
    EMAIL;TYPE=INTERNET:****@yahoo.de
    BDAY:1947-10-20
    NOTE;CHARSET=:Notizen
    END:VCARD



    Arbeitest du unter Windows7?
    Könnte es Sein das Thunderbird die Datei in einen Ordner speichern möchte wo du keine Schreibrechte hast?
    Die Ordneransicht mal mit F5 aktualisieren.
    Den Speicherordner kannst du in Thunderbird an folgender Stelle einstellen:
    Extras --> Einstellungen --> Anhänge
    Dateien Speichern unter und mit dem durchsuchenknopf das Verzeichnis wählen.
    Ich selber machte mir im Verzeichnis "Eigene Dateien" (heisst in windows7 anders) ein extra Verzeichnis mit dem Namen "Email Anhänge"
    auf das ich dann verweise.


    So nun bin ich mit meinem Latein auch am Ende, den Outlook war schon immer sch****e und die Symbiose mit anderen Mailprogramme immer etwas mühsam, das liegt aber an MS = (Mühsamer Sch***t)


    Heute 01.08.2010 wurde das Add-on morefunctionsforAB aktualisiert auf die Version 0.5.8.5.xpi Du musst achten das du auf der Homepage auch wirklich die Version für TB 3 erwischst https://nic-nac-project.org/~k…ionsforAB-TB3-0.5.8.5.xpi

  • Hallo vcard-Nutzer,


    ich habe jetzt einen Umweg gefunden für den korrekten Zeichenimport. Voraussetzung ist das Add-on MoreFunctionsFor Adressbook.


    Vcard nicht direkt durch klick auf das Männchen öffnen, sondern:
    1. Rechtsklick auf die vcard in der Datei-Anhang-Leiste
    2. Speichern wählen, in irgend einem Verzeichnis zwischenspeichern
    3. Adressbuch öffnen
    4. Extras ==> Kontakte ==>vcard öffnen
    5. vcard-Datei auswählen, nach kurzer Zeit erscheint Kontakt
    6. Bei "Hinzufügen zu ..." das gewünschte Adressbuch auswählen
    7. Mit ok bestätigen


    Eigentlich sollte das ja direkt mit dem Klick auf das Männchen funktionieren, aber da ist wohl irgendwo noch ein Pferdefuß drin. Vielleicht kümmert mal ein Entwickler darum.


    Freundliche Grüße an alle, die hierzu beigetragen haben, besonders pcfreakwin!


    Hansjörg

  • Hallo Hansjörg
    Freut mich wenns nun funktioniert.
    Wenn für dich das Thema nun gelöst ist, so ändere bitte noch den Haupttitel der Diskusion in dem du dahinter [gelöst] scheibst.
    und danke für die Blumen.

  • Hallo.


    Ich hatte gerade eben das gleiche Problem und konnte es noch auf eine andere Art lösen, die ich Euch nicht vorenthalten möchte.
    (meine Thunderbird-Version ist die 16.0.2)
    Bei mir lag folgendes Fehlerbild vor: jedes Feld, was ein Sonderzeichen (ä,ö,ü) enthalten hatte, wurde ab dem Sonderzeichen getrennt bzw. der Rest verworfen. z.B. Jürgen resultierte in einem "J" etc.
    Meine Lösung:
    Die VCard in Notepad++ öffnen und per "Kodierung - konvertiere zu UTF-8 ohne BOM" umkodieren und die Datei speichern.
    Wird die VCard jetzt im Thunderbird geöffnet, wird alles erkannt.
    Was leider nicht funktionierte ist eine Zeile einzufügen, um Thunderbird das Characterset mitzuteilen.
    CHARSET=Windows-1252: ... sollte eigentlich funktionieren, tut´s aber nicht.


    Gruß,
    Jochen

  • Hallo und willkommen im Forum!


    Leider ist der Thread mehr als 2 Jahre alt (vergleiche mal die Thunderbird-Versionen!) und deshalb kaum noch aktuell.
    Es ist hier im Forum nicht gern gesehen, sich an so alte Thread zu hängen.
    Foren-Regeln
    Ich werde deshalb einen Moderator bitten, diesen zu schließen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw