Umlaute beim Kunden falsch dargestellt

  • Hallo zusammen,
    habe seit neustem folgendes Problem:
    ein Kunde meldet, dass die Umlaute u. Sonderzeichen meiner E-Mails bei ihm nicht richtig dargestellt werden (dies betrifft nicht nur ihn, sondern auch andere Kunden).


    z.B. "Sicherungsmaï¿œnahmen" statt "Sicherungsmaßnahmen"


    Ich verwende TB 3.1.7.


    Woran kann das liegen?
    Einstellungen Zeichenkodierung bei mir:
    aus- und eingehende Nachrichten: Westlich (ISO-8859-1)


    Gruß smokie

  • Hallo smokie
    Ich habe das gleiche Problem. Mir trifft es auf, wenn ich eine vorbereitete neue Nachricht speichere und ich diese später aus dem Ordner "Entwürfe" wieder weiter bearbeiten möchte. Dann werden die Umlaute und andere Sonderzeichen auch automatisch umgestellt. Ich verwende den Zeichensatz (Westlich ISO 8859-15). Meiner Meinung muss es irgendwie mit der Auswahl des Zeichensatzes zu tun haben. Grundsätzlich stellt sich die Frage, welchen Zeichensatz für uns Mitteleuropäer der sinnvollste ist. Vielleicht kann uns jemand einen Tipp hierzu geben. Apropos, wo sind die verschiedenen Zeichensätze überhaupt einsehbar?
    Gruss :help:

  • "roland1955" schrieb:

    Grundsätzlich stellt sich die Frage, welchen Zeichensatz für uns Mitteleuropäer der sinnvollste ist. Vielleicht kann uns jemand einen Tipp hierzu geben. Apropos, wo sind die verschiedenen Zeichensätze überhaupt einsehbar?
    Gruss :help:


    Hallo, meinst Du das hier:
    http://de.wikipedia.org/wiki/ISO_8859-15


    http://de.wikipedia.org/wiki/UTF-8
    Das Internet Mail Consortium (IMC) empfiehlt, dass alle E-Mail-Programme UTF-8 darstellen und senden können.


    Ich würde UTF-8 empfehlen. Damit habe bis auf eine ungeklärte Ausnahme keine Probleme. :rolleyes: 
    Gruß

  • Hallo,
    es wäre daher besser gewesen, dass jeder Fragesteller einen eigenen Thread erstellt, anstatt sich hier dranzuhängen.


    Ob alle Fragesteller die gleiche Fehlerursache haben, möchte ich dahin gestellt lassen, da nur schwer zu erkennen ist, wer der Schuldige ist.
    Man müsste sich dann testweise bei jeder Mail als Bcc eintragen, um dann den Quelltext (Strg+U) zu überprüfen.
    Ist das bereits geschehen? Falls nicht, holt das bitte nach, sonst kann ich nicht weiterhelfen.


    Regel: ist im Quelltext z.B. bei einem charset UTF-8 der Nachrichtentext korrekt lesbar, ist der Versender aus dem Schneider, wenn beim Empfänger falsch dargestellt wird.


    Bei Roland1955 ist vermutlich eine falsche Einstellung die Ursache.
    Extras, Einstellungen, Ansicht, Erweitert, dort sollte der unterste Auswahlpunkt niemals angehakt sein, um Probleme beim Beantworten bzw. beim Empfänger zu vermeiden.


    Um Altlasten aus älteren TB-Versionen zu vermeiden, sollte man generell dieses kontrollieren:
    Aus meinem privaten Archiv:

    Zitat

    überprüfe in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten"), ob der Eintrag mailnews.force_charset_override auch wirklich auf "false" steht, das sollte er unbedingt.
    Danach alle Ordner mit Rechtsklick auf diese --> Eigenschaften--> Allgemein überprüfen, ob dort ein Haken gesetzt ist. Falls ja, bitte entfernen.



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • roland1955 ,


    Zitat

    Meiner Meinung muss es irgendwie mit der Auswahl des Zeichensatzes zu tun haben. Grundsätzlich stellt sich die Frage, welchen Zeichensatz für uns Mitteleuropäer der sinnvollste ist


    Nein eher nicht, sondern mit deinen Einstellungen. TB ist so ausgelegt, dass bei nicht veränderten Einstellungen jeden Zeichensatz (=Zeichenkodierung) automatisch erkennt und korrekt darstellt. Unter der Voraussetzung, dass dieser in der Mail richtig deklariert wurde etwa:

    Code
    1. Content-Type: text/html; charset=ISO-8859-15
    2. Content-Transfer-Encoding: 8bit


    7bit oder 8bit bedeutet immer, dass unkodiert versendet wurde.
    Oft steht dort auch "quoted printable". In diesem Fall ist der Quelltext kodiert bei Sonderzeichen und Umlauten, was aber normalerweise nicht schlimm ist, da ein moderner Mailklient das im Nachrichtentext wieder richtig dekodiert.


    Ist aber keine Deklarierung vorhanden oder ist diese falsch, kann TB nur noch raten und dann meistens falsch.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Moin,
    habe mir die Mail mit BCC auch an mich gesandt. In Quelltext steht:


    Content-Type: text/plain;
    charset="windows-1258"
    Content-Transfer-Encoding: quoted-printable


    und nun???

  • Hallo,
    dann stelle ihn doch einfach auf ISO-8859-15 oder UTF-8 um.
    Unter Extras, Einstellungen, Ansicht, Erweitert, dort ausgehende Nachrichten auswählen.
    Aber bitte unten keinen Haken machen.


    War die Mail in HTML oder in Reintext?
    Falls in Reintext, wundert mich die Kodierung "quoted printable" schon etwas.
    Normalerweise müsste dort 7-bit oder 8-bit stehen (beides unkodiert).
    Überprüfe daher mal in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten"), welchen Wert der Eintrag mail.strictly_mime bei dir hat.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Danke für die Antwort - habe das jetzt mal umgestellt, mal sehen, was der Kunde nun sagt.


    Nachricht war in HTML.
    Wert: mail.strictly_mime --> false

  • Zitat

    Nachricht war in HTML.


    Dann allerdings ist "quoted printable" OK.
    Die Einstellung ist auch OK.
    Ach ja, schicke dir doch selbst mal eine Mail und kontrolliere den Quelltext.
    Du kannst auch testweise, wenn du an andere schreibst, deine eigene Adresse als Bcc einzufügen.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "mrb" schrieb:


    Du kannst auch testweise, wenn du an andere schreibst, deine eigene Adresse als Bcc einzufügen.
    Gruß


    Das mache standardmäßig - nur habe ich nie mit Strg+U den Quelltext und hier die Zeichenkodierung überprüft. Bei mir sind die E-Mails dann immer lesbar.

  • So, habe jetzt gerade die Nachricht vom Kunden erhalten --> immer noch verunstaltet.


    Ergebnis seiner Antwort mit STRG+U:


    This is a multi-part message in MIME format.
    ------_=_NextPart_001_01CBB23C.801664E2
    Content-Type: text/plain;
    charset="UTF-8"
    Content-Transfer-Encoding: base64


    bei meiner mit BCC selbst an mich gesandten Mail:


    This is a multi-part message in MIME format.
    --------------050409050502090503060204
    Content-Type: text/plain; charset=ISO-8859-15; format=flowed
    Content-Transfer-Encoding: 8bit


    Liegt der Fehler jetzt bei mir oder bei dem Kunden???

  • Hallo,

    Zitat

    Content-Transfer-Encoding: base64


    hattest du bei dieser Mail einen Anhang beigefügt?
    Du hast nicht alle Parts der Deklarierung aufgeführt:

    Zitat

    This is a multi-part message in MIME format.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,

    "mrb" schrieb:

    Hallo,


    hattest du bei dieser Mail einen Anhang beigefügt?


    Nein, Anhang war nicht dabei - es handelte sich um eine "weitergeleitete" Nachricht und darauf die Antwort vom Kunden.

    Zitat


    Du hast nicht alle Parts der Deklarierung aufgeführt:


    Ich füge mal ein wenig mehr vom Quelltext bei...
    hier erst mal die Antwort vom Kunden...



    Bei <Inhalt entfernt> habe ich den eigentlichen Nachrichtentext gelöscht. Mir ist allerdings hierbei aufgefallen, dass der Nachrichtentext nicht in reiner Textform vorhanden ist, sondern eine "wirre" Zeichenfolge, welche ich eher als Darstellung eines Anhanges kenne.
    Beispiel:
    Zm9udCBzaXplPTEgY29sb3I9Z3JheSBmYWNlPVRhaG9tYT48c3BhbiBzdHlsZT0nZm9udC1zaXpl
    Og0KNy41cHQ7Zm9udC1mYW1pbHk6VGFob21hO2NvbG9yOmdyYXknPkRpZXNlIEUtTWFpbCBlbnRo


    und jetzt noch meine vorangegangene Mail an den Kunden...


    Hier fällt mir auf, dass als Zeichensatz ISO-8859-15 enthalten ist. In meinen Einstellungen steht aber ISO-8859-1.


    Gruß smokie

  • Hallo,

    Zitat

    Hier fällt mir auf, dass als Zeichensatz ISO-8859-15 enthalten ist. In meinen Einstellungen steht aber ISO-8859-1.


    Nun, ich nehme an du hattest unter Ansicht, Erweitert, keinen Haken in der untersten Option gemacht.
    Also übernimmt TB in diesem Fall (also beim Antworten und Weiterleiten) den Zeichensatz des Absenders, was auch sinnvoll ist.
    Oder bezieht sich deine Beschreibung auf von dir neu gesendete Mails?
    Dann allerdings stimmen deine Einstellungen nicht.
    Übrigens hat der Zeichensatz ISO-8859-1 den Nachteil, bestimmte Sonderzeichen nicht zu besitzen etwa das €-Zeichen,



    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    "mrb" schrieb:


    Nun, ich nehme an du hattest unter Ansicht, Erweitert, keinen Haken in der untersten Option gemacht.


    Das ist richtig. Kein Haken.

    Zitat

    Oder bezieht sich deine Beschreibung auf von dir neu gesendete Mails?


    Die Beschreibung bezog sich auf die neue mittels BCC an mich gesandte E-Mail.


    Gruß

  • Du hast also im bekannten Ansicht/Einstellungsmenü "Erweitert" bei ausgehenden Mails IS0-8859-1 eingestellt und die Mail wird mit -15 gesendet?
    Dann stimmt es etwas nicht.
    Überprüfe in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten") , ob dort der Eintrag mailnews.force_charset_override auf "false" (=default) steht.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,

    "mrb" schrieb:

    bei ausgehenden Mails IS0-8859-1 eingestellt und die Mail wird mit -15 gesendet? Dann stimmt es etwas nicht.


    Nicht unbedingt würde ich sagen. Wenn ISO-8859-1 zum Versenden eingestellt ist, eine Nachricht verfasst wird, in der sich ein Zeichen
    außerhalb der ISO-8859-1 befindet [z.B. €], sendet TB die Nachricht eigentlich mit dem Zeichensatz Windows-1252.
    Falls man das nicht möchte, kann es in der user.js eingestellt werden, welcher Zeichensatz stattdessen genommen werden soll.
    Vielleicht wurden ja da schon mal Änderungen vom TE vorgenommen? Dann müsste es aber auch entsprechende Einträge in der about:config
    dazu geben -->holgermetzger.de


    Gruß
    muellerpaul

    --
    Hier könnte Ihre Werbung stehen

  • "mrb" schrieb:


    Überprüfe in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten") , ob dort der Eintrag mailnews.force_charset_override auf "false" (=default) steht.


    Eintrag steht auf "false".

    "muellerpaul" schrieb:


    Vielleicht wurden ja da schon mal Änderungen vom TE vorgenommen? Dann müsste es aber auch entsprechende Einträge in der about:config
    <span>dazu geben -->holgermetzger.de" class="smarterwiki-linkify">http://www.holgermetzger.de/faqmailnews.html#29]holgermetzger.de[/url]</a></span>


    Damit kenne ich mich überhaupt nicht aus, von daher habe ich hier auch keine Einträge geändert, hinzugefügt etc.


    Gruß
    smokie

  • "muellerpaul" schrieb:

    Hallo,


    Nicht unbedingt würde ich sagen. Wenn ISO-8859-1 zum Versenden eingestellt ist, eine Nachricht verfasst wird, in der sich ein Zeichen
    außerhalb der ISO-8859-1 befindet [z.B. €], sendet TB die Nachricht eigentlich mit dem Zeichensatz Windows-1252.
    Falls man das nicht möchte, kann es in der user.js eingestellt werden, welcher Zeichensatz stattdessen genommen werden soll.


    Früher war das nicht so, da verhielt sich TB wie Outlook Express und der monierte das mit einer Fehlermeldung.
    Ich habe das aber schon lange nicht mehr getestet und ein paar Test gestern bestätigen deine Annahme.
    Insofern könnte also smokie durchaus Recht haben und der Zeichensatz wird von TB wegen des fehlenden €-Zeichen auf -15 verändert. Das muss ja nicht der Windows-Zeichensatz sein.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • smokie ,
    ich gehe also davon aus, dass deine Bcc Mails anschließend korrekt in TB dargestellt wurden und nur der Kunde das Problem hat?
    Manchmal hilft - das kannst du zunächst testweise machen - dass man permanent in quoted printable kodiren lässt, wenn man merkt, dass der Empfänger mit unkodiertem Zeichensatz (7-bit, 8-bit) nicht klarkommt.
    Hierzu in der erweiterten Konfiguration (Extras, Einstellungen, Erweitert, Allgemein, "Konfiguration bearbeiten")
    den Eintrag mail.strictly_mime auf true stellen.
    Beobachte nach dem Neustart von TB die Änderungen in der Deklarierung des Zeichensatzes.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw