Ab und zu keine Umlaute in der Darstellung (3.1.7 Mac)

  • Hallo,


    ich habe immer wieder das Problem, dass in einigen Nachrichten (Newsletter) keine Umlaute dargestellt werden. Ich habe mir zwar hier den einen oder anderen Tip durchgelesen (löschen von *.msf Datei oder Reparieren oder unter about_config den charset false Wert überprüfen usw.) Alles nichts. Es kommt zwar nicht unbedingt sehr oft vor aber eben so oft dass es etwas nervt.


    Hier ein kleiner Beispiel


    Codierung aus dem Header:


    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: multipart/mixed; boundary=0016e6dee7844eeb220498298a17
    Message-ID: <5ee12b2d4fb088e502a90b247502a7a238800923@eload24.com>
    X-Mailer: PHP/5.2.4-2ubuntu5.14
    X-Mailer-Script: /index
    Date: Thu, 20 Jan 2011 16:44:03 +0100
    X-KasLoop: m01e1398


    --0016e6dee7844eeb220498298a17
    Content-Type: multipart/alternative; boundary=0016e6dee7844eeb1c0498298a15


    --0016e6dee7844eeb1c0498298a15
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit


    Hmm, entweder finde ich es nicht oder darf ich kein Screenshoot anhängen deswegen nur als Text


    "Wichtig: Wer jetzt die Flatrate bucht, beh�lt die super-g�nstige Rate, so lange die Flatrate nicht gek�ndigt wird. Das ist unser zweites "


    Vielleicht hat jemand eine gute Idee dafür.


    Gruß Robert

  • Hallo,

    "RobiWan" schrieb:


    Hmm, entweder finde ich es nicht oder darf ich kein Screenshoot anhängen...


     :arrow: http://www.wintotal.de/Tipps/tipp865,rubrik5.html oder
    Anleitung zum Erstellen und Hochladen von Screenshots


    Bitte vor dem Posten die Abbildung mittels "Vorschau" überprüfen und persönliche Daten (falls vorhanden) anonymisieren!

  • Hallo,


    wie sieht denn der Quelltext [Strg+U] der geposteten Textpassage aus? An ihm könnte man es vielleicht
    eindeutiger festmachen, ob ein Einstellungsfehler bei dir, oder dem Versender vorliegt.


    Unabhängig davon, kommt mir etwas komisch vor: Die schwarze Raute mit dem Fragezeichen - als einzigen
    Platzhalter für Umlaute - sehe ich nur dann, wenn ich TB dazu zwinge eine ISO-8859-1, bzw.ISO-8859-15
    verfasste Nachricht in UTF-8 anzuzeigen. In deinem Fall ist der Zeichensatz der Nachricht aber als UTF-8 deklariert.


    Welchen Zeichensatz glaubt denn TB bei dieser Nachricht zu erkennen? ->Ansicht->Zeichencodierung
    Hast du dem Ordner, in der die Nachricht liegt, eine feste Zeichencodierung vorgegben? ->Eigenschaften


    Gruß
    muellerpaul

    --
    Hier könnte Ihre Werbung stehen

  • Hallo,


    also von hinten -
    - nein ich habe an den Ordnern Einstellungen nichts verändert d.h steht wie die Installation es vorgesehen hat. Unter Eigenschaften steht "Standard Zeichenkodierung Westlich iso-8859-15"
    - Unter Ansicht/ Zeichenkodierung ist UTF-8 ausgewählt. "Komisch" ist, wenn ich an der Stelle selbst iso-8859-15 auswähle, wird die Nachricht richtig also mit Umlauten angezeigt.
    - Die gleiche Nachricht wird mit dem Mac Mail Programm sofort richtig angezeigt.


    - Da die Nachricht als definiert ist, ist auch der Text 2x vorhanden


    Hier als "normaler" Text


    "Sie haben richtig gelesen. Sie zahlen für die
    Flatrate nur 24,- Euro im Jahr - statt dem regulären Preis
    von 48 Euro. Sie sparen also 50%.
    "


    Hier als HTML Teil


    "
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />


    ...
    ...
    <p>Sie haben richtig gelesen. <strong>Sie</strong> zahlen für die


    <strong>Flatrate nur 24,- Euro im Jahr</strong> - statt dem regulären Preis
    von 48 Euro. Sie <strong>sparen also 50%</strong>.</p>
    "


    Spontan wurde ich ja sagen irgendwelche Sachen passen in TB nicht zusammen/ übereinander. Nur welche - dafür kenn ich TB zu wenig.


    Gruß Robert

  • Hallo,
    ein typisches Beispiel für eine falsche Deklarierung.
    Die Mail ist in ISO-8859-15 geschrieben, aber in UTF-8 deklariert. Unter Ansicht, Zeichenkodierung zeigt ja TB den Zeichensatz an, der in der gerade geöffneten Mail deklariert ist. Der angezeigte Zeichensatz kann also bei jeder Mails anders sein. Da du durch Änderung auf iso-8859-15 die Mail korrekt darstellen kannst, ist der Fall klar.
    Leider kommen derartige Mails selten, aber leider immer wieder vor.
    Gegen solche Fehler ist TB machtlos, auch wenn der Mac es richtig macht. Letzteres kann aber ein Zufall sein und hängt von den Einstellungen ab. Würdest du Tb zwingen (was man kann) jede Mail in iso-8859-15 darzustellen, hätte es TB richtig macht. Diese Einstellung sollte man aber nie machen und man kann sie im normalen Menü gar nicht mehr aktivieren.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    OK so weit "fast" alles akzeptiert. da wäre noch ein kleines Aber - in der Mail gibt es ein Link "wenn die Darstellung falsch ist, dann im Browser abgucken". Wieso kann damit Safari und Firefox auch umgehen, nur TB nicht ?
    Auch wenn es ein Fehler des Absenders ist, schöner wäre es wenn TB etwas "zaubern" könnte ;)


    Gruß Robert

  • Hallo,

    "RobiWan" schrieb:

    in der Mail gibt es ein Link "wenn die Darstellung falsch ist, dann im Browser abgucken"


    na dann wissen die Versender zumindest um ihre Probleme ;-)
    Es gibt keinen Standard für HTML in E-Mails.


    Gruß
    muellerpaul

    --
    Hier könnte Ihre Werbung stehen