Weiterleiten von HTML-Mails

  • Thunderbird-Version 11.0.1:


    Hallo zusammen


    Ich möchte Nachrichten grundsätzlich im Reintext-Format senden, empfangene HTML-Mails aber als HTML weiterleiten.
    Die Lösung mit der Umschalttaste ist für mich nicht praktikabel, da ich einige automatische Weiterleitungen über Filter habe. Kann ich das irgendwie realisieren?


    Schönen Dank schon mal
    Christian

  • Hast du denn alle Konten für HTML konfiguriert?


    Benutze das Add-on
    QuoteAndComposeManager
    Dort gibt es eine Option, die zum Öffnen des HTML-Fenster erzwingt (im Reiter "Verfassen-fenster").


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb


    Vielleicht habe ich mich missverständlich ausgedrückt.
    Ich möchte bei Mails, die ich schreibe (über 'Verfassen') eben kein HTML benutzen. Deshalb kann ich die Konten auch nicht auf HTML umstellen. Ich habe Filter, die bestimmte Mails, die im HTML-Format ankommen, automatisch weiterleiten. Diese Mails sollen als HTML weitergeleitet werden.


    Ich lese jetzt zum wiederholten Mal (auch bei dem von dir verlinkten Add-On), dass Thunderbird Mails beim Verfassen nicht als HTML-Mail sendet, wenn keine Formatierung enthalten ist. Das funktioniert bei mir so nicht. Es wird immer HTML gesendet. Kann dazu jemand was sagen?
    Achja, Thunderbird läuft hier unter Linux.


    Schöne Grüße
    Christian

  • "Mailfrosch" schrieb:

    ... Achja, Thunderbird läuft hier unter Linux.


    Hallo Mailfrosch,


    Linux ist ein weites Feld ... ;-)


    Könntest Du ein klein wenig präziser werden?


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Moin;


    ich nutze es nicht, deshalb kann ich nur eine Vermutung anstellen......
    Es gibt die Möglichkeit vorzugeben, welche Domain welches Format haben soll. Hier könntest Du Deine "Weiterleitungsdomain" eintragen und sie würde immer HTML erhalten.
    Ansonsten kann man iwo einstellen, das der TB immer beide Formate schicken soll, also Plaintext und HTML.


    Ich denke das die Kombination hilfreich ist, neben der Einstellung das selbstverfasste Mails Plaintext sein sollen.


    Greetz

  • Hallo DerCrabbe


    Leider funktioniert das auch nicht so wie ich das brauche. Wenn in den Konteneinstellungen HTML beim Verfassen ausgeschaltet ist, wird kein HTML weitergeleitet, auch wenn Domains eingetragen sind.
    Abgesehen davon brauche ich die Unterscheidung auch zwischen verschiedenen Adressen innerhalb einer Domain.


    Schöne Grüße
    Christian

  • Moin Christian;


    mir ist auch schon aufgefallen, das es hier anscheinend ein kleines Problem gibt (erhalte ich eine Mail, die nur ein Bild enthält, wird es nicht dargestellt und auch kein Hinweis angezeigt das ein Bild enthalten ist. Stelle ich das Konto `auf HTML um´, wird das Bild logischerweise angezeigt. *hrmpf*)


    Da ich für mein Problem keine wirklich praktikable Lösung gefunden habe, kann ich nicht wirklich helfen. Allerdings bin ich heute morgen über dieses Addon gestolpert, das eventuell Dir weiterhelfen könnte: Outgoing Message Format.


    Greetz

  • Zitat

    Ich möchte Nachrichten grundsätzlich im Reintext-Format senden, empfangene HTML-Mails aber als HTML weiterleiten.


    Meine Antwort bezog sich auf genau diese Aussage.
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo DerCrabbe


    Ich bräuchte genau das, was eigentlich ohne das von dir verlinkte Add-On funktionieren sollte:
    Without the addon, when "always HTML" option is enabled in TB, and one sends an unformatted email, TB will send it in plaintext format.
    Aber das funktioniert bei mir nicht, vielleicht ist es auch ein Linux Problem, ich werde das mal unter Windows testen.


    Dein Problem mit den Bildern kenne ich auch. Bei der Anzeige habe ich inzwischen fest auf HTML umgestellt.



    Schöne Grüße
    Christian

  • Moin Christian;


    Du hast sicherlich schon mit den ganzen Einstellungen gespielt und folgende Konstellation getestet?
    Die gewünschten HTML Adressaten im Adressbuch aufgenommen und als HTML eingestuft. Außerdem das versenden der Mails als "Reintext und HTML" eingestellt, sowie den Haken für "Mail in HTML verfassen" im Konto rausgenommen.


    Nach meinem Verständnis (durch lesen der Einstellmöglichkeiten) sollte sich Deine Szenario dadurch abbilden lassen.


    Und um mrb nicht zu verärgern, das Addon bietet Deine gewünschte Möglichkeit nicht? Ich haeb mrb bislang als sehr kompetent kennen gelernt. Wenn er etwas sagt, sollte man das lieber einmal mehr kontrollieren, bevor es einfach abgetan wird.


    Auch wenn ich lieber ohne Addon meine gewünschte Funktion abbilden würde.....wenn es ohne nicht geht, geht es eben nicht ohne. :nixweiss:


    Greetz


    P.S.: Möglich das ich wieder was in den falschen Hals bekommen habe, aber ich hatte jetzt keine Lust das ganze geschriebene wegzuschmeissen oder umzutexten. :) :redface:

  • Es ist durchaus möglich, dass Add-ons auf Linux nicht wie auf Windows funktionieren.
    Das genannte Add-on ist Standard um den oft häufigen Wechsel von Schriftart und -größe in Thunderbird (der schon in Version 1.0 bestand und als nicht gefixter Bug anzusehen ist) zu stabilisieren.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • DerCrabbe
    Mit deinen vorgeschlagenen Einstellungen funktioniert es leider nicht.


    Ich gebe zu, dass ich bei dem Beitrag von mrb den Eindruck hatte, dass meine Problembeschreibung überhaupt nicht richtig gelesen wurde. Ich finde jedenfalls in der Beschreibung und den Einstellmöglichkeiten zu dem Add-On nichts, was mich weiterbringen würde. Ich werde es aber bei Gelegenheit noch mal ausführlich testen.


    Ich habe jetzt das Ganze unter Windows versucht. Dort funktioniert es so, wie alle schreiben: Beim Verfassen ohne Formatierung wird Plaintext gesendet. Das wäre für mich die Lösung, geht aber nicht mit Linux. Möglicherweise ein Problem mit den Schriftarten.
    Wenn ich wieder mehr Zeit habe, werde ich mich weiter damit beschäftigen.


    Schönen Dank an alle
    Christian