Profil nach Neuinstallation Wiederherstellung n. in Ordnung

  • Thunderbird-14.0:
    Windows 7 Home Premium SP1:
    POP & IMAP:
    mehrere, unter anderem gmx:


    Auf meinem Laptop ist die Festplatte kaputt gegangen. Ich konnte die Profile gerade noch retten, bevor ich den Laptop zum Service gebracht habe. Ich hatte aber eindeutig die frühere Version von Thunderbird. Nach paar Wochen hatte ich Laptop mit neuer Festplatte (und nacktem System) zurück.
    Ich habe die neuste Version von Thunderbird installiert und UPS - gestartet, ohne Profile reinzukopieren...
    Die wurden auf separater Festplatte gesichert.
    Dann habe ich die Profile nach und nach auf alle möglichen Weisen versucht wiederherzustellen - ohne Erfolg.
    Erst mal habe ich aus backup\c\users\user\appdata\local\Thunderbird alles übernommen => Thunderbird gestartet - kommt das Fenster zum Erstellen eines neuen Accouts. Von Adressen/Mails/EMail-Kontos - keine Spur.
    Dann mal dasselbe aus backup\c\users\user\appdata\roaming\Thunderbird (da waren anscheinend die richtigen Profile) übernommen => Thunderbird gestartet - wieder dasselbe Fenster und von meinen Daten keine Spur...
    thunderbird.exe --profilemanager => nacheinander mit beiden verfügbaren Profilen ausprobiert => ohne Erfolg.


    Habe profiles.ini selber editiert, um zu prüfen, ob da nicht der Pfad falsch ist => Pfad angepasst => Thunderbird gestartet => Fehler ... Der ging gar nicht mehr hoch.
    Also daran lag es auch nicht.


    Dann habe ich im Internet gesehen, dass die Indizes evtl. neu gebildet werden müssen. Also habe ich nach Anleitung alle msf-Dateien rausgelöscht...
    Kein Erfolg. :wall:


    Ich habe irgendwann mal die erweiterten Einstellungen von Thunderbird auf gehabt und die geänderten Werte gesehen. Da gab es die Einstellung browser.cache.disk.smart_size.first_run, die auf false gesetzt wurde. Ich habe dann den Verdacht gehabt, dass die Konvertierung des Formates erforderlich ist, die nur beim ersten Start losgetriggert wird... :?:


    Zwischendurch habe ich in die Fehlerkonsole reingeschaut. Da stand der Fehler beim Laden einer Datei aus dem Profil. Das war glaube ich die Datei, die zur DE-Dictionary Extension gehört. Ich habe auch mal vorsichtshalber alle Dateien aus dem Profil-Unterordner extensions gelöscht, da ich dachte, dass die Extensions noch nicht installiert sind und zur Problemen führen könnten => nichts gebracht... :wall:


    Ich bin langsam am Ende meiner Fantasie angelangt. Bin selbst Softwareentwickler und habe deswegen bisschen Ahnung, was man so alles ausprobieren kann... :)


    Kann mir da jemand was empfehlen, bevor ich einen Bug-Report erfasse?


    Mit freundlichen Grüßen
    Konstantin

  • Hallo Konstantin,


    wenn ich mich nicht irre, dann sollte die Reihenfolge in so einem Fall doch so sein:


    1. Das gesicherte Profil auf die neue Platte kopieren und erst danach
    2. das Donnervogel-Programm neu installieren.


    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Hallo Konstantin.


    "alles mögliche ausprobieren" kann vielleicht auch zum Ziel führen, aber man kann es auch einfach gleich richtig machen, wie hier beschrieben.
    So ähnlich hast du es ja gemacht - aber irgendeine Kleinigkeit übersehen. Hast du die Profile (den Ordner profiles mit sämtlichen Inhalt) und die Profiles.ini unverändert übernommen und nach c:\users\<user>\appdata\roaming\Thunderbird\ kopiert?


    Welchen Pfad hast du angegeben, als du den Versuch mit dem Profilmanager unternommen hast?


    Feuerdrache : Solange man den TB noch nicht startet, dürfte es doch keine Rolle spielen, wann man das Profil (oder die Profile) kopiert?


    Gruß, muzel

  • Hallo muzel,


    das was Du Konstantin als Lektüre-Hinweis empfiehlst (Stichwort: hier) sagt doch genau das aus:



    Gruß
    Feuerdrache

    „Innerhalb der Computergemeinschaft lebt man nach der Grundregel, die Gegenwart sei ein Programmfehler, der in der nächsten Ausgabe behoben sein wird.“
    Clifford Stoll, amerik. Astrophysiker u. Computer-Pionier

  • Hallo Feuerdrache,


    das ist eine richtige Vorgehensweise, aber nicht die einzige. Es ist vollkommen egal, ob TB schon installiert ist, solange er nicht gestartet wird, sein Profil nicht findet und ein neues anlegt.


    Grüße, muzel

  • Hallo,
    das Problem dabei ist doch, dass bei einer Neuinstallation TB bzw. der Kontenassistent fragt, ob er ein Konto einrichten möchte. Bricht man das ab, wird ein neues Profil erzeugt. Das ist nicht weiter schlimm, kompliziert aber für unerfahrene User das Handling.
    Ist aber der gesamte Profilordner mit dem alten Profil schon vorhanden, kann u.U., selbst wenn der Pfad korrekt ist,
    der Pfad in der profiles.ini falsch sein, wenn man z.B. einen kompletten Profilordner aus WinXP auf Win7 einkopiert hat.
    Der für den User einfachste Weg ist daher der, zunächst TB zu installieren, ein Profil anlegen zu lassen (durch Abbruch der Kontenassistenten), und dann den Inhalt des alten Profils in das neue zu kopieren. Bei virginen Profilen erübrigt sich dabei das vorherigen Löschen des Inhalts des neuen Profils.
    Hierbei ist nur daran zu denken, TB vorher zu beenden, das Profil wird auf jeden Fall gefunden, da Name und Pfad in der profiles.ini korrekt sind.
    Wer das Ganze schon öfter durchgezogen/trainiert hat, kommt aber sicher mit allen 3 Anleitungen zurecht.
    Da ich mit mehreren Profilen, die sich auf einer zweiten Festplatte befinden zu tun habe, bevorzuge ich persönlich, die Änderungen in der profiles.ini, da sie mir einen genauen Überblick gibt.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    nur, um es für spätere Leser ganz klar zu sagen:


    es ist vollkommen egal, ob man erst das Profil kopiert und dann TB installiert oder umgekehrt, der Zeitpunkt der Installation hat nichts mit dem Anlegen des Profils zu tun. Also nicht die Installation des Donnervogels, sondern erst der erste Start nach der Installation führt zum Anlegen oder Übernehmen des Profils und ab dann gilt, was mrb beschreibt.


  • Mit dem Neuinstallieren ist das einzige, was ich noch nicht ausprobiert habe. Das halte ich aber auch für unwahrscheinlich, dass es hilft, denn man kann ja beim hinzufügen der Profile auch eigenen Ordner auswählen, sodass wenn ich die gesicherte Profile dann auswähle, diese dann importiert werden müssten... :) Probiere aber glaube ich auch noch aus.

  • Vielen Dank allen für die Vorschläge.


    Ich habe eigentlich schon nach Einleitung gemacht. In der Anleitung steht doch auch, dass man auch nach dem ersten Start einfach die Profile + profiles.ini reinkopieren kann. So habe ich auch gemacht, aber ohne Erfolg. Natürlich erst mal unverändert und alles wie es ist. Hab Windows 7 und habe sicherheitshalber bei der Übernahme beide Verzeichnisse vom alten Rechner übernommen: c:\users\user\appdata\local\Thunderbird und c:\users\user\appdata\roaming\Thunderbird. Das hat aber nichts gebracht.


    Aber auf Nummer sicher zu gehen, habe ich jetzt folgendes gemacht:
    - Thunderbird deinstalliert
    - dann beide oben genannten Verzeichnisse gelöscht
    - c:\users\user\appdata\roaming\Thunderbird von der Sicherung übernommen (unverändert reinkopiert)
    - Thunderbird-Installer für 14.0 noch mal heruntergeladen
    - Installiert
    - Gestartet - kommt wieder der Kontenassistent und keine Spur von meinen Daten.


    Da es nicht geholfen hat, habe ich gleich anderen Vorschlag ausprobiert:
    - also noch alles gelöscht
    - Thunderbird gestartet - Assistent abgebrochen - Thunderbird geschlossen
    - ins c:\users\user\AppData\Roaming\Thunderbird\Profiles\g4lxn8uy.default reingegangen. Hab alles rausgelöscht und Inhalt aus meinem Profil reinkopiert.
    - Thunderbird --profilemanager gestartet - es gibt auch nur ein Profil - starten => Assistent und keine Spur von meinen Daten... :wall::wall::wall:

  • Zitat

    c:\users\user\appdata\local\Thunderbird


    Dieses Verzeichnis braucht man nicht.
    Ansonsten musst du etwas falsch gemacht haben. Hattest du vorher ein älteres Betriebssystem?
    Wie auch immer, öffne die Datei profiles.ini mit einem Editor und überprüfe die Richtigkeit der dortigen Pfade und des Profilnamens. Ist dort auch nur ein einziger kleiner Fehler, findet TB das Profil nicht.

    Zitat

    c:\users\user\AppData\Roaming\Thunderbird\Profiles\g4lxn8uy.default reingegangen. Hab alles rausgelöscht und Inhalt aus meinem Profil reinkopiert.


    Was hast du rausgelöscht aus welchem Ordner?

    Zitat

    Thunderbird --profilemanager gestartet - es gibt auch nur ein Profil - starten => Assistent und keine Spur von meinen Daten


    Ja, dort sollte auch nur ein Profil sein. Hast du im Profilordner "Profiles" etwa jetzt 2 Profile?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Mit fällt noch etwas ein:
    du hast die Besitzrechte des TB-Profils?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw