Thunderbird versendet "falsche" Fotos in Mail!

  • Thunderbird-Version: 14.0
    Betriebssystem + Version: Windows XP Professional
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): 1und1


    Hallo zusammen,
    ich habe folgendes dringliches Problem: Nach Speichern einer Mail als "Entwurf" oder "Vorlage" und anschließendem erneuter (Text-)bearbeitung sendet Thunderbird völlig andere als die von mir ursprünglich in die Mail eingebunden Fotos! Vor dem Senden sagt das Programm (manchmal, nicht immer) Anhängen der Datei...Und hängt dann was anderes an (z.B. private Fotos in beruflicher Mail: :(
    Vieeelen Dank für eine Idee oder Lösung

    Einmal editiert, zuletzt von rum () aus folgendem Grund: BBCode eingeschaltet

  • "thunderbolt" schrieb:

    (z.B. private Fotos in beruflicher Mail


    Na das nenne ich mal ein feature! Aber es kommt irgendwie zu spät. Mr. Zuckermountain war schneller ;-)

  • Danke, liebe(r) rum, ich denke, das wars. susi tux. danke für mitgefühl. ist allerdings nur halb-lustig, wenn einem beim ABSENDEN noch die richtigen fotos angezeigt werden, auf der anderen seite aber falsche ankommen....

  • Hallo thunderbolt,


    "thunderbolt" schrieb:

    ... ist allerdings nur halb-lustig


    Ja, das glaub' ich wohl, selbst in Zeiten des e,- , i- oder f-books, in denen es vielen egal scheint, was für Fotos von Ihnen so in der Cloud sind. Ich möchte ja auch nicht, dass jeder Susi auf der Wolke sehen kann ;-)


    Ernsthaft, von solch einer schlimmen Auswirkung eines defekten Index' habe ich bisher noch nicht gehört. Ich frage mich, wie das passieren kann. Ich kann mir ehrlich gesagt nicht vorstellen, dass ein defekter Index dafür ursächlich ist. Die Wahrscheinlichkeit, dass ein zufälliger Fehler zu einer tatsächlich vorhandenen Datei führt, geht gegen null. Woher soll der TB den Pfad und den Dateinamen einer ganz anderen Datei kennen? Der einzige "Index", von dem ich mir das erklären könnte, wäre der des Filesystems. (ein fsck, unter Windows glaub' ich chkdsk, sollte den Fehler reparieren. Aber ich rate ausdrücklich nicht zum chkdsk ohne Backup)


    Einen Fehler im Cache des TB könnte ich mir ebenfalls als Ursache vorstellen. Hast Du besagte Bilder zuvor privat per E-Mail verschickt? Oder kann es sein, dass in der Zeit zwischen Entwurf und Versenden Änderungen im Verzeichnis oder bzgl. der Dateinamen stattfanden?


    Gruß


    Susanne

  • Ich muss mal auf dieses alte Thema antworten, da mich die selben Probleme plagen.


    Wenn ich eine E-Mail mit z.B. einer Auftragsbestätigung versende, prüfe ich immer vorher, ob es der richtige Anhang ist.
    Jetzt habe ich es schon 3-4 mal gehabt, dass mich der Gegenüber angeschrieben hat, das der Anhang ja garnicht für ihn sei. Er sendet mir die Nachricht zurück
    und im Anhang ist jedesmal eine bestimmte Gutschrift, die ein Kunde von mir irgendwann einmal erhalten hat.


    Eine Reparatur des Index in jedem Ordner hat keine Besserung gebracht.


    Weis jemand Rat ?


    PS: Es handelt sich bei mir nicht um Bilddateien, sondern um eine PDF.

  • Hallo,


    ich sende geschäft. sehr viele Mails mit Anhang raus und hatte noch nie ein Problem seitens TB damit.
    Eher schon mit mir, deshalb öffne ich jeden Anhang im Verfassen-Fenster noch mal, weil ich schon falsche Anhänge angehängt habe :stupid:
    Ich würde mal eine Zeit lang die Mails erst mit Später Senden in den Postausgang legen und dort die Anhänge kontrollieren.


    Da mein Profil sowie ausgehende Mails nicht vom Virenscanner gescannt werden, ist es selbstverständlich, dass ich grundsätzlich alle Anhänge aktuell vor dem Anhängen im jeweiligen Ordner außerhalb von TB scanne, auch dann, wenn die Datei vor geraumer Zeit bereits mal gescannt wurde.

  • Hallo Lazzard,


    ich kann mich hier nur rum anschließen.
    Im Verlauf der Jahre habe ich einige 10.000 Mails mit dem Thunderbird verschickt. Davon auch etliche mit Anhängen. Und ich habe wirklich noch nie eine Mitteilung wegen eines falschen Anhanges bekommen.
    Und da ich meine Mails grundsätzlich mit elektronischer Signatur versende, kann ich mit Bestimmtheit sagen, dass alle meine Mails (incl. der Anhänge) bitgenau übertragen wurden.


    Trotzdem glaube ich dir selbstverständlich, dass bei dir der beschriebene Effekt eintritt! Ich will das also keinesfalls "wegdiskutieren".


    Deswegen schlage ich dir folgendes vor:
    1.) Sende alle Mails per BCC an dich selbst! Der Empfang der eigenen Mails und nur das ist die ultimative Sendebestätigung!
    2.) Schau dir die Anhänge der empfangenen Mails an. Sind sie korrekt oder nicht? [Ab hier, wenn nicht korrekt!]
    3.) Handelt es sich bei den Empfängern um Anhänge, welche von dir stammen?
    4.) Liegen diese bei dir im gleichen Ordner, wie die gewünschten Anhänge?
    5.) Welcher Dateiname ist im Quelltext der gesendeten (Ordner "Gesendet") und der wieder erhaltenen Mail sichtbar?



    Wie gesagt, ich kenne keine Ursache. Aber wir können versuchen, ihr gemeinsam auf die Spur zu kommen.



    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Leute,


    keine Angst, ich verstehe das sicherlich nicht falsch. Tausende von Benutzer arbeiten problemlos mit Thunderbird. Ich ja ebenfalls.
    Nur irgendwann taucht halt dieser nicht reproduzierbare Fehler auf. Ich rege mich da ja selbst auf, dass ich nicht finde womit dies zusammenhängt. Ich versende wirklich viele E-Mails und diese auch ohne Probleme, nur irgendwann ca. 2-3 im Jahr taucht dieser Fehler auf. Ich nutze den Thunderbird wirklich intensiv und habe nur für dieses Jahr rund 20.000 Mails im Postausgang, da ist es wirklich zu verschmerzen, dass der Fehler 2-3 mal im Jahr auftaucht. Aber es ist schon unangenehm, wenn ein Kunde, den Anhang eines anderen Kunden bekommt. Vorallem handelt es sich immer wieder um die selbe PDF Datei. Der Dateiname ist ja auch beim zurücksenden des Kunden genau der, von der richtigen Datei, nur wenn man diese aufmacht, sieht man die falsche pdf. Ganz ganz merkwürdig.


    Ich habe die original Datei ja bereits gesucht, ob ich die irgendwo noch im Ordner "versendet", aber nein. Die Datei ist aus 2011 und taucht irgendwie immer mal wieder auf. Ich weis leider auch nicht, wie der original Dateiname einmal gewesen ist, sonst hätte ich danach mal gesucht. Die Ordner im Thunderbird habe ich bereits durchsucht, zumindestens nach E-Mails in diesem Zeitraum. Aber nein, ich finde nicht dazu.


    Dein Rat mit dem BCC ist sicherlich richtig, jedoch wenn ich den Inhalt dann sehe, ist die Mail ja bereits zum Kunden raus.

  • Hallo,


    deshalb

    "Lazzard" schrieb:

    Dein Rat mit dem BCC ist sicherlich richtig, jedoch wenn ich den Inhalt dann sehe, ist die Mail ja bereits zum Kunden raus.

    sagte ich

    "rum" schrieb:

    Ich würde mal eine Zeit lang die Mails erst mit Später Senden in den Postausgang legen und dort die Anhänge kontrollieren.



    Was steht denn im Quelltext der Mail beim Anhang?

    Zitat

    Ich habe die original Datei ja bereits gesucht, ob ich die irgendwo noch im Ordner "versendet", aber nein. Die Datei ist aus 2011

    Hast du mal die tmp-Ordner durchgesehen, scheinbar bedient sich der Donnervogel ja dort.
    Wenn du, was man ja nie tun sollte, direkt in TB einen Anhang öffnest, wird der aus der Mail heraus in den tmp-Speicher decodiert und von dort angezeigt. Das ist auch der Grund, warum man beim direkten Bearbeiten eines so geöffneten Anhanges nicht direkt auf Speichern gehen kann, sondern mit "Speichern unter" einen "normalen" Platz zuordnen muss.