Windows 7: Update nicht möglich ("Laufende TB prozesse")

  • Thunderbird-Version: ca. seit V10, zuletzt bei V14
    Betriebssystem + Version: Windows 7 Ultimate x64


    Hallo,


    seit mindestens Version 10 funktionieren bei mir die automatischen Updates nicht mehr. Es heißt immer (sinngemäß), "es laufen noch andere Thunderbird-Prozesse"; auch die "Eskalationsstufe" des Updates will schlicht nicht.


    Ich habe bei V13 schon eine komplette Neuinstallation von TB gemacht, vorher viel mit Dateibesitzern und -rechten rumgespielt, ohne Erfolg.
    In die Suppe spucken könnten Free-AV "Avira" und Comodo Firewall, aber ich hatte die eben beide deaktiviert, ohne Erfolg. "Als Administrator ausführen" hilft auch nicht.


    Ich muß jedesmal das komplette Paket runterladen und installieren, was schon irgendwie lästig ist.


    Ich bin offenbar nicht der einzige mit diesem Problem, aber bislang fand ich keine Lösung, die mir weiterhilft.


    Hat jemand noch Lösungsvorschläge parat?



    danke


    Faroul

  • Nachtrag: auf einem mehr oder minder identischen Win7-System funktioniert es einwandfrei.


    Jetzt stellt sich mir also die Frage: wie kann ich feststellen, was da quer läuft?


    Irgendein Prozess/Programm muß da ja etwas sperren/verhindern, daß das Update meint, es liefe noch ein TB-Prozess.


    Ich hatte mir mal das Install-Log angesehen, fand aber keine (für mich brauchbare) Erkenntnis darin.


    Faroul

  • Hallo Faroul und willkommen im Thunderbird-Forum,


    zwei mögliche Fehlerquellen:
    1. Betriebssystem
    2. Thunderbird-Profil


    Kopiere mal das TB-Profil von der funktionierenden Installation auf den anderen Rechner und binde es ein.
    Starte den Profilmanager und damit das nun neue Profil. Hast Du das gleiche Problem?


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 32 Bit | Firefox 64 Bit | Avira Free Security Suite

  • Ich kann mich nur den Vorrednern anschliessen. Thunderbird-Update (auf meiner Maschine - Windows 7 64 bit - !, nicht auf anderen meiner Familie) funktioniert einfach nicht. Und das schon seit Version < 10 (glaube ich).


    Ich habe mittlerweile auch schon einmal den Versuch gemacht, Thunderbird zu deinstallieren, neu mit einer Update-Version zu installieren, in der Hoffnung, dass nachfolgende Updates wieder regulär via Thunderbird selber installiert werden. Hat nicht funktioniert, und wie gesagt - es nervt. Firefox hat auf meiner Maschine diese Probleme nicht.


    Eigentlich sollten die Entwickler doch in der Lage sein, dieses Problem mal endlich anzugehen - diese mysteriöse Fehlermeldung, dass ein Thunderbird-Prozess noch läuft (derselbe, der sich darüber beschwert?).


    Gerade eben habe ich Version 16.1 neu installiert. Als dann der Installationsprozess die neue Version startete, fand die offenbar die Überbleibsel des vorigen Versuchs eines automatischen Updates - und beschwerte sich wieder. Runter fahren, wieder hoch: dieselbe nervige Fehlermeldung! Ätzend.


    Weiß jemand, welche Dateien/Verzeichnisse hier zu löschen sind?


    Ich habe mal meinen System-Tempordner gelöscht und in %appdata% gesucht, ob ich da was verdächtiges zu Thunderbird finde. Hat nichts gebracht.
    Dann habe ich noch einen Mitschnitt vom ProcessMonitor, der den Start von Thunderbird protokolliert. Ich selber kann damit aber nicht fündig werden. Gibt's hier Entwickler, die damit etwas anfangen könnten? Könnte ein csv-Datei schicken.

    Einmal editiert, zuletzt von carlolf ()

  • Hallo carloff (schön, begrüßt zu werden, oder?) und willkommen im Thunderbird-Forum,


    überprüfe, ob die Datei parent.lock im Profilverzeichnis liegt. Wenn ja, lösche sie.


    Gruß
    slengfe

    Meine Beiträge sind subjektiv und manipulativ, erheben Anspruch auf Allwissenheit und können Spuren von Ironie oder Sarkasmus enthalten.


    Windows 10 Professional 64 Bit | Thunderbird 32 Bit | Firefox 64 Bit | Avira Free Security Suite

  • Hallo,


    es gibt außer dem versteckten Profilordner


    C:\Dokumente und Einstellungen\%Benutzer%\Anwendungsdaten\Thunderbird\Profiles


    auch einen Ordner für Caches und Update.


    C:\Dokumente und Einstellungen\%Benutzer%\Lokale Einstellungen\Anwendungsdaten\Thunderbird\Profiles


    löscht den mal vor der Installation.

  • 1) "parent.lock" im Ordner "C:\Users\%benutzername%\AppData\Roaming\Thunderbird\Profiles\zam9h4jd.default" gefunden und gelöscht - brachte nichts. Die Datei wird danach auch wieder angelegt.


    2) C:\Dokumente und Einstellungen\%benutzername%\Lokale Einstellungen\Anwendungsdaten\Thunderbird\Profiles\zam9h4jd.default hat diverse Dateien und Verzeichnisse. Habe die Cache-Ordner gelöscht - weiter die Meldung wegen fehlgeschlagenem Update. Die Cache-Ordner werden wieder angelegt.


    3) es gibt aber noch "C:\Dokumente und Einstellungen\%benutzername%\Lokale Einstellungen\Anwendungsdaten\Thunderbird\thunderbird" mit einem "updates"-Subverzeichnis. Den habe ich komplett gelöscht - jetzt ist Ruhe.

  • Hallo,


    sorry,

    "rum" schrieb:

    C:\Dokumente und Einstellungen\%Benutzer%\Anwendungsdaten\Thunderbird\Profiles

    das Profiles habe ich versehentlich nicht gelöscht, ich meinte den gesamten Ordner ab Thunderbird, deshalb sagte ich

    "rum" schrieb:


    ...auch einen Ordner für Caches und Update.

    als Löschempfehlung.
    Aber du warst ja schlau genug :zustimm:

  • Es NERVT! Ich weiß nicht mehr, wieviele Updates ich mittlerweile eingespielt habe, und jedesmal tricksen musste. Oft habe ich in letzter Zeit einfach neu installiert - brachte aber nicht die erhoffte Wirkung.
    Leider habe ich keinen Schimmer, warum das schief geht. Alle verwendeten Verzeichnisse habe mich als vollberechtigten Besitzer.
    Im updatelog steht: "NS_main: file in use - failed to exclusively open executable file: D:\Programme\Mozilla Thunderbird\thunderbird.exe". Warum das nicht geht, wo doch Firefox das problemlos kann - keine Ahnung. Auf anderen PCs mit Windows 7 und Vista in meiner Familie gibt's dieses Problem nicht.