Thunderbird Rechtschreibung markiert Teile von Wörtern

  • Hallo zusammen,


    wie oben schon beschrieben habe ich Probleme mit der Rechtschreibung. Beizeiten markiert TB Bruchteile von Wörten als fehlerhaft, obwohl dies natürlich schwachsinnig ist, denn entweder ganz oder garnicht. Bei TB 16 hatte ich die Probleme auch schon, hatte die Wörterbücher auch schon ausgetauscht, jedoch ohne eine Besserung!
    Ich hatte auch schon Mal in den Neuerungen von TB 17 gelesen, das genau dieses Problem nun erledigt sein sollte, bei mir aber leider nicht.


    Ich hoffe mir schreibt jetzt keiner, das ich doch bitte meine Texte über Office gestalten soll und dann in TB einfüge, das taugt überhaupt nicht!


    Gibt es Lösungen?



    Vielen Dank für Euer Bemühen!




    [IMG:http://up.picr.de/12584608zh.jpg]


    VG
    N8falke




    TB 17:
    Win7 64bit:

  • Hallo,


    warum hast du die von uns gewünschten 4 Fragen nicht beantwortet? Wir möchten dadurch unnötige und zeitkostende Nachfragen vermeiden.
    Weiterhin wäre eine Info über die verwendete Sicherheitssoftware interessant und ob sie das TB-Profil abscannen darf.
    Sicherlich ist ein Fehler im Profil für das Problem zuständig.


    Starte bitte mal TB im safe-mode (= > Hilfe > "mit deaktivierten Add-ons neu starten...") und überprüfe dort das Verhalten.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • "N8falke" schrieb:


    Ich hatte auch schon Mal in den Neuerungen von TB 17 gelesen, das genau dieses Problem nun erledigt sein sollte, bei mir aber leider nicht.
    TB 17:
    Win7 64bit:


    Hallo,
    Bug 790475 --> https://bugzilla.mozilla.org/show_bug.cgi?id=790475
    Eigentlich sollte des Problem in der Version TB 17 gelöst sein, es scheint aber noch bei einigen Nutzern weiter zu bestehen.
    Hast du schon mal Reintext versucht?
    Oder in HTML einen anderen Schrifttyp?

  • Tut mir Leid, ich erwarte die obligatorischen Fragen nicht am Ende des ersten Beitrags, und ich erwarte sie in einer bestimmten Breite:
    Thunderbird-Version:
    Betriebssystem + Version:


    Mapenzi ,
    die Ausgangsfrage in Bugzilla bezieht sich ja auf einen Mac, so dass der Bug sich nicht unbedingt auf andere Versionen auswirkt und in den vielen weiteren Antworten sehe ich keinen eindeutigen Zusammenhang mit Windows.
    Auch z.B. hier: Spell check problem in version 16
    sagt kaum ein User sein Betriebssystem.
    Erfahrungsgemäß kommen viele Bugs auf dem Mac nicht zwangsläufig auch in Windows vor und umgekehrt.
    Ich habe hier den Fehler wie beschrieben versucht zu provozieren in mehreren Sprachen ohne ein zutreffendes Ergebnis, auch mit verschiedenen Fonts.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • "mrb" schrieb:


    Mapenzi ,
    die Ausgangsfrage in Bugzilla bezieht sich ja auf einen Mac, so dass der Bug sich nicht unbedingt auf andere Versionen und in den vielen weiteren Antworten sehe ich keinen eindeutigen Zusammenhang mit Windows.


    Stimmt, der Bug report wurde von einem Mac user erstellt, aber spätesten in comment #23 meldet sich ein Win user zu Wort und in #26 ein Linux user, beide haben das selbe Problem.

    Zitat

    Auch z.B. hier: Spell check problem in version 16 sagt kaum ein User sein Betriebssystem.


    Den Thread habe ich schon vor einiger Zeit gelesen, daher ist mir auch sofort die Übereinstimmung der Bildschirmfotos in N8falkes Beitrag und diesem Beitrag des Threads aufgefallen:
    http://forums.mozillazine.org/….php?p=12383393#p12383393
    Es genügt, sich im mozillazine.org Forum einzuloggen, und dann kann man sehen, dass unter jedem Beitrag das Betriebssystem des Erstellers angezeigt wird. Ich habe in diesem Thread 16 Win user und 6 Mac user gezählt, die das selbe Problem in der Version 16 haben, einer von ihnen sogar noch nach dem Update auf TB 17.
    Ich glaube also nicht, dass ich leichtfertig oder unüberlegt den Zusammenhang mit Bug 790475 aufgedeutet habe.

    Zitat

    Erfahrungsgemäß kommen viele Bugs auf dem Mac nicht zwangsläufig auch in Windows vor und umgekehrt.

    Gleiche Erfahrung hier seit der Netscape und Mozilla Suite Ära, und wenn ich sie bislang nicht nicht "am eigenen Leib" gemacht hatte, dann spätestens mit der Mac-Version von TB 15, als der Bug 790234 bei mir TB mindestens achtzig Mal beim Start zum Absturz gebracht hat [IMG:http://smileys.sur-la-toile.com/repository/M%E9chant/0009.gif], sodass ich schließlich nur noch Earlybird benutzt habe.

    Zitat

    Ich habe hier den Fehler wie beschrieben versucht zu provozieren in mehreren Sprachen ohne ein zutreffendes Ergebnis, auch mit verschiedenen Fonts.

    Ich kann ihn auch nicht reproduzieren, aber das will nichts sagen.
    In mozillazine.org hat es keiner der "Stützpfeiler" des Forums geschafft, den Bug zu provozieren.


    Zum Abschluss noch ein Link zu einer Mozilla-Seite, auf der ersichtlich wird, dass das Problem Bug 790475 auch mit der Version 17 noch nicht (endgültig) gelöst ist:
    https://getsatisfaction.com/mo…spell_checker_on_steroids
    Ich bedaure, dass ich N8falke damit nicht helfen kann, aber vielleicht ist es tröstlich für ihn, dass er nicht allein ist und dass an dem Bug weiter gearbeitet wird.
    Offenbar berührt der Bug aber "nur" HTML und nicht Reintext.
    Gruß

  • Zitat

    Ich glaube also nicht, dass ich leichtfertig oder unüberlegt den Zusammenhang mit Bug 790475 aufgedeutet habe.


    Ich wollte das Aufführen des Bugs keinesfalls kritisieren, sondern nur klarmachen, dass nicht zwangsläufig auch jeder mit Windows davon betroffen sein muss.
    Das unerklärliche Phänomen bei Fehlern in Thunderbird ist ja leider, dass sie selten alle treffen, sondern dieses nur unter ganz bestimmten (meist unergründlichen) Voraussetzungen passiert.
    Eigentlich müssten alle Bug-Melder die Fehler erst in einem neu angelegten Profil überprüfen, bevor sie ihn posten. Leider wissen aber 80% jener User nicht einmal, was ein Profil ist.


    Darum würde ich hier n8falke empfehlen, diesen Fehler in einem neuen Profil zu überprüfen.


    4 Ein neues Profil erstellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat

    Ich glaube also nicht, dass ich leichtfertig oder unüberlegt den Zusammenhang mit Bug 790475 aufgedeutet habe.


    Ich wollte damit ausdrücken, dass ich N8falkes Problembeschreibung mit dem Thread http://forums.mozillazine.org/viewtopic.php?f=31&t=2571011 verglichen habe (insbesondere die beiden Fotos), und die originale Beschreibung des Bugs herangezogen habe
    "Actual results:
    Partial words are marked in error, then the red underline is not removed when the word is spelled correctly (and in total)."
     

    woraus ich den Schluss gezogen habe, dass es sich in der Tat um den gleichen, OS-übergreifenden, Bug handelt.

    "mrb" schrieb:

    Ich wollte das Aufführen des Bugs keinesfalls kritisieren, sondern nur klarmachen, dass nicht zwangsläufig auch jeder mit Windows davon betroffen sein muss.


    Ich habe es nicht als Kritik aufgefasst ;-) sondern als den Ausdruck einer anderen Meinung. Deshalb habe ich in meiner Antwort detailliert, warum ich nicht mit dir übereinstimme.
    Das Forum ist ja auch dazu da, dass man unterschiedliche Ursachen eines Problems vertritt und verschiedene Lösungsansätze diskutiert, sonst wird's ja auch langweilig ;-)

    Zitat

    Darum würde ich hier n8falke empfehlen, diesen Fehler in einem neuen Profil zu überprüfen.


    Logisch, dagegen ist sicher nichts einzuwenden.


    Gruß

  • So, liebe Forenmitglieder,


    der Aussage von mrb bin ich gefolgt und habe ein neues Profil angelegt. Das Problem wurde dadurch tatsächlich gelöst, deshalb vielen Dank an mrb, sowie die Kollegen die sich hier mit eingebracht haben.


    Ich habe hier absichtlich 2 Fehler eingebaut um darzustellen, das die Rechtschreibung auch aktiviert ist.


    Neues Profil:


    [IMG:http://www10.pic-upload.de/thumb/25.11.12/2plhb4hdqik1.jpg]


    Altes Profil:


    [IMG:http://www10.pic-upload.de/thumb/25.11.12/rhgv3nhh1tw.jpg]





    Thunderbird 17/POP/Windows 7 / 64bit

  • "N8falke" schrieb:


    der Aussage von mrb bin ich gefolgt und habe ein neues Profil angelegt. Das Problem wurde dadurch tatsächlich gelöst, deshab vielen Dank an mrb, sowie die Kollegen die sich hier mit eingebracht haben.


    Danke fur die Rückmeldung und ein Bravo auf mrb's Vorschlag! ;-)
    Wir wissen allerdings nicht, ob du mrb's ersten Vorschlag mit dem Test in safe mode durchgeführt hast.
    Es könnte durchaus sein, dass der Fehler durch ein Add-on oder einen Konflikt zwischen Add-ons verursacht wurde, und weiter, dass der Fehler wieder auftritt, wenn du dieselben Add-ons im neuen Profil installierst (vorausgesetzt, dass du überhaupt Add-ons benutzt).

  • Guten Morgen Mapenzi,


    ja, ich habe tatsächlich nicht probiert im abgesicherten Modus zu testen, ob das Problem noch besteht. An den AddOns liegt es aber definitiv nicht, denn diese habe ich aktuell alle am Laufen.

  • Und hast du das mittlerweile auspropiert?
    Würde mich interessieren, ob das das Problem ist!

  • N8falke,

    Zitat

    An den AddOns liegt es aber definitiv nicht, denn diese habe ich aktuell alle am Laufen.


    So etwas würde ich nie behaupten, weil ich Thunderbird inzwischen so gut kenne, dass ich das durchaus im Bereich des Möglichen sehe. Alte Add-ons verhalten sich anders als neu installierte. Diese sind Teil eines neuen Profils. Das alte kann defekt sein, was auch durch die (längere) Anwesenheit von Add-ons oder Themes geschehen kann.
    Oft ist es sogar so, dass nach Start im safe-mode und die dadurch vorgenommene Deaktivierung mit der anschließend erfolgten Reaktivierung der Fehler behoben ist.
    Warum, weiß niemand so recht.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,


    das hier beschriebene Problem tritt auch bei mir auf. Deshalb hier erst einmal meine Informationen:


    Thunderbird Version 17.0
    Windows 7 64 Bit
    Kontoart Pop3
    Zum Schreiben der Mail verwende ich eine andere Schrift (Calibri) und das mit einer anderen Schriftgröße.


    Anmerkung: Das Verhalten bekomme ich aber auch noch mit meinen anderen Rechnern und das sind Windows Vista 32 Bit, Windows XP 32 Bit und jeweils Thunderbird Version 17.0 und Kontoarten POP3 / IMAP hin.


    Thunderbird wurde für einen kleinen Test ohne AddOns gestartet und nachfolgende Mail geschrieben.


    Text im Plaintextmodus:
    "Hallo zusammen,


    diese Mail hier ist mit mehreren Schreibfehlern und Verbesserungen
    geschrieben.


    Gruss
    M."


    Thunderbird macht daraus im HTML Teil dann folgendes:


    Und hier vermute ich die Ursache für diese fragmentierten Rechtschreibfehleranzeigen. Denn es ist mir aufgefallen, dass immer, wenn ich zu manuellen Korrektur angesetzt habe, dieses Tag für den Font auftaucht.


    Mache ich diesen Test nämlich mit wieder aktivierten AddOns (also auch mit der Rechtschreibprüfung), dann tauchen an den Stellen die unterstrichenen Fehler auf.


    Vielleicht hilft das der Suche nach dem Problem weiter.


    Gruss
    Micha

    Einmal editiert, zuletzt von graba () aus folgendem Grund: Code-Tags gesetzt

  • Hallo und willkommen im Forum!


    Ich habe den HTML-Code in ein neues Verfassenfenster kopiert (> Einfügen > HTML...) und kann deine Beobachtungen nicht bestätigen. Die Rechtschreibprüfung verhält sich absolut normal.
    Überprüfe dein Problem in einem neuen Profil und berichte vom Ergebnis.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo mrb,


    hier also mein Testbericht:


    Komplett neues Profil erstellt - keine Änderungen an den Einstellung des Profilemanagers vorgenommen:
    Eines meiner Pop3 Konten eingerichtet.


    Test 1. Eine Mail geschrieben, wie oben beschrieben.
    Die Mail ist (im HTML Teil) korrekt ohne die Font Tags. Die Rechtschreibung arbeitete aber nicht. Wörterbuch fehlte.


    Test 2. Wörterbücher Deutsch (alte und neue Rechtschreibung, s.u.) installiert. Kein weiteres Addon.
    Mail geschrieben. Jetzt arbeitet die Prüfung normal. Keine teilunterstrichenen Teile.
    Dafür kommt die Mail aber nur als Plaintext. Der HTML Teil fehlt.


    Test 3. Konfiguration geändert (alle Änderungen aufgeführt):

    Extras - Einstellungen

    - Verfassen

    --Schriftart Calibri
    --Größe groß
    -- Alle 5 Minuten speichern deaktiviert
    (Rechtschreibung steht auf Deutsch)


    - Ansicht

    --Standardschrift Calibri
    --Größe 12



    Damit dann eine Mail, wie oben beschrieben, und hier kommen wieder die teilunterstrichenen Teile. Im HTML tauchen die Font Tags wieder auf.


    Die in dem Profil installierten Addons:
    - German Dictionary (de-DE) old spelling standards 2.0.2
    - Test Pilot for Thunderbird 1.3.9
    - Wörterbuch Deutsch (de-DE), Hunspell-unterstützt 10120628


    Falls noch etwas anderes übermittelt werden soll, dann jederzeit !


    Gruss
    Micha

  • Zitat

    Dafür kommt die Mail aber nur als Plaintext. Der HTML Teil fehlt.


    Und unter > Ansicht > Nachrichtentext war "Original HTML" angehakt?


    Zitat

    - German Dictionary (de-DE) old spelling standards 2.0.2
    - Wörterbuch Deutsch (de-DE), Hunspell-unterstützt 10120628


    Könnte es sein, dass TB bei 2 gleichsprachigen Add-ons nicht zurecht kommt?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Edit: Vollzitat gelöscht! Bitte zum Antworten die Buttons Antworten oder SchnellAntwort verwenden bzw. bei Einsatz des Buttons Zitieren nur das unbedingt Notwendige aufführen! Mod. graba



    Nein das kann wohl nicht sein. Denn ich habe das erste in dem Zitat hier angeführte Wörterbuch deinstalliert und einen Neustart von TB gemacht. Ergebnis wie vorher.


    Noch einen Test habe ich gemacht. Das Profil gelöscht und ein neues Profil mit anderem Namen angelegt und dann den Test noch einmal durchgeführt. Hierbei habe ich dann die Schriften und Größen (s.o.) geändert, das eine Wörterbuch (... Hunspell ...) installiert und den Schalter kontrolliert.


    Wenn ich da eine Mail erfasse und dabei manuelle Korrekturen mache, dann kommen die teilunterstrichenen Fehleranzeigen wieder. Und immer an den Stellen wo TB diese Font Tags einbaut.


    Warum ist das eigentlich so, dass da diese Tags eingebaut werden? Ich ändere doch nicht die Schrift oder die Schriftgröße ???


    Gruß

  • Wenn du in die Erweiterungen schaust, welches Wörterbuch hast du installiert? Dort steht eine Zahl.

    Zitat

    und den Schalter kontrolliert.


    Welchen Schalter?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • OK.
    Ich habe dasselbe Wörterbuch und deine Einstellungen für die Schrift übernommen und kann dieses Problem nicht nachvollziehen.
    Ich vermute externe Einflüsse etwa durch andere Software.
    Rein theoretisch könnte auch das Programm beschädigt sein. Dann sollte man einen neuen Installer von der Mozilla-Seite herunterladen und neu installieren.
    Mehr kann ich dir leider nicht anbieten, da ich nicht vor deinem Computer sitze.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw