Umlaute werden katastrophal angezeigt

  • Thunderbird-Version: 17.0
    Betriebssystem + Version: Windows 7 - 64 Bit Professional
    Kontenart (POP / IMAP): POP3 / IMAP




    Wir haben das Problem das plötzlich die Umläute nicht mehr richtig dargestellt werden.
    Wie kann ich das wieder normalisieren??


    Hier ein paar Screenshots....

  • Hallo,


    gehe mal auf: Ansicht, Zeichenkodierung, z.B Unicode UTF-8 bei der entsprechenden Mail. Notfalls andere testen. Ist sonst irgendwas am System verändert worden? Kommt ja nicht von alleine. Anrede wäre nicht schlecht! :)


    Grüße
    Peter B-L

  • Hallo,
    es gibt dazu 3 Möglichkeiten:


    - dein TB kann den richtigen Zeichensatz nicht automatisch anzeigen, da die originale Einstellung dafür verändert wurde.
    Dazu Rechtsklick auf den Ordner > Eigenschaften > Allgemein, das untere Kästchen darf nicht angehakt sein.


    - der Zeichensatz ist auch im Quelltext (Strg+U) der Mail falsch, dann kann sie Thunderbird nicht richtig anzeigen


    - die Mail wurde falsch deklariert, heißt: sie wurde z.B. in ISO-8859-1 geschrieben aber als UTF-8 deklariert.


    In diesem Fall kann man temporär unter > Ansicht > Zeichenkodierung diese mal auf die alternativen dort angebotenen einstellen.
    In diesem Fall ist eine dauerhafte richtige Anzeige nur durch Änderung des Quelltextes möglich.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallöchen Peter und mrb,


    die beiden Einstellungen haben wirklich geholfen, aber leider immer nur einmalig für die eine angezeigte eMail.
    Kann man das auch dauerhaft umstellen?
    Die Änderung bei jeder eMail zu nutzen, empfinde ich als sehr umständlich.... :redface:

  • Hast du meine Antwort ganz durchgelesen und verstanden?

    Zitat

    - die Mail wurde falsch deklariert, heißt: sie wurde z.B. in ISO-8859-1 geschrieben aber als UTF-8 deklariert.


    In diesem Fall kann man temporär unter > Ansicht > Zeichenkodierung diese mal auf die alternativen dort angebotenen einstellen.
    In diesem Fall ist eine dauerhafte richtige Anzeige nur durch Änderung des Quelltextes möglich.


    Und diese Änderung ginge nur mit einem Add-on und ist auch nicht ganz einfach.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Um überhaupt in den editierbaren Quelltext zu kommen brauchst du das Add-on HeaderToolsLite.
    Dann musst du nach Aufruf des Add-on (Anleitung siehe auf der Autorenseite) dort "Edit Full source" aufrufen.
    Dann musst du die falsche Deklaration durch die richtige ersetzen.
    Hierzu braucht man viel Erfahrung, und wenn dann etwas schiefgeht und du von der Mails keine Kopie hast, kann es passieren, dass der Nachrichtentext leer bleibt.
    Bei dem weiteren Vorgehen kann ich dir nicht helfen, da jede Mail etwas anders ist und die Deklaration auch mehrfach vorkommen kann.
    Und du musst diese Änderungen bei jeder Mail neu machen. Das kann ein Abend füllendes Unternehmen sein.
    Gewarnt habe ich davor.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Danke dir mrb,


    aber ich werde mich da nicht ran trauen. Ich leite das einfach mal meinem Männe weiter - soll
    er sich mal Nachts in Ruhe damit austoben :lol:

  • Noch ein Tipp:


    man findet die für die Zeichenkodierung verantwortliche Deklarierung rechts neben dem Eintrag
    content-Type z.B.

    Code
    1. Content-Type: text/html; charset=iso-8859-1


    Hier muss der charset geändert werden in z.B.

    Code
    1. Content-Type: text/html; charset=UTF-8


    Das ganz kann auch genau umgekehrt sein, also UTF-8 in ISO-8859-15 (oder-1) ändern.
    Andere Kombination gibt es in unserem Sprachraum kaum.
    Um auch alle charsets zu finden sollte man im Editor-Fenster nach allen charsets suchen und diese ändern.
    Da das Add-on in dem Fenster keine Suchfunktion anbietet sollte man schon vorher durch Aufrufen des Quelltext (Strg+U) und der dortigen Suchfunktion (Strg+F) ungefähr den Ort der Deklarationen wissen. Bei Anhängen kann das schon mal sehr nervig sein.
    Manchmal stehen die charsets auch in Anführungsstrichen, etwa charset="ISO-8859-1"
    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Hallo,
    ich habe seit heute ein ähnliches Problem, aber beim Verfassen einer eigenen Nachricht! Als ich den gestern gespeicherten Entwurf mit "Bearbeiten" öffnete, wurden die Umlaute und ß mit seltsamen Zeichen dargestellt.
    Eingestellt ist bei "TB/Einstellungen/Ansicht/Erweitert" "Westlich (ISO 8859-15)" sowohl für "Westlich" wie für "Unicode", der Haken im untersten Kästchen ist nicht gesetzt. Umschalten unter "Ansicht/Zeichenkodierung" auf "Unicode (UTF-8)" brachte nur andere Sonderzeichen, auch alle anderen Einstellungen führten nicht zu den richtigen Umlautzeichen. Ich habe auch die Angaben in "Einstellungen" nochmals wiederholt, ohne Erfolg. Die neu gespeicherte Nachricht bleibt bei der seltsamen Zeichenkodierung.
    Alle anderen Nachrichten in den Ordnern werden nach wie vor richtig dargestellt.
    Was kann ich da noch tun?


    Gruß raiSCH


    TB 17.02 POP Mac OS 10.8.2

  • Hallo,
    ich habe zur Überprüfung den neu gespeicherten Entwurf an meine zweite Email-Adresse gesandt, und er hat dort auch die falsche Zeichenkodierung, die sich nicht richtigstellen lässt.
    Interessanterweise sind die Sonderzeichen aber dort verlängert:
    Entwurf "vielen Dank für" gespeichert: vielen Dank fÃÂŒr
    Entwurf "vielen Dank für" mit 2. Adresse empfangen: vielen Dank fÃÂÃÂŒr


    Außerdem springt bei "Ansicht: Zeichenkodierung" der Haken von "Westlich...-15" manchmal auf "Westlich...-1", ohne dass ich etwas geändert habe.


    Störung durch Würmer o.ä. mit einer neuen Mail kommt auch nicht in Frage, da ich heute noch nichts empfangen habe.


    Gruß
    raiSCH

  • Hallo,

    Zitat

    Außerdem springt bei "Ansicht: Zeichenkodierung" der Haken von "Westlich...-15" manchmal auf "Westlich...-1", ohne dass ich etwas geändert habe.


    Nun, wenn ein ankommende Mail in UTF-8 deklariert ist und vorher ISO-8859-15, dann springt die Zeichenkodierung automatisch um. Das ist völlig normal.


    Für alles andere habe ich keine Erklärung, da ich keinen Mac habe und bei mir das Verhalten korrekt ist.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo mrb,
    das Umspringen kommt ohne ankommende Mails zustande, schon beim Navigieren in den Mailordnern. Aber das ist sicher nicht das Problem.
    Bis gestern war alles in Ordnung, nur heute dreht die Zeichenkodierung durch, ohne dass ich vorher eine Einstellung geändert habe.
    Gruß raiSCH

  • In dem Moment, in dem eine Mail markiert wird, wird die Deklarierung (Content-Type: text/plain; charset="ISO-8859-15") dafür ausgelesen.
    Und solange keine andere neue Deklarierung gelesen wurde, bleibt sie erhalten.
    Entscheidend ist immer, dass die Deklarierung im Quelltext (Strg+U) der Mail mit der unter > Ansicht
    > Zeichenkodierung übereinstimmt.


    Besteht das Problem auch in einem neuen Profil?
    4 Ein neues Profil erstellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

    Einmal editiert, zuletzt von mrb ()

  • Hallo mrb,
    es wird immer seltsamer. Ich habe mir selbst eine Probemail geschickt, die nur aus Umlauten, ß und € bestand - sie wurde beim Verfassen, Speichern und auch als empfangene Mail richtig angezeigt (Ansicht: Kodierung "W...-15").
    Ich habe daraufhin die oben erwähnte bearbeitete Mail mühsam von Hand wieder auf den richtigen Stand gebracht (man glaubt gar nicht, wieviele Umlaute und ß die deutsche Sprache hat), und auch die gespeicherte Fassung blieb in der richtigen Zeichenform .
    "Ansicht/Zeichenkodierung war auf "W..-1" gesprungen. Als ich auf "W..-15" umschaltete, waren wieder die falschen Zeichen da, bei "Unicode...-8" war wieder alles richtig. Ich habe es jetzt so gelassen - angezeigt wird (natürlich?) jetzt wieder "W...-1" - verstehe das, wer will, Hauptsache, es funktioniert wieder.


    Beste Grüße
    raiSCH

  • Hallo,
    mein Aufatmen war wohl zu früh, aber ich hatte sowieso ein komisches Gefühl., dass da einiges nicht stimmt.
    Eine Mail ist angekommen und wurde richtig angezeigt. Als ich danach wieder zu der zu bearbeitenden Mail wechselte, waren die Umlautzeichen wieder verrutscht, und "Ansicht/Zeichenkodierung" war auf "Vietnamesich (Windows 1258)" gesprungen! Eine Korrektur war in allen dort angegeben Kodierungen nicht möglich, es änderten sich nur die Sonderzeichen.
    Ich vermute, dass andere Mails die Kodierung beeinflussen. Vielleicht sollte ich doch ein neues Profil probieren, aber ich fürchte, dass es daran nichts ändern wird.


    Gruß raiSCH

  • Hallo,
    eine weitere Vermutung habe ich: Gestern Abend wurde Thunderbird auf 17.02 geupdatet; vielleicht ist das Update nicht mehr mit dem Betriebssystem Mac OS 10.8.2 kompatibel?
    Gruß raiSCH

  • Hallo,

    Zitat von "raiSCH"

    Thunderbird auf 17.02 geupdatet; vielleicht ist das Update nicht mehr mit dem Betriebssystem Mac OS 10.8.2 kompatibel?


    das dürfte kein Problem sein. Soweit ich weiß, setzt Thunderbird 17.0.2 "Mac OS X 10.6" oder neuer voraus.

  • Hallo graba,
    das dachte ich auch, aber laut einer Auskunft im Macwelt-Forum scheint es schon prinzipiell Kompatibilitätsprobleme zwischen Mac und TB zu geben - ich bin dafür kein Fachmann. Tatsächlich ist der Fehler eben erst seit heute aufgetreten, und gestern Abend fand das Update statt.
    Beste Grüße
    raiSCH