Wo kann meine profiles.ini sein

  • Thunderbird-Version: 17.0.2
    Betriebssystem + Version: Windows 7, 32 bit
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): versatel


    Guten Abend,
    nach Neuaufspielen von Windows 7 versuche ich verzweifelt TB ans Laufen zu bringen. Firefox hat überhaupt kein Problem gemacht und läuft mit den rückgespielten Sicherungsdateien. Ich kann TB installieren, beim Startversuch sagt er aber.
    Ihr Profil "Thunderbird" kann nicht geladen werden. Es ist möglicherweise nicht vorhanden oder ein Zugriff ist nicht möglich.[/u]
    Die Suche nach profiles.ini ist und bleibt vergeblich - die Datei gibt es auf meinem Rechner nicht, und sie wurde bei nunmehr 9 Versuchen der Installation auch nicht geschrieben.
    Ich habe 2 Profile unter %APPDATA%\....Roaming, also am eigentlich richtigen Ort auf die ich aber nur auf dem Umweg über die TB-Hilfe zugreifen kann. Eins ist ein neues Default, das andere mein rückgespieltes altes. Offenbar ist TB nicht imstande, die Profile zu finden, weil ihm die profiles.ini mit dem Pfad fehlt.
    Woran könnte es liegen, dass er sie nicht schreibt - Reste von vor dem Windows-Crash irgendwo? Wie finde und lösche ich die dann? Die vergeblichen Installationen habe ich alle komplett (auch Registry) jedesmal mit iobituninstaller entfernt. Aber es war ja auch beim 1. wie beim 9.Mal dasselbe, also hat sich offenbar kein "Müll" bei den Installationsversuchen angesammelt. Hinweise auf ein anderes TB oder Reste davon finde ich auf den erhalten gebliebenen Partitionen und Festplatten nicht. Kann im "Windows.old" ein Verwirrer stecken?
    Kann man die profiles.ini selber schreiben? Äh, falls ja - wie geht das, und wo muss sie hin, also in welches Verzeichnis? Zuletzt hab ich sowas mal vor Windows 3, also noch bei DOS, versucht., Das ist auch alles, woran ich mich erinnere.
    Vielen Dank vom Rand der Hoffnmungslosigkeit
    Wilfried

  • Guten Morgen,
    danke, aber nein - da ist sie nicht. Und über Thunderbird.exe -ProfilManager komme ich zwar zu den Profilen, aber nicht zur profiles.ini.

  • Hallo steffens_w,


    Zuerst trenne bitte mal zwischen dem Dateimanager und der im von Mapenzi geposteten Link beschriebenen Lage der profiles.ini und dem Profilmanager des Thunderbird. Das sind zwei völlig verschiedene Sachen!


    Die profiles.ini liegt immer dort, wo sie der Thunderbird im jeweiligen Betriebssystem sucht bzw. wo sie bei der ersten Installation auf dem jeweiligen Betriebssystem hingeschrieben wird. Und dort muss sie auch bleiben, sonst findet sie das Programm nicht.


    Das eigentliche TB-Userprofil kann überall abgelegt werden, wo <user> Vollzugriff hat. Ohne manuelles Eingreifen wird es an dem Platz angelegt, der in dem geposteten Link steht. Aber das ist auf der WinDOSe nicht die beste Lösung. Der mitdenkende User legt sich bei der Installation eine getrennte Datenpartition an, und speichert dort sämtliche "Nutzdaten", und eben auch das TB-Userprofil. Und wo dieser Speicherort ist, muss in die profiles.ini eingetragen werden. Der kundige User macht das mit einem Texteditor, der Normaluser nutzt dazu den Profilmanager.


    Und mit dem Profilmanager suchst du nicht etwa die profiles.ini (deren Ort ist dem Profilmanager wohl bekannt!), sondern du suchst den Ort deines TB-Userprofiles. (Egal, ob du dort erst eines einrichten willst, oder ob du dort bereits ein bestehendes hinkopiert wurde.) Und mit einem Klick passiert nichts anderes, als das der Profilmanager diesen Ort in die profiles.ini einträgt. Und somit wird das Profil beim nächsten Start gefunden.


    OK?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo,
    tut mir leid, ich habe mich, fürchte ich, nicht richtig verständlich gemacht. Ich versuche es mal so:
    - Neuinstallation von TB 17.0.2 auf c:\Programme. Geht verblüffend schnell. Dann klicke ich Fertigstellen mit Häkchen bei "Thunderbird jetzt starten" und bekomme sofort meinen LIeblingskasten
    Ihr Profil "Thunderbird" kann nicht geladen werden. Es ist möglicherweise nicht vorhanden oder ein Zugriff ist nicht möglich.


    Soweit ich das prinzipiell und von Peter verstehe, sollte doch TB bei der Installation ein Profil anlegen. Wenn der Vogel das tut - wo tut er das dann und wieso findet er es nicht wieder? Und vor der Installation ist jeweils der vorige Versuch komplett deinstalliert einschließlich Registry-Einträgen (iobituninstaller).
    Ich verstehe Peter jetzt so, dass das Profil standardmäßig auf C: angelegt wird, was man lieber anders machen sollte. Ich bekomme aber bei der Installation kein Angebot, darüber zu entscheiden. Und um es zu ändern, muss ich als Normaluser in den Profilmanager. Da komme ich ja auch hin, und da steht auch ein default mit dem Pfad C:...User...etc.


    Im ProfileManager kann ich ein Profil erstellen, von da aus startet TB dann auch. Es liegt angeblich auf c:\User\***\AppData\Roaming\Thunderbird\profiles\....default. Wenn ich TB schließe und neu starte, kommt aber wieder mein obiger LIeblingsspruch. So als vergässe TV sofort wieder, wo es gerade noch war...


    Übrigens - die 17.0.2 exe hab ich inzwischen sowohl direkt von Mozilla als auch von Chip und Computerbild runter geladen. Immer dasselbe.... Ich habs auch schon mit der 16.0.1 versucht, die ich auch gefunden hatte - dasselbe Spiel.
    MfG Wilfried

  • Hallo Wilfried,


    zuerst einmal vorweg: TB trennt (wie wohl jedes "vernünftige" Programm) sauber zwischen Programm- und Benutzerdaten.
    Das Programm installierst du mit den Rechten eines Adminkontos (welches du dann hoffentlich nicht zur täglichen Arbeit benutzt!). Und die Benutzerdaten (das "Profil") werden dann standardmäßig beim ersten Start des Programms im Userbereich des angemeldeten Users angelegt.
    Hier kann es dabei zu folgendem Problem kommen: du installierst das Programm als Administrator und startest es dann gleich aus diesem Konto heraus, also nach der Installation vergessen den Haken vor dem Beenden zu entfernen. Das kann dann dazu führen, dass dieses Profil dem Admin gehört.
    (Ich muss hier sehr viel mit "kann" arbeiten, denn bei mir gibt es privat "Windows" nur als verglaste Löcher in den Wänden.)


    Die von dir dankenswerterweise gepostete Fehlermeldung ist typisch dafür, dass es zwar eine profiles.ini gibt, aber an dem in dieser Datei eingetragenen Pfad kein Profil gefunden wird oder, was auch vorkommt, der angemeldete User mangels Rechte auf dieses Profil nicht zugreifen kann.
    Im Unterschied dazu führt eine fehlende profiles.ini (oder ein fehlender oberster Profilordner \Thunderbird, in welchem ja die profiles.ini liegt) immer dazu, dass der TB mit der Aufforderung zum Einrichten des ersten Kontos startet!


    Ich würde jetzt:

    • Mit dem Dateimanager den lt. unserer Aleitung bestimmten Ort des usereigenen TB-Profiles aufsuchen. Also auf der 7er WinDOSe: Benutzer\%Benutzername%\AppData\Roaming\Thunderbird\
    • Jetzt den obersten Profilordner \Thunderbird <= durch Umbenennung in \Thunderbird_old vor dem Programm verstecken.
    • Den TB als Benutzer starten. Jetzt muss die Aufforderung zur Einrichtung des ersten Kontos kommen.
    • Diese Konto einrichten und den TB vollständig konfigurieren.
    • Die eventuell vorhandene "Profilruine" \Thunderbird_old entweder, wenn da noch keine relevanten Daten vorliegen, gleich löschen, oder vorhandene Daten (vorhandene Mails oder Adressbücher) in das neue Profil übernehmen. Aber das ist ein anderes Thema, auf das ich hier nicht eingehen will.


    Wenn das ganze bis dahin nicht funktioniert, liegt irgend ein anderes Problem an deinem Betriebssystem vor.
    Wenn es aber, wie ich erwarte, funktioniert, kannst du (du musst aber nicht!) darüber nachdenken, dein TB-Userprofil auf eine Datenpartition zu verlegen. Dabei werde ich dir gerne helfen, wenn das o.g. erfolgreich verlaufen ist.


    OK?


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Super, danke - in mir keimt Hoffnung. Ich habe als Admin installiert (und muss gestehen, das ich bei all den Programminstallationen nach Neuaufsetzen noch keinen eigentlichern Benutzer angemeldet habe) und dann sofort mit Starten bei Fertigstellen, also mit Haken, weiter zu machen versucht.
    Jetzt warte ich sehnsüchtig auf das Arbeitsende, um Deine Hinweise umzusetzen....
    MfG
    Wilfried

  • So, Thunderbird läuft beim Benutzer (nach wie vor nicht beim Administrator). Jetzt muss ich es nur noch schaffen, das alte Profil zu übertragen.
    Herzlichen Dank für die Hilfe!
    WIlfried