Gelesene Mails werden als ungelesen markiert

  • Thunderbird-Version: 17.0.5
    Betriebssystem + Version: XP 2002 SP3
    Kontenart (POP / IMAP): POP
    Postfachanbieter (z.B. GMX): online.de (1+1) / web.de (?)


    Hallo zusammen!


    Nur lästig: Häufig werden einige oder alle Mails eines Ordners wieder als ungelesen markiert (gibt es deshalb die Funktion "Ordner als ungelesen markieren"?).
    - Kann ich da was dran ändern?
    - Muss jemand schlaueres als ich Oldie einen Patch schreiben?


    Für Rat und Hilfe dankt
    migrant (migriert von Eudora)

  • Hallo migrant,


    und willkommen im Forum!
    Also der von dir bemerkte Fehler ist wirklich unüblich. Kann mich nicht erinnern (in meinem Alter darf ich vergesslich sein ;)), dass wir diesen Fehler schon mal hatten.


    Bist du ganz sicher, dass du nicht innerhalb der Auflistung der Mails so ganz zufällig mal auf das kleine "m" drückst? ("m" = Hin- und Herschalten zwischen den Zuständen "gelesen" und "ungelesen" einer markierten Mail).


    Zitat

    (gibt es deshalb die Funktion "Ordner als ungelesen markieren"?)


    Also mein Thunderbird hat diese Funktion definitiv nicht! Dafür habe ich die Funktion "Ordner als gelesen markieren"


    Der Status der Mails wird innerhalb des Headers im so genannten X-Mozilla-Status gespeichert => http://www.eyrich-net.org/mozilla/X-Mozilla-Status.html
    Du kannst, wenn das wieder mal auftritt, im Quelltext danach suchen.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Peter,


    danke für die freundliche Begrüßung.
    Diese Fehlfunktion trat heute schon wieder auf, überigens auch auf meinem Laptop unter Win 7.


    Ich bin aber ziemlich sicher, dass ich unwillentlich nichts umschalte. Ich habe eher den Eindruck, dass der Fehler nach dem Runterladen und Filtern einer neuen Nachricht auftritt.


    Natürlich heißt die schöne Patch-Funktion "Ordner als gelesen markieren" (in meinem Alter muss man mit Altheimer rechnen, Entschuldigung!).


    migrant

  • Hi,


    hast du dir mal den Quelltext dieser Mail angesehen?
    Ich meine den x-mozilla-Status.


    Du kannst gern den Quelltext (persönliche Sachen etwas anonymisieren!) hier posten. Dann schauen wir uns das an.


    MfG Peter

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • TB 26.6.0 (portabel), POP, div. Anbieter
    Vista Bus. SP2


    Auch wenn der Thread schon etwas älter ist, ich hab dasselbe Problem und es wird langsam lästig.
    Wochenlang passiert nichts, und seit gestern werden etliche alte Mails und Ordner als ungelesen angezeigt.


    Ich muß dann die Mails bzw enthaltende Ordner mühsam suchen, markieren und auf gelesen setzen.
    Aber heute sind schon wieder zig Mails als ungelesen markiert. :aerger:


    Leider wirkt die Funktion "Ordner als gelesen markieren" nur auf die direkt in diesem Ordner vorhandenen Mails, nicht auf Unterordner.... :wall:


    Ich hatte in den Einstellungen unter "Lesen&Ansicht" den Haken gesetzt bei "Nachrichten automatisch als gelesen markieren -nach dem Anzeigen für 5 Sekunden" .
    Den hab ich jetzt weggenommen in der Hoffnung, daß sich etwas ändert...


    Weiß sonst niemand, was da los sein könnte?


    Gruß
    Wolfgang

  • Hallo
    und dein X-Mozilla-Status?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat

    Hallo
    und dein X-Mozilla-Status?


    Kann ich jetzt nicht mehr sagen. Dummerweise habe ich schon alle Mails wieder auf gelesen gesetzt, bevor ich gemerkt hab, daß die Option unter "Lesen&Ansicht" gesetzt war. Ich hatte mich schon gewundert, daß die markierten Mails nach einigen Sekunden als gelesen erschienen. Das war zu kurz um die Quellansicht zu starten und um den Status zu ermitteln....


    Aber egal, es gibt ja nur diese Beiden Stati, die verantwortlich sein können:


    0001 (gelesen) und 0000 (ungelesen).


    Dann gibt's aber eigentlich auch nur 2 Möglichkeiten: Entweder irgegendetwas setzt den Status von hunderten von Mails auf 0000 (ungelesen) oder TB "verliest" sich bei diesen Mails aus irgendeinem Grund. Ich vermute aber eher Ersteres.


    Hatte kürzlich versucht, das mit Löschen der .msf-Dateien zu beheben, ging aber nicht. Offensichtlich wurde der X-Status bei allen betroffenen Mails tatsächlich zurückgesetzt. Und daß das von außerhalb TB passiert, kann ich mir nicht vorstellen...


    Aber ich melde mich wieder wenn das Phänomen erneut auftritt. Es scheint ja noch ein paar andere zu geben bei denen das aufgetreten ist.

  • jetzt hab ich doch noch eine Mail gefunden, die als ungelesen markiert war...
    X-Mozilla-Status: 0001


    Nein, Entwarnung.
    Es war wieder "Nachrichten automatisch als gelesen markieren" aktiviert. Das hab ich aber mit Sicherheit nicht gemacht, weil ich das beim letzten Mal bewußt deaktiviert habe.


    TB scheint ein "eigenes Leben" zu führen...
    Ich glaub jetzt schon an einen Bug...

  • Sorry,
    wäre es ein Bug hätten alle von uns das gleiche Problem.
    Dem ist nicht so.
    Folgerung: dein Profil muss beschädigt sein.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Wenn das Profil beschädigt wäre, müßte das wahrscheinlich dauernd passieren. Zwischen den Ereignissen liegen jedoch Wochen, was ist mir den anderen Leuten, die dasselbe Problem haben? Die melden sich zwar nicht alle hier, es sind jedoch in Fremdforen schon einige zu finden...

  • Zitat

    Zwischen den Ereignissen liegen jedoch Wochen,


    Hattest du die Antworten von deinem ersten Bugreport (David :Bienvenu) gelesen, warum das passieren kann?
    Das ließe sich ja leicht überprüfen, indem du jegliches automatische Abrufen abstellst und manuell die Mails anforderst - immer langsam nacheinander.
    Und noch eine Frage: tritt dieses Verhalten bei deinen beiden Konten auf oder nur bei einem?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Zitat


    Hattest du die Antworten von deinem ersten Bugreport (David :Bienvenu) gelesen, warum das passieren kann?


    Nein, das hatte ich gar nicht gesehen daß da Kommentare sind, ich hab nur die erste Reportseite angeschaut.
    Ich werde mich da mal durchwühlen...


    Zitat

    tritt dieses Verhalten bei deinen beiden Konten auf oder nur bei einem


    Wie kommst du auf zwei... Ich hab 12 bei verschiedenen Anbietern, aber nur als Beispiel 2 angegeben... war vielleicht mein Fehler. Es passiert bei verschiedenen Konten, und zwar nicht unbedingt beim Abruf, nach dem Start von TB hab ich festgestellt, daß ich alle möglichen Ordner plötzlich fett dargestellt waren und auch die Inhalte, aber dort nicht alle...


    Ich kann das momentan nicht reproduzieren. Aber wenn es wieder auftritt, passe ich genau auf, unter welchen Bedingungen. Jedenfalls handelt es sich um Mails, die ich ewig nicht angefaßt habe.


    Aber wie gesagt, ich muß mir mal die ganzen Kommentare zu Gemüte führen und melde mich wieder wenn es etwas Neues gibt.

  • So, jetzt ist es wieder passiert nach ca. 4 Wochen.
    Einige als gelesen markierte werden wieder als ungelesen angezeigt. Die entsprechenden Verzeichnisse hab ich nicht angefaßt die letzten 4 Wochen. Die als ungelesen angezeigten Mails haben den X-Mozilla-Status: 0000, die gelesen markierten 0001
    D.h., irgendetwas setzt diesen Status von 0001 auf 0000 zurück... :aerger:
    und zwar planlos und unsystematisch...

  • Da du dich ja unüblicherweise an einen älteren Thread gehängt hast, kennst du natürlich auch unsere 4 obligatorischen Fragen nicht, die man beantworten sollte


    Betriebssystem?
    IMAP oder POP?


    Weiterhin: welche Sicherheitssoftware verwendest du?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Da du dich ja unüblicherweise an einen älteren Thread gehängt hast, kennst du natürlich auch unsere 4 obligatorischen Fragen nicht, die man beantworten sollte


    Betriebssystem?
    IMAP oder POP?


    Du hattest die betr. Ordner schon mal repariert? (Ordner reparieren: Rechtsklick auf den Ordner, Eigenschaften, Allgemein, "Reparieren".)
    Schon mal im safe-mode gestartet? (In TB > Hilfe > "Mit deaktivierten Add-ons neu starten" und den Button "Im abgesicherten Modus weiterarbeiten" verwenden oder Start mit gedrückter Umschalt-Taste.
    Oder über Win+R --> thunderbird -safe-mode --> OK.)
    Und falls das alles nicht hilft, mal testweise ein zweites Profil hinzugefügt und das Verhalten dort überprüft?
    Weiterhin: welche Sicherheitssoftware verwendest du?


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • oha...


    Thunderbird-Version: 31.0 portabel
    Betriebssystem + Version: Vista Business SP2
    Kontenart (POP / IMAP): POP3
    Postfachanbieter: Diverse: 1&1 (Provider), Web.de, GMX, Yahoo, Arcor, T-Online, GMX


    Sorry... :flehan:


    Zitat

    Du hattest die betr. Ordner schon mal repariert? (Ordner reparieren: Rechtsklick auf den Ordner, Eigenschaften, Allgemein, "Reparieren".)


    Ja, schon mehrfach. Auch schon mal alle Index-Dateien gelöscht. Hat nix geholfen, passiert immer wieder...
    Es hilft wirklich nur die manuelle Zurücksetzung auf "gelesen". Glücklicherweise funktioniert das auch über Mehrfachauswahl...


    Zitat

    Schon mal im safe-mode gestartet? (In TB > Hilfe > "Mit deaktivierten Add-ons neu starten" und den Button "Im abgesicherten Modus weiterarbeiten" verwenden oder Start mit gedrückter Umschalt-Taste.
    Oder über Win+R --> thunderbird -safe-mode --> OK.)


    Ja... aber das Problem tritt ca. alle 4 Wochen auf, und solange will ich nicht im Safe-Mode sein...


    Zitat

    Und falls das alles nicht hilft, mal testweise ein zweites Profil hinzugefügt und das Verhalten dort überprüft?


    Nein, da müßte ich ja alle Konten neu anlegen, Schweinsarbeit... Auch da müßte ich dann wochenlang warten.


    Zitat

    Weiterhin: welche Sicherheitssoftware verwendest du?


    Avast Free. Aber ich kann mir nicht vorstellen daß das etwas mit der Sicherheitssoftware zu tun hat. Ich hab den Mail-Ordner als Ausnahme zugefügt, da faßt AVAST nicht hinein.

  • Zitat

    Nein, da müßte ich ja alle Konten neu anlegen, Schweinsarbeit... Auch da müßte ich dann wochenlang warten.


    Eins max. zwei würden reichen, vorzugsweise IMAP, so kommen sich IMAP und POP nicht in die Quere.
    Alle von dir aufgeführten Mailprovider bieten IMAP kostenlos an.
    Es genügt ja dann von Zeit zu Zeit mal in das Testprofil zu schauen.
    Übrigens: im Zusammenspiel mit dem Kontenassistenten und den bereitgehaltenen Konteneinstellungen wäre die 6 Konten in 10 Minuten eingerichtet. Und außerdem würde ich alle IMAP konnten im zweiten Profil so einstellen, dass das sog. "Bereithalten von Nachrichten" abstellt ist. So bleibt das Profil recht klein.
    Was AVAST angeht, hat dieses ja eine spezielle Mailüberwachung ("Mail-Schutz!"), die solltest du abstellen.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw

  • Ich hab insgesamt 12 Konten bei den genannten Providern. (Warum, ist eine andere Sache).


    Also, ich bin ja bereit alles Mögliche auszuprobieren, wenn ich den Sinn erkenne...


    soweit ich weiß ist der wesentliche Unterschied zwischen IMAP und POP3, daß bei IMAP eigentlich nur die Kopfzeilen in TB angezeigt werden, die Mail aber am Server verbleibt...
    Bei POP3 lädt man wirklich die Mail auf den Rechner herunter und diese wird dann i.d.R. am Server gelöscht, sofern man das nicht anders eingestellt habe. (das benutze ich z.B., wenn ich mit meinem Laptop Mails herunterlade. Da hab ich alles auf "am Server belassen" eingestellt. Die Mails lagern dann auf meinem Haupt-PC.)


    Was würde mir die Einrichtung eines neuen Profils mit IMAP-Konten bringen?


    Es ist ja so, daß der TB offensichtlich unsystematisch die bereits seit längerem heruntergeladenen Mails mit x-mozilla stati auf 0000 zurücksetzt.
    Das kann ich jetzt überhaupt nicht mit IMAP in Verbindung bringen...


    Zitat

    Was AVAST angeht, hat dieses ja eine spezielle Mailüberwachung ("Mail-Schutz!"), die solltest du abstellen.


    Das Problem bestand schon bevor AVAST die Mailüberwachung eingeführt hat, und letzteres funktioniert einwandfrei. Und Avast setzt bestimmt nicht den Mozilla-Status zurück...


    Hier ein beispielhafter Screenshot. die mit Pfeilen versehenen Verzeichnisse enthalten plötzlich Mails mit x-mozilla status 0000, die vorher 0001 waren (auch bei uralten Mails):


    [IMG:http://www11.pic-upload.de/thumb/08.08.14/lpq25i8bsneo.gif]

  • Durch das sporadische Auftreten des Fehlers sind meine Hilfen recht eingeschränkt, zumal du ja auch kein neues Profil einrichten willst. Mehr kann ich dir leider nicht anbieten.
    Eins weiß ich aber, würde der Fehler bei mir auftreten, bekäme ich ihn weg.


    Gruß

    Konversationen ohne vorherige Anforderung werden ignoriert..
    Windows 10, 64-bit, immer die aktuelle Thunderbird-Version und ältere Testversionen. Testprofile vorhanden.
    Testkonten bei den meisten größeren Mailanbietern wie GMX, Web.de usw