Fehlerhafter Versand von jpeg-Dateien [erl.]

  • Thunderbird-Version: 17.0.6
    Betriebssystem + Version: Mac OS 10.8.3 (Mountain Lion)
    Kontenart (POP / IMAP): POP 3
    Postfachanbieter: freenet.de


    Hallo Leute,


    auch auf die Gefahr hin, dass man dieses Problem in die Ecke Foto-Hardware, Dateiformat des Fotos etc. abschieben könnte, bitte ich um Prüfung meiner Anfrage. Dieses Problem wurde bereits im Fotografie-Forum besprochen. Und da aus dieser Richtung keine Lösungen abzusehen waren, wende ich mich - also schon im zweiten Schritt - an das TB-Forum.


    Sollte das Thema in einem anderen Unterforum besser aufgehoben sein, bitte ich die Mods, es zu verschieben.


    Vorgang: Versenden von jpeg-Dateien der Kamera "Pentax K5 II" als Dateianhang unter TB unter Zuhilfenahme der AddOn "Shrunked Image Resizer" (aktuellste Version)


    Beim Versand meiner Fotos (Pentax K5 II) habe ich ein uriges Phänomen:


    Was passiert?
    Möchte ich ein Foto (nur aufgenommen mit der Pentax K5 II) per E-Mail im jpeg-Datei-Format versenden, ist der Inhalt leer. Ein graues Feld. Sowohl unter "Versendete E-Mails" als auch unter "Empfang".


    Dieses Phänomen tritt (unter gleichen Voraussetzungen) nicht auf bei:
    - Versand in Originalgröße der Fotos aus der K5 II unter TB
    und Achtung jetzt:
    - Versand von Fotos aus verschiedenen anderen Kameras


    Habe eine der "problematischen" Dateien jeweils in PSE, LR und unter der Vorschau-App von Mac geöffnet und noch einmal als jpeg-Datei exportiert bzw. gespeichert.


    Mit diesen Dateien ist TB + Addon wie gewohnt umgegangen, hat sie verkleinert und als jpeg-Datei versendet!
    Ich weiß, jpeg ist jpeg. Aber warum werden die einen jpeg-Dateien verarbeitet und die anderen nicht?????


    Ich habe außerdem noch einmal verschiedene Einstellungen (Auflösung, Qualität) ausgetestet. Habe vermutet, die Ausgangsdatei war zu groß für die AddOn. Sogar mit verschiedenen SD-Karten habe ich gearbeitet. Das gleiche Ergebnis!


    Aus den beiden letztgenannten Gründen habe ich angefangen, zuerst das Fotoforum zu befragen, denn offensichtlich funktioniert ja der Versand von jpeg-Dateien, die aus anderen Cams kommen. Ohne Ergebnis!


    Hat da denn jemand ´ne Idee, ob das Problem aus Richtung TB / AddOn kommen könnte?????


    Gruß Vandenburgh

  • Hallo Vandenburgh,


    ich vermute sehr, dass das Problem von der Erweiterung kommt. Du benutzt die aktuelle Version?


    "Vandenburgh" schrieb:

    Ich weiß, jpeg ist jpeg. Aber warum werden die einen jpeg-Dateien verarbeitet und die anderen nicht?


    (ein Fragezeichen tut's auch ;-))


    So ganz stimmt das nicht. Ein Unterschied könnte z.B. in den EXIF-Daten liegen. Das würde dazu passen, dass es offenbar ein Rolle spielt, aus welcher Quelle die Fotos stammen. Zudem schreibt der Autor auf der zugehörigen Webseite, dass es jüngst Änderungen in diesem Bereich gegeben habe:



    Wenn die auf der Seite genannten Änderungen nicht helfen, würde ich von dem Angebot Gebrauch machen, und dem Autor per E-Mail kontaktieren.


    Gruß


    Susanne

  • Hallo Vandenburgh,


    nein, eine Lösung habe ich auch nicht ... .
    Ich habe weder einen Mac noch so eine Kamera noch nutze ich ein Add-on, um Bilddateien zu verkleinern. Habe allerdings schon recht viele jpeg-Dateien verschickt.
    Ich gehe davon aus, dass du die Fotos ganz normal aus der Kamera auf deinen Mac ziehst. Dort sind sie danz normal im "Mac-Betrachter" zu sehen. Und du kannst sie auch von dort aus als Dateianhang per TB versenden. Richtig?


    Und wenn du sie über das mir unbekannte Add-on "Shrunked Image Resizer" vor dem Versenden bzw. vor dem Anhängen an die Mail "verkleinern" lässt, tritt das Problem auf. Dann und nur dann. OK?


    Ich habe ja dieses Add-on nie gebraucht und somit nie benutzt. Unter Linux markiere ich den Inhalt eines Bilderordners > Rechsklick > "KIM Compress & Resize" > und schon habe ich je eine Kopie des Bildes in meinetwegen 600x800. Gibt es etwas derartiges, zumindest zum Test, vielleicht auch für den Mac? (Aus meinen Windows-Zeiten kenne ich ein Programm namens "Pixresizer")
    Zumindest könntest du mit einer derartigen "Vorher-Verkleinerung" eindeutig den TB als Verursacher ausschließen und den Verdacht deutlich auf das o.g. Add-on lenken. => Dann wäre mein nächster Ansprechpartner der Entwickler des Add-on.


    Ich würde aber auch noch etwas anderes austesten: mit einem Exif-Editor testweise bei einem Bild alles rausnehmen, was auf deine Kamera hindeuten könnte. Das geht ja wohl mit jedem guten Bildbearbeitungsprofgramm. Also die Exif-Daten faken.


    Ja, mehr fällt mir dazu nicht ein.


    MfG Peter (wieder mal zu langsam ...)

    Thunderbird 45.8.x, Lightning 4.7.x, openSUSE Tumbleweed, 64bit
    S/MIME, denn ich will bestimmen, wer meine Mails lesen kann.
    Nebenbei: die Benutzung der (erweiterten) Suche, und von Hilfe & Lexikon ist völlig kostenlos - und keinesfalls umsonst!
    Und: Ich mag kein ToFu und kein HTML in E-Mails!

  • Hallo Vandenburgh,


    ich habe keine Idee, warum das Add-on Shrunked Image Resizer 3.0.1 nicht mit den Bildern deiner Kamera arbeitet.
    Hatte zwar sofort an das Sichern mit Vorschau.app gedacht, aber das hast du ja schon gemacht.
    Wenn ich auf diese Seite gehe https://addons.mozilla.org/fr/…n/shrunked-image-resizer/
    sehe ich, dass auch andere Anwender Probleme mit dem Add-on haben.


    Vielleicht hat ein Forum-Mitglied die gleichen materiellen Voraussetzungen, das Add-on zu testen, aber die Wahrscheinlichkeit das Problem zu reproduzieren ist eher gering.
    Du kannst dich direkt mit dem Autor in Verbindung setzen https://addons.mozilla.org/fr/…-image-resizer/developers
    und/oder auch gleichzeitig eine andere Version des Add-on testen, entweder eine der Beta-Versionen oder eine ältere Version:
    https://addons.mozilla.org/fr/…d-image-resizer/versions/


    Darüber hinaus gibt es natürlich die Möglichkeit, ein einzelnes Foto vor dem "Anheften" innerhalb von wenigen Sekunden in "Vorschau.app" über "Sichern als..." zu verkleinern.


    [OT] Wenn es sich um Stapel von Bildern handelt, hat Mac OS X hat die ausgezeichnete Anwendung "Automator.app", mit der man sogenannte "Workflows" erstellen kann, um beispielsweise Stapel von Fotos verkleinern und/oder umbenennen, Stapel von Dateien oder Ordnern umbenennen kann, ... usw, allgemein gesagt, bestimmte zeitraubende Prozesse automatisieren.
    Meine Workflows zum Umbenennen oder Verkleinern von Fotos machen das selbe in wenigen Sekunden, wozu Photoshop mehrere Minuten braucht.
    (Falls Interesse, mehr per PN) [OT]


    Gruß

  • Applaus!


    Hallo ihr da draußen! Erst einmal vielen, vielen Dank, für eure Hilfe. Es waren einige Denkanstöße dabei, einer hat mir geholfen!


    @ SusiTux

    Zitat

    (ein Fragezeichen tut's auch )


    Sorry, ja, merke ich mir. Aber du kannst dir vorstellen, dass es mehr Fragezeichen fett und kursiv gab, die über meinem Kopf standen! :wall:


    @ Mapenzi
    Dein Vorschlag, eine andere Version zu nutzen, hat letztendlich Erfolg gebracht. Musste mich aber etwas herantasten, weil nicht alle älteren Versionen mit der aktuellsten TB-Version kompatibel sind. Die Version 2.8 arbeitet so wie gewohnt. Aktuelle, auch Vor- Versionen arbeiten noch fehlerhaft. Jedenfalls was mein Problem betrifft.


    Vielleicht sollte ich dem Entwickler wirklich mal ´ne Mail schicken, auch wenn die Wahrscheinlichkeit, dass es weitere Leute gibt, die sowohl die Pentax K5 II und TB/Shrunked nutzen, äußerst gering ist!
    Ich hoffe nur, dass er nach meiner Mail noch klar denken kann und sich vor Lachen nicht auf dem Boden wälzt! :rofl: :rofl: Bei meinem Teutonen-Englisch! :redface:


    Also noch einmal, herzlichen Dank an ALLE, die sich ´ne Platte zu meinem verwurschtelten Problem gemacht und sich hier geäußert haben! :top:


    Gruß Vandenburgh